16:00:24 <etoews> #startmeeting api wg
16:00:37 <openstack> Meeting started Thu Oct 8 16:00:24 2015 UTC and is due to finish in 60 minutes. The chair is etoews. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:41 <openstack> The meeting name has been set to 'api_wg'
16:00:50 <cdent> o/
16:00:50 <elmiko> hi
16:00:54 <etoews> hola
16:01:50 <vikram> bye
16:01:56 <etoews> just adding something to agenda...
16:02:42 <etoews> #topic agenda
16:02:51 <etoews> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:03:11 <etoews> if anybody wants to add something, now is a good time ;)
16:03:18 * cdent looks
16:03:41 <etoews> #topic previous meeting action items
16:03:53 <etoews> #link http://eavesdrop.openstack.org/meetings/api_wg/2015/api_wg.2015-09-24-16.00.html
16:05:02 <elmiko> hmm, i failed to complete my action item =(
16:05:20 <etoews> ¯\_(ツ)_/¯
16:05:25 <elmiko> hehe
16:05:39 <etoews> the world kept turning :)
16:05:47 <elmiko> good point ;)
16:06:07 <etoews> did you still want to do it or just drop it?
16:06:20 <elmiko> i'll still do it, just needed a good reminder
16:06:32 <elmiko> unless someone else wants to take it
16:06:34 <etoews> care to action item yerself?
16:06:38 <elmiko> sure
16:06:51 <elmiko> #action elmiko to make PR against http://docs.openstack.org/infra/manual/developers.html to add info about the openstack-api irc channel
16:06:55 <cdent> I noticed a slowdown in the turning of the earth recently. It was a near miss.
16:07:04 <elmiko> haha
16:07:18 <stevelle> would like to get help with a guideline to need to increase the limit on hours per day. I suspect that we might be able to leverage this
16:07:29 <etoews> yes
16:07:31 <elmiko> +1
16:07:34 <cdent> stevelle++
16:07:42 <etoews> #topic Magnum
16:07:59 <etoews> #link https://swaggerhub.com/api/etoews/OpenStack-Magnum/1.0
16:08:12 <elmiko> that looks nice
16:08:14 <etoews> that is 100% not my work ^
16:08:28 <etoews> entire credit to jamie hannaford and annegentle
16:08:41 <annegentle> and really it's 90% Jamie :)
16:08:46 <etoews> i just threw it out on swaggerhub to share with others
16:09:36 <etoews> i've been having an email chat with adrian otto (magnum ptl) about getting a liaison from them
16:10:08 <etoews> now that we have an api ref for magnum, i think it would be good to get some more api wg eyeballs on it
16:10:25 <etoews> and have a liaison to work with us on any feedback
16:10:56 <stevelle> I see it continues the openStack pattern of url commands
16:11:11 <etoews> i noticed that too
16:11:35 <etoews> but we don't have a guideline for such a thing
16:11:37 <etoews> :(
16:11:54 <cdent> stevelle?
16:12:21 <elmiko> etoews: +1 for more engagement with magnum
16:12:21 <annegentle> say more about that stevelle, what do you mean?
16:12:30 <cdent> oh I found it: pause, unpause, stop etc
16:12:34 <annegentle> cdent: ah ok
16:12:44 <annegentle> stevelle: is that what you mean?
16:12:45 <stevelle> re: /containers/{identifier}/start
16:12:48 <stevelle> etc
16:12:51 <annegentle> ok
16:13:11 <etoews> that's still better than tunneling imo
16:13:39 <stevelle> we have had discussions in the WG before about this but it was a while ago
16:13:52 <etoews> i vaguely recall...
16:14:30 <etoews> i think miguelgrinberg had an strong opinion on how actions should be done in an api
16:14:36 <stevelle> unless the API was actually fully designed to use a CQRS pattern, this ends up being not as RESTful as it could be, and it's spreading
16:14:57 <stevelle> yes, he was one who spoke about it strongly.
16:15:07 <miguelgrinberg> yeah
16:16:12 <etoews> miguelgrinberg: do you have the time/interest to do a guideline for actions?
16:17:06 <miguelgrinberg> I could, but I expect it will not be easy to agree on this topic
16:17:24 <etoews> i agree it will not be easy to agree on
16:17:42 <miguelgrinberg> I'll probably soften my approach a bit, take what some of the APIs do instead of just propose what I would do from sctratch
16:17:55 <elmiko> probably a wise idea ;)
16:17:55 <miguelgrinberg> but certainly the /start /stop have to go
16:18:01 <elmiko> +1
16:18:40 <miguelgrinberg> Okay, I'll give it a try
16:19:11 <etoews> #action miguelgrinberg to begin a guideline for actions
16:19:19 <etoews> many thanks miguelgrinberg
16:20:51 <miguelgrinberg> etoews: it should be fun :)
16:20:58 <etoews> #action etoews to get a api wg liaison from magnum
16:21:30 <etoews> #action etoews annegentle to figure out how to best collaborate on the magnum api ref
16:21:59 <etoews> boom. drive by action item on annegentle.
16:22:26 <etoews> anything else on magnum?
16:22:31 <elmiko> lol
16:23:26 <etoews> #topic links
16:24:16 * etoews searches meeting minutes
16:24:49 <annegentle> heh I'll take it.
16:24:54 <elmiko> is this about the embedded links href vs ref issue?
16:25:22 <etoews> yes
16:25:34 <etoews> i know we discussed it in the recent past but can't find it
16:25:43 <elmiko> cool, i've started to analyze the openstack apis, but it's been slow going.
16:25:55 <elmiko> i am working on creating a list of all references though.
16:26:48 <etoews> elmiko: what are you doing to analyze?
16:27:03 <elmiko> mainly grepping through the api-ref site
16:27:11 <elmiko> well, the source wadls
16:27:31 <etoews> i had envisioned just searching through http://developer.openstack.org/api-ref.html and copying examples of how people are doing links into https://wiki.openstack.org/wiki/API_Working_Group/Current_Design
16:27:53 <elmiko> ok, maybe i'm going about this in an inefficient manner then
16:27:59 <etoews> gotcha. that was pretty much what i had in mind.
16:28:08 <annegentle> yeah either way should work elmiko
16:28:26 <elmiko> should i keep going and post my results on the wiki then?
16:29:16 <etoews> sure
16:29:30 <etoews> i'd say post them as soon as you discover them.
16:29:35 <elmiko> put it on this page https://wiki.openstack.org/wiki/API_Working_Group/Current_Design/Links ?
16:29:51 <elmiko> yea, that's probably smart
16:30:12 <etoews> y
16:30:13 <elmiko> i'll start posting them by service then
16:30:19 <elmiko> sorry for the delay
16:30:54 <etoews> np.
16:31:07 <elmiko> gonna escalate this on my trello ;)
16:31:23 <etoews> then we can do some analysis ala https://wiki.openstack.org/wiki/API_Working_Group/Current_Design/Metadata#Analysis
16:31:37 <elmiko> yea, i figured that was the end goal
16:31:53 <etoews> miguelgrinberg: i just discovered/remembered https://wiki.openstack.org/wiki/API_Working_Group/Current_Design/Actions
16:32:07 <etoews> there's some fodder for the action guideline
16:32:31 <etoews> although it doesn't include any examples of the /start /stop stuff
16:32:51 <miguelgrinberg> etoews: ah, great, didn't know about that. It's useful, the nova style is what I was thinking would work well for openstack
16:33:04 <miguelgrinberg> and it does support the start/stop actions already
16:34:50 <etoews> elmiko: need an action item for the links thing?
16:35:01 <elmiko> sure
16:35:21 <elmiko> #action elmiko create analysis of link references for each service in api-ref
16:35:30 <etoews> thx
16:35:40 <etoews> #topic guidelines dashboard
16:35:50 <etoews> #link http://ghostcloud.net/openstack_gerrit_dashboards/dashboard_api-wg.html
16:36:05 <elmiko> this one https://review.openstack.org/#/c/214817/ seems like it might be ready for freeze
16:36:36 <elmiko> https://review.openstack.org/#/c/221163/ too
16:37:12 <etoews> y and y
16:37:27 <elmiko> do you want to +2 them?
16:37:34 <etoews> sure
16:37:47 <elmiko> also, have the dashboard been updated with our recent process change?
16:38:11 <etoews> #action etoews to freeze https://review.openstack.org/#/c/214817/ and https://review.openstack.org/#/c/221163/
16:38:21 <elmiko> ty
16:38:24 <etoews> elmiko: which change is that?
16:38:52 <elmiko> using +2 as the freeze marker, or did we do that awhile ago /me forgets
16:39:29 * etoews goes to check
16:39:53 <etoews> yep. step #4 http://specs.openstack.org/openstack/api-wg/process.html
16:40:20 <elmiko> ok, cool. and it looks like the dashboard reflects too. thanks =)
16:40:39 <etoews> anything we need to do to move https://review.openstack.org/#/c/187112/ along?
16:40:56 <etoews> cdent: you have the last comment there.
16:41:10 * cdent looks
16:41:35 <etoews> do you think it needs that explanation before it can merge?
16:41:52 <cdent> Yeah, I intentionally did not leave a vote on with that comment, was just reflecting my own reaction to all the microversion discussions I've seen on the mailing list and elsewhere
16:41:53 <elmiko> i think we need some grammar cleanup on that one too (as i see draft comments of mine)
16:42:20 <cdent> I think it is okay (with grammar tidy) to move it in, and then revise later if possible
16:42:38 <elmiko> agreed, content-wise it seemed ok
16:42:43 <cdent> In the sense that the microversion ship has sailed far enough that we dont' want to real it in
16:42:51 <cdent> (despite the fact that I think it is completely the wrong way to do things ;) )
16:42:53 <etoews> sorry, i should have said before we *freeze* it
16:43:03 <cdent> s/real/reel/
16:43:11 <elmiko> it needs cleanup before freeze
16:43:20 <etoews> cdent keeps it reel
16:43:25 <elmiko> lol
16:43:37 <cdent> /o/
16:43:39 <cdent> \o\
16:43:45 <cdent> /o/
16:44:12 <elmiko> that goes so well with the music i am listening to
16:44:43 <annegentle> heh
16:44:53 <etoews> elmiko: can you comment there on the grammar stuff and when it's ready, go through the freeze process?
16:45:04 <elmiko> etoews: yes
16:45:41 <elmiko> #action elmiko comment on https://review.openstack.org/#/c/187112 and freeze when ready
16:47:16 <etoews> any other guidelines to dive into?
16:47:34 <elmiko> nothing from me
16:48:20 <etoews> #topic APIImpact
16:48:31 <etoews> #link https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z
16:49:55 <etoews> anything anyone wants to highlight?
16:54:27 <elmiko> i realize that i forgot to add this to the agenda, but could we talk about summit for a few?
16:54:49 <etoews> #topic summit
16:54:56 <elmiko> thanks
16:55:00 <elmiko> #link https://etherpad.openstack.org/p/mitaka-api-wg-session-plans
16:55:14 <elmiko> just wanted to link this again, as i could use some assistance filling out the agenda for our meeting
16:55:37 <cdent> elmiko: please hassle me to help you with that
16:55:39 <etoews> sure. 3.3 is my axe to grind. :)
16:56:00 <cdent> I've been sort of all around the place lately but should be fairly present in the week running up to summit
16:56:02 <elmiko> cdent: noted, increasing cdent.hassle_factor
16:56:16 <elmiko> cool, i just wanted to bring it up again
16:56:33 <elmiko> i imagine some of my 12hr flight will be spent finalizing these pads
16:57:05 <elmiko> but, you know, many hands and all... ;)
16:59:15 <etoews> if there's nothing else, we can pack it in a whole minute early.
16:59:19 <elmiko> that was all i had, thanks for any contributions folks want to add there =)
16:59:27 <elmiko> and cdent, i'll bug you some next week
16:59:37 <cdent> cool, please and thank you
16:59:49 <elmiko> etoews: +1
17:00:02 <etoews> #endmeeting