16:00:16 <etoews> #startmeeting api wg
16:00:17 <openstack> Meeting started Thu Jan 14 16:00:16 2016 UTC and is due to finish in 60 minutes.  The chair is etoews. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:21 <openstack> The meeting name has been set to 'api_wg'
16:00:28 <elmiko> heyo/
16:00:54 <etoews> hiya
16:01:04 <cdent> o/
16:02:14 <elmiko> slow day...
16:02:18 <etoews> smallish crowd today
16:02:30 <etoews> #topic agenda
16:02:37 <etoews> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:02:47 <etoews> #topic previous meeting action items
16:02:56 <etoews> #link http://eavesdrop.openstack.org/meetings/api_wg/2015/api_wg.2015-12-17-16.00.html
16:03:38 <cdent> I did mine
16:03:44 <elmiko> \o/
16:03:54 <etoews> huzzah!
16:03:56 <cdent> https://wiki.openstack.org/wiki/API_Working_Group/Current_Design/Version_Responses#Telemetry
16:04:23 <cdent> I know, right? I'm pretty impressed too.
16:04:23 <elmiko> that page has filled out nicely
16:04:31 <elmiko> hehe
16:04:44 <etoews> looks like a pretty good cross section of projects to me
16:04:50 <elmiko> yea
16:05:15 <cdent> This big "GET / requires auth, which is probably a bug. " is being fixed in at least gnocchi
16:05:19 <cdent> s/big/bit/
16:05:40 <elmiko> i noticed sahara does that too, should these calls be unauth'd?
16:06:29 <cdent> I tend to think: why should they be authed?
16:06:33 <elmiko> or is that a decision we leave up to the projects?
16:06:41 <elmiko> yea, i agree. just didn't know the full history
16:06:49 <cdent> me neither
16:07:17 <elmiko> ok, maybe i'll push on sahara then. thanks
16:07:42 <cdent> It turns out that the fix in gnocchi is more complex than I would have predicted, because of keystone middleware
16:07:50 <elmiko> doh!
16:07:59 <cdent> https://review.openstack.org/#/c/266301/
16:09:51 <etoews> okay to move on?
16:10:06 <elmiko> good here
16:10:12 <etoews> #topic openstack summit in austin
16:10:34 <etoews> #link https://www.openstack.org/summit/austin-2016/
16:11:02 <etoews> i actually live in the austin area so this will be nice :)
16:11:17 <elmiko> so, you'll be showing us the hot night spots ;)
16:11:29 <etoews> :P
16:12:05 <etoews> i know a few places to get a good beer
16:12:22 <elmiko> \o/
16:12:29 * cdent needs a bit of mexican food
16:12:32 <etoews> they better be serving breakfast tacos every morning or it will be an outrage
16:12:39 <elmiko> ooh, yea, i heard rumors of breakfast tacos
16:12:46 <elmiko> must try
16:12:48 <cdent> \o/
16:13:03 <elmiko> as for the actual summit itself, i'm totally up for doing another "state of the wg" type session
16:13:12 <etoews> cool.
16:13:14 <elmiko> it was small in tokyo, but we had a really nice discussion
16:13:25 <cdent> the new track rules are interesting but kinda make sense
16:13:26 <ryansb> oh mean, I forgot Austin would have great texmex
16:13:38 <etoews> we have to submit it formally as a presentation this year.
16:13:39 <ryansb> best summit ever
16:13:44 <elmiko> and i would really like to talk more about the mission of the wg, and if it's appropriate to work on code projects under the guise of the wg
16:14:02 <etoews> didn't we already okay that?
16:14:13 <etoews> ryansb: it's gonna be a good one ;)
16:14:15 <elmiko> ah, did we? if so, maybe i misse dit
16:14:20 <cdent> there was a bit of pushback from somewher, but I can't remember where/when
16:14:29 <cdent> things went funky one xmas rolled around
16:14:29 <elmiko> yea, that's what i thought too
16:14:32 <cdent> everything is a haze now
16:14:44 <elmiko> +1
16:14:52 <etoews> we discussed in an api wg meeting sometime last year
16:15:03 <elmiko> yea, when the fairy-slipper stuff came up
16:15:20 <elmiko> and actually, i think i owe the ML a message about project ideas
16:15:31 <etoews> i'm basically a +0 on it
16:15:40 <elmiko> ok, noted
16:15:49 <etoews> no strong opinion but i'm certainly not against it.
16:15:52 <elmiko> we had some good excitement for an "example project" at the summit
16:16:04 <etoews> and i have zero time to put towards something like that
16:16:09 <elmiko> fair
16:16:26 <etoews> but if you can build some momentum for the api wg with it. more power to you.
16:16:27 <elmiko> i'm up for taking the reigns on this one, if we get some good traction
16:16:40 <elmiko> yea, i'm trying to build up a good piece of code to show off
16:16:42 * cdent gives elmiko some leather
16:16:44 <etoews> cool. just go for it. no need for more discussion.
16:16:48 <cdent> you can probably pick up some boots in austin
16:16:51 <elmiko> great, thanks!
16:17:11 <etoews> you can definitely pick up boots in austin. they come with a free 10 gallon hat.
16:17:20 <elmiko> ooh, nice =)
16:17:31 <ryansb> for an extra buck, you can upgrade to a 15 gallon hat
16:17:33 <cdent> big hat, no cattle
16:18:01 <etoews> cdent: elmiko: how do you want to get the prez proposal written up? etherpad like last cycle?
16:18:11 <cdent> sounds good
16:18:13 <elmiko> etoews: yea, i think that work
16:18:15 <elmiko> s
16:18:23 <etoews> do you have a link handy to the last one?
16:18:40 * cdent looks at elmiko
16:19:06 * etoews looks at elmiko
16:19:10 <elmiko> #link https://etherpad.openstack.org/p/mitaka-api-wg-session-plans
16:19:12 <elmiko> this one?
16:20:07 <etoews> i don't even know what the n release is going to be called :|
16:20:29 <cdent> legal is still chewing, aren't they?
16:20:50 <etoews> ¯\_(ツ)_/¯
16:20:56 <ryansb> cdent: yeah, haven't seen anything other than the poll
16:21:03 <ryansb> so someone is chewing
16:21:28 <etoews> far too much time/effort/money is spent on that naming nonsense IMO
16:21:43 <etoews> anyway, don't want to go off on that tangent
16:22:49 <etoews> #link https://etherpad.openstack.org/p/austin-api-wg-session-plans
16:23:30 <cdent> i'll drop some stuff on that tomorrow after sleeping on it
16:23:48 <cdent> (that's my new strategy for everything: tomorrow after I sleep on it)
16:24:01 <elmiko> nice
16:25:13 <etoews> cdent: your taking advantage of your diffuse mode thinking
16:25:19 <etoews> s/your/you're/
16:25:25 <etoews> i do that often too
16:25:47 <cdent> I guess someone decided the proposal process was too chaotic. Lots more rules and forms and guidelines and what not this time around. I guess that's to dissuade the dilletantes
16:26:02 <cdent> diffuse mode is where the cool stuff is
16:26:15 <etoews> i copied the CFP sections into the etherpad. i think most of those section can be pretty "thin" for a WG prez proposal.
16:26:22 <cdent> agreed
16:27:17 <etoews> okay. we just need to get it finished by feb. 1. lots of time.
16:27:30 <etoews> let's move on
16:27:37 <elmiko> cool
16:27:40 <etoews> #topic magnum api refresh
16:27:50 <etoews> #link https://etherpad.openstack.org/p/magnum-unified-container-actions
16:28:19 <etoews> the magnum team seems to be considering a big api refresh. maybe a v2?
16:28:32 <elmiko> interesting
16:28:40 <etoews> i highlight this because this is an area i'm becoming much more involved in
16:29:12 <elmiko> nice, looks like a cool project
16:29:14 <etoews> the new carina (containers as a service) product at rackspace will be built on magum
16:29:21 <etoews> #link https://getcarina.com/
16:29:38 <elmiko> oh yea, i remember looking at that after the keynotes. looks very cool!
16:29:46 <etoews> so we want to make sure they have a first rate api
16:30:27 <etoews> another person on my team is taking the lead on proposing changes and i'm helping guide from an api wg perspective
16:30:29 <elmiko> do they just want more eyes on the proposal?
16:30:42 <etoews> i expect so
16:30:45 <elmiko> k
16:31:07 <etoews> some parts of that api make heavy use of actions.
16:31:15 <elmiko> ah, interesting
16:31:27 <etoews> so i pointed them at #link https://review.openstack.org/234994
16:31:30 <cdent> that old canard
16:31:32 <elmiko> cool
16:31:32 <cdent> ;)
16:31:44 <elmiko> i like that spec, but it seemed to run aground slightly
16:31:53 <cdent> sort of my fault
16:32:10 <etoews> hopefully some of the work in magnum can feedback into that guideline
16:32:14 <elmiko> also, i think we probably need to carry the baton from miguelgrinberg as i think he is working on other things now
16:32:26 <etoews> cdent: anything you can do to move it forward?
16:32:27 <cdent> That's a shame
16:32:57 <cdent> I can re-evalulate my position and add a dash of pragmatism and it will probably be all fine.
16:33:00 <elmiko> i can take over and attempt to address the issue in the guideline if folks want?
16:33:08 <etoews> sgtm
16:33:20 <cdent> I was originally trying to push for some measure of aspiration
16:33:21 <etoews> as long as that's cool with miguelgrinberg
16:33:33 <elmiko> i *think* so, but i'll ping him
16:33:41 <ryansb> etoews: he emailed the heat team to that effect
16:33:42 <elmiko> #action elmiko to ping miguelgrinberg about taking over https://review.openstack.org/#/c/234994/
16:33:48 <etoews> ++
16:33:57 <ryansb> (as in, go ahead and take over my WIP, my focus is changing a bit)
16:34:05 <cdent> #action cdent to re-review https://review.openstack.org/#/c/234994/ with an eye to reaching consensus
16:34:06 <ryansb> fwiw
16:34:15 <elmiko> ryansb: ah, which one was yours?
16:34:34 <ryansb> no, I mean miguel said that
16:35:13 <elmiko> oh, great. thanks
16:36:07 <etoews> #topic guidelines to propose for freeze
16:36:15 <etoews> #link https://review.openstack.org/#/c/190743
16:36:46 <cdent> yes
16:37:04 <elmiko> i added this, seemed like it was ready again
16:37:38 <etoews> elmiko: go ahead and freeze it
16:37:48 <elmiko> k, i'll make the preparations ;)
16:37:57 <elmiko> #action elmiko to freeze https://review.openstack.org/#/c/190743
16:38:22 <etoews> prepare it for freezing in carbonite
16:38:35 * elmiko calls ahead to Lando
16:38:57 <cdent> best leave him in there, things get dangerous after he's let out
16:39:15 <elmiko> lol
16:39:22 <etoews> :)
16:39:55 <etoews> this needs more eyeballs https://review.openstack.org/#/c/243041/
16:40:21 <elmiko> yes, +1
16:40:23 <etoews> #action etoews to add more eyeballs to https://review.openstack.org/#/c/243041/
16:40:38 <elmiko> we also merged two very old guidelines =)
16:40:48 <cdent> that reminds me: I think we probably need to send a reminder to the mailing list about the group's existence, because of the usual post xmas amnesia
16:41:00 <elmiko> ooh, good idea
16:41:07 <elmiko> "happy new year from the api-wg" ?
16:41:09 <elmiko> ;)
16:41:20 <cdent> so that people who would normally be here remember to come and to review (before freeze time)
16:42:04 <etoews> cdent: care to send that reminder?
16:42:21 <cdent> Sure, can do
16:43:09 <cdent> #action cdent send an api-wg exists reminder email
16:43:14 <etoews> ++
16:43:22 <etoews> #action etoews to add more eyeballs to https://review.openstack.org/#/c/254895/
16:43:51 <elmiko> +1 * 2 ;)
16:44:23 <etoews> i'll hold off on https://review.openstack.org/#/c/234994/ until it gets at least one more patch set (likely from elmiko)
16:44:44 <elmiko> cool, i'll get that in before the next meeting
16:46:04 <etoews> https://review.openstack.org/#/c/187896/ and https://review.openstack.org/#/c/243414/ and https://review.openstack.org/#/c/243429/ are in need of some love
16:46:25 <etoews> alex_xu: do you have sometime to review/update those guidelines? ^
16:48:10 <etoews> this seems like a reasonable thing to do but i'm not really familiar with it https://review.openstack.org/#/c/267329/
16:48:45 <cdent> yes, it's fine. that's one of the recent "let's fix something in all the repo mass bug fixes"
16:49:06 <cdent> I think someone must have run some kind of audit against the code
16:49:17 <cdent> _all_ the code
16:49:53 <elmiko> yea, this change has been making the rounds
16:50:12 <ryansb> yeah, it's handy that it's an autopatch though
16:50:33 <ryansb> just so deprecated junk isn't kicking around forever
16:50:42 <elmiko> yup
16:50:47 <cdent> this one actually works. there have been some others that are wrong.
16:50:49 <etoews> can someone more familiar with the change go ahead and merge it?
16:51:04 <elmiko> sure
16:51:07 <etoews> i just bumped https://review.openstack.org/#/c/161946/
16:51:15 * cdent can only +1
16:51:27 <elmiko> k, i'll +A
16:52:11 <elmiko> sigmavirus24 is at the ossp midcycle currently, but maybe he will take a look later
16:52:21 <sigmavirus24> durwasa:What's up?
16:52:23 <elmiko> sigmavirus24: your thoughts, https://review.openstack.org/#/c/161946/
16:52:30 <etoews> bumped https://review.openstack.org/#/c/183599/
16:52:38 <sigmavirus24> Oh I can probably rebase that
16:52:53 <etoews> cdent: you can only +1? wha???
16:52:54 <elmiko> sigmavirus24: sweet =)
16:53:08 <elmiko> weird...
16:53:10 <cdent> it's just you and elmiko and jaypipes at this point I think?
16:53:22 <elmiko> you were supposed to be added too
16:53:26 <jaypipes> yeah...
16:53:30 <cdent> hawt
16:53:32 <cdent> ;)
16:53:45 <jaypipes> in fact, I believe it's best to remove me and replace with cdent.
16:53:53 * elmiko gasps
16:53:55 <elmiko> ;)
16:54:06 <cdent> does this mean I need to shave my head?
16:54:11 <elmiko> haha
16:54:12 <jaypipes> elmiko: it's already tough to find time to perform my Nova duties :(
16:54:20 <etoews> cdent: yes
16:54:20 <jaypipes> cdent: yes, of course it does.
16:54:29 <elmiko> jaypipes: i hear ya, and no worries on this end =)
16:54:34 <etoews> jaypipes: thank you for service good sir.
16:54:38 <cdent> /o\
16:54:38 <elmiko> +1
16:54:54 <jaypipes> etoews: cheers
16:55:25 <etoews> i'll go ahead and make those changes right now if there are no objections.
16:55:36 <cdent> Thanks, I'll try not to break everything.
16:56:09 <elmiko> etoews: none here
16:56:18 * elmiko watches cdent closely...
16:56:32 * cdent starts shaving
16:56:37 <elmiko> lol
16:56:46 <elmiko> well played sir /me tips fedora
16:57:27 <etoews> anything else in the last few min?
16:57:37 <elmiko> nothing from me
16:57:49 <cdent> nor me
16:58:06 <ryansb> nope
16:58:17 <etoews> alright then. let's end it a little early. thanks all!
16:58:24 <etoews> #endmeeting