#openstack-meeting-3: api wg

Meeting started by etoews at 16:00:05 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (etoews, 16:02:16)

  1. previous meeting action items (etoews, 16:03:08)
    1. http://eavesdrop.openstack.org/meetings/api_wg/2016/api_wg.2016-01-14-16.00.html (etoews, 16:03:19)

  2. api wg cfp for openstack summit in austin (etoews, 16:09:22)
    1. https://etherpad.openstack.org/p/austin-api-wg-session-plans (etoews, 16:09:34)
    2. ACTION: elmiko to post api-wg submission for austin summit (elmiko, 16:12:04)
    3. ACTION: etoews to try to find out just how much hoop jumping we need to do for the wg submission (etoews, 16:14:27)

  3. magnum api refresh (etoews, 16:16:19)
    1. https://blueprints.launchpad.net/magnum/+spec/standardised-error-messages (etoews, 16:16:39)
    2. ACTION: etoews to reach out to the magnum CPLs and highlight https://blueprints.launchpad.net/magnum/+spec/standardised-error-messages for them (etoews, 16:17:58)
    3. ACTION: give feedback to magnum team on ways to do "optional" parts of an api (etoews, 16:29:55)

  4. guidelines (etoews, 16:34:59)
    1. ACTION: elmiko freeze the server-side traceback guideline (elmiko, 16:37:08)
    2. http://lists.openstack.org/pipermail/openstack-dev/2016-January/085229.html (rosmaita, 16:45:10)
    3. http://governance.openstack.org/reference/projects/cinder.html (elmiko, 16:52:03)


Meeting ended at 17:00:21 UTC (full logs).

Action items

  1. elmiko to post api-wg submission for austin summit
  2. etoews to try to find out just how much hoop jumping we need to do for the wg submission
  3. etoews to reach out to the magnum CPLs and highlight https://blueprints.launchpad.net/magnum/+spec/standardised-error-messages for them
  4. give feedback to magnum team on ways to do "optional" parts of an api
  5. elmiko freeze the server-side traceback guideline


Action items, by person

  1. elmiko
    1. elmiko to post api-wg submission for austin summit
    2. elmiko freeze the server-side traceback guideline
  2. etoews
    1. etoews to try to find out just how much hoop jumping we need to do for the wg submission
    2. etoews to reach out to the magnum CPLs and highlight https://blueprints.launchpad.net/magnum/+spec/standardised-error-messages for them


People present (lines said)

  1. etoews (86)
  2. elmiko (70)
  3. cdent (59)
  4. agentleweb (20)
  5. rosmaita (20)
  6. scottda (14)
  7. ameade (10)
  8. openstack (3)


Generated by MeetBot 0.1.4.