#openstack-meeting-3: api wg

Meeting started by elmiko at 16:00:40 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (elmiko, 16:02:15)

  1. previous meeting action items (elmiko, 16:02:29)
    1. http://eavesdrop.openstack.org/meetings/api_wg/2016/api_wg.2016-01-28-16.00.html (elmiko, 16:02:59)

  2. service type vs. project name for use in headers (elmiko, 16:04:57)
    1. http://lists.openstack.org/pipermail/openstack-dev/2016-January/085145.html (elmiko, 16:05:03)
    2. http://eavesdrop.openstack.org/meetings/tc/2016/tc.2016-02-02-20.01.log.html#l-263 (elmiko, 16:05:12)
    3. http://lists.openstack.org/pipermail/openstack-dev/2016-February/085670.html (sdague, 16:15:31)
    4. IDEA: : For future reference resist standardizing on header types with meaingful and changeable identifiers in the header left hand side. Bad for flexibility and bad HTTP. (cdent, 16:19:56)
    5. ACTION: : cdent writes up his ideas on resist headers (cdent, 16:33:39)
    6. ACTION: sdage to update https://review.openstack.org/#/c/243429 by adding API- back in (elmiko, 16:38:54)

  3. experimental api inclusion (elmiko, 16:40:12)
    1. : https://review.openstack.org/#/c/273158/ (gouthamr, 16:40:36)

  4. service type name registry (elmiko, 16:54:54)
    1. http://lists.openstack.org/pipermail/openstack-dev/2016-February/086269.html (sdague, 16:59:52)
    2. https://review.openstack.org/#/c/278612/ (elmiko, 17:00:00)


Meeting ended at 17:00:56 UTC (full logs).

Action items

  1. : cdent writes up his ideas on resist headers
  2. sdage to update https://review.openstack.org/#/c/243429 by adding API- back in


Action items, by person

  1. cdent
    1. : cdent writes up his ideas on resist headers
  2. openstack
    1. sdage to update https://review.openstack.org/#/c/243429 by adding API- back in


People present (lines said)

  1. elmiko (133)
  2. sdague (88)
  3. cdent (64)
  4. annegentle_ (59)
  5. etoews (54)
  6. gouthamr (5)
  7. openstack (5)
  8. notmyname (3)
  9. SergeyLukjanov (1)


Generated by MeetBot 0.1.4.