16:00:11 <etoews> #startmeeting api wg
16:00:12 <openstack> Meeting started Thu Mar 10 16:00:11 2016 UTC and is due to finish in 60 minutes.  The chair is etoews. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:16 <openstack> The meeting name has been set to 'api_wg'
16:00:23 <cdent> etoews as far as I can tell we're going to need to make up the agenda as we go as the one there is not really up to date. I was planning to do some reconstruction and didn't get around to it
16:00:31 <etoews> np
16:01:56 <etoews> anyone else joining us?
16:02:22 <cdent> elmiko is on well deserved holiday in the highlands
16:02:37 <cdent> I reckon many folk are in the rc-* crunch
16:02:43 <etoews> i love the highlands
16:03:05 <etoews> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:03:14 <etoews> #topic previous meeting action items
16:03:48 * etoews goes to dig out previous meeting link
16:03:55 <cdent> http://eavesdrop.openstack.org/meetings/api_wg/2016/api_wg.2016-02-25-16.00.html
16:04:42 <etoews> :)
16:05:29 <etoews> cdent is a man of action
16:06:06 <etoews> did you want to give an update on those?
16:07:57 * cdent tries to summarize
16:08:57 <cdent> the service-types-authority and service-catalog work is proceeding slowly because of release crunch, however sd*ague has put up some initial bits of code for the service-types, enough for us to start moving on that one release crunch has cleared
16:09:26 <cdent> bknud*son has made a good schema for service catalog that people agree is good, but no further action yet
16:09:48 <cdent> everybody was cool with the microversion header changes, and that's been reflected in the in progress guidelines
16:10:24 <cdent> the header related guidelines (non-proliferation on the left, don't be redudant on the rigth) are both well received, the former has been announced to cpls, the latter will be soon
16:10:55 <cdent> there a couple guideline reviews which are ready for freeze, which I can do soon
16:11:12 <cdent> #action: cdent to freeze the reviews sent out earlier this week for cpl review
16:11:16 <etoews> nice
16:11:30 <etoews> thanks for the update to the add reviewers script too.
16:11:31 <cdent> EOF
16:13:20 <etoews> are any of the "new" topics in the meeting wiki still relevant?
16:13:28 <etoews> i kind of don't think so
16:13:47 <cdent> I'm not sure about the magnum thing
16:15:41 <etoews> the only there of interest is https://blueprints.launchpad.net/magnum/+spec/standardised-error-messages
16:15:57 <etoews> which got implemented in https://review.openstack.org/#/c/287269/
16:16:16 <cdent> ah that reminds me
16:16:21 <etoews> it sure got workflow +1'd pretty quick...
16:16:50 <cdent> the microversion interaction describes a 406 response when  version doesn't match, but a response body that doesn't align with the errors guideline
16:16:56 <cdent> which seems a bit of an issue
16:18:29 <cdent> (I commented on the guideline: https://review.openstack.org/#/c/243429/ )
16:19:01 * etoews looks
16:20:31 <etoews> hmmm...i see what you mean
16:21:10 <etoews> it's also pretty awesome that camel case (versionFault) and underscores (max_version) are mixed in the same body.
16:22:39 * cdent nods
16:24:13 <etoews> i think we do want that microversion response returning structured data
16:24:23 * cdent nods
16:24:43 <cdent> you should comment that and then either I or alex*xu can fix it
16:25:39 <etoews> how do we resolve that with the errors spec though?
16:26:15 <etoews> have it still follow the error spec but add those 2 fields?
16:26:23 <cdent> Maybe I misunderstood you. I thought you were saying "yes, that microversion spec needs to follow the errors spec"
16:26:48 <cdent> oh I see what you mean
16:26:57 <cdent> Hmmm.
16:27:31 <etoews> i wouldn't want to stuff max_version and min_version into detail
16:27:31 <cdent> I think additional properties in the individual objects in the errors list is okay
16:28:36 <cdent> in fact in many cases may be required
16:28:39 <etoews> me too
16:28:53 * etoews works up an example
16:31:08 <etoews> http://paste.openstack.org/show/490029/
16:31:59 <cdent> a) that looks correct b) correct is really noisy :)
16:32:25 <etoews> hey hey it even validates! http://jsonschemalint.com/draft4/
16:32:49 <etoews> i use computer programs to filter out noise :)
16:33:10 <etoews> noise mostly generated by other computering programs
16:33:49 <etoews> i'll comment on the issue
16:33:52 <etoews> review that is
16:33:54 <cdent> cool, thanks
16:36:02 <etoews> #action etoews to comment on https://review.openstack.org/#/c/243429/7/guidelines/microversion_specification.rst following the errors spec
16:36:12 <etoews> cdent: thanks for pointing that out
16:36:52 <cdent> I need to meditate on "i use computer programs to filter out noise"
16:37:05 <cdent> because it is and always has been a bit of an issue for me
16:37:57 <etoews> my usual default is to prefer more information than less and filter out what i don't need.
16:38:43 <cdent> reasonable
16:38:50 <etoews> cdent: have you given any more thought to implementing the error spec in ceilometer? (is it ceilometer?)
16:39:38 <cdent> I don't really do much on ceilometer any more, and even if I did its api is basically considered legacy so not much change happening there
16:40:07 <cdent> the place where I'm exploring the errors guideline is on an experimental facade over the nova api (mostly a learning exercise)
16:40:27 <etoews> ah
16:41:49 <cdent> the gnocchi api would be an interesting place to explore errors and the like, but gnocchi isn't really subscribing to the guidelines in general (at least last I checked)
16:42:10 <etoews> okay
16:43:17 <etoews> #topic guidelines
16:43:38 <etoews> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:43:53 <etoews> cdent: anything to highlight here?
16:45:24 <cdent> there are some arguments on https://review.openstack.org/#/c/281511/ and https://review.openstack.org/#/c/260292/ but they are reaching consensus
16:46:01 <cdent> elmiko was going to resurrect actions guideline https://review.openstack.org/#/c/234994/ but I guess hasn't had a chance yet
16:46:11 <cdent> there are hangups on pagination: https://review.openstack.org/#/c/190743/
16:48:47 * etoews ganders
16:50:59 <etoews> i'll have to give those a deeper look later
16:51:33 <cdent> There's nothing deeply unsettled, except for the actions one, just some consensus building that needs to happen
16:54:17 <etoews> anything else in the last few minutes here?
16:54:43 <cdent> Don't think so.
16:54:56 <cdent> Things will pick up again soon.
16:55:01 <etoews> i'll schedule the api wg session at the summit for early monday afternoon. we can change it later if need be.
16:55:11 <cdent> ++
16:56:11 <cdent> let's call it a day
16:56:28 <etoews> sgtm. thx!
16:56:37 <cdent> thank you
16:56:37 <etoews> #endmeeting