16:00:07 <etoews> #startmeeting api wg
16:00:08 <openstack> Meeting started Thu May  5 16:00:07 2016 UTC and is due to finish in 60 minutes.  The chair is etoews. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:12 <openstack> The meeting name has been set to 'api_wg'
16:00:20 <etoews> hi
16:00:25 <elmiko> hi
16:00:30 <leong> o/
16:00:33 <piet> howdy
16:00:35 <cdent> o/
16:00:53 <etoews> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:01:57 <etoews> going to skip previous meeting action items
16:02:26 <etoews> #topic usability study
16:02:38 <etoews> piet: please take it away
16:02:42 <piet> That would be me
16:02:44 <ameade> o/
16:02:48 <piet> OpenStack UX presented to the board this past summit and they suggested we engage w your team and see if there were any research needs
16:03:29 <cdent> a) I think doing some kind of evaluation is a great idea but
16:03:43 <piet> I went and give you slot within the next six months, but need to understand your needs
16:03:58 <cdent> b) we need to be clear that the api-wg is concerned about APIs, not about client implementations against those apis
16:04:18 <cdent> and that makes evaluation a lot more complex
16:04:30 <piet> We actually did a study on the OpenStackClient for Dean that was very successfully
16:04:47 <piet> UX research doesn't need to focus exclusively in GUIs
16:05:19 <piet> In that case, we gave operators a few tasks to complete in command line and took notes
16:05:36 <piet> Helped Dean prioritize his efforts
16:06:08 <etoews> piet: what do you envision as the result of this research?
16:06:33 <piet> I need to do a deeper dive with the team to understand your specific focus
16:06:52 <piet> Are you trying to build consistency across APIs?
16:07:09 <cdent> that's definitely one
16:07:21 <etoews> piet: this will fill in a lot of blanks https://wiki.openstack.org/wiki/API_Working_Group
16:07:29 <piet> Kk
16:07:43 <etoews> of particular interest to you might be https://wiki.openstack.org/wiki/API_Working_Group/Current_Design
16:08:15 <etoews> that's where we record analysis of current design, mostly with an eye towards consistency
16:08:37 <piet> A lot of times there is a huge value in having the opportunity to simply want folks use the different APIs with a specific set of tasks
16:08:39 <piet> Kk
16:08:45 <piet> I'll look today
16:09:00 <etoews> i can see that
16:09:03 <elmiko> a caveat about the current designs is that we didn't have a strong consistency about the project sampled. something we will change in the future (from notes at summit)
16:10:06 <cdent> piet the reason for my comments above is that many people use existing client code to interact with the apis and that client code abstracts away much of HTTP API itself, so unless we are observing people making requests without a pre-built client, we'll be evaluating the pre-existing client, not the actual HTTP API
16:10:45 <piet> So, we don't need to land on a specify kind of study now, but want to make sure we have you schedule for one of the slots
16:11:15 <piet> Is there someone on this team that can be a focal for me?
16:11:28 <etoews> and if we ask people to talk directly to the api with curl or something, i guarantee you the first thing they'll cite is issues with docs.
16:11:39 <elmiko> lol, so true
16:11:41 <cdent> etoews: maybe that's okay?
16:11:48 <etoews> yep
16:11:58 <etoews> can't shine a bright enough light on that
16:12:02 <cdent> piet, I'm happy to be the contact, I've got some background with HCI/UX/UI stuff
16:12:06 <elmiko> etoews++
16:12:12 <piet> Yep, docs is consistently an issue in literally every study we've done
16:12:36 <piet> cdent coolio - will reach out to you
16:12:42 <cdent> I suspect of the three of us I'm also the most available
16:12:52 <elmiko> most likely...
16:13:00 <etoews> piet: i'd ask that you please keep the conversations as public as possible. we all hang out in #openstack-sdks if you need to reach out on short notice.
16:13:02 <cdent> etoews is that true for you (I know it is for elmiko )
16:13:09 <cdent> etoews++
16:13:22 <etoews> cdent: that's true for me
16:13:24 <cdent> Yeah, doing the planning and chatting via the mailing list and irc would be best
16:13:29 <piet> Yeah, we typically create a wiki so everyone can comment
16:13:43 <cdent> It's probably true for me too, but I'm happy to take the hit :)
16:13:47 <piet> I can also reach-out via IRC
16:13:53 <etoews> piet: if you go the mailing list route just prefix the subject with [api]
16:14:03 <piet> k
16:14:49 <etoews> piet: anything else you'd like to add on this topic?
16:14:50 <piet> Cool - appreciate your engagement on this! Look forward to helping ya'll
16:15:01 <piet> No - I think we're good
16:15:11 <etoews> cool. thanks for taking the time to reach out.
16:15:13 <cdent> yay!
16:15:22 <etoews> #topic summit recap
16:15:29 <elmiko> thanks piet !
16:15:32 <etoews> #link https://etherpad.openstack.org/p/austin-api-wg-session-plans
16:15:46 <etoews> let's try to make sense of the summit session and extract action items (to be put into https://bugs.launchpad.net/openstack-api-wg)
16:16:15 <elmiko> cdent had a nice idea too, we should probably craft a recap email to the ml as well
16:16:24 <cdent> That's seems to be the trend
16:16:49 <etoews> agreed it's a good idea...that i personally wouldn't have time for.
16:17:24 <elmiko> i could probably distill the etherpad down into an email, if i sent it monday does that work for everyone?
16:17:33 <cdent> elmiko++
16:17:46 <elmiko> k, i'll target for that then
16:17:51 <etoews> ++
16:18:22 <etoews> #action elmiko: recap summit session in email to openstack-dev
16:18:49 <elmiko> the whole api-wg endorsed tag thing, seems like it could be a big design effort on our part. at least to figure out the metrics for inclusion.
16:19:11 <elmiko> but would be a huge asset in the carrot/stick effort to get projects on-board
16:19:29 <cdent> so the idea is that a project can declare "we follow the guidelines"
16:19:36 <elmiko> something like that, yea
16:19:36 <etoews> basically
16:19:44 <cdent> and every now and again people would check, in some fashion
16:19:50 <elmiko> and from the looks of it, thingee agreed to help out with the tag investigation side of it
16:19:51 <etoews> but we'd need some hard criteria for that
16:19:54 <cdent> or demonstrate
16:20:02 <elmiko> yea, +1 for hard criteria
16:20:14 <etoews> we were tossing around the idea of using gabbi to do so
16:20:22 <elmiko> hehe, was just typing that
16:20:38 <cdent> well part of the reason I made the gabbi-tempest thing is to make it easy for people to dynamically create tests against any service that is able to run in devstack (with tempest available)
16:21:10 <elmiko> it would be cool if we could have a gabbi template that contained the tests that a project would need to pass for compliance with the guidelines
16:21:11 <cdent> so one way to do it would be for rather than us creating a set of tests that are generic
16:21:27 <cdent> people instead create their own suite that people can look at to say "yup, looks good!"
16:21:37 <etoews> yep.
16:21:39 <cdent> elmiko: I'm not sure that's possible
16:21:46 <elmiko> i think they would need to create their own tests, but don't we need to tell them what tests?
16:22:06 <cdent> aren't the guidelines us saying what the tests are?
16:22:08 <etoews> "what tests" would be something of a spec
16:22:14 <etoews> basically
16:22:28 <elmiko> ok, so more of a descriptive document than something code-backed
16:22:40 <elmiko> yea, good point
16:23:06 <etoews> i'm envisioning a single doc that brings the guidelines together in a checklist fashion
16:23:13 <etoews> projects implement tests based on that
16:23:51 <cdent> that sounds good
16:23:59 <elmiko> etoews: +1
16:24:33 <cdent> does this mean that any new guideline should potentially add to that document as part of its patch? or should that happen separately?
16:24:42 <etoews> i won't be surprised if it lends itself to further refinement of the guidelines.
16:25:01 <etoews> adding as part of the patch is probably best
16:25:09 <elmiko> +1 for part of the patch
16:25:21 <elmiko> and this probably requires a fix to the process doc as well ;)
16:25:52 <cdent> I think the process doc is somewhat antiquate and doesn't adequately reflect our "mission" which has evolved somewhat and that's great
16:26:17 <elmiko> hmm, interesting thought
16:26:18 <etoews> i'm always up for less process
16:27:04 <cdent> All I'm saying is that there are probably more than one fix that the doc needs
16:27:21 <etoews> sure. no need to bite it all off at once though.
16:27:58 <cdent> yup
16:28:02 <etoews> so should we create an issue for this in https://bugs.launchpad.net/openstack-api-wg ?
16:28:21 <cdent> \o/
16:28:37 <etoews> okay. i'll come up with something right now.
16:28:46 <etoews> please continue on with the summit recap
16:29:47 <elmiko> ok, so yea, guideline tag was a big discussion point as it pertained to giving the wg a little more weight in the community
16:30:02 <elmiko> better signaling from the wg was another big topic
16:30:15 <elmiko> how can we more clearly inform when new guidelines are added, send more email , etc
16:30:30 <elmiko> this dovetails with the conversation that cdent and i had about how much email
16:30:50 <elmiko> and the community consensus seemed to be that a weekely "what's up doc" style email would be appreciated
16:30:52 <cdent> besides thingee were there other cross project type folks there who had anything to say about "weight in the community"
16:31:25 <elmiko> yea, i believe devananda was quite interested in how the api-wg could have greater effect in the community
16:31:46 <elmiko> there might have been a few more whose names i am forgetting at the moment
16:32:25 <elmiko> some good suggestions came up about emailing CPLs when new guidelines are added
16:32:56 <cdent> we have the script that adds them to reviews but this suggestion is for when they merge?
16:33:06 <elmiko> also, targetted emails when an APIImpact tag has been applied. basically to help inform the project teams about that
16:33:17 <elmiko> right, when they merge
16:33:38 <elmiko> so, we make our weekly email, and maybe just CC all CPLs directly
16:34:03 <elmiko> weekly email could have, guidelines in freeze, recently merged, apiimpact, and aob
16:34:07 <cdent> if we do that it should be BCC otherwise the replay all goes crazy
16:34:12 <elmiko> +1
16:34:20 <cdent> but I'd much rather that the cpls just pay attention to the [api] tag on the ml
16:34:36 <elmiko> yea, i think we all would ;)
16:34:48 <cdent> my point is: if they don't, they don't get the tag...
16:35:01 <cdent> s/don't/can't/
16:36:03 * devananda perks up, reads backscroll
16:36:40 <elmiko> devananda: we're recapping the summit session for api-wg
16:37:14 <elmiko> so, another topic was improving the guidelines with more examples from the field, so to say
16:37:24 <elmiko> i think this kinda fits into our design work
16:37:33 <elmiko> maybe a way to link between the guidelines and the design, not sure
16:38:28 <elmiko> there was a strong suggestion to cleanup our specs landing page, basically to help people in seeing which links are placeholders and which have info
16:38:36 <elmiko> i think we could definitely do more in this area
16:39:13 <elmiko> we agreed to axe the 0000UTC meeting, and just move back to weeklies at the normal time
16:39:57 <elmiko> i /think/ that covers most of it
16:40:14 <cdent> The current specs landing page implies that all of the guidelines are a draft and that at some point the entire things is going to be "published" upon approval by the TC.
16:40:16 <elmiko> i may be missing some details about our conversations surrounding the integration with other WGs
16:40:24 <elmiko> ooph
16:40:27 <cdent> Is any of that actually meaningful, given that we want people to treat the guidelines and rule, now
16:40:33 <elmiko> so, yea, it needs a rebuff
16:40:45 <cdent> We need more participants
16:40:54 <elmiko> that came up several times as well ;)
16:41:03 <cdent> Or to actualized the observers a bit more
16:41:43 <elmiko> i think that is closer to the truth
16:41:59 <elmiko> we get great feedback, but when the collection plate is passed, no coinage =(
16:42:21 <cdent> heh
16:42:32 <elmiko> i think, this is why the tag talk came up. it's something concrete we can use with projects to help them.
16:42:36 <cdent> that's the nature of our interrupt driven culture
16:42:40 <elmiko> maybe help roust people
16:42:46 * cdent nods
16:42:46 <elmiko> right
16:42:59 <cdent> It sounds like it was a really good session.
16:43:02 * cdent is very disappointed
16:43:30 <elmiko> yea, was really good. definitely missed your presence /sniffle
16:44:22 <elmiko> etoews: that's all i have, did you want to add anything?
16:44:46 <etoews> #action etoews: create issue for guideline compliance doc
16:44:50 <etoews> done!
16:44:53 <etoews> #link https://bugs.launchpad.net/openstack-api-wg/+bug/1578728
16:44:54 <openstack> Launchpad bug 1578728 in openstack-api-wg "Guideline compliance doc" [Undecided,New]
16:45:00 <elmiko> nice!
16:45:40 <etoews> elmiko: any action items to come out of the above?
16:46:20 <elmiko> we do have some loose action items, but i imagine we will need to consider how we will go forward with them as action items.
16:46:47 <elmiko> imo, we should talk next week after the email is out and we make a plan for acting on the issues
16:47:08 <elmiko> like, increasing our email output, fixing the specs front page, gabbi testing, etc...
16:47:25 <elmiko> i think we need to have stronger plans before we start making some action items
16:47:51 <elmiko> oh, one thing i missed
16:48:08 <cdent> elmiko: it sounds like in addition to your email summarizing the sesion, it needs to also needs to summarize this summary here :)
16:48:12 <elmiko> we were asked to make a clearer message about how the APIImpact tag should be used and what we will do with it.
16:48:18 <elmiko> cdent: haha
16:48:46 <elmiko> i'll try to bring it all together
16:49:16 <cdent> unless we have more horses in the race, I'm concerned that using APIImpact as a way to call for the api-wg to come visiting is going to lead to disappointment
16:49:34 <elmiko> yup, we discussed that too
16:49:40 <elmiko> basically, we need more engagement from CPLs
16:49:44 <cdent> because I don't know about you guys, but that's one of the things that falls off the bottom of my to do list
16:49:52 <elmiko> yea, for sure
16:50:15 <elmiko> but, if we communicated to people exactly how we work with the APIImpact, maybe it would help bring folks to meetings
16:50:23 <cdent> yes, very true
16:50:32 <elmiko> so, instead of just fire-and-forget, APIImpact should be a way to help start a conversation with the api-wg
16:50:43 * cdent nods
16:50:53 <etoews> i also made the point that in many cases an APIImpact review is flat out difficult to review
16:51:21 <etoews> if there are no doc changes, we have to wade through code just to understand the impact to the api
16:51:35 <etoews> i think that'll get better now that api docs are moving in tree
16:51:44 <cdent> yeah, good point
16:51:49 <etoews> #action etoews: axe the 0000 utc meeting
16:51:51 <etoews> done!
16:51:53 <etoews> #link https://review.openstack.org/313053
16:52:01 <cdent> huzzah
16:52:21 <elmiko> hehe nice!
16:53:00 <cdent> etoews: I think you missed a bit, left a comment
16:53:18 <etoews> cdent: elmiko: did we want to go weekly?
16:53:28 <elmiko> etoews point about the reviews was good too, we discussed having better commit messages to help direct api reviews
16:53:38 <elmiko> etoews: i thought we had agreed to that
16:54:04 <etoews> my brain was probably somewhere else at the time
16:54:09 <etoews> will fix
16:54:13 <elmiko> heh, i know the feeling ;)
16:54:41 <cdent> I reckon even if we don't have specific things on the agenda, having the slot will give us workshopping time that is reserved
16:55:07 <cdent> that might be useful to me (I'm struggling with the discovery that I need to be better at timeboxing, makes me sad)
16:56:18 <elmiko> yea.. having a schedule is so.... restrictive ;)
16:56:29 <etoews> that's exactly want out of it too.
16:56:44 <etoews> less TODOs and more work during the meeting
16:57:05 <etoews> i definitely have a finite amount of time i can commit to the api wg
16:57:16 <etoews> need to make the most of it
16:57:35 <cdent> we should totally find someone who has infinite time to commit, they'd get so much done
16:57:54 <elmiko> lol
16:57:55 <etoews> no doubt
16:57:57 <etoews> :)
16:57:58 * cdent loves idiom
16:58:38 <etoews> anything else?
16:59:19 <cdent> I think the "else" will come in response to elmiko's forthcoming email (which I'm told is going to be _amazing_).
16:59:20 <elmiko> nothing here
16:59:26 <elmiko> haha
16:59:36 <elmiko> no pressure though, right?
16:59:42 <etoews> yep. i heard it's going to be amazing too.
16:59:44 <etoews> :)
16:59:46 <elmiko> lol
16:59:57 <etoews> elmiko: feel free to link to that new compliance issue
17:00:02 <elmiko> "it was the best of times, it was the APIImpact of times..."
17:00:06 <etoews> just as an early signal to the community
17:00:11 <etoews> we're done!
17:00:11 <etoews> #endmeeting