16:00:28 <elmiko> #startmeeting api wg
16:00:29 <openstack> Meeting started Thu May 19 16:00:28 2016 UTC and is due to finish in 60 minutes. The chair is elmiko. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:32 <openstack> The meeting name has been set to 'api_wg'
16:00:34 <cdent> o/
16:00:42 <elmiko> hi
16:00:57 <cdent> do we have any other participants?
16:01:14 <elmiko> excellent question =)
16:02:08 <elmiko> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:02:26 <elmiko> #topic previous meeting action items
16:02:34 <elmiko> since we didn't meet last week, these are still good
16:02:41 <elmiko> #link http://eavesdrop.openstack.org/meetings/api_wg/2016/api_wg.2016-05-05-16.00.html
16:02:59 <elmiko> i did mine, and i/think/ etoews covered his as well
16:03:08 <cdent> yes, I believe he did
16:03:14 <elmiko> cool
16:03:50 <elmiko> hmm, need to groom this agenda slightly
16:05:05 <elmiko> #topic guidelines
16:05:12 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:05:24 <elmiko> is there anything we need to freeze?
16:05:37 <cdent> oh hey, there are new things there I hadn't seen yet
16:05:53 <elmiko> we should just merge this https://review.openstack.org/#/c/312970/1
16:06:59 <cdent> done
16:07:30 <elmiko> thanks
16:07:41 <elmiko> https://review.openstack.org/#/c/312971
16:07:57 <elmiko> that seems easy too, but i like the suggestion
16:08:55 <elmiko> should we put this up for freeze? https://review.openstack.org/#/c/281511
16:09:09 <cdent> I've fixed 312971 in place
16:09:23 <elmiko> ah, excellent!
16:10:05 <cdent> so we can probably merge that one too, if you liked to do those honors?
16:10:06 <elmiko> this is probably ready for freeze as well https://review.openstack.org/#/c/301846
16:10:15 <elmiko> sure
16:10:58 <elmiko> ok then
16:11:27 <elmiko> i think we should propose these for freeze, https://review.openstack.org/#/c/301846 , https://review.openstack.org/#/c/281511
16:11:31 <cdent> on metadata changes, there are still some unresolved comments on etag stuff, but maybe not worth fussing
16:11:43 <elmiko> yea, we might as well put them up
16:11:58 <cdent> yeah more eyes would be good
16:12:10 <elmiko> do you want to take the action or shall i?
16:13:43 <elmiko> ok, i'll take it ;P
16:13:57 <cdent> sorry, I'm being a bad multitasker :(
16:14:15 <cdent> but yes, if you could do the honors that would be great
16:14:15 <elmiko> #action elmiko propose 301846 and 281511 for freeze
16:14:23 <elmiko> no worries, these are pretty low bandwidth actions for me
16:15:38 <elmiko> the other guidelines look like they need some work
16:16:34 <elmiko> #topic weekly email
16:16:49 <elmiko> not sure if we want to dive into this, but i wanted to mention it
16:17:05 <cdent> agree that other guidelines need work
16:17:24 <cdent> yeah, weekly email a) great idea b) hard to do
16:17:36 <elmiko> right
16:17:52 <elmiko> i wonder if we could start by coming up with a template or something?
16:18:18 <elmiko> maybe annegentle would share some secrets learned from the "What's up doc" emails =)
16:18:27 <annegentle> heya
16:18:30 <elmiko> =D
16:18:51 <elmiko> we're talking about the possibility of doing a weekly email from the api-wg. any advice you might have to share?
16:18:52 <annegentle> I do think that ML post regularly does help, since people know they can look it up later for a point-in-time.
16:19:50 <annegentle> I think you could have a simple 3-header template. Stuff in progress, stuff to think about and join in the discussion (needs input), status/done.
16:19:56 <annegentle> that's a terrible outline :)
16:20:00 <annegentle> but you hopefully get the gist
16:20:30 <elmiko> do you use a template with the doc emails?
16:20:33 <cdent> it's a good structure: simple, meaningful
16:20:42 <annegentle> yeah it was simply a text file with headers
16:20:47 <annegentle> super low tech
16:20:48 <elmiko> ok, cool
16:21:15 <elmiko> should we make a wiki page to iterate on the template?
16:21:53 <annegentle> one thing lana moved to was a weekly etherpad update for everyone to add to by a certain day
16:21:58 <annegentle> then she can include that info in the weekly email
16:22:07 <elmiko> ah, nice. that's a good idea
16:22:12 <annegentle> so for docs, it's a specialty team etherpad
16:24:20 <elmiko> ok, so now the tough question. do you want to take this or shall i? (cdent)
16:24:38 <elmiko> probably makes sense for me to drive it for now
16:24:49 <elmiko> unless you want it
16:25:22 <cdent> elmiko: given your extraction I figured it would have to be me, but given my complete awash in resource providers it being you is nice
16:25:35 * cdent is frusrated
16:25:48 <elmiko> ok, i'll get the ball rolling then we can figure out who does the weekly mails later
16:25:48 <cdent> so frustrated I'm spelling even worse than usual
16:25:52 <elmiko> haha
16:25:54 <cdent> +1
16:26:05 <elmiko> #action elmiko setup wiki page with some details about weekly email from api-wg
16:26:08 <elmiko> that sound good?
16:26:24 <elmiko> i'll incorprate an etherpad for suggestions and a template for the email
16:29:04 <cdent> ossum
16:29:43 <elmiko> ok
16:29:48 <elmiko> #topic APIImpact
16:29:55 <elmiko> #link https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z
16:30:22 <elmiko> not sure if we want to address anything, but i want to give for any reviews that lurkers may want to bring up ;)
16:30:23 <cdent> I'm way behind on these
16:30:27 <elmiko> same
16:30:44 <elmiko> and this is one of the points we have about clarifying how APIImpact is sued
16:30:48 <elmiko> er, used
16:32:00 <elmiko> ok, then
16:32:04 <elmiko> #topic open discussion
16:32:11 <elmiko> anything else we should discuss?
16:32:59 <cdent> maybe annegentle can give us a crash course in "how to remain engaged in a cross project thing and keep sane and get stuff done"
16:33:07 <elmiko> haha, +1
16:33:27 <edleafe> cdent: no such thing exists :)
16:33:44 <cdent> edleafe: did you just rise from the ashes?
16:34:05 <edleafe> nah, I've been popping in here while doing 6 other things
16:34:07 <cdent> music plays, coffin opens, edleafe intones "sorry, mate, no can do"
16:34:23 <elmiko> lol!
16:36:51 <elmiko> shall we reclaim part of the day?
16:37:55 <cdent> yessir
16:38:38 <cdent> I promise to become a good api-wg-member asap
16:38:42 <elmiko> cool, take care, see ya next week o/
16:38:47 <elmiko> hehe, no worries =)
16:38:52 <elmiko> #endmeeting