16:01:39 <elmiko> #startmeeting api-wg
16:01:39 <openstack> Meeting started Thu Sep 8 16:01:39 2016 UTC and is due to finish in 60 minutes. The chair is elmiko. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:43 <openstack> The meeting name has been set to 'api_wg'
16:01:44 <openstack> etoews: Error: Can't start another meeting, one is in progress. Use #endmeeting first.
16:01:59 <etoews> lol.
16:02:02 <elmiko> oops, i flubbed the start meeting
16:02:18 <elmiko> should i undo then restart?
16:02:22 <elmiko> #undo
16:02:35 <etoews> nope. i flubbed it. no need to restart i think.
16:02:53 <etoews> i was just popping up to say i can't make it :)
16:02:54 <scottda> hi
16:02:57 <elmiko> ok, didn't i mess up the name though?
16:03:01 <elmiko> haha
16:03:03 <elmiko> hi scottda
16:03:05 <cdent> elmiko: you did it right
16:03:08 <cdent> I'm only half here
16:03:17 <elmiko> k
16:03:25 <elmiko> #chair cdent elmiko etoews
16:03:26 <openstack> Current chairs: cdent elmiko etoews
16:03:34 <gouthamr> hi
16:03:34 <elmiko> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda\
16:03:38 <elmiko> #undo
16:03:39 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x7f23bd8685d0>
16:03:41 <elmiko> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:04:25 <elmiko> i think this is gonna get screwed up in the log archives. i named the meeting "api-wg" should be "api wg"
16:04:45 <elmiko> ah well, maybe meetbot did the right thing
16:04:53 <cdent> elmiko: i think it translates
16:04:58 <elmiko> yeah, looks like it
16:05:12 <elmiko> i don't think we had any action items from last time
16:05:41 <elmiko> #topic Consistent endpoint discover
16:05:49 <elmiko> #link http://markmail.org/message/o4k7wd7vqxon2ypk
16:06:14 <elmiko> not sure who added this topic, does anyone have a comment on it?
16:07:18 <cdent> that was me, I thought the email was relevant to us, but couldn't decide, wanted to highlight it
16:07:26 <elmiko> cool
16:07:36 * elmiko still reading it
16:09:14 <elmiko> interesting topic, i'm not exactly clear on the course of action. dont' microversion already get us to a point of determinism for the resources?
16:10:15 <cdent> the concern there is that there's no clean way to get the microversion info
16:10:22 <cdent> for many situation you get /
16:10:27 <cdent> but sometimes that is authed
16:10:30 <cdent> sometimes it is not there
16:10:44 <elmiko> oh, gotcha
16:11:06 <elmiko> i thought we had talked about standardizing a version response endpoint
16:12:00 <elmiko> yeah, we started this:
16:12:02 <gouthamr> https://wiki.openstack.org/wiki/API_Working_Group/Current_Design/Entry_Points
16:12:03 <elmiko> #link https://wiki.openstack.org/wiki/API_Working_Group/Current_Design/Version_Responses
16:12:03 <gouthamr> ?
16:12:33 <elmiko> those 2 pages could probably be related
16:13:08 <gouthamr> true..
16:13:26 <gouthamr> what could be the rationale behind not requiring authentication though?
16:13:28 <scottda> I'll update that cinder/block storage part...we've v3 endpoint now with microversions.
16:14:14 <elmiko> gouthamr: i think mainly so you could discover things like version level, which may or may not be seen as needing auth
16:15:53 <gouthamr> elmiko: yes, but i'm thinking in terms of applications that might initialize client/s with that information.. and that would be used to make other requests.. so, the auth information should be there?
16:16:14 <elmiko> yeah, that makes sense
16:16:32 <elmiko> i'm not sure about the intent behind having this info not require auth
16:17:01 <cdent> elmiko: i think it is more about consistency than any particular preference
16:17:09 <elmiko> ah, gotcha
16:17:45 <elmiko> so, i guess my question is, do we want to take the version response research and attempt to craft a guideline based on it?
16:17:56 * elmiko double checks to make sure we didn't do that already
16:18:33 <elmiko> yeah, i don't see anything yet
16:18:48 <gouthamr> https://specs.openstack.org/openstack/api-wg/guidelines/microversion_specification.html#version-discovery
16:19:15 <elmiko> ah, nice. good one gouthamr
16:19:24 <elmiko> i thought we did something about this lol
16:20:53 <gouthamr> elmiko: yes, the guideline already suggests that the versions endpoint "should return the minimum and maximum versions".. we should probably address the concern regarding authentication there
16:21:03 <elmiko> unfortunately, it seems like we need to get consistency about the version negotiations
16:21:19 <elmiko> yeah, what is the guidance though?
16:22:00 <elmiko> i mean, i don't see a reason to have the root version endpoint be authenticated, but that's just my opinion
16:22:39 <gouthamr> hmmm, not sure on this one.. nova, cinder, manila require authentication
16:22:50 <scottda> I don't think cinder does...
16:23:05 <gouthamr> oh.. might be wrong..
16:23:31 <elmiko> maybe we should start by doing an analysis of the services now
16:23:35 <scottda> no, cinder does not need auth
16:23:45 <elmiko> look through them all and see who wants auth for that endpoint
16:24:13 <elmiko> if a majority require auth, no reason to advice against that
16:24:18 <scottda> What about keystone? How do we figure out which version (when they have microversions) if we need auth to check?
16:24:27 <elmiko> good point
16:25:45 <elmiko> i guess that's partially why i'm in favor of no auth for version discovery. but, this is an effort someone would need to champion across the projects, just as Krotscheck suggests in the email
16:26:32 <gouthamr> scottda elmiko: okay, i was wrong.. manila doesn't need auth too
16:26:58 <scottda> gouthamr: That makes sense. Since I copied Cinder's from Manila :)
16:27:54 <gouthamr> scottda: :) and we copied from nova.. so.. lemme quickly confirm nova's status
16:28:40 <gouthamr> okay, not sure how the OP tested this.. but http://paste.openstack.org/show/569259/
16:29:37 <elmiko> not sure, maybe worth engaging on the ml
16:29:44 <cdent> It's quite likely things have changed
16:29:45 <gouthamr> elmiko: +1
16:30:10 <cdent> In any case we don't need to solve this today, the agenda item was: do we own this. Sounds like we do :)
16:30:53 <elmiko> gouthamr: would you be willing to make a response on the ml?
16:31:21 <gouthamr> elmiko: sure thing
16:31:25 <elmiko> thanks!
16:31:52 <elmiko> #action gouthamr respond to Michael Krotscheck's email about consistent endpoint discovery
16:32:06 <elmiko> #topic Prepping any summit stuff
16:32:23 <elmiko> who else aside from cdent is going to barcelona?
16:33:04 <gouthamr> scottda and I will be there..
16:33:06 <scottda> I'm not sure yet, but probably I will go.
16:33:09 <elmiko> very cool!
16:33:14 <gouthamr> oh :P you have a talk scottda
16:33:15 <gouthamr> https://www.openstack.org/summit/barcelona-2016/summit-schedule/events/15434/api-microversions-for-operators-what-why-and-how
16:33:27 <elmiko> cdent: are you going to lead a wg session?
16:33:42 <scottda> gouthamr: I'm pretty sure, but things change within my company, so I'm being cautious...
16:33:48 <gouthamr> scottda: :)
16:34:27 <cdent> elmiko: I had hoped to ask about that today and get suggestions on what it should do, if it is just me and the limited space available ,etc
16:34:36 <elmiko> k
16:34:36 <cdent> but myattention is very partial right now
16:34:43 <elmiko> maybe we keep this on the agenda till next week then
16:35:04 <elmiko> if we do a session, we'll need the usual etherpad with topics, etc
16:35:21 <elmiko> although, next thursday is the deadline...
16:35:47 <elmiko> cdent: etoews: maybe we should shoot for a BoF gathering instead of a full session if it's going to be light?
16:35:58 <cdent> we can do some email, especially since next thursday I'll be at pyconuk
16:36:04 <elmiko> k
16:36:08 <elmiko> we'll table for now then
16:36:11 <cdent> yeah bof seems nice
16:36:27 <elmiko> might be more appropriate, although we did have a good crowd in austin
16:36:36 <elmiko> #topic guidelines
16:36:43 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:36:51 <elmiko> only one open right now, not a guideline per se
16:37:09 <elmiko> i like you suggestions cdent, i need to make another version but could use a little more advice
16:39:06 <elmiko> #topic bug review
16:39:12 <elmiko> #link https://bugs.launchpad.net/openstack-api-wg
16:39:16 <cdent> yeah, I just saw that, will think about it
16:39:25 <elmiko> cool, thanks cdent !
16:39:27 <cdent> no new bugs, and no recent changes except for your thing
16:39:45 <elmiko> we still have several open bugs, just wanted to post in case folks are looking for something to do =)
16:40:00 <elmiko> i'm not taking a new one till i finish that one ;P
16:40:41 <elmiko> #topic APIImpact
16:40:46 <cdent> i have doing the one about summary of testing types on my to do list but it keeps getting deferred
16:40:52 <elmiko> #link https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z
16:40:57 <elmiko> cdent: i hear that...
16:41:13 <elmiko> any APIImpact reviews that people would like to highlight?
16:43:50 <elmiko> #topic open mic
16:43:55 <elmiko> any other business?
16:44:11 <elmiko> i can handle the weekly newsletter
16:44:25 <cdent> reality presents many challenges in the face of doing cross project stuff :(
16:44:31 <cdent> this is an upsetting problem
16:44:33 <elmiko> so true...
16:49:49 <elmiko> cdent: do you have a link to notmyname's comments about the payload stuff?
16:50:09 * cdent thinks
16:50:42 <elmiko> i'm trying to remember where that was
16:50:50 <elmiko> it was like a review or something
16:50:58 <cdent> https://review.openstack.org/#/c/322194/
16:51:02 <cdent> not a lot there, but some
16:51:06 <elmiko> thanks!
16:51:12 <cdent> and some here https://review.openstack.org/#/c/354266/
16:51:14 <cdent> both very short
16:52:06 <notmyname> payload?
16:52:18 * notmyname tries to catch up
16:52:21 <notmyname> what's going on?
16:52:39 <elmiko> we are trying to address some comments you had about the implicit assumptions in the api-wg guidelines about json bodies and whatnot
16:53:04 <elmiko> we'd like to be more clear about what we are generally referring to when speaking about APIs and their payload contents
16:53:06 <notmyname> ah, ok. cool
16:53:15 <elmiko> i think we all agree you made some very salient points
16:53:32 <notmyname> thanks
16:54:19 <elmiko> and thank you for the input =)
16:54:50 <notmyname> is there something further I can help with?
16:55:05 <elmiko> i don't think so, i just wanted to have some links to provide reference for our newsletter
16:56:33 <elmiko> #topic weekly newsletter
16:56:40 <elmiko> #link https://etherpad.openstack.org/p/api-wg-newsletter
16:56:47 <elmiko> cdent: that look good to you ^^
16:57:01 * cdent reads
16:57:50 <cdent> quick skim reads well
16:57:56 <elmiko> cool, thanks
16:58:43 <elmiko> if there is no other business, i'm gonna end the meeting
16:58:49 <elmiko> thanks everyone for showing up!
16:59:01 <elmiko> #endmeeting