16:00:01 <etoews> #startmeeting api wg
16:00:02 <openstack> Meeting started Thu Oct 6 16:00:01 2016 UTC and is due to finish in 60 minutes. The chair is etoews. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:06 <openstack> The meeting name has been set to 'api_wg'
16:00:12 <openstack> cdent: Error: Can't start another meeting, one is in progress. Use #endmeeting first.
16:00:12 <cdent> you win!
16:00:21 <etoews> #chair cdent elmiko etoews
16:00:21 <openstack> Warning: Nick not in channel: elmiko
16:00:22 <openstack> Current chairs: cdent elmiko etoews
16:00:34 * etoews hits cdent with a #chair
16:00:46 * sigmavirus lurks
16:01:14 * cdent makes customary wave to mlavalle
16:01:24 <cdent> sigmavirus: nice to have you with us
16:01:28 <etoews> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:01:37 <etoews> #topic previous meeting action items
16:01:54 <etoews> #link http://eavesdrop.openstack.org/meetings/api_wg/2016/
16:02:12 * mlavalle customarily waves back at cdent :-)
16:02:17 <etoews> i've been out of touch. what's been happening?
16:02:46 <cdent> I had one, about usability study. From what I can tell piet is no longer going to be doing them, perhaps because he won't be at summit
16:03:06 <cdent> In any case I've heard nothing since early inquiries about it
16:03:19 <etoews> alrighty
16:04:00 <etoews> #topic open mic
16:04:02 <cdent> so I think that's stalled (again)
16:04:12 <cdent> ah these are all me:
16:04:47 <cdent> on summit: I signed up for a birds of a feather session for api-wg and never heard anything back. it was only this week that I realized I had not, so I've not followed up to see if anything is happening. Will do that
16:04:53 <cdent> #action: cdent to query about summit bof session
16:05:44 <cdent> "sevice catalog thoughts" is a revisit of an old topic: improving the service catalog to be more consistent and authoritative.
16:06:09 <cdent> I'm bringing it up here because I asked the people in the newly formed architecture working group if that is something they, us, both should take on
16:06:30 <etoews> there was a big push around that a year or so ago. i don't know what came of it.
16:06:54 <cdent> It was agreed that it is something that needs to happen and since it doesn't currently have a lot to do with HTTP guidelines that it would be driven in the arch-wg, for now.
16:07:10 <cdent> Yeah, I was a part of that push and it stalled on more practical matters (as usual)
16:07:29 <etoews> at least arch-wg is picking up the torch?
16:07:37 <cdent> yeah
16:07:56 <cdent> they've got some buzz/energy at the moment to at least identify important issues
16:08:15 <cdent> so no action for us on that, at least for now
16:08:21 <etoews> is there a link you can share where the work is going on?
16:08:26 <gouthamr> nice.. iirc that was around the microversion header issue...
16:08:52 <cdent> nothing solid yet but: https://etherpad.openstack.org/p/arch-wg-status-board
16:08:57 <cdent> #link: https://etherpad.openstack.org/p/arch-wg-status-board
16:09:39 <cdent> gouthamr: some of it was what should go in the microversion header, but that became the service-authority discussion, which was registering service types/names in the era of the big tent
16:10:00 <cdent> the service catalog was more about making sure that interations with a service catalog on any cloud can be expected to work similarly
16:10:24 <etoews> lol
16:10:26 <etoews> > because like a good rug, the service catalog really pulls the room together.
16:10:31 <gouthamr> cdent: yes.. i recall service-types-authority #link https://review.openstack.org/#/q/project:openstack/service-types-authority
16:10:43 <cdent> thank you etoews ! I'm so glad someone reacted to that
16:11:27 <etoews> is "filtering on time intervals" also you cdent ?
16:11:39 <cdent> yeah, I just wanted to draw attention to it so people will comment
16:11:57 <cdent> I think I mostly agree with the "just use a comma" message that was at the end of the thread a few minutes ago
16:12:24 <cdent> but since it is a message that was directed at us directly, we ought to say/do something
16:12:32 <etoews> ah. [API WG] instead of [api] missed my filter.
16:16:02 <etoews> sounds like they might need a new operator?
16:17:26 <cdent> I'm not sure. I find the filtering style in the guideline to be strange in the first place (haven't got an immediate alternative) so I'm not clear on what's right
16:18:02 <cdent> to me there are two divergent goals: avoid proliferating too many filtering parameters
16:18:19 <cdent> express date ranges and absolute dates
16:18:39 <cdent> given those: finished_at=between:timea,timeb
16:18:44 <cdent> makes fair sense
16:20:39 <cdent> We don't have to decide here, I just wanted to make sure that we reacted
16:20:49 <cdent> ready to move one?
16:20:50 <etoews> agreed. i was going to suggest something closer to the iso standard. ?finished_at=time_interval:<ISOdate_a>/<ISOdate_b>
16:20:50 <cdent> on!
16:21:12 <etoews> but that `/` is probably inconvenient
16:21:20 <cdent> yeah
16:21:28 <etoews> who is responding to the email?
16:21:40 <etoews> you, me, someone else?
16:22:02 <etoews> we should ask them to propose a change to the filtering guideline
16:22:23 <etoews> i'm fine with responding
16:22:42 <cdent> go for it, if it meanders I'll jump in too
16:24:38 * etoews reads up on whole thread and starts to reply
16:25:22 <cdent> in the meantime if you agree etoews I'll freeze: https://review.openstack.org/#/c/364460/
16:25:32 <etoews> sure
16:25:40 <cdent> I think that one, despite being not quite a guidelines is probably freezeworthy
16:34:15 <etoews> response sent
16:34:29 <etoews> anything anyone else want to bring up in open mic?
16:35:39 <etoews> #topic guidelines
16:35:47 <etoews> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:36:00 <etoews> heh. well that's that.
16:36:52 <cdent> yup, I mentioned to elmiko a few days ago that I'm going to try harder to mark out time to work on writing guidelines, henceforth, but that may not come about in any real form until after summit
16:37:03 <cdent> but I'd like to address the bug list, as I can
16:39:24 <cdent> the bug list has not changed since last week
16:39:26 <etoews> sounds good. it's unlikely i'll be able to tackle anything in oct.
16:40:15 <cdent> for the past few weeks (months?) we've been mostly ignoring the APIImpact tag, hoping that people will bring things up here as needed, until we get some more cycles
16:40:30 <etoews> agreed
16:40:34 <cdent> and I've started editing today's newsletter over at:
16:40:39 <cdent> #link: https://etherpad.openstack.org/p/api-wg-newsletter
16:40:39 <etoews> oh nice
16:40:51 <cdent> in fact it might be done
16:41:21 <etoews> ship it.
16:41:27 <cdent> ✔
16:42:41 <cdent> done
16:43:43 <cdent> Anybody have anything else?
16:44:18 <etoews> nada
16:45:15 <cdent> Then I think that's it, I'm going to do the honors since I lost out on the star.
16:45:20 <cdent> t
16:45:25 <etoews> have at it :)
16:45:27 <cdent> #endmeeting