#openstack-meeting-3: api-wg

Meeting started by cdent at 16:00:45 UTC (full logs).

Meeting summary

    1. agenda: https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (cdent, 16:01:05)

  1. action items from last meeting (cdent, 16:02:49)
    1. https://www.openstack.org/summit/barcelona-2016/summit-schedule/events/16817/api-working-group-meetup (cdent, 16:03:46)

  2. open mic (cdent, 16:04:33)
    1. api usability: https://wiki.openstack.org/wiki/UX#Participate_in_a_usability_study_being_conducted_at_the_Barcelona_Summit.21 (cdent, 16:06:20)
    2. https://etherpad.openstack.org/p/osux-api-oct2016 (etoews, 16:08:29)
    3. error knowledge base proposal: https://docs.google.com/document/d/1fdRuPsIenaulxjXGgEK35UeWORiwOPpdX7OxL6E-ICw/edit (cdent, 16:17:23)
    4. same doc but on etherpad https://etherpad.openstack.org/p/api-error-messages ;) (ediardo, 16:18:08)
    5. And made this website http://172.99.106.155/exceptions/ (ediardo, 16:18:42)

  3. GET with request body vs. querystring vs. POST (edleafe) (cdent, 16:35:41)
    1. came up in review https://review.openstack.org/#/c/300178/ (cdent, 16:35:55)
    2. with commentary on https://review.openstack.org/#/c/385618/1/specs/ocata/approved/resource-providers-get-by-request.rst (cdent, 16:36:08)
    3. and references in http://stackoverflow.com/questions/978061/http-get-with-request-body (cdent, 16:36:26)
    4. etherpad discussing other proposals: https://etherpad.openstack.org/p/placement-request-providers (cdent, 16:40:58)
    5. ACTION: : edleafe will write up proposed guideline for complex queries (cdent, 16:50:24)

  4. null/special case in time intervals: https://review.openstack.org/#/c/383862/8 (cdent, 16:55:11)
    1. ACTION: elmiko make the newsletter go (cdent, 16:59:19)


Meeting ended at 17:00:07 UTC (full logs).

Action items

  1. : edleafe will write up proposed guideline for complex queries
  2. elmiko make the newsletter go


Action items, by person

  1. edleafe
    1. : edleafe will write up proposed guideline for complex queries
  2. elmiko
    1. elmiko make the newsletter go


People present (lines said)

  1. cdent (84)
  2. edleafe (43)
  3. elmiko (36)
  4. etoews (31)
  5. ediardo (31)
  6. piet_ (5)
  7. openstack (5)
  8. jlopezgu (1)


Generated by MeetBot 0.1.4.