#openstack-meeting-3: api-wg

Meeting started by cdent at 16:00:09 UTC (full logs).

Meeting summary

    1. agenda https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (cdent, 16:00:51)

  1. old biz (cdent, 16:01:23)
    1. last minutes http://eavesdrop.openstack.org/meetings/api_wg/2017/api_wg.2017-01-05-16.00.html (cdent, 16:01:44)

  2. new biz: service types authority (cdent, 16:02:36)
    1. https://github.com/openstack/service-types-authority (cdent, 16:02:47)
    2. ACTION: edleafe, scottda, mordred to drive some dicussion about api versioning at ptg (cdent, 16:16:54)

  3. new biz: status of the glance change? (cdent, 16:18:45)
    1. http://lists.openstack.org/pipermail/openstack-dev/2017-January/109965.html (rosmaita, 16:19:45)
    2. http://lists.openstack.org/pipermail/openstack-dev/2017-January/110018.html (rosmaita, 16:20:33)
    3. https://review.openstack.org/#/c/414261/ (rosmaita, 16:26:28)
    4. the glance change to tempest https://review.openstack.org/#/c/414261/ (cdent, 16:26:51)

  4. new biz: open mic (cdent, 16:31:05)
    1. ACTION: scottda to send out email to get things started for consistent versioned endpoints (cdent, 16:38:00)

  5. guidelines (cdent, 16:38:16)
    1. lots of guidelines https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z (cdent, 16:38:27)
    2. capabilities guideline: https://review.openstack.org/386555 (cdent, 16:42:47)

  6. : bug review (cdent, 16:58:27)
    1. bugs: https://bugs.launchpad.net/openstack-api-wg (cdent, 16:59:30)


Meeting ended at 17:00:47 UTC (full logs).

Action items

  1. edleafe, scottda, mordred to drive some dicussion about api versioning at ptg
  2. scottda to send out email to get things started for consistent versioned endpoints


Action items, by person

  1. edleafe
    1. edleafe, scottda, mordred to drive some dicussion about api versioning at ptg
  2. mordred
    1. edleafe, scottda, mordred to drive some dicussion about api versioning at ptg
  3. scottda
    1. edleafe, scottda, mordred to drive some dicussion about api versioning at ptg
    2. scottda to send out email to get things started for consistent versioned endpoints


People present (lines said)

  1. cdent (102)
  2. rosmaita (32)
  3. scottda (31)
  4. elmiko (29)
  5. edleafe (28)
  6. mordred (27)
  7. sigmavirus (6)
  8. openstack (4)
  9. stevelle (2)
  10. jokke_ (2)
  11. dtroyer (1)
  12. hemanthm (1)


Generated by MeetBot 0.1.4.