16:00:28 <cdent> #startmeeting api-wg
16:00:29 <openstack> Meeting started Thu Mar  9 16:00:28 2017 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:32 <openstack> The meeting name has been set to 'api_wg'
16:00:37 * mlavalle traditionally waves back at cdent :-)
16:00:38 <elmiko> hi
16:00:40 <cdent> #chair elmiko edleafe
16:00:41 <openstack> Current chairs: cdent edleafe elmiko
16:00:42 <edleafe> \o
16:00:59 <cdent> who we have today beside elmiko and edleafe ?
16:01:36 <cdent> #topic last meeting
16:01:39 <cdent> #link http://eavesdrop.openstack.org/meetings/api_wg/2017/api_wg.2017-03-02-16.00.html
16:01:49 <cdent> there were no action items from the last meeting
16:01:58 <cdent> #topic
16:02:03 <cdent> #undo
16:02:04 <openstack> Removing item from minutes: #topic
16:02:17 <cdent> #topic open mic and new biz
16:02:24 <edleafe> thought you were getting zen on us
16:02:27 <cdent> agenda, for referene is:
16:02:37 <cdent> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:02:41 * cdent is always a bit zen
16:03:14 <cdent> Our first order of business is to honor etoews who has had to step down from his api-wg duties.
16:03:19 * cdent passes out virtual beer
16:03:32 * edleafe raises virtual glass
16:03:45 <cdent> to etoews
16:03:49 * elmiko raises virtual glass
16:03:57 <knikolla> o/ hi
16:04:00 * cdent drinks
16:04:05 * elmiko drinks
16:04:15 * edleafe sips delicately
16:04:22 * elmiko pours some out for biggie
16:04:26 * cdent gives a beer to knikolla
16:04:43 <cdent> Okay, with that sad business done we can move on:
16:04:46 * knikolla thanks and drinks
16:04:58 <cdent> #topic finalizing stability guidelines
16:05:07 <cdent> #link https://review.openstack.org/#/c/421846/
16:05:11 <cdent> this is getting close
16:05:27 <elmiko> nice
16:05:28 <cdent> mtreinish said he had some small comments but was too busy yesterday with TC to get them down
16:05:43 <cdent> and I've been too busy this week to incorporate other comentary
16:05:49 <cdent> but what's there is light, so we're nearly there
16:06:14 <edleafe> I still wish you had put the Monty reference in :)
16:06:17 <cdent> the only caveat is that there's ongoing discussion that has not been reflected in the review, see:
16:06:25 <cdent> #link http://p.anticdent.org/rsQ
16:06:36 <cdent> I think there's plenty of monty in there, yeah?
16:06:54 <cdent> if we see him everywhere, we don't need to use his name
16:08:14 * cdent needs to fix navigation in those logs
16:09:13 <cdent> anyway, I'm not sure what else to say about this other than I think it might be important to have a very small section with reiterates that "these are the guidelines you should follow for interop, but if you're not following them, it's okay"
16:09:26 <elmiko> +1
16:09:52 <edleafe> What do you mean by "it's ok"?
16:10:18 <elmiko> the api police won't show up at your repo, i think
16:10:24 <cdent> that
16:10:38 * elmiko still waiting for his api police badge
16:10:54 <edleafe> but will you be able to qualify for the stability tag?
16:11:01 <cdent> there's quite a lot of concern, especially since the glance-related chaos with QA, that these guidelines will be wielded to prevent code from merging
16:11:05 <cdent> edleafe: no!
16:11:07 <elmiko> edleafe: i wuold think not
16:11:33 <edleafe> then I guess the "don't worry, it's fine" has to be clear on that
16:11:38 <cdent> but people have demonstrated that they will wield the guidelines in situations where people are not asserting they follow them
16:11:51 <cdent> yes, of course, the quote above is a stub
16:12:13 <elmiko> yeah, i have mixed feelings on the tags. i like them when they aren't used as cudgels to beat project with.
16:12:26 <cdent> if either of you have ideas on how best to unstub, please put it on the review
16:12:26 <edleafe> when have the guidelines been used in such a club-like fashion?
16:12:49 <elmiko> i don't think i've witnessed them being used that way, but i've heard folks talk about them like that
16:12:50 <edleafe> People seem to follow them as, well, guides
16:12:52 <cdent> when glance was trying to fix those two things
16:12:54 <elmiko> i'd hate to see it go that way
16:13:11 <cdent> QA said "this doesn't follow (the existing) guidelines"
16:13:23 <edleafe> cdent: I felt like it was more of the Tempest POV than the guidelines
16:13:32 <cdent> there was both
16:13:41 <elmiko> cdent: but is that different than saying "you don't follow tag X, get in line!"
16:13:49 <elmiko> i think it is
16:13:49 <edleafe> But they cited the guidelines to buttress their case
16:13:57 <edleafe> and that is the appropriate thing to do
16:14:06 <edleafe> they were using tempest failures as the club
16:14:15 <elmiko> edleafe: yeah, that makes sense to me
16:14:25 <elmiko> using it as evidence to support change is good
16:15:13 <cdent> there's a lot of concern about this stuff (if you read the full hour or so of linked irc above you'll see it) being wielded in ways that people don't like
16:15:36 <cdent> I want to be sure we acknowledge that concern
16:15:43 <cdent> we don't have to agree with the concern
16:15:57 <cdent> but saying we know it is there seems pretty important (to me)
16:16:03 <elmiko> i agree
16:16:09 <edleafe> yeah, I read that yesterday
16:16:48 <edleafe> "son"
16:16:50 <edleafe> :)
16:17:01 <cdent> i say son, i say i say
16:17:33 <cdent> anyway, shall we move on, I think we can address the rest of it on the review?
16:17:52 <edleafe> The "just make a major release and make everyone move" thing is crazy. Didn't anyone learn from Nova V3?
16:18:30 <cdent> I think the assertion, if I'm interpreting correctly, is that we learned the wrong thing or the incomlete thing.
16:18:58 <cdent> #topic membership drive / blowing the dust out
16:19:32 <cdent> This is to give us a few moments to brainstorm about how we might get some more active participants and participation
16:19:55 <edleafe> Free candy?
16:20:05 <cdent> scottda: you with us today?
16:20:12 <elmiko> i can share some experience from the ossg on how they grew membership, but i'm not sure we'll be able to duplicate their effort
16:20:23 <cdent> We got free beer today, that's bettery than candy isn't it?
16:20:28 <elmiko> haha
16:20:45 <edleafe> Yeah, but only because our membership -= 1
16:20:53 <elmiko> right
16:20:55 <edleafe> not a sustainable pattern
16:21:08 <edleafe> elmiko: share away
16:21:17 <elmiko> ok
16:21:48 <elmiko> so, a big thing they did was to create some specific messaging about joining the "team", mainly through a blog and handouts that they pasted around at openstack events
16:22:11 <elmiko> they also started to do "road show" type presentations that were like lightning talks with a common slide deck
16:22:23 <elmiko> these presentations were held at several regional openstack events
16:22:26 <elmiko> user groups, etc
16:22:42 <elmiko> i think the blog, and the shared slide deck made a big difference
16:23:08 <elmiko> the downside for us, is that these efforts required bodies and the ossg had several more folks than us
16:23:23 <cdent> sounds like it also required, to some degree,  travel budget
16:23:24 <elmiko> i don't think just emailing the -dev list is going to help, we probably need to wrangle folks in the door
16:23:32 <elmiko> cdent: yeah, that didn't hurt
16:23:42 <elmiko> and frankly, security is much more sexy than api stuff
16:24:06 * cdent looks around the room
16:24:07 <cdent> yeah
16:24:08 <elmiko> and it's tough enough to get orgs to spend on security, i can't imagine getting them to spend on api
16:24:18 <edleafe> true dat
16:24:28 <elmiko> anyways, they had some nice actions that really helped out
16:24:38 <edleafe> speaking of spending, what are the odds of each of you going to Boston?
16:24:52 <edleafe> For me there's only a 20% chance I'll be there
16:24:56 <elmiko> i _might_ be able to get there for the kubernetes day stuff
16:25:21 <elmiko> i could at least make a case for that
16:25:40 <cdent> It's extremely unlikely for me unless the foundation wants to fund me for two events in a row or I very quickly get a new employer
16:25:55 <elmiko> oof
16:27:10 <elmiko> is there any assistance we could call on from tc or similar. like, if they view the api-wg as useful project, how can we get some help?
16:27:29 <elmiko> imo, just asking the community is not working
16:27:45 <edleafe> We could raise it at the next TC meeting
16:27:52 <edleafe> See if they have any ideas
16:27:55 <elmiko> oh, just remembered, another thing the ossg did well was engaging the cpls by attending their meetings and dragging folks in
16:27:57 <cdent> I don't think the api-wg is suffering anything that other groups are not, but yeah, might be worth pinging
16:28:29 <cdent> it may also be the case that we are a little bit of a victim of our own success an we need revisit our goals a bit
16:28:45 <cdent> a _lot_ of guidelines have been written over the last 2 years or so
16:28:51 <elmiko> good point
16:28:55 <edleafe> cdent: what do you mean by "victim of our own success"?
16:29:01 <elmiko> i guess, is there a path to "maintenance mode" then?
16:29:06 <edleafe> like, we're mostly done?
16:29:11 <cdent> people aren't contributing because there's not as much to contribute
16:29:19 <cdent> or at least not as much _obvious_
16:30:06 <elmiko> this is kinda why i thought it would be cool to have some code project for the api-wg, easier to keep folks around
16:30:17 <elmiko> but, maybe too far outside our stated purpose
16:30:40 <cdent> we talked about a guideline tester as well as a reference framework
16:30:44 <elmiko> right
16:30:48 <edleafe> elmiko: something like API Flake?
16:30:54 <cdent> but both of those are quite a lot of work
16:30:57 <elmiko> edleafe: yeah, that would be cool as well
16:31:00 <elmiko> right
16:31:11 <cdent> and money/time/etc
16:31:19 <elmiko> yeah
16:31:25 <elmiko> same old story
16:31:37 <cdent> I think we're probably better off figuring out ways to make casual and small contribution more available and accessible
16:31:50 <elmiko> agreed, that makes more sense
16:31:55 <cdent> the current bugs are really topic holders for people in the know
16:32:18 <cdent> and those of us in the know only address them sometimes (edleafe had a very good run for a while)
16:32:42 <edleafe> So our major focus is a) writing the guidelines and b) mediating disputes on API design
16:33:10 <edleafe> cdent: yeah, that was when I had like nothing to work on in Nova
16:33:30 <elmiko> c) fix bugs
16:33:38 <cdent> and we seem to be doing okay on that focus. it's not like we have a problem, now, it's more concern about the future
16:33:40 <elmiko> once you're "in the know"
16:33:46 <elmiko> yeah
16:34:02 <cdent> so maybe we should just roll with it
16:34:21 <elmiko> i guess
16:34:30 <cdent> until one more of us is fully gone things are okay enough, but not ideal
16:35:11 <elmiko> yeah, i can keep attending meetings and devoting maybe like 1-2 hours extra a week to the group, but that's my limit currently. i do apologize, but it's what i've got :/
16:35:26 <cdent> that's a lot better than fully gone
16:35:49 <elmiko> i just feel bad because i'm kinda out of touch with the openstack world
16:35:53 <cdent> we're not going to solve this today, but we should carry on thinking about it in the background. I do think that talking to the tc about it is probably wise.
16:35:56 <edleafe> can't give what ya ain't got
16:36:03 <cdent> should we do that formally or casually?
16:36:17 <elmiko> i vote formally
16:36:18 <edleafe> I thought this was a better topic for the bar track at PTG
16:36:40 <edleafe> Yeah, I can add an item to their agenda
16:36:46 <elmiko> probably true edleafe
16:36:53 <cdent> #action edleafe to make a tc agenda item
16:37:09 <cdent> i was too tired most of the time to reach the bar
16:37:17 <elmiko> only downside to bar tracking this topic is that it becomes really difficult to get an actual action item
16:37:42 <cdent> let's move on?
16:37:52 <edleafe> elmiko: dunno - seems pretty easy to get people to commit to drinking beer
16:37:53 <cdent> #topic guidelines
16:37:56 <cdent> https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:38:00 <cdent> oops
16:38:01 <cdent> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:38:10 <elmiko> edleafe: LOL
16:38:13 <elmiko> edleafe++
16:38:14 <cdent> nothing ready there
16:38:42 <cdent> dulko has said that he hasn't got time to continue on capabilities
16:38:45 <elmiko> given that comment, we should change the name from api-wg to beer-wg, we'll have people beating down the door ;)
16:38:55 <cdent> and pagination is also stalled
16:39:03 <cdent> i'll do a new version on stability asap
16:39:16 <edleafe> Pouring guidelines; ideal temperature; and the like
16:39:16 <elmiko> cool, i'll make some time for reviews
16:39:23 <elmiko> yeah, totally!
16:39:41 <elmiko> and then we sneak in talk of api couched in the language of beer, it'll be awesome
16:39:47 * cdent can't wait for the debates on which cup or glass to use with which beer
16:39:59 <elmiko> oh man... holy wars already
16:40:00 <cdent> fisticuffs!
16:40:12 <edleafe> Or the americans insisting that all beer be ice-cold
16:40:31 <cdent> #topic bug review
16:40:34 <cdent> no new bugs
16:40:41 <cdent> #topic back to opens
16:40:45 <elmiko> good, bugs in beer make it too crunchy
16:40:57 <cdent> I forgot to ask if anyone had any new business that's not on the agenda?
16:41:08 <elmiko> i have a general question
16:41:18 <edleafe> elmiko: +1
16:41:19 <elmiko> what ever happened to the openapi/swagger effort in openstack world?
16:41:51 <cdent> at least some people decided that swagger was great for new apis (as a design and doc tool) but not so great for existing apis
16:41:56 <cdent> especially ones with microversions
16:42:16 <elmiko> ah, right, microversions kinda bork the whole openapi schema
16:42:23 <elmiko> oh well
16:42:32 <cdent> so the docs with swagger idea got killed in favor of a sphinx extension
16:42:53 <cdent> effectively the hegemony of nova squelched it
16:42:59 <elmiko> right, ok thanks for the memory jog. i do remember that
16:43:22 <edleafe> Idea for a summit talk: "the hegemony of nova"
16:43:23 <elmiko> nova, the 2000lb gorilla
16:43:29 <elmiko> haha, yes edleafe !
16:43:34 <cdent> you'd need a big room
16:44:33 <cdent> any other new business?
16:44:36 <elmiko> would be fun though
16:45:00 <cdent> knikolla: did you have some api-wg business or were you just after free beer (which is just fine, btw)?
16:45:29 <knikolla> cdent: it's something i would like to be more involved with
16:45:42 <elmiko> \o/
16:45:47 <elmiko> we love to hear that =)
16:46:04 <knikolla> cdent: i maintain openstack/mixmatch which is an api proxy between openstack deployments to allow services between them to communicate with each other
16:46:19 <cdent> a) awesome b) ouch!
16:46:23 <knikolla> like attaching a cinder volume in cloud2 from nova in cloud1
16:46:49 <elmiko> interesting
16:46:56 <elmiko> i agree with cdent though, ouch!
16:47:08 <knikolla> elmiko: the api part is easy. the backend part is tough
16:47:33 <cdent> I imagine you must encounter inconsistencies (consistency sort being the reason the api-wg exists)?
16:47:58 <knikolla> cdent: a lot of them, mostly when we were trying to do aggregation instead of only simple routing
16:48:10 <knikolla> but i'm removing that functionality
16:48:19 <knikolla> since it's baked into horizon now with k2k support.
16:48:33 <knikolla> so it constraints it to only be a router based on resource_id and type
16:48:37 <knikolla> which works pretty well
16:49:11 <knikolla> vbrownbag talk https://www.youtube.com/watch?v=O0euqskJJ_8 if anyone is interested :)
16:49:12 <cdent> it's a shame how much cool stuff is going on that there's so little time to explore
16:49:37 <elmiko> neat, gonna give that a watch later
16:49:45 <elmiko> cdent: so true... so true
16:49:52 <knikolla> cool
16:49:56 * cdent puts it in the queue
16:50:07 <knikolla> pagination was the most inconsistent issue
16:50:14 <cdent> yeah
16:50:25 <knikolla> then glance v1 with their headers which apache skips
16:50:27 <cdent> we have a stalled guideline on trying to make it consistent:
16:50:37 <knikolla> and also chunked transfer encoding
16:50:45 <knikolla> since it's not really wsgi
16:50:56 <cdent> #link pagination https://review.openstack.org/#/c/390973/
16:51:33 <cdent> knikolla: should that problem go away as part of the move to hosting the services as proper wsgi apps with proper wsgi servers?
16:52:19 <knikolla> cdent: that will be a problem when moving to wsgi
16:52:35 <knikolla> since wsgi doesn't have that mechanism as a standard as far as i know
16:52:48 <knikolla> it only really works in apache embedded mode
16:52:50 <cdent> right, but most servers that host wsgi apps will do it for you
16:53:01 <cdent> (under the right conditions, I thought)
16:53:16 <knikolla> uwsgi does a pretty good job
16:53:46 * cdent wishes we could all just leap to uwsgi
16:54:12 <knikolla> that would be awesome
16:54:30 <cdent> there's some interest in that happening, but it is considered a big leap
16:54:39 <cdent> (5 minute warning)
16:54:57 <knikolla> even moving away from eventlet is pretty big
16:55:05 <cdent> Can someone else be the newsletter author this week?
16:55:08 <knikolla> a little further doesn't hurt
16:55:22 <edleafe> cdent: sure, I can take a crack at it
16:55:27 <cdent> thanks edleafe
16:55:35 <elmiko> edleafe++
16:55:38 <cdent> #link https://etherpad.openstack.org/p/api-wg-newsletter
16:56:44 <knikolla> which irc channel can i usually find you?
16:56:48 <cdent> knikolla: there's pretty strong talk of switching to nginx+uwsgi in devstack, which would have a pretty big impact
16:57:02 <cdent> #openstack-sdks is where the api-wg hangs out when meetings aren't happening
16:57:17 <elmiko> wow, that is a big change
16:57:48 <knikolla> yeah, wow
16:58:14 <cdent> elmiko: the driver on that is that is that apache's log handling is limited when you have multiple services under the same host
16:58:18 <cdent> (which is another goal)
16:58:29 <cdent> the current virtualhost by port thing is icky
16:58:41 <cdent> but if you change to using a prefix (like placement tries to), the logs get lost
16:58:50 <cdent> or integratd with the main longs
16:58:50 <elmiko> interesting, i'm really curious about the server techs. i've been reading up on the different usage patterns.
16:58:54 <cdent> s/longs/logs
16:59:09 <elmiko> the whole nginx v. apache thing is fascinating to me
16:59:42 <knikolla> there's a lot of differences once you dive deep.
16:59:48 <knikolla> https://github.com/openstack/mixmatch/blob/master/mixmatch/session.py#L21
16:59:58 <knikolla> example
17:00:33 <cdent> times up
17:00:39 <cdent> thanks for coming and the interesting discussion
17:00:45 <cdent> continues in #openstack-sdks
17:00:47 <edleafe> yep!
17:00:47 <elmiko> knikolla: thanks!
17:00:50 <cdent> #endmeeting