16:00:21 <edleafe> #startmeeting api wg
16:00:22 <openstack> Meeting started Thu Mar 16 16:00:21 2017 UTC and is due to finish in 60 minutes.  The chair is edleafe. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:26 <openstack> The meeting name has been set to 'api_wg'
16:00:29 <cdent> o/
16:00:31 <elmiko> yo/
16:00:56 <edleafe> #chair cdent elmiko edleafe
16:00:57 <openstack> Current chairs: cdent edleafe elmiko
16:01:09 <edleafe> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:01:26 * cdent feels like death warmed over today, so spectating
16:01:36 <edleafe> #topic previous meeting action items
16:01:40 <elmiko> bummer, feel better soon cdent
16:02:35 <edleafe> The only action item was for me, and I didn't get to it in time
16:02:49 <edleafe> Didn't really matter, as the TC meeting was pretty full
16:03:12 <edleafe> But the feeling from their discussion of other WGs is that these are supposed to be ephemeral
16:03:24 <edleafe> IOW, when the work's done, time to move on
16:03:42 <edleafe> So while our work isn't done, it's certainly not at the level it was
16:03:57 <edleafe> So perhaps natural attrition is just to be expected
16:04:02 * edleafe sighs
16:04:09 <edleafe> Comments?
16:04:37 <elmiko> i guess
16:04:53 <cdent> I think there's some truth to that, but I also think there's a lot left to do. The bigger truth is that there's simply less people with the freedom to do it.
16:04:54 <elmiko> i mean, we just have to deal with bare bones membership for the time being
16:05:07 <elmiko> cdent++
16:05:32 <elmiko> i'm still really curious to hear how the tc feels about declining membership of the api-wg
16:05:33 <edleafe> We should always look out for people showing some interest and help them get more involved
16:05:38 <elmiko> seems like we know they value the work
16:05:44 <elmiko> edleafe++
16:06:03 <edleafe> elmiko: but I guess I wonder what they could possibly do about it
16:06:13 <cdent> which, by the way, after talking to dtantsur about the stability guidelines he expressed some interesting in being more actively involved
16:06:17 <edleafe> TC Resolution: API WG GOOD
16:06:18 <elmiko> do we have enough bug/guideline backlog that we could approach outreachy or someone about offering an internship spot?
16:07:08 <edleafe> elmiko: not sure if writing project-wide guidelines is the best place for a newbie to start
16:07:27 <edleafe> unless they are new to OpenStack, but familiar with APIs
16:07:30 <elmiko> edleafe: yeah, i was thinking more about the bugs and smaller stuff
16:07:41 <elmiko> just spit-balling
16:08:06 <edleafe> Moving on...
16:08:07 <edleafe> #topic open mic and new biz
16:08:16 <edleafe> Should we revive the pagination spec? It was recently abandoned.
16:08:18 <edleafe> #link https://review.openstack.org/#/c/390973/
16:08:33 <edleafe> Guess the original author lost interest or changed focus
16:08:45 <edleafe> I'd be happy to take that over
16:09:00 <elmiko> seemed like it was very close
16:09:08 <edleafe> yeah
16:09:08 <elmiko> just a couple outstanding questions to answer
16:09:28 <edleafe> So unless there are any objections, I'll re-start that effort
16:09:34 <cdent> yes please
16:09:42 <elmiko> +1
16:09:43 <edleafe> #action edleafe to take over the pagination spec
16:09:56 <edleafe> Anything else for Opens?
16:10:26 <cdent> only to mention: stability guidelines getting pressure to close up
16:10:38 <cdent> in my latest comment there I tried to identify the current sticking points
16:11:05 <cdent> #link  https://review.openstack.org/#/c/421846/
16:11:26 <edleafe> yeah, let's keep up the reviews on that
16:11:40 <cdent> still not managed to draw out people who will talk about it in voice but not writing
16:11:56 <cdent> I guess that's just the way it goes.
16:12:17 <edleafe> yes, unfortunately
16:12:52 <edleafe> Along those lines...
16:12:53 <edleafe> #topic guidelines
16:12:53 <edleafe> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:12:56 <edleafe> What's ready to freeze? Or what's not, what's missing?
16:12:59 <edleafe> What's ready to merge?
16:13:12 <edleafe> Two new guidelines, both dealing with microversions
16:13:33 <edleafe> Microversions: add next_min_version field in version body, from jroll
16:13:38 <edleafe> #link https://review.openstack.org/446138
16:13:59 <cdent> nothing ready to merge or freeze
16:14:02 <edleafe> and WIP: microversion architecture archival doc, from sdague
16:14:05 <edleafe> #link https://review.openstack.org/444892
16:14:10 <jroll> ohai
16:14:22 <sdague> edleafe: fyi... that's so incredibly uber rough right now :)
16:14:45 <edleafe> sdague: gotcha
16:14:48 <sdague> so... consider it not much more than "I'm finally getting around to doing it"
16:15:05 <sdague> hopefully it will be in a reviewable state in a couple of weeks
16:15:05 <edleafe> still, always good to keep everyone in the loop
16:15:16 <edleafe> sounds good
16:15:30 <edleafe> Any other guidelines to discuss here?
16:15:35 <elmiko> seems like jroll's addition is almost ready, just needs a round of reviews before freeze
16:16:49 <edleafe> #topic bug review
16:16:49 <edleafe> #link https://bugs.launchpad.net/openstack-api-wg
16:17:24 <edleafe> Doesn't look like anything new this week
16:18:08 <edleafe> Moving on...
16:18:09 <edleafe> #topic weekly newsletter
16:18:09 <edleafe> #link https://etherpad.openstack.org/p/api-wg-newsletter
16:18:23 <edleafe> I doubt that cdent is up for that :)
16:18:45 <edleafe> I can start, and then ping you guys for sanity checks
16:18:45 <elmiko> yeah
16:18:50 <cdent> no, thanks, I think I'm going to go to bed. I feel worse than I did in the morning, which is a bad sign.
16:19:02 <elmiko> thanks edleafe, greatly appreciated =)
16:19:20 <edleafe> #agreed cdent to go back to bed
16:19:22 <elmiko> erf, rest easy cdent
16:19:28 <elmiko> agreed
16:19:42 <edleafe> So with that, I think we're done
16:19:48 <edleafe> #endmeeting