#openstack-meeting-3: api_wg

Meeting started by cdent at 16:00:14 UTC (full logs).

Meeting summary

    1. agenda https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (cdent, 16:00:32)
    2. last meeting http://eavesdrop.openstack.org/meetings/api_wg/2017/api_wg.2017-03-30-16.00.html (cdent, 16:00:44)

  1. action items (cdent, 16:01:05)
    1. ACTION: elmiko to continue thinking about how to discuss and formulate what we do (cdent, 16:03:12)

  2. new biz (cdent, 16:03:35)
    1. ACTION: elmiko and cdent to decide (with input from everyone) about how to do summit (cdent, 16:07:56)

  3. sarah and microversions (cdent, 16:08:17)
    1. never break compat: https://review.openstack.org/#/c/446561/ (cdent, 16:27:07)
    2. Tolerant reader https://martinfowler.com/bliki/TolerantReader.html (edleafe, 16:27:40)
    3. https://blog.leafe.com/api-longevity/ (edleafe, 16:40:11)
    4. interop: https://review.openstack.org/#/c/421846/ (cdent, 16:42:37)

  4. guidelines (cdent, 16:44:55)
    1. https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z (cdent, 16:45:00)

  5. bug review (cdent, 16:46:48)
    1. https://bugs.launchpad.net/openstack-api-wg (cdent, 16:46:54)

  6. guidelines (cdent, 16:49:13)
    1. pagination guideline https://review.openstack.org/#/c/446716/ (cdent, 16:50:27)


Meeting ended at 17:00:25 UTC (full logs).

Action items

  1. elmiko to continue thinking about how to discuss and formulate what we do
  2. elmiko and cdent to decide (with input from everyone) about how to do summit


Action items, by person

  1. cdent
    1. elmiko and cdent to decide (with input from everyone) about how to do summit
  2. elmiko
    1. elmiko to continue thinking about how to discuss and formulate what we do
    2. elmiko and cdent to decide (with input from everyone) about how to do summit


People present (lines said)

  1. cdent (100)
  2. elmiko (73)
  3. tosky (63)
  4. dtantsur (47)
  5. edleafe (40)
  6. openstack (4)
  7. rosmaita (2)


Generated by MeetBot 0.1.4.