16:01:14 <edleafe> #startmeeting api-wg
16:01:15 <openstack> Meeting started Thu Apr 20 16:01:14 2017 UTC and is due to finish in 60 minutes.  The chair is edleafe. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:18 <openstack> The meeting name has been set to 'api_wg'
16:01:30 <edleafe> #chair cdent elmiko edleafe
16:01:30 <edleafe> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:01:31 <cdent> o/
16:01:31 <openstack> Current chairs: cdent edleafe elmiko
16:01:45 <edleafe> anyone else around?
16:02:44 <cdent> oh dear
16:02:56 <edleafe> I knew I should have showered!
16:03:14 <edleafe> well, I guess we can make this quick :)
16:03:22 <edleafe> #topic previous meeting action items
16:03:23 <edleafe> #link http://eavesdrop.openstack.org/meetings/api_wg/2017/
16:03:51 <edleafe> The only item was: "elmiko and cdent prepare to chat about the future at forum"
16:03:58 <edleafe> I assume that's completed?
16:04:15 <cdent> not so much
16:04:23 <cdent> we've talked about it, but I wouldn't call us prepared
16:04:27 <cdent> we will be by the time it happens
16:04:37 <cdent> we don't know our time slot yet, but it has probably already been chosen, haven't looked yet
16:04:48 <edleafe> #action elmiko and cdent prepare to chat about the future at forum
16:05:01 <edleafe> ^^ just as a reminder
16:05:11 <edleafe> elmiko and cdent prepare to chat about the future at forum
16:05:15 <edleafe> doh!
16:05:21 <edleafe> coppa pasta fail
16:05:24 <cdent> typing is hard
16:05:29 <edleafe> #topic open mic and new biz
16:05:42 <edleafe> getting liaisons up to date
16:05:43 <edleafe> #link http://lists.openstack.org/pipermail/openstack-dev/2017-April/115723.html
16:05:52 <cdent> So yeah, that needs to happen
16:06:06 <edleafe> So... do we send pings to all the current liasons?
16:06:24 <edleafe> and if they don't respond, ping the PTL?
16:06:56 <cdent> it's suppose to be self-selected and managed, but we might want to perform some action if people don't do anything
16:07:23 <edleafe> that's true, but sometimes a nudge helps them to re-foucs
16:07:28 <edleafe> re-focus, even
16:07:42 <edleafe> I'm sure they all have a zillion other things to think about
16:07:49 <cdent> indeed
16:08:09 <cdent> maybe if nothing by end of next tuesday, send some direct pings
16:08:44 <edleafe> hmmm... looking at the list, it might be good to add an email address in addition to the IRC nick
16:09:25 <edleafe> Any other stuff for Open discussion?
16:09:49 <cdent> i think the name is enough to make gerrit happy, but yeah email would be nice
16:09:54 <cdent> not from me, not this week
16:09:59 <edleafe> #topic guidelines
16:10:00 <edleafe> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:10:18 <edleafe> So we have 3 frozen guidelines
16:10:23 <cdent> so: the reason I thought about the liaisons is becuse the things we froze didn't really get much attention
16:10:25 <edleafe> Any feedback at all?
16:10:28 <cdent> which means they are good to go
16:10:30 <cdent> but ...
16:10:31 <cdent> meh
16:10:40 <edleafe> silence is consent?
16:10:57 <cdent> yes, but as you can imagine, I'm not a huge fan of that
16:11:21 <edleafe> After the long review period, and the freeze, if someone comes up with an objection, these are electronic bits, not chiseled marble
16:11:32 <cdent> yes, of course
16:11:38 <cdent> but still
16:11:54 <cdent> i'm not saying we should stall these, just a datapoint
16:11:58 <edleafe> So how about we ping the liasons and give it one more week?
16:12:31 <edleafe> I mean, it was over the easter holiday, so many might not have been paying attention to anything other than chocolate
16:12:48 <cdent> I have no opinion
16:13:35 <edleafe> ok, how's this: I can ping the liasons, and we'll hold off on merging these until next week?
16:13:51 <cdent> I applaud your initiative :)
16:14:34 <edleafe> #action edleafe to ping the liasons about frozen guidelines and possible updates on their continued involvement
16:15:00 <edleafe> No action on any of the other guidelines
16:15:39 <edleafe> #topic bug review
16:15:41 <edleafe> #link https://bugs.launchpad.net/openstack-api-wg
16:16:05 <elmiko> heyo
16:16:11 * elmiko is partially here
16:16:22 <edleafe> The only new one is the liaisons one by cdent
16:16:43 <edleafe> #topic weekly newsletter
16:16:45 <edleafe> #link https://etherpad.openstack.org/p/api-wg-newsletter
16:16:58 <edleafe> Since elmiko was late, let's make him do it!
16:17:01 <elmiko> haha
16:17:12 <elmiko> i don't mind
16:17:14 <edleafe> jk, I can do it, unless cdent really wants to
16:17:30 <elmiko> short meeting today, should be easy
16:17:33 <cdent> I'm not keen today, I think edleafe is well contextualized etc
16:17:49 <cdent> besides I already sent one api-wg email today, I'd be over quota
16:17:52 <edleafe> ok, I'll ping you in -sdks when it's ready
16:17:56 <elmiko> also, good chance i will miss next week's meeting. it's conference season \o/
16:18:07 <elmiko> i'll do my best to be there, but no gaurantees
16:18:13 <edleafe> elmiko: lucky you
16:18:25 <edleafe> IBM cut down their conference budget dramatically
16:18:36 <edleafe> which is why I won't be at the Forum
16:18:37 <elmiko> 2 weeks in boston, back-to-back confereces... lucky for some definition ;)
16:18:40 <elmiko> bummer =(
16:18:49 <edleafe> Hell, they won't even pay for PyCon, so that's coming out of my pocket
16:18:55 <elmiko> wow, lame
16:19:05 * edleafe grumbles about his employer
16:19:08 <elmiko> i've wanted to do pycon for many years, still haven't made the trip
16:19:25 <edleafe> I haven't missed one since 2004 - not about to start now!
16:19:32 <elmiko> neat!
16:19:51 * cdent has never been to a us pycon
16:20:00 <edleafe> On that note...
16:20:01 <edleafe> #endmeeting