16:00:03 <cdent> #startmeeting api-wg
16:00:04 <openstack> Meeting started Thu Jun  1 16:00:03 2017 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:07 <openstack> The meeting name has been set to 'api_wg'
16:00:13 <dtantsur> o/
16:00:19 <cdent> what fine folk are here for some api-wg meeting pleasure?
16:00:26 <cdent> edleafe, elmiko ?
16:00:26 <elmiko> hi
16:00:27 <edleafe> \o
16:00:37 <cdent> #chair cdent elmiko edleafe
16:00:38 <openstack> Current chairs: cdent edleafe elmiko
16:00:55 <cdent> #topic old biz
16:00:58 <cdent> #link http://eavesdrop.openstack.org/meetings/api_wg/2017/api_wg.2017-05-25-16.00.html
16:01:19 <cdent> main action item from last week was to review mordred's fine stuff
16:01:26 <cdent> which lots of people seem to have bene doing, which is dandy
16:02:01 <elmiko> yeah, we added the item for re-reviews
16:02:17 <edleafe> I read War and Peace in between his patches for some light reading
16:02:27 <dtantsur> lol
16:02:31 <elmiko> imo, i seem to be far less opinionated about those specs, so i'm not sure that i'm adding much to the review process
16:02:37 <elmiko> haha
16:02:47 * dtantsur did not have time to come back to it, sorry
16:02:48 <edleafe> Monty is the domain expert there
16:03:06 <cdent> yeah, so it is mostly a matter of catching errors in presentation
16:03:07 <edleafe> So I'm treating this as a brain dump, and only questioning when things aren't clear
16:03:21 <elmiko> cdent: that's been my main goal
16:03:34 <cdent> c00l
16:03:42 <cdent> #topic open mic and new biz
16:03:46 * mordred waves
16:04:24 * edleafe particles
16:04:31 <cdent> does anyone have anything to say about mordred's stuff (which is the only item on the agenda) or is it all happening on the reviews?
16:04:32 <mordred> thanks for the reviews folks! fwiw, I updated the cloud-profile one at the top of the stack, which might be interesting new reading
16:06:07 <elmiko> i've been more or less in agreement with mordred's PRs, not much controversial stuff for me
16:06:07 <mordred> also, cmurphy, edleafe and efried left some good reviews I need to go deal with
16:06:11 <mordred> woot
16:06:45 <edleafe> we didn't want you to feel lonely
16:07:15 <cdent> "interesting new reading" is almost like a curse
16:07:30 <cdent> but is really blessings in disguise
16:07:48 <mordred> :)
16:07:57 <cdent> soon we will all rejoice
16:08:07 <mordred> cdent: I trimmed it down a bit from the original and left out the network access schemes for now
16:08:21 <mordred> figured get in the easy stuff and then we can have a basis to iterate on it over time
16:08:34 <cdent> good plan
16:09:10 <cdent> anything else on version-discovery topic?
16:09:28 <cdent> #action everyone carry on with https://review.openstack.org/#/q/status:open+project:openstack/api-wg+branch:master+topic:version-discovery
16:09:36 <elmiko> +1
16:09:39 <cdent> any other new business? any lurkers lurking?
16:10:11 * edleafe loves a good tautology
16:10:47 * cdent immanentizes the eschaton
16:10:56 <cdent> #topic guidelines
16:10:59 <elmiko> getting deep in here
16:11:06 <cdent> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:11:25 <cdent> I think we're still pending on everything?
16:12:16 <elmiko> think so
16:12:43 <cdent> #topic bug review
16:12:50 <cdent> #link https://bugs.launchpad.net/openstack-api-wg/+bugs?orderby=-id&start=0
16:13:05 <cdent> no new bugs, plenty of bugs still left to deal with
16:13:09 <edleafe> sorry, was looking at the reviews
16:13:20 <edleafe> Are there any issues with https://review.openstack.org/#/c/446138/
16:13:21 * cdent slows down
16:13:29 <edleafe> (the next_min_version)
16:13:45 <elmiko> edleafe: looks like we could move to freeze
16:13:48 <edleafe> just some naming issues?
16:13:48 <cdent> there are some non -1 coments (that are not +1)
16:14:11 <cdent> and a JSON fix
16:14:20 <edleafe> which are trivial
16:15:36 <cdent> are you suggesting we should take advantage of the opportunity to freeze it?
16:15:47 <cdent> and work on the name in the wider audience?
16:15:50 <cdent> or something else?
16:15:55 <edleafe> no, I just wanted to make sure that there weren't any other objections
16:16:02 <dtantsur> I personally don't have better ideas about the name
16:16:12 <cdent> let's make mordred name it, he loves naming
16:16:20 <edleafe> It's the worst name, except for all the other variations :)
16:16:21 <elmiko> haha +1
16:16:24 * cdent suggests restconf
16:16:30 * cdent lies
16:16:34 <mordred> I'm so good at naming
16:17:05 * edleafe suggests 'convefe'
16:17:12 <edleafe> oops
16:17:13 <mordred> oh - I just saw a thing in that ..
16:17:14 <elmiko> LOL
16:17:17 <cdent> dammit.
16:17:22 * edleafe suggests 'covfefe'
16:17:30 <cdent> I was hoping to get through the day without that
16:17:32 <mordred> edleafe: not_raise_min_before ... is that intended to be set by the deployer?
16:17:44 <cdent> project
16:17:54 <mordred> yah - the project has no clue
16:17:55 <edleafe> the project
16:18:10 <edleafe> mordred: that's why it's a guarantee
16:18:19 <edleafe> a deployer may raise it much later
16:18:25 <mordred> ah - like "definitely won't happen until"
16:18:28 <mordred> gotcha
16:18:30 <cdent> 'xactly
16:18:32 <edleafe> but not before the project releases it
16:18:45 <mordred> neat
16:19:08 <edleafe> so this way if a user sees that the min version is going to be raised, they at least have a clue as to how urgent the change is
16:19:17 <mordred> min_version_supported_until_at_least
16:19:29 <edleafe> red!
16:19:40 <cdent> _unless_we_change_our_minds_or_made_a_mistake
16:19:44 <dtantsur> lol
16:19:48 <mordred> :)
16:19:59 <mordred> well - it's still accurate - at_least is very forgiving ;)
16:20:23 <edleafe> the hope is that a) projects won't ever raise the min or b) if they do, we have a way to signal that
16:20:35 * cdent looks at dtantsur
16:20:35 <mordred> wont_bump_min_version_before_date_but_it_may_be_longer
16:20:48 <dtantsur> jroll wanted to raise the min for ironic, but then he left..
16:21:04 <cdent> oh, does that take it off the table?
16:21:12 <mordred> just for the record, I still contend that raising the  min is a de-facto major version bump
16:21:14 <dtantsur> we_are_thinking_to_raise_this_min_version_maybe_after_this_date
16:21:26 <dtantsur> cdent: not entirely. we will do it eventually, I think
16:21:28 <mordred> but I'm willing to not make too big of a stink about that
16:22:07 <edleafe> mordred: the argument in microversions is that there is never a major version bump
16:22:08 <dtantsur> mordred: in ideal world, I agree. in our world, I'm looking at keystone v2->v3 and don't want to ever raise the major version :D
16:22:22 <mordred> edleafe: right. but it's a major version bump- we're just calling it something different
16:22:29 <edleafe> yep
16:22:37 <cdent> names are powerful
16:22:45 <mordred> microversoins lets the user opt-in to changes, but the floor of the major version is always available, so they can also completely ignore it
16:22:51 <cdent> s/names/words/
16:22:52 <mordred> a major version bump cannot be ignored
16:23:01 <mordred> becaues it's a major version and signals a breaking change
16:23:10 <dtantsur> raising min version can *often* be ignored
16:23:14 <mordred> so even if we call it "a microversion min bump" - it's a major version bump
16:23:15 <dtantsur> this is probably the difference
16:23:41 <dtantsur> well, I think this is why it's not the same actually
16:23:52 <dtantsur> I mean, practically speaking
16:23:59 <edleafe> something like Nova dropping nova-network is certainly a breaking change
16:24:15 <mordred> you "might" be able to ignore it - but you don't know - the contract has changed
16:24:22 <mordred> I mean, cinder v2 to cinder v3 is largely the same api
16:24:22 <dtantsur> bumping the default ironic version from 1.1 to 1.10 will barely be noticeable by 99% of our users
16:24:25 <mordred> you can mostly ignore it
16:24:40 <dtantsur> yeah, this is why I'm referring to practical aspects here
16:24:45 <edleafe> But that isn't done with a min_version bump; it's just a version that says "that thing is gone", even if you request an old version
16:25:00 <mordred> dtantsur: totally understand - and I understand the motivation - I just want to make sure that the end effects for people writing api consumption code are the same between a min bump and a major bump
16:25:02 <smcginnis> mordred: *is* the same API. Until you microversion.
16:25:09 <mordred> smcginnis: yes :)
16:25:12 <edleafe> So there are lots of inconsistencies
16:25:36 <cdent> cinder is a summoning word for smcginnis
16:25:42 <elmiko> lol
16:25:46 <mordred> I mostly want to make sure everyone understands that the potential cost for consumers in a min bump are extremely similar to a major version bump ...
16:25:58 <smcginnis> cdent: hehe
16:26:05 <dtantsur> sure, potentially yes
16:26:10 <mordred> and if a user isn't actually using micorversions yet, could lead to them having two different behaviors for a thing labeled with the major version
16:26:12 <edleafe> mordred: sure, but that's not what this patch is about
16:26:14 <dtantsur> e.g. when/if we cross 1.11, we're going to break people
16:26:29 <edleafe> this is about "if you are raising the min, here's how to signal it"
16:26:30 <mordred> edleafe: TOTALLY - if we're going to bump the min, then I fully support the communicatoin channel
16:28:05 <cdent> we can probably "enhance the messaging" (in the microversion spec or the interop guideline) on what a min version bump implies (at a later time)
16:28:16 <cdent> I hear mordred likes to write
16:28:37 <edleafe> I hear mordred has two sprained hands
16:28:53 <elmiko> ouch
16:29:03 <mordred> oy
16:29:08 <mordred> MOAR WRITING
16:29:10 * dtantsur finds this meeting the funniest meeting he attends
16:29:39 * edleafe proposes changing the group's name to the API Comedy Troupe
16:29:48 <elmiko> +1
16:29:51 <cdent> dtantsur: I think that's because we do a pretty good job of allowing ourselves to roam around a bit
16:29:55 <elmiko> i would so travel for that edleafe
16:30:24 <cdent> api comedy toupée
16:30:39 * elmiko chuckles
16:30:40 <dtantsur> :D
16:30:49 <edleafe> is that a crack about my thinning hair?
16:31:20 <mordred> edleafe: is that a crack in your thinning hair?
16:31:22 <cdent> if you hadn't said anything, i would have thought that, but now I'm deperate to get you an api wig
16:31:31 <cdent> wouldn't!
16:32:10 <cdent> anyway
16:32:44 <cdent> is there something to take away from that? a summary? a plan? an action?
16:33:22 <edleafe> Dunno - we just need to settle on a name for the "good_until" date
16:33:33 <cdent> oh yeah
16:33:41 <elmiko> "best-before" ?
16:33:43 <elmiko> ;)
16:34:15 <dtantsur> your_app_breaks_after
16:34:31 * dtantsur cannot be serious today any more, and you're to blame :-P
16:34:36 <elmiko> dtantsur: LOL yes!
16:34:41 <edleafe> _unless_your_app_is_already_broken
16:36:18 <cdent> we've made some fantastic progress today
16:36:32 <elmiko> i feel better =)
16:36:41 <cdent> me too
16:36:51 <cdent> api group therapy
16:36:57 <elmiko> hehe
16:37:54 <cdent> so, by means unclear to me, my dinner is ready earlier than expected so I'd like to dash, can someone do the newsletter honors?
16:38:19 <edleafe> I can, but it won't be for an hour or so
16:38:28 <elmiko> i'm ok with that
16:38:57 <cdent> in other news for much of the month of june I'll be between jobs so trying to relax a bit. I'll still be around for this and a few other meetings (most of the time) but may be somewhat not here
16:39:23 <edleafe> a gentleman of leisure
16:40:18 <cdent> I'm going to have to try really hard
16:40:38 <elmiko> ack
16:40:43 <cdent> anyway, thanks for a fun meeting, goodnight
16:40:48 <elmiko> o/
16:40:48 <dtantsur> thanks!
16:41:02 <edleafe> ciao!
16:42:39 <edleafe> guess he forgot
16:42:42 <edleafe> #endmeeting