16:00:30 <elmiko> #startmeeting api-wg
16:00:31 <openstack> Meeting started Thu Jul 13 16:00:30 2017 UTC and is due to finish in 60 minutes. The chair is elmiko. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:35 <openstack> The meeting name has been set to 'api_wg'
16:00:42 <elmiko> #chair cdent edleafe
16:00:43 <openstack> Current chairs: cdent edleafe elmiko
16:00:55 <elmiko> anyone lurking about?
16:01:29 <cdent> o/
16:01:36 <cdent> I believe edleafe is fetching a glass of water
16:01:40 <elmiko> cool
16:01:46 <cdent> these meetings are parching work
16:01:48 <edleafe> \o
16:01:51 <elmiko> totally
16:01:55 * edleafe swallows quickly
16:02:18 <elmiko> just a heads up, i'm listening in on a company meeting as well
16:02:24 <elmiko> so, kinda bifurcated atm
16:02:36 * cdent will drive
16:02:43 <cdent> #link agenda https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:02:47 <elmiko> thanks, i appreciate it =)
16:03:05 <cdent> #topic old biz
16:03:15 <cdent> #link last meeting log: http://eavesdrop.openstack.org/meetings/api_wg/2017/api_wg.2017-07-06-16.00.html
16:03:17 <cdent> no action items from that meeting
16:03:20 <cdent> #topic new biz
16:04:07 <cdent> people are starting to talk about ptg planning, and I landed in a discussion with rocky that had an interesting idea: http://p.anticdent.org/1X6I
16:04:27 <cdent> which was to do “does my project align with the guidelines” meet and greets
16:04:47 <cdent> because unless we do something and don’t have microversions to talk about, no one will show up
16:05:07 <elmiko> i like the idea
16:05:19 <edleafe> So send something out to all project PTLs?
16:05:39 <elmiko> any thoughts about how this will scale if we get more than say 3-4 requests?
16:05:41 <cdent> some kind of announcement in advance to say that the opportunity will be there
16:05:57 <cdent> if we get a let than it can become more generic I suppose?
16:06:15 <cdent> listening to some other projects issues/concerns is bound to be educational for everyone involved
16:06:26 <elmiko> i like that a lot, i've always wanted to see something to help projects out in this area
16:06:33 <edleafe> cdent: we'd need some prior work to know what the issues are
16:06:55 <edleafe> IOW, we can't just do a wholesale review of their entire API
16:07:06 <elmiko> +1
16:07:12 <cdent> would we? I was thinking something fairly informal? “We’re not sure we’re doing this right?” “yeah, you’re not it should be like this”
16:07:45 <cdent> If we like the idea in general we can tune the details (we have a fair bit of time)
16:07:46 <elmiko> that would be ideal, maybe some sort of form we could provide to help participants think about the best questions to ask the wg?
16:07:52 <edleafe> cdent: well, at least have them come with specific concerns
16:08:01 <elmiko> edleafe: +1
16:08:04 <cdent> yeah
16:09:46 <cdent> so our action from here would be “chew on this and come up with a plan” or something more specific?
16:10:14 <elmiko> yeah, i would go even further and maybe come up with an initial draft of our pitch that we could host on the wiki or something
16:10:40 <cdent> #action elmiki to come up with an initial draft of our pitch that we could host on the wiki or something
16:10:41 <elmiko> but i'm +1 for "chew on this and come up with a plan"
16:10:47 <edleafe> and possibly send out to project PTLs. No one reads out wiki (or anyone else's)
16:10:49 <elmiko> haha, i stepped in that one didn't i
16:10:58 <cdent> oh hoisted on my own typo
16:11:00 <cdent> #undo
16:11:01 <openstack> Removing item from minutes: #action elmiki to come up with an initial draft of our pitch that we could host on the wiki or something
16:11:15 <cdent> : #action elmiko to come up with an initial draft of our pitch that we could host on the wiki or something
16:11:22 <elmiko> edleafe: i was proposing wiki as a place we could collaborate before sending
16:11:57 <cdent> #action everyone to chew on the idea to flesh out a plan for ptg-based api-review
16:11:59 <elmiko> and then it would be reference for later, i would like to see some seed info to help the ptls come with appropriate expectations and information
16:12:20 <cdent> yeah, that would be nice
16:13:08 <cdent> Any other new business or open topics anyone would like to bring up?
16:13:12 <edleafe> elmiko: I knew that. :)
16:13:51 <elmiko> =)
16:14:01 <elmiko> nothing from me
16:14:07 * elmiko doesn't want to get hit with another action item
16:14:25 <cdent> #topic guidelines
16:14:35 <cdent> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:15:13 <cdent> I think we’re still in the same space we were in last week: continued effort from mordred on his novel, not yet ready
16:15:25 <elmiko> seems like it
16:15:49 <edleafe> yup
16:15:59 <cdent> #topic bug review
16:16:06 <cdent> #link https://bugs.launchpad.net/openstack-api-wg
16:16:10 <cdent> also same, I believe
16:16:44 <cdent> I’m still working out my real schedule, but I think I might be able to eke some time out for some of these
16:17:01 <cdent> at least we don’t add many
16:17:15 <cdent> #topic weekly newsletter
16:17:25 <cdent> #link https://etherpad.openstack.org/p/api-wg-newsletter
16:17:46 <cdent> elmiko already got volunteered for something, so I guess it wouldn’t be fair...
16:17:53 <elmiko> hehe
16:18:08 <cdent> edleafe is in the belly of nova resource tracker code, so adding to his load would just hard (unles you want to?)
16:18:13 <edleafe> I can do it. It would be a nice break from that ironic stuff
16:18:13 <elmiko> oh wow
16:18:22 <cdent> have at
16:18:34 <elmiko> speaking of the ptg, are any of us gonna be there?
16:18:44 <edleafe> I am
16:18:47 <cdent> i have to be in denver that week for tc/board meeting so I will
16:19:09 <elmiko> ah, cool
16:19:27 <elmiko> i don't have plans to be there, was more curious about any api-wg activities
16:19:30 <cdent> so clearly we need to come up with some way to get you there elmiko
16:19:43 <cdent> for these office hours
16:19:44 <elmiko> api review booth, ala http://frontierpsychiatrist.co.uk/wp-content/uploads/lucy-psychiatrist.gif ?
16:19:58 <cdent> exactly so
16:20:24 <edleafe> We'll have to charge much more, though
16:20:28 <elmiko> when is the ptg?
16:20:35 <cdent> september 11
16:20:47 <edleafe> thru 15
16:20:54 <elmiko> don't think i have a conflict, so it's at least possible
16:21:05 <elmiko> might be a tough sell to my team though
16:21:17 <edleafe> what could go wrong, flying on September 11?
16:21:21 <elmiko> hehe
16:21:40 <elmiko> i'll put out some feelers to see if i might be able to make it
16:21:49 * edleafe was at a conference in San Diego on 2001.09.11
16:21:49 <elmiko> would we actually do some sort of "office hours" there?
16:22:22 <cdent> that was the original proposal: that in the absence of anything else to talk about for the two days of room that we have, we can do the office hours
16:22:31 <cdent> the api-wg sessions at the last ptg were hugely attended
16:22:40 <cdent> in part because we had a big room
16:22:48 <elmiko> that's cool to hear
16:22:49 <cdent> in part because we were takling about microversions
16:23:01 <elmiko> hence your comment in the tc mtg ;)
16:23:31 <edleafe> and API stability/compatibility
16:24:03 <cdent> edleafe: yeah, but everybody thought that was microversions in compability clothing, thus the energy, maybe?
16:24:13 <elmiko> it'll be tough, my schedule is going to be crazy this fall but perhaps i could make it for the api-wg days. is there a schedule out yet for the ptg?
16:24:32 <cdent> monday and tuesday for ptg
16:24:34 <cdent> yeah, one sec
16:24:39 <cdent> s/ptg/api-wg
16:24:46 <elmiko> ack, thanks
16:24:59 <elmiko> i'll see if it's possible
16:25:01 <cdent> https://docs.google.com/spreadsheets/d/1xmOdT6uZ5XqViActr5sBOaz_mEgjKSCY7NEWcAEcT-A/edit#gid=397241312
16:25:07 <elmiko> thanks
16:26:20 <cdent> so if edleafe has the newsletter, any thing else or shall we call it and await a proofing ping from ed?
16:26:30 <elmiko> nothing more from me
16:27:13 <edleafe> I'm good
16:28:37 <cdent> then thank you very much
16:28:40 <cdent> #endmeeting