16:00:16 <cdent> #startmeeting api-wg
16:00:26 <openstack> Meeting started Thu Aug  3 16:00:16 2017 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:29 <openstack> The meeting name has been set to 'api_wg'
16:00:31 <edleafe> \o
16:00:32 <dtantsur> o/
16:00:33 <elmiko> hi
16:00:40 <cdent> #chair edleafe elmiko
16:00:41 <openstack> Current chairs: cdent edleafe elmiko
16:00:48 <cdent> #link agenda https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:01:07 <cdent> #topic old biz
16:01:13 <cdent> #link old minutes http://eavesdrop.openstack.org/meetings/api_wg/2017/api_wg.2017-07-27-16.00.html
16:01:37 <cdent> elmiko: has the action to create a thing and he did! https://review.openstack.org/#/c/487847/
16:02:04 * edleafe pats elmiko on the back
16:02:04 <elmiko> i missed dtantsur's comments by about 1 minute when i pushed rev 4, i'm gonna fold them into the next rev
16:02:06 <cdent> and we saw it and said it was good
16:02:20 <dtantsur> cool
16:02:21 <elmiko> but, i think he raises a good question about storing the results
16:02:44 <cdent> oh yeah, publishing is a great point
16:02:49 <cdent> dtantsur++
16:02:59 <dtantsur> :)
16:03:04 <elmiko> how should we approach that though? (email, wiki, etc)
16:03:22 <elmiko> i'm just thinking what should go in the review process doc
16:03:28 <dtantsur> email or the api-wg repo, I would say
16:03:41 <cdent> in the repo I would think
16:04:22 <elmiko> is that the guidance repo, or?
16:04:37 <cdent> perhapd as clarifications/examples on existing guidelines? or maybe simply as a separate collection of concrete examples with links?
16:04:42 <cdent> I think in the guidance somewhere is right
16:04:46 <elmiko> ok, cool
16:04:55 <elmiko> i kinda lean towards having them as separate docs
16:05:23 <dtantsur> we may link to them from guidelines as examples, when appropriate
16:05:26 <elmiko> i feel like maintaining the linkage between reviews and guidelines might become cumbersome
16:05:41 <elmiko> for sure, as long as it doesn't incur a crazy amount of tech debt
16:06:08 <edleafe> So sort of a "war stories" document?
16:06:15 <elmiko> yeah, i think so
16:06:37 <elmiko> the cross-linkage thing, while it would be awesome, i just worry about the long tail
16:06:59 <cdent> yeah, war stories sounds right/good
16:07:12 <cdent> and less effortful than integrated with existing guidelines
16:07:24 <cdent> if we make it too effortful, nothing will happen
16:07:38 * cdent looks at everyone over his glasses
16:08:02 <elmiko> hehe, agreed
16:08:08 <edleafe> dtantsur: is "war stories" understandable?
16:08:16 <cdent> I don’t think we should use that term
16:08:30 <elmiko> no no, something more like "case studies"
16:08:33 <edleafe> well not in the doc
16:08:45 <edleafe> I meant for the purposes of this discussion
16:08:50 <elmiko> oh yeah
16:10:19 <dtantsur> edleafe: tbe first time I hear this term, but don't rely on my English :)
16:10:21 <elmiko> ok, so i'll put up some changes after the meeting incorporating dtantsur's nits and what we are talking about
16:10:22 <edleafe> "Case studies" sounds too formal. Maybe just "discussion archive"
16:10:47 <elmiko> +1, i'll go more that direction edleafe
16:11:00 <dtantsur> "Stone tablets of inevitable awesomeness"
16:11:04 <elmiko> haha
16:11:05 <edleafe> dtantsur: as soon as I wrote it I thought it may not translate well
16:11:15 <cdent> we’ll figure it out, and if we find we no likie, we can change
16:11:21 <edleafe> dtantsur: but I like your suggestion!
16:12:17 <cdent> #action elmiko to continue with review process doc
16:12:25 <cdent> #topic new biz
16:12:40 <cdent> #link Do we become a SIG? http://lists.openstack.org/pipermail/openstack-sigs/2017-July/000022.html
16:12:48 <cdent> are people aware of that thread?
16:13:04 * dtantsur is
16:13:10 <edleafe> me too
16:13:19 <dtantsur> I think we're a good example of a SIG, actually
16:13:21 <elmiko> i read some of it
16:13:37 <elmiko> yeah, i don't see any reason not to become a sig
16:13:51 <cdent> dtantsur: me too, until ttx said moving our mail to the -sig list. At that point I thought “hmm, there goes our main audience”
16:13:52 <elmiko> but, i admit i might be missing some nuanced level of this process
16:14:01 <dtantsur> mmmmmm
16:14:03 <elmiko> like that detail
16:14:05 <edleafe> it does seem like for us it would be not much more than a name change
16:14:18 <dtantsur> I missed this bit. Why can't we use [tags] like everyone?
16:14:22 <cdent> I don’t know that there is much nuance. It is just a shuffling of pieces on the board to try to draw more attention to the need for boundary blurring
16:14:37 <elmiko> ahh, gotcha
16:14:38 <edleafe> cdent: we could move internal stuff to -sig, but weekly updates should still go to -dev
16:14:58 <edleafe> (as if we have much internal email discussion)
16:15:00 <dtantsur> do we have much internal stuff?
16:15:02 <dtantsur> aja
16:15:08 <dtantsur> * aha
16:15:11 <cdent> edleafe: but then we’re not doing the desired boundary blurring. As the intention is to reach a broader audience
16:16:29 <edleafe> cdent: separating email communication hardly seems like boundary blurring
16:16:30 <elmiko> but it seems like our primary audience is openstack devs
16:16:46 <elmiko> in specific, openstack project devs
16:16:56 <cdent> edleafe: what I mean is that if we only send the newsletter to -dev, we are not reaching ops/users/pms/etc
16:17:24 <dtantsur> moving anything to another mailing list will complicate things like "[api] [ironic] What to do about your API, folks?" :)
16:17:25 <cdent> the point of sigs to make it easier for everyone to be encourage to become a contributor in many various ways
16:17:36 <dtantsur> I mean, several tags, including us and not us
16:17:37 <cdent> yeah, I agree it is messy
16:17:48 <elmiko> dtantsur: ++
16:17:56 <cdent> which is why I brought it up
16:18:43 <elmiko> at this point, i feel i have to ask are we looking to solicit more input from those other categories ops/users/pms ?
16:18:58 <elmiko> not trying to say we reject them, but i thought we served the dev community mostly
16:19:06 <dtantsur> we want for sure
16:19:22 <edleafe> cdent: we can send the newsletter to whatever lists we want today. Changing to a SIG doesn't affect that
16:19:35 <cdent> I think we do need input from those communities because without it we have less insiight into the inconsistencies
16:19:37 <dtantsur> if you followed (cdent did) the discussion re api interop tag, one of my complains was being dev-centric
16:19:50 <elmiko> cdent: and i agree with that sentiment
16:19:57 <dtantsur> * openstack dev centric (/me cannot English after 6pm)
16:20:01 <cdent> edleafe: yes, I’m saying that maybe that should change if we buy into sig-ness
16:20:16 <elmiko> dtantsur: a fair point
16:20:56 <edleafe> cdent: to my thinking, we should do that whether we are a WG or a SIG or whatever
16:20:56 <elmiko> maybe i'm just skeptical about the involvement of ops/users/pms
16:21:14 <cdent> edleafe: yes, that’s the underlying point
16:21:36 <cdent> elmiko: that’s fair, because there’s not that much involvement from devs either ;)
16:21:38 <edleafe> cdent: so remind me again what this has to do with becoming a SIG
16:21:47 <elmiko> cdent: right!
16:22:45 <cdent> So the reminder is this: As there is this move on to become a SIG, shall we use that as an excuse to expand our audience and publish output and solicit input more widely, or are we in fact an openstack-dev oriented org and as such we should not become a SIG?
16:22:53 <cdent> Does that encapsulate the issue(s) better?
16:23:06 <dtantsur> this is an interesting way to put it, hmm
16:23:21 <dtantsur> I'm all for listening to people we seem to help :)
16:23:23 <edleafe> cdent: that sort of begs the question
16:23:41 <cdent> it is for the begging of the question that we speak
16:23:47 <edleafe> of course we want to be as broadly relevant and helpful as possible
16:23:48 <elmiko> cdent: it does encapsulate well, and at the same time makes the question much more interesting to digest
16:24:00 <elmiko> edleafe: +1
16:24:31 <cdent> edleafe: is that an of course? I think some of the time we think so, but earlier in the conversation we had comments to suggest otherwise.
16:25:20 <elmiko> i can totally understand the angle of accepting more input from outside contributors, that makes sense. but what are the long term goals from interacting with a wider community? for example, would we see a day where the api-wg is providing api advice to projects that merely built on top of openstack?
16:25:21 <cdent> _I_ think it is an of course, but I also fear that we may not have the resource of wherewithal to be useful more broadly (not that I can really enumerate what the broader obligations would be).
16:25:28 <cdent> jinxish
16:25:38 <edleafe> cdent: what sort of comments were they?
16:25:40 <elmiko> heh
16:25:46 * edleafe has swiss cheese memory
16:26:06 <cdent> edleafe: elmiko’s comments “but i thought we served the dev community mostly"
16:26:14 <dtantsur> elmiko: if we're not confident in our guidelines enough to recommend them to people outside of the TC coverage, then something is wrong
16:26:48 <elmiko> dtantsur: oh, i think we are, it's just a question of outreach. will we be directly interacting with folks from outside the openstack dev community in the same capacity?
16:27:15 <dtantsur> if they come to us, why not? there is a whole trend on getting closer to e.g. container communities
16:27:31 <elmiko> like, our guidelines are useful, they provide a nice conversation point for starting design/analysis. but they are mainly focused on the works of the openstack community
16:27:33 <cdent> cross-community outreach is on trend
16:27:34 <edleafe> cdent: we may have arisen from the dev community in response to shortcomings in the dev community, but that doesn't mean that's all we should be
16:27:38 <dtantsur> I've heard some folks can learn from our API versioning (no irony this time)
16:27:52 <cdent> edleafe: I agree, you don’t need to convince me.
16:28:20 <cdent> dtantsur: that topic will come up shortly when we get to guidelines
16:28:45 <elmiko> i guess i now have mixed feelings about the sig expansion
16:29:05 <elmiko> i'm a little nervous about the scope expansion of the group given our size and history
16:29:10 <edleafe> cdent: but it's no fun if we don't argue
16:29:35 <edleafe> elmiko: there's always the chance that we might attract new blood
16:29:53 <elmiko> edleafe: definitely, and that could be good or bad depending on the situation
16:30:17 <elmiko> like, i sit in on some of the sig meetings for kubernetes and i just wonder how much additional density we could handle
16:30:45 <elmiko> like, if our group got popular in a cross-project way, it could become quite hectic in a short amount of time
16:30:58 <elmiko> not saying that's a bad thing, just a risk to understand
16:31:34 <elmiko> how much thrashing could we withstand kind of thing
16:32:08 * elmiko steps off soapbox
16:32:09 <cdent> better to burn out than fade away
16:32:21 <cdent> or something
16:32:22 <edleafe> REST never sleeps
16:32:29 <elmiko> haha, i dunno, i've been thinking about that phrase in my personal life recently and i think i prefer fade away
16:32:40 <cdent> heh, me too
16:32:44 <elmiko> LOL
16:33:10 <dtantsur> :D
16:33:42 <elmiko> so, maybe we should consider it for a little more time then hold a vote or something at an upcoming meeting?
16:33:54 <elmiko> i'm not sure the best way to proceed
16:34:17 <cdent> I don’t think there’s any rush. Pausing for reflection is warranted and fine.
16:34:31 <elmiko> ok, cool. i didn't know if we needed to decide by the ptg or something
16:34:35 <cdent> no
16:35:17 <cdent> we should, however, reflect soe of our concerns back to that email thread, so that the notion of us being an early adopter isn’t as simple as “yeah, sure”
16:35:27 <elmiko> +1
16:35:53 <cdent> I can do that if nobody else wants to, but it won’t be today or tomorrow
16:36:25 <edleafe> I was sort of hoping to have a SIG discussion at PTG
16:36:46 <edleafe> I'm still not clear on how it would affect us long term
16:36:58 <elmiko> edleafe: +1 i'd like that too
16:37:13 <cdent> you mean a discussion about sigs?
16:37:41 <cdent> if so, I’d suggest saying so in response to ttx’s thread (the link above): More info required please.
16:37:53 <dtantsur> CLOSED INSUFFICIENT_DATA
16:37:55 <elmiko> yes, i do mean that
16:38:04 <elmiko> and yeah, i'll make a response
16:38:22 <elmiko> i'm not sure the specifics as i've been getting digest emails but i'll figure it out (any advice appreciated)
16:39:07 <cdent> any more on that or or any other new biz/open topic?
16:39:31 <edleafe> #action edleafe to respond to ttx on ML
16:39:38 <edleafe> #undo
16:39:39 <openstack> Removing item from minutes: #action edleafe to respond to ttx on ML
16:39:45 <edleafe> #action edleafe to respond to ttx on ML regarding SIGs
16:39:52 <elmiko> +1, thanks edleafe
16:40:18 <cdent> okay
16:40:24 <cdent> #topic guidelines
16:40:29 <cdent> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:41:28 <cdent> the thing I wanted to mention about versioning was that sdague has had a talk accepted at apistrat about microversions. As part of that he’s going to be updating the doc at https://review.openstack.org/#/c/444892/ more vigorously in prep
16:41:57 <elmiko> ooh, neat! and congrats to sdague
16:42:16 <edleafe> the latest rev of that doc wasn't changed much
16:42:34 <cdent> yeah, I’m very curious to hear how people respond. There will be some purists who will react very poorly, and some pragmatists who will be interested
16:42:52 <elmiko> cdent: are you gonna be there as well?
16:43:04 <cdent> not last I checed
16:43:11 <elmiko> ack
16:43:16 <cdent> but I’m hoping to hear about it on the grapevine
16:43:23 <elmiko> yeah for sure, was just curious
16:43:59 <cdent> it’s the sort of thing I’d like to go to, but not even thought of investigating until about 2 minutes ago
16:44:19 <elmiko> haha
16:44:37 <cdent> we’ve already talked about the review process guideline
16:44:39 <cdent> so that leaves
16:44:45 <cdent> #link https://review.openstack.org/#/c/487504/
16:45:00 <cdent> does that count as a non-guidance change?
16:45:22 * elmiko looks
16:45:35 <cdent> it’s basically repointing links
16:45:39 <edleafe> Yes, IMO
16:45:48 <elmiko> yeah, i think so too
16:46:05 <edleafe> Shall I pull the trigger?
16:46:33 <cdent> go fer it
16:46:46 <edleafe> Done
16:46:47 <elmiko> \o/
16:46:51 <cdent> #topic bug review
16:46:58 <cdent> when that merges we’ll have one less bug
16:47:03 <cdent> #link https://bugs.launchpad.net/openstack-api-wg
16:47:23 <edleafe> Hey, I had a question about the Monty series
16:47:39 <edleafe> I tried rebasing it, and got stuck on the middle patch
16:48:04 <edleafe> Can I push it with the one conflict I couldn't resolve?
16:48:34 <edleafe> Of course, I'd -1 it until Monty can fix it
16:48:41 <cdent> good with me
16:48:44 <elmiko> that sounds fair
16:48:48 <edleafe> ok
16:51:14 <cdent> when (in the mythical future) placement allocation handling resolve, I ought to be able to pick up one more buglet from the bug list. I’m going to try to do that regularly, but I’m not sure when the mythical future gets here.
16:51:32 <elmiko> +1
16:52:21 <cdent> anything else on bugs?
16:52:53 <edleafe> nope
16:52:55 <cdent> #topic weekly newsletter
16:53:00 <cdent> #link https://etherpad.openstack.org/p/api-wg-newsletter
16:53:13 <cdent> I can’t do it this week, I need to run off an fetch my wayward lovely wife from the train station
16:53:35 * elmiko hides behind the couch
16:53:40 <edleafe> Guess it's my turn, huh?
16:53:52 <elmiko> either that or we flip a coin
16:54:02 <edleafe> Heh, as if I had any money
16:54:04 <elmiko> i have time to do it
16:54:06 <elmiko> lol
16:54:08 <edleafe> I'll do it
16:54:11 <elmiko> thanks
16:54:18 <cdent> thanks edleafe
16:54:26 <cdent> anything else from anyone about anything?
16:54:51 * edleafe has nothing
16:55:06 * dtantsur too
16:55:23 <elmiko> nothing from me
16:55:34 <elmiko> although, anything you say....?
16:55:37 <elmiko> XD
16:56:36 <edleafe> So are we done? I'll ping you in -sdks when the newsletter is done
16:56:44 <cdent> we done
16:56:48 <cdent> thanks everybody
16:56:52 <cdent> #endmeeting