16:00:27 <cdent> #startmeeting api-wg
16:00:28 <openstack> Meeting started Thu Aug 10 16:00:27 2017 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:31 <openstack> The meeting name has been set to 'api_wg'
16:00:36 <cdent> who is here to api-wg?
16:00:42 <edleafe> \o
16:00:46 * dtantsur is lurking
16:00:52 <cdent> #chair edleafe elmiko
16:00:53 <openstack> Current chairs: cdent edleafe elmiko
16:01:11 <cdent> #link agenda https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:02:42 <cdent> #topic old business
16:03:02 <cdent> #link http://eavesdrop.openstack.org/meetings/api_wg/2017/api_wg.2017-08-03-16.00.html
16:03:24 <cdent> elmiko was going to continue on the in person review process doc (he did)
16:03:37 <cdent> edleafe was going to respond about sigs (he did, so did )
16:03:47 <elmiko> o/
16:03:59 <cdent> I the review process doc is close to ready?
16:04:35 <elmiko> imo, we are just missing the example, but i thought maybe we could either do a mock review or just wait till the ptg to add the example
16:04:38 * edleafe apologizes for not having reviewed the latest
16:05:00 <elmiko> no worries edleafe, i missed your response about sigs and was curious
16:05:05 <elmiko> so, we're even =)
16:05:11 <edleafe> elmiko: Well, we want to use this as the template for what we send to PTLs
16:05:19 <cdent> I think waiting until after the ptg for the example is a good idea, drop in a TODO?
16:05:22 <elmiko> ok, should i add an example?
16:05:30 <edleafe> So we should have something soon, and add the example in a follow-up
16:05:43 <elmiko> agreed
16:05:46 <edleafe> yeah, what cdent said
16:06:05 <elmiko> i have a couple cases that i've been involved with in the past that could be fodder for an example, if we want to push it
16:06:33 <edleafe> Will they be obfuscated, or will you name names?
16:06:53 <elmiko> i was going to name names, i did enough work on the sahara api that i don't feel it would wrong to use that as an example
16:07:18 <elmiko> like "sahara team approaches with problem X, etc...."
16:07:28 <cdent> If you have an example to hand, may as well do it, but perhaps base it on top of the original doc?
16:07:39 <elmiko> i'm perfectly fine with that
16:07:44 <cdent> word
16:07:52 <edleafe> ok, that's fine. There are some overly-sensitive folks in the OpenStack world who might object if they felt we were criticizing
16:07:54 <elmiko> i think getting this out sooner is better to give folks a chance to get ready
16:08:02 <edleafe> Because you know, no one in OpenStack ever makes a mistake
16:08:21 <elmiko> edleafe: yeah, i would choose an example that i was directly invovled with. so i could be the subject of criticism
16:09:02 <edleafe> elmiko: that *might* make them feel safer :)
16:09:07 <elmiko> hahaha
16:09:19 <elmiko> you know this community too well edleafe ;)
16:09:41 <cdent> shall we move on to new biz (which includes some old biz)
16:09:48 <edleafe> yep
16:09:48 <elmiko> sounds good
16:09:57 <cdent> # topic new biz
16:10:11 <cdent> the sig stuff.
16:10:21 <cdent> There’s been further discussion in email and elsewhere
16:10:27 <elmiko> cool
16:10:33 <cdent> #link original thread http://lists.openstack.org/pipermail/openstack-sigs/2017-July/000022.html
16:10:45 <edleafe> And I just had all my business cards and letterhead printed with "API-WG" on it
16:11:04 <elmiko> i wanted to reply to Thierry's email, mainly asking about the email list questions we raised last time
16:11:12 <elmiko> edleafe: LOL
16:11:14 <cdent> the gist seems to be : if api-wg hops on this train it will be helpful in encouraging the concept and getting other more entrenched actors acting
16:11:41 <edleafe> elmiko: as I understand it, intra-SIG discussions happen on the SIG list
16:11:42 <cdent> the mailing list question was clarified: outward publishing still goes wherever we want
16:11:47 * elmiko imagine cdent, edleafe and himself taking a train ride
16:11:50 <edleafe> elmiko: We can still post to dev list
16:11:55 <cdent> the *-sig list is for us (members of the group) to talk to each other
16:12:10 <elmiko> ok, that's makes things easier for us to decide
16:12:12 <elmiko> imo
16:12:20 <edleafe> ...which we do *so* much of
16:12:24 <elmiko> haha
16:13:15 <elmiko> so, given that, i'd be ok with taking that train ride
16:13:18 <cdent> to make the transition all we realy have to do is say “yes” and we’ll end up on wiki page soemwhere
16:13:22 <elmiko> right
16:13:32 <cdent> and we might want to change some branding in the newsletter
16:13:44 <cdent> I don’t personally think it is worth the effort to change launchpad, gerrit, git
16:13:53 <elmiko> yeah, probably need to sweep through the wiki and spec site as well
16:13:56 <elmiko> ahh, ok
16:13:59 <edleafe> cdent: they can be changed as we get to them
16:14:18 <edleafe> so for a period we'll have both names in various places
16:14:56 <cdent> so you think we should change launchpad etc, eventually?
16:15:31 <elmiko> you mean like change the project links from api-wg to api-sig (more than just changing the names)?
16:15:33 <cdent> (which is fine, but I remember when I set up launchpad I wanted to run screaming)
16:15:39 <elmiko> yeah...
16:16:08 <elmiko> i'm not sure the best answer, maybe we can engage the infra folks for advice?
16:16:09 <edleafe> launchpad is fun!
16:16:16 <elmiko> my concern is breaking all our old links
16:16:34 <cdent> #action edleafe to manage any name change concerns, eventually
16:16:41 <cdent> since you think it’s fun
16:16:45 <edleafe> sure, I can do that
16:17:18 <cdent> shall we do an agreed, for formality?
16:17:24 <edleafe> of course!
16:17:27 <elmiko> +1
16:17:32 <edleafe> since it's so rare for us to agree
16:17:35 <elmiko> haha
16:17:41 <edleafe> Or should we do a vote?
16:17:46 <edleafe> We never get to do those
16:17:47 <cdent> #startvote shall we become a SIG?
16:17:47 <openstack> Begin voting on: shall we become a SIG? Valid vote options are Yes, No.
16:17:48 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
16:17:58 <cdent> #vote yes
16:17:59 <dtantsur> where is "meh"?
16:18:01 <edleafe> #vote Maybe
16:18:02 <elmiko> #vote yes
16:18:05 <edleafe> :)
16:18:10 <elmiko> haha, i was waiting for the jokes
16:18:11 <edleafe> #vote Yes
16:18:33 <elmiko> dtantsur: YOUR MEH IS NOTED!
16:18:37 <edleafe> you can vote too, dtantsur
16:18:44 <elmiko> yea, please do =)
16:18:44 <cdent> dtantsur: meh should always be an option but [t v2a]
16:18:48 <dtantsur> oh rly?
16:18:52 <cdent> (except no purplerboth in here)
16:18:57 <dtantsur> cdent: no dark magic for you!
16:19:03 <dtantsur> #vote Yes
16:19:09 <elmiko> dtantsur: you've been a more regular attendee to these meetings than most
16:19:09 <cdent> #endvote
16:19:10 <openstack> Voted on "shall we become a SIG?" Results are
16:19:37 <edleafe> the suspense is killing me!
16:19:40 <cdent> apparently I’m not a good operator
16:19:42 <elmiko> =)
16:19:50 <cdent> #agreed api-wg will become a sig
16:20:02 <dtantsur> Results are <scary emptyness looking into your soul>
16:20:07 <elmiko> do we have cake now or something?
16:20:11 <edleafe> #alsoagreed votebot sucks
16:20:16 <elmiko> haha
16:20:20 <cdent> cake!
16:20:25 <cdent> already next topic
16:20:57 <edleafe> heh, we're still on "old business"
16:21:04 <cdent> I picked a bug about extensions and started a review, which has begun a discussion with morder
16:21:08 <cdent> #topic extensions
16:21:31 <cdent> mordrer is the some more mord version of mordred
16:21:45 <cdent> #link extensions https://review.openstack.org/#/c/491611/2
16:22:04 <cdent> he raises the issue of “capabilities”, which I was hoping to avoid entirely
16:22:19 <cdent> this all started because I asked about a link that explains the intent of the service catalog
16:22:22 * mordred likes to make things hard
16:22:42 * mordred is very much in favor of the patch in question, fwiw
16:22:50 <edleafe> no, it all started when I suggested such a link
16:23:09 * dtantsur sees another recommendation, which ironic is not conforming to..
16:23:24 <cdent> edleafe: yes, you’re right, so sorry, credit where credit is due. here’s your 2c
16:23:41 * edleafe goes to buy some hard candy
16:23:58 <cdent> yeah, it’s an issue dtantsur
16:24:08 <cdent> sometimes reality isn’t well aligned with some of this stuff
16:24:32 <elmiko> +1
16:24:33 <dtantsur> we've been talking about Bare Metal API V2 for some time. we're not even close to starting though..
16:24:36 <cdent> but I think we need to decide if we’re writing to describe an ideal, harsh reality, or somewhere in between
16:24:54 <dtantsur> well, in mordred's terms we're at "Less good", not "Bad". which is relieving :)
16:25:24 * edleafe hopes someday to achieve "pure evil"
16:25:31 <mordred> edleafe: I believe in you
16:25:35 <dtantsur> ++
16:26:24 <cdent> so anyway: that review is there, please look and make some commentary, unless you feel you can construct something useful to say right now, in which case let’s talk about it
16:26:25 <elmiko> dtantsur: it took us nearl 6 cycles to go from planning a sahara v2 api, to actually making it happen
16:26:39 <dtantsur> otherwise, the recommendation is good in theory (esp. if you don't deal with hardware)
16:26:41 <elmiko> cdent: ack, will do
16:27:20 <cdent> Any other new biz?
16:28:26 <elmiko> nothing from me
16:28:33 <edleafe> nope
16:28:44 <dtantsur> not here
16:29:58 <cdent> movin’ on
16:30:02 <cdent> #topic guidelines
16:30:09 <cdent> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:30:54 <cdent> I think we’ve covered the state of those
16:31:07 <edleafe> cdent: just about to type that!
16:31:24 <cdent> did I just win a typing race?
16:31:29 <cdent> alert the media
16:31:59 <edleafe> well, I hadn't started, so...
16:32:09 <edleafe> the thought was stuck in my brain
16:32:20 <cdent> too much evil
16:32:41 <cdent> move to next topic?
16:32:52 <elmiko> lol
16:32:59 * edleafe nudges cdent forward
16:33:17 <cdent> #topic bug review
16:33:27 <cdent> #link https://bugs.launchpad.net/openstack-api-wg
16:34:06 <cdent> the big news here is that for want of a better place, service-type-authority bugs are happening in openstack-api-wg
16:34:12 <cdent> efried needed a place to put a bug
16:34:51 <elmiko> interesting
16:35:11 <elmiko> although there was some overlap early on between the api-wg and service-type participants
16:35:50 <dtantsur> do we have TC bugs? :)
16:35:53 <cdent> we are all core in service-type-authority
16:36:01 <elmiko> right
16:36:17 <cdent> and generally considered “keepers of the service type religion"
16:36:21 <cdent> so it sort of makes sense
16:36:29 <cdent> but naming etc
16:36:53 <elmiko> ok, i hadn't realized the second part
16:37:02 <cdent> also launchpad is involved so I ran away
16:37:05 <elmiko> haha
16:37:23 <dtantsur> I don't know how good for a SIG is to own such a global and cornerstone thing
16:37:31 <dtantsur> I mean, from governance point of view
16:37:32 * edleafe didn't even know that was a separate project
16:37:56 <cdent> dtantsur: the tc and sdague and mordred are also cores of service-type-authority
16:38:43 <mordred> well ... the API-WG is a little different than a normal sig
16:38:54 <cdent> mordred: see earlier vote
16:38:59 <edleafe> We're... special!
16:39:07 <elmiko> haha
16:39:09 <mordred> cdent: I can't keep up with things
16:39:09 <cdent> we have been nominated (and accepted) being one of the sig trailblazers
16:39:27 <cdent> you are blinding by edleafe’s evil darkness
16:39:30 <cdent> damn
16:39:32 <cdent> blinded
16:40:04 <mordred> neat. well - I think the fact that the TC has delegated some specific authoirty to the api-wg-sig still stands and is why I'm personally ok with api-wg-core having core on sta
16:40:18 <mordred> that said - we could also loop that back around with the tC just to make sure
16:40:55 <edleafe> wait - so will we be the api-wg-sig or the api-sig?
16:41:06 <cdent> latter?
16:41:06 <elmiko> are the sigs supposed to have more space between themselves and the core governance of repos?
16:41:35 <cdent> so something to consider here
16:41:48 <cdent> there are repos associated by name with the api-wg
16:41:54 <cdent> but they are actually owned by the tc
16:41:59 <cdent> “owned”
16:42:16 <cdent> so the stuff that happens in those repos is delegated to the people who are known as the api-wg cores
16:42:18 <edleafe> You mean we've been renting them?
16:42:53 <cdent> but the activity which is associated with the idea of improving APIs and helping people, and such like that there, is something that is easily api-sig?
16:43:35 <elmiko> that makes some sense to me
16:43:46 <elmiko> still a little fuzzy on the repo stuff, but it's not a huge dela
16:43:49 <elmiko> deal
16:44:03 <edleafe> So the guidelines and such would still be our domain, as per ttx
16:44:12 <edleafe> IOW, no major functional changes
16:44:13 <cdent> yah
16:44:26 <elmiko> ok, that's what i figured. just curious
16:44:43 <cdent> I was more trying to address the idea of a SIG and service-types
16:44:53 <cdent> there is a boundary there
16:45:23 <elmiko> that makes sense
16:46:10 <edleafe> I would propose that we continue as we have, without worrying about potential scenarios down the road
16:46:18 <cdent> fair
16:46:24 <edleafe> When we encounter a definite issue, we can deal with it then
16:46:27 <elmiko> yeah, agreed
16:46:46 <cdent> i was just trying to make dtantsur feel better! seeing as he has notmuchtime to be worrying about such things
16:46:47 <edleafe> The last thing we should do with the SIG switch is break things that are working now
16:46:48 <elmiko> can we get an animal logo for the api-sig?
16:46:57 * dtantsur feels better
16:46:58 <elmiko> maybe a dung beetle or skunk?
16:47:07 <cdent> anything else on bugs?
16:47:20 <elmiko> edleafe: +1
16:47:38 <edleafe> elmiko: http://imgur.com/98WLNPW
16:48:00 <cdent> such pun
16:48:15 <dtantsur> wow
16:48:38 <cdent> #topic weekly newsletter
16:48:45 <elmiko> edleafe: +1
16:49:20 <cdent> is it my turn?
16:49:35 <elmiko> well, since you are offering XD
16:49:59 <edleafe> then it's unanimous! Congrats, cdent!
16:50:04 <elmiko> haha
16:50:27 <cdent> #link https://etherpad.openstack.org/p/api-wg-newsletter
16:50:28 <cdent> fair
16:51:15 <cdent> i’ll ping for proofing shortly
16:51:24 <cdent> anyone have anything else to add?
16:51:35 <edleafe> not I
16:51:36 <elmiko> i made my reservations for denver =)
16:51:41 * dtantsur too
16:51:43 <elmiko> i have to leave on tuesday though
16:52:18 <elmiko> that's all
16:52:20 <cdent> are all four of us going to be there? how very exciting
16:52:26 <elmiko> yeah! \o/
16:52:39 <cdent> api-dinner
16:53:06 <dtantsur> \o/
16:53:12 <elmiko> hell to the yes cdent
16:53:13 <edleafe> api-bar
16:53:17 <elmiko> that too!
16:53:24 <cdent> api-dinner-at-a-bar
16:53:33 <elmiko> wow, this just gets better and better
16:54:24 <elmiko> api-dinner-at-a-bar-sig ?
16:54:29 <elmiko> maybe too far
16:54:49 <cdent> sounds like we need a pre bar bar to plan the bar
16:54:52 <edleafe> api-breakfast-at-a-bar
16:54:53 <elmiko> LOL
16:55:06 <cdent> okay
16:55:10 <cdent> #endmeeting