17:00:33 <docaedo> #startmeeting app-catalog
17:00:34 <openstack> Meeting started Thu Jul 30 17:00:33 2015 UTC and is due to finish in 60 minutes.  The chair is docaedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:38 <openstack> The meeting name has been set to 'app_catalog'
17:00:52 <docaedo> #topic rollcall
17:00:56 <kfox1111> o/
17:01:01 <rhagarty_> o/
17:02:43 <kzaitsev_ip> Almost made it :) but still have to use my phone for now.
17:03:14 <docaedo> ooh, that can't be too fun for an IRC meeting :)
17:03:17 <j^2> Hi!
17:03:33 <docaedo> #topic Status updates (docaedo)
17:03:48 <docaedo> The change to the hosting server to support CORS landed. This allowed cross-origin queries and creates JSON files from the YAML files.
17:03:51 <docaedo> #link https://review.openstack.org/194875
17:04:34 <docaedo> I requested a new repo (apps-catalog-ui) for the horizon panel work
17:04:48 <docaedo> #link https://review.openstack.org/#/c/207253/
17:05:34 <docaedo> um .. any other status updates?
17:05:45 <kzaitsev_ip> But that repo commit would take some time to land, cause of zuul I guess.
17:05:59 <docaedo> yes, suspect we are a few days out at a minimum
17:06:33 <docaedo> (and I got some feedback finally, have things to fix today anyway)
17:06:59 <rhagarty_> sorry for silly question - where will the panel reside in horizon?
17:07:09 <j^2> on the side bar right?
17:07:26 <kfox1111> #link https://youtu.be/9TlPhmml-T8 :)
17:07:29 <rhagarty_> under Application Catalog?
17:07:36 <rhagarty_> thanks
17:07:41 <kzaitsev_ip> Yep, like any horizon dashboard
17:08:11 <j^2> nice, i love that vido kfox1111
17:08:20 <kfox1111> thx. :)
17:08:51 <docaedo> OK the only other update I have is that the "move into single YAML file" effort is in progress, and we are discussing how to break it up into smaller chunks on IRC right now
17:09:13 <j^2> for that we really should alphabetize the sections
17:09:29 <j^2> it would be easier as we add more and more options
17:09:37 <kfox1111> yeah. when we do the final merge, I really would like to see that too.
17:09:56 <j^2> #agreed kfox1111
17:10:15 <docaedo> easy enough to do (and we can specify order by type first, asset name second)
17:11:14 <docaedo> OK anything else before we move on to the next topic (roadmap)?
17:11:16 <kfox1111> I'd like to see it just by name.
17:11:24 <kfox1111> type's filterable.
17:11:37 <kfox1111> the user probably shouldn't care about type at all.
17:12:11 <docaedo> what's the point of alphabetizing the sections? I thought the value to that was to make it easier for people to find the right place to slot in their addtion when modifying the YAML?
17:12:14 <j^2> in most cases your right kfox1111
17:12:28 <j^2> docaedo: that’s where i’m coming from
17:12:30 <kfox1111> docaedo: exactly.
17:12:30 <docaedo> As it stands right now, the web site alphabetizes what is displayed, so that's handled regardless of order in YAML
17:12:49 <j^2> it’s just odd not to have the yml alphabitized
17:13:02 <kfox1111> it means we can drop the sort in the ui though too, which should increase performance a bit.
17:13:09 <docaedo> and in that case, if I'm adding a Heat template it would be pretty easy to search for the first asset_type: heat and then add my thing under that
17:14:00 <docaedo> I think dropping sort from the UI would be a mistake, there's no way that's a performance hit - on the web side, you are loading the whole file no matter what, basically into a dictionary
17:14:27 <docaedo> dropping sort means we hope users will always get the order right, in all cases, which they won't
17:14:37 <kfox1111> your right in that its probably minor compared to loading the whole thing...
17:14:44 <docaedo> BUT I propose we move on and debate that in reviews :)
17:14:53 <kfox1111> k.
17:15:01 <docaedo> #topic All about the roadmap
17:15:01 <j^2> sounds good
17:15:50 <docaedo> I don't want to re-hash what I wrote to the ML last week, but thought we should take some time today to discuss it at least. I didn't get any feedback on what I wrote, so either nobody read it, or everyone agrees with all I said
17:16:12 <kfox1111> what was the subject?
17:16:20 <docaedo> (hold for link to message)
17:16:29 <kfox1111> thx.
17:16:33 <j^2> i’m still attempting to get my head around this project, i didnt feel like i could add anythnig constructive till i get the lay of the land
17:16:48 <kfox1111> I did read it at the time, and I didn't disagree with it if I remember correctly.
17:16:53 <docaedo> #link http://lists.openstack.org/pipermail/openstack-dev/2015-July/070423.html
17:17:12 <docaedo> Subject: [app-catalog] Catalog roadmap and next steps
17:17:47 <kfox1111> ah. right.
17:17:56 <docaedo> A big reason I sent that out was to hopefully attract some more folks to get them involved
17:18:04 <kfox1111> yeah, I agree, its a good bit of work there. and it seems to fit.
17:18:30 <docaedo> j^2: do you feel like you're getting your head around the project, and the lay of the land? Maybe first item on the roadmap should be "clarify what we are trying to do"? :)
17:18:37 <j^2> ha!
17:18:42 <kfox1111> I'm really hoping when we get a dashboard plugin going, more users that are developers start surfacing.
17:18:50 <kzaitsev_mb> back to my laptop
17:19:01 <docaedo> kzaitsev_mb: nice!
17:19:47 <j^2> docaedo: yeah i think i’m starting to understand whats going on; i like that “stage” conversation from the other day, it made the charter of this project make more sense
17:19:49 <kfox1111> I think part of the problem may be in the ambiguity that still exists related to multiple openstack components claiming app catalog bits.
17:20:43 <rhagarty_> kfox1111: do you have any docs related to the "get a dashboard plugin going"?
17:20:55 <kfox1111> rhagarty_: yes. sec...
17:21:16 <kfox1111> until the stackforge repo's ready, its located here:
17:21:20 <kfox1111> #link https://github.com/kfox1111/apps-catalog-ui/
17:21:28 <kfox1111> the readme has instructions.
17:21:37 <rhagarty_> kfox1111: thanks!
17:21:46 <kfox1111> np. please let me know if you run into any issues.
17:21:56 <kfox1111> Its also very green at the moment. :)
17:23:04 <docaedo> Regarding the roadmap in my email, I did not put them in the order of implementation (I should have!) but I feel like we have a good path planned for handling multiple asset types, and integrating glance as the backend solves other stuff (like search/sort, etc).
17:23:12 <docaedo> Regarding the roadmap in my email, I did not put them in the order of implementation (I should have!) but I feel like we have a good path planned for handling multiple asset types, and integrating glance as the backend solves other stuff (like search/sort, etc).
17:23:13 <rhagarty_> I think I already installed it... does that UI reside under "Murano" panel?
17:23:39 <docaedo> definitely not under the Murano panel (and you've just hit the confusion kfox1111 was alluding to!)
17:24:08 <rhagarty_> oh, because it has an Application Catalog section
17:24:08 <kfox1111> no. murano also claims to be an app catalog. which is part of the confusion. :/
17:24:15 <kfox1111> yeah.
17:24:32 <rhagarty_> ok - good. I'm not the only one
17:24:42 <kfox1111> Murano's a local app catalog for murano apps.
17:25:04 <kfox1111> the apps-catalog project is for global apps and components...
17:25:07 <rhagarty_> yeah, that's confusing
17:25:13 <kfox1111> murano apps are part of what we provide.
17:25:24 <kfox1111> thats something that we really need to resolve at some point.
17:25:36 <rhagarty_> ok - that makes some sense
17:25:51 <kfox1111> so an op downoads a murano app from the catalog, loads it into murano,
17:26:00 <kfox1111> and their users can then launch it from the murano catalog...
17:27:17 <rhagarty_> ... and that is just one part of the global apps project (you guys)?
17:27:21 <docaedo> any thoughts about how we could include comments/feedback on a per-asset basis?
17:27:34 <kfox1111> right. apps written as heat templates work too,
17:27:38 <kfox1111> as well as glance images, etc.
17:27:41 <docaedo> rhagarty_: no actually Murano is it's own thing, fully independent
17:27:43 <j^2> docaedo: can you define “asset?"
17:27:43 <kzaitsev_mb> docaedo: discuss? =)
17:28:14 <kfox1111> docaedo: we really need something dynamic to support that. elasticsearch or something.
17:28:28 <kfox1111> or mongodb.
17:28:49 <kzaitsev_mb> wonder if glance storage might help with that as a backend. although i doubt that, actually
17:28:51 <docaedo> kfox1111: probably start the conversation though with "build it ourselves" or use something external
17:29:18 <docaedo> (which kzaitsev_mb was probably suggesting disquss I think, or whatever that's called?)
17:29:27 <kfox1111> we probably should back up and ask ourselves at that point should we restart the website.
17:29:41 <kfox1111> we already chose "do it ourselves".
17:30:22 <docaedo> not quite - lots of static sites include external comment/feedback mechanisms
17:30:37 <kzaitsev_mb> #link https://en.wikipedia.org/wiki/Disqus yep, these guys
17:30:59 <kzaitsev_mb> but it's just a suggestion, I've never really used them
17:31:20 <kfox1111> hmm... I was thinking more programatically. like number of stars on the entries, that users could adjust.
17:31:22 <j^2> if you’re looking fro a forum style: http://www.discourse.org/ is awesome
17:31:29 <kzaitsev_mb> Every time I used some glue code to stich some commenting/voting system by hand.
17:32:02 <kfox1111> Does openstack promote any web services that can't run on their own hardware?
17:32:06 <j^2> commenting and voting also can be problematic, at a certian point it litterally means nothing unless you moderate it
17:32:18 <kfox1111> yeah.
17:32:21 <docaedo> j^2: yes completely agree
17:32:24 <kzaitsev_mb> j^2: thats important point too.
17:32:39 <j^2> chef is having issues with this and our supermarket
17:32:57 <j^2> it just happens which is annoying because in general people suck on the internet
17:33:07 <docaedo> I'm just VERY concerned that the further we go down the road of build it ourselves, the slower we will progress
17:33:09 <kfox1111> heh. yeah.
17:33:15 <kzaitsev_mb> voting is a bit easier with UP and DOWN votes. but commenting HAS to be moderated (either post or pre)
17:33:32 <kfox1111> thats whlimit just how simple it is for now.
17:33:44 <j^2> kzaitsev_mb: yeah and it gets expodentially harder as you add more and more things to moderate
17:33:48 <kfox1111> +1 -1 or 1-5 rating is not as prone to abbuse.
17:34:04 <j^2> it becomes a full time job before you know it
17:34:11 <kfox1111> yeah.
17:34:20 <kzaitsev_mb> kfox1111: but you'll never at least see profane language there )
17:34:28 <docaedo> moderation I don't think will be that difficult until we have thousands of assets .. but main reason I brought this up is that solving this is going to be a big important step to help build up the catalog
17:34:50 <kzaitsev_mb> also. this rises the question of authentication
17:34:53 <j^2> docaedo: i just wanted to make sure the statement that it cuts both ways was made
17:35:05 <docaedo> we're definitely not going to sort it today but the seed has been planted and we can start talking about it, eventually maybe write up a spec (to bike-shed this into oblivion!)
17:35:32 <j^2> my bikeshed is cyan btw
17:35:48 <kfox1111> yeah. one action item would be to check if openstack resources must host openstack sites.
17:36:07 <docaedo> kfox1111: you mean - can an "openstack" thing use an external service?
17:36:12 <kfox1111> ie, is it ok to farm out forum like stuff to another site that does it without access to the code to run local.
17:36:25 <kzaitsev_mb> like. If I can vote — I must authenticate somehow. (But that can be possibly solved with our gerrit/l-pad accounts
17:36:28 <docaedo> got it .. good thing to sort out
17:36:51 <docaedo> quite possibly we can re-use much of ask.openstack.org for this stuff
17:37:02 <docaedo> (solved problem which works nicely)
17:37:03 <kfox1111> ie, must the forum software be open source? and not a free as in beer website.
17:37:14 <kfox1111> ah. interesting. yeah.
17:37:21 <j^2> kzaitsev_mb: ooh good point, if we attach it to lp then you have to sign the CLA and that’s a great gater
17:37:28 <docaedo> questions == assets, you get conversation, voting, authentication...
17:37:45 <kfox1111> yeah. lets bring it up with them.
17:38:04 <kzaitsev_mb> docaedo: you mentioned specs. maybe we should also add a spec repo?
17:38:23 <kfox1111> -1
17:38:28 <j^2> -1
17:38:30 <kzaitsev_mb> ok =)
17:38:34 <kfox1111> they really tend to slow things down, and we're too green at the moment. :/
17:38:36 <docaedo> kzaitsev_mb: yes, I had that on my to-do list from the summit, but honestly held back because I'm not entirely convinced it would be a benefit :)
17:38:39 <j^2> specs are…combersume for the most part
17:38:46 <docaedo> haha, as the -1's while I was typing show
17:39:08 <kfox1111> once we have alot of base functionality roughed in, then we should do it.
17:39:23 <kfox1111> for now, lets stay more agile.
17:39:29 <j^2> +1
17:39:29 <docaedo> #action discuss/consider using ask.openstack.org code for voting/comments
17:39:51 <docaedo> ah, that should have been "discuss with ask.openstack.org folks"
17:40:11 <kzaitsev_mb> you can undo with #
17:40:13 <kzaitsev_mb> I think
17:40:28 <docaedo> eh, no biggie :)
17:41:25 <docaedo> Anyone feel like picking up the "stale entry checker" blueprint? Haven't heard from Gosha on that in a while, assuming he's staying focused on Murano fun
17:43:28 <docaedo> silence ..heh, ok, will table it for now
17:43:33 <kzaitsev_mb> I'm not yet that familiar with zuul jobs
17:43:42 <docaedo> moving on then?
17:44:00 <docaedo> #topic App Catalog Horizon Plugin Update (kfox1111)
17:44:32 <kfox1111> Since the last update, I've gotten glance image support added.
17:45:19 <kfox1111> Also split the code out into its own repo, and a patch submitted to horizon for liberty
17:45:44 <docaedo> Nice work!
17:45:56 <kfox1111> #link https://youtu.be/9TlPhmml-T8
17:46:04 <kzaitsev_mb> kfox1111: asked me to take a look into murano-apps, which I hope to do by the next meeting
17:46:10 <kfox1111> #link https://github.com/kfox1111/apps-catalog-ui/
17:46:11 <docaedo> I have small things to do on the repo request and will address them right after this meeting, maybe new repo will be available soon
17:46:12 <kzaitsev_mb> #link https://review.openstack.org/#/c/206773/
17:46:34 <kfox1111> Right now, the ui's not structured quite right.
17:46:45 <kfox1111> heat templates are in apps, glance is under components.
17:46:55 <rhagarty_> is this all brand new stuff? Did any form of this land in Kilo?
17:46:58 <kfox1111> but long term, we want to tag images as possibly being apps so they show up under apps.
17:47:14 <kfox1111> The code relies on some of the angular changes in liberty.
17:47:30 <kfox1111> I haven't looked at how hard it would be to backport, but I think relatively hard. :(
17:47:47 <kfox1111> fortunatly, newer horizon tends to work well with older everything else.
17:48:38 <kfox1111> same thing with murano. we sould tag things launchable by users as apps, and leave the libraries and such as components.
17:49:09 <kzaitsev_mb> there's a lot of angular work going on in horizon for liberty, that was not present in kilo, so I bet it would be hard to make the plugin work with kilo
17:49:14 <docaedo> rhagarty_: nothing in Kilo for sure, and won't land in Liberty either, but I have high hopes that having it in M is possible...
17:49:37 <docaedo> I would say backporting the Horizon panel is not worth the effort
17:49:42 <kfox1111> I'm hoping the patch lands for liberty. should be time.
17:49:51 <kfox1111> then the plugin can be added to any liberty horizon.
17:49:57 <rhagarty_> ok - is there an existing CLUI to see this data?
17:50:03 <docaedo> kfox1111: that's great!
17:50:29 <kzaitsev_mb> theres 1 month before L3 and FF, so there's quite some time for patch to land )
17:50:45 <kfox1111> rhagarty_: no. someone would need to code it. Its not clear how well a cli would work for this ultimately.
17:51:14 <rhagarty_> ok - just used to seeing CLUI's first, then the Horizon view of it
17:51:16 <kfox1111> most of the work is in the user interface for searching via facts and stuff. that tends to not adapt well to cli's. :/
17:51:35 <kzaitsev_mb> rhagarty_: looks more like, that individual clients would have to support catalog
17:51:36 <kfox1111> but maybe a cli for pulling an app and all its dependencies once you know which one you want might make sense.
17:51:53 <docaedo> In my head (not put down on a roadmap yet) I do think having this added to the openstack cli would be really valuable
17:52:19 <docaedo> essentially a shim between the different supported asset types, and doing the same thing the horizon panel does
17:52:28 <kfox1111> yeah, just not sure how a cli ui for that would look. has anyone written a cli for amazon's store? :/
17:52:50 <kzaitsev_mb> murano does have rudimentary support for app catalog in CLI, btw.
17:52:55 <docaedo> I'm thinking more along the lines of "docker search" and "docker pull"
17:53:06 <kzaitsev_mb> but adding support to openstack-client does sound like a nice idea
17:53:16 <kfox1111> hmm... maybe. should explore that more.
17:53:26 <rhagarty_> so would this UI live along side Murano? If so, that would really be confusing
17:54:03 <kzaitsev_mb> rhagarty_: sorry, which UI?
17:54:11 <docaedo> rhagarty_: it would be in the same horizon, yes, but it's not going to be easy to convince Murano to rename their bits to not include "application catalog", since they were there first
17:54:31 <rhagarty_> and then your UI would also show Murano apps?
17:54:46 <kfox1111> yeah. really not sure how that's going to work. :(
17:54:57 <docaedo> 5 minutes left - kfox1111 had one more item (other horizon plugins), just want to make sure we hit that if he wants to cover it
17:55:11 <kfox1111> oh. yeah.
17:55:16 <rhagarty_> +1
17:55:33 <docaedo> #topic Other Horizon Plugins (kfox1111)
17:55:41 <kfox1111> should horizon plugins be in the app catalog as another asset type?
17:55:47 <docaedo> -1
17:55:50 <rhagarty_> +1
17:55:57 <rhagarty_> please :)
17:56:04 <kfox1111> Its unlikely to be something that could easily just be installed by the app catalog engine.
17:56:20 <kfox1111> but we have other assets that can't either. the windows image for example.
17:56:33 <rhagarty_> pip install and one config file... typically
17:56:36 <docaedo> that's only because of a EULA click-through though
17:56:50 <kfox1111> rhagarty: the majority of plugins I've experienced didn't work that cleanly.
17:57:15 <kfox1111> docaedo: sure, but it is still something that fails the directly installable sniff test.
17:57:18 <rhagarty_> yeah, there is usually a glitch, but that usually the extent of it
17:57:22 <kfox1111> it just depends on how we define the line.
17:57:32 <kfox1111> not in my experience.
17:57:41 <kfox1111> for example, I tried to install the murano plugin,
17:57:55 <kfox1111> but a pip install would have pulled in lots of kilo clients overwriding all the juno stuff, breaking stuff badlyl.
17:58:24 <docaedo> I'm going to always be pushing from the perspective of cloud users, with the opinion that cloud OPERATORS have different resources when it comes to building clouds
17:58:34 <kfox1111> it may work if your using pip for deploying horizon, not sure. but I'm using RDO.
17:58:35 <rhagarty_> that one was a bit more involved than most I've had experience with
17:58:43 <rhagarty_> how about just a list with PiPY pointers, as a start?
17:58:46 <kfox1111> I know fuel based horizons will probably run into similar issues.
17:59:17 <rhagarty_> a short description, then a link to the PyPI package
17:59:33 <docaedo> IMO we are hitting a legitimate issue (Where do I find all the parts that I can use to build an OpenStack cloud?), but that was not the idea of the app catalog
17:59:34 <kzaitsev_mb> kfox1111: probably you should have installed juno murano-dashboard, but yeah, that's a very good point. pip install can ruin your horizon in a lot of ways.
17:59:36 <kfox1111> I'm both a cloud op and cloud user. I'd say cloud op is a subset of cloud user and should have their own view.
17:59:46 <kfox1111> hide op stuff from regular users. but don't disallow it.
18:00:22 <kfox1111> kzaitsev_mb: yeah, but I was running a kilo murano because juno murano wasn't quite featureful enough for what we wanted. :/
18:00:25 <rhagarty_> users want the plug-ins, not OPS. But how do they know they exist?
18:00:31 <kfox1111> wasn't sure the juno ui would work with the kilo engine. :/
18:00:55 <docaedo> ah, times up :(
18:01:02 <docaedo> we can debate on the channel now!
18:01:05 <kfox1111> that goes back to the question is the app catalog a discovery mechanism
18:01:16 <kfox1111> to let users discover something, then tell their op they want it.
18:01:16 <docaedo> #endmeeting