17:00:33 <docaedo> #startmeeting app-catalog
17:00:34 <openstack> Meeting started Thu Aug  6 17:00:33 2015 UTC and is due to finish in 60 minutes.  The chair is docaedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:37 <openstack> The meeting name has been set to 'app_catalog'
17:00:45 <docaedo> #topic rollcall
17:00:48 <kfox1111> o/
17:00:53 <kzaitsev_mb> o/
17:01:19 <kzaitsev_mb> docaedo: you should o/ too =)
17:01:23 <docaedo> o/
17:01:28 <docaedo> haha, was about to do that
17:01:33 <docaedo> #topic Status updates
17:01:43 <docaedo> New repo for App Catalog UI work landed
17:01:43 <docaedo> #link https://review.openstack.org/#/c/207253/
17:01:52 <docaedo> I added a handful of new blueprints based on things we've been discussing/planning.
17:01:55 <docaedo> #link https://blueprints.launchpad.net/app-catalog
17:02:04 <docaedo> "Multiple asset types" work appears to be making really good progress, kfox1111 do you want to give a quick update?
17:02:22 <kfox1111> Sure.
17:02:29 <kzaitsev_mb> I've promised to work on murano part of the ui-thingy, but failed to keep my promise =(
17:02:44 <kfox1111> glance_images and heat_templates are sharing a common schema now.
17:02:45 <kzaitsev_mb> strated to work on that today, but was constantly distracted by different stuff
17:03:16 <docaedo> kfox1111: thanks!
17:03:17 <kzaitsev_mb> hope to sort it out though
17:03:22 <kfox1111> I've been looking at the murano one too. Just need to add the deps stuff I think to the common schema and then can merge that schema too.
17:03:32 <kfox1111> but that is partially related to
17:03:42 <kfox1111> #https://blueprints.launchpad.net/app-catalog/+spec/murano-apps-dependencies
17:03:46 <kfox1111> #link https://blueprints.launchpad.net/app-catalog/+spec/murano-apps-dependencies
17:04:14 <kfox1111> since it would be common, we should fix it at the same time so deps work with heat templates too.
17:04:25 <docaedo> regarding murano-apps-dependencies, I added a note to the whiteboard suggesting app catalog should not get into the business of dependency management...
17:04:44 <kfox1111> I added a note saying it was already in the buisness.
17:04:49 <docaedo> unless we can agree it would be VERY minimal - otherwise, starts to sound like we want to become a package manager
17:05:10 <kfox1111> yeah. the web ui already has the ability to install components.
17:05:22 <kfox1111> I think for now, all it would do is show you each with a link by each to install it.
17:05:27 <kfox1111> something simple, but usable.
17:05:46 <docaedo> ah, we moved on BTW to:
17:05:49 <docaedo> #topic App Catalog Horizon Plugin Update (kfox1111)
17:06:43 <docaedo> so - I agree there is value there (dep management), just want to make sure we don't start getting too complicated with multiple recursions of checking and fetching deps
17:07:07 <kfox1111> ah. yeah. agreed.
17:07:27 <kfox1111> no complicated dep resolver.
17:07:31 <docaedo> +1
17:08:28 <docaedo> Any other updates, or do we move on to open discussion?
17:08:58 <docaedo> actually before we move on, and on this topic (horizon plugin)
17:09:26 <docaedo> Just wanted to say the more I think about it, the more excited I get about the potential for this to bring in more contributors from the openstack dev side
17:09:45 <kfox1111> #link https://youtu.be/2UQ6xa6uDQY
17:09:51 <kfox1111> newest plugin demo.
17:10:01 <docaedo> as we talked about on the main IRC channel, it really could become THE way to bring things into your OpenStack environment regardless of which service you're talking about
17:10:10 <docaedo> thanks for sharing the demo!
17:10:13 <kfox1111> its already a bit out of date as of this morning. I got magic search working. :)
17:10:24 <docaedo> awesome!
17:10:34 <kzaitsev_mb> damn you're fast =)
17:10:49 <kfox1111> I also got the ability to point it at a local server running apps-catalog content.
17:11:01 <kfox1111> One of the next thigns I want to play with is a more
17:11:19 <kfox1111> #link https://play.google.com/store
17:11:31 <kfox1111> style display for the apps view.
17:11:45 <kfox1111> icon, description, can go in and look at details, install/launch.
17:12:14 <docaedo> I like that idea, also touches on something I was going to bring up later - I want to include a way for a contributing company to include their logo with the asset
17:12:38 <docaedo> I know for certain the idea of visibility is holding back a few people who have existing assets that would be good in the catalog
17:12:45 <kfox1111> yeah. I was starting to work on that this morning, and then realized, I needed a place to try adding icons, where the horizon ui coudl get it,
17:12:53 <kfox1111> but before it was committed to apps.openstack.org.
17:12:54 <docaedo> (ie they worked hard on the assets and still want SOME branding indicating they contributed them)
17:13:36 <kfox1111> hmm...
17:13:43 <kfox1111> so we have provided_by, and supported_by.
17:14:07 <kfox1111> provided_by maybe shoudl have an icon too?
17:14:19 <docaedo> yep - just adding the ability to include an image there too (like provided_by HP, and a small HP logo there too)
17:14:21 <kfox1111> company_logo?
17:14:27 <docaedo> exactly what I was typing :)
17:14:36 <kfox1111> cool. makes sense to me.
17:15:06 <docaedo> nice, I'll add a blueprint for that - just so we don't lose track
17:15:17 <kfox1111> k. thx.
17:15:21 <kzaitsev_mb> sounds nice to me. That would actually make companies use app-catalog as an advert platform
17:16:03 <kzaitsev_mb> although it does bring up some concerns, cause the app-catalog would use assets, that might be copirighted. But I guess that's on users concious
17:16:23 <docaedo> kzaitsev_mb: that should be covered by the license details
17:17:31 <kfox1111> I think firefox has had recent conversations on this topic.
17:17:37 <kzaitsev_mb> docaedo: let's maybe add a bp for license, too? I believe, that we've all signed a license when we started contributing ot OS, but what happens, when we contribute to app-catalog?
17:18:01 <kfox1111> they are shipping logo's as part of the search widget. they are not open source because they are logo's...
17:18:10 <kfox1111> so debian kind of had issue with it.
17:18:31 <docaedo> you have to agree to the openstack contributor license to contribute to the app catalog, so that's covered - but I see what you're saying w/r/t logos
17:18:36 <kfox1111> I'd say, for those logo's, we just link to them in the metadata and pulll right from the url.
17:18:40 <docaedo> is it a concern if you link
17:18:47 <docaedo> haha, yeah, again typing same thing same time
17:19:04 <kfox1111> if we just link, thats a lot less dangerous.
17:19:07 <kfox1111> :)
17:19:43 <docaedo> #link https://blueprints.launchpad.net/app-catalog/+spec/contributed-by-logo
17:20:40 <kzaitsev_mb> although that leaves place for resources getting deleted from remote stuff, but that's something we have covered in the stale-resources bp, I guess
17:20:51 <kfox1111> yeah.
17:20:52 <kzaitsev_mb> but generally sounds nice )
17:21:24 <docaedo> once again with ninja stealth we changed topics :)
17:21:26 <docaedo> #topic Open discussion
17:21:34 <kfox1111> longer term, we might be able to come up with a thing that says, if you license it to us in such a way it can be associated with the catalog and we distribute it, it can go on apps.openstack.org. but thats way out.
17:22:10 <docaedo> agreed, definitely have a few other things to solve first :)
17:22:25 <docaedo> I had an idea, wanted to get your thoughts.
17:22:29 <docaedo> Should we consider storing Heat templates in the app-catalog repo? I think it would be a good way to encourage people to contribute templates, and we could encourage people in the Heat community to help review them as well.
17:22:36 <docaedo> Right now there's no obvious place to go find or put heat templates. We obviously want the app catalog to be the place to find heat templates, and the mechanism right now assumes the contributor has their own repository for holding the templates (so contributions are just pointers to templates hosted elsewhere).
17:22:41 <docaedo> Any reason not to encourage people to start keeping them in app catalog? Thoughts?
17:24:13 <docaedo> *crickets*
17:24:27 <kzaitsev_mb> that depends...
17:25:24 <kfox1111> sorry...
17:25:30 <kfox1111> Yes, and no?
17:25:35 <kzaitsev_mb> on the one hand I can imagine people constantly improving their template, like on github. in that case we would have access to the latest version
17:25:55 <kzaitsev_mb> unless linked directly to some pinned version
17:25:57 <kfox1111> Yes, I totally want a place where I can contribute templates to the greater community that isn't "examples" like heat-templates.git repo.
17:26:13 <kfox1111> but, probably doesn't belong in the app-catalog repo?
17:26:33 <kfox1111> maybe a app-catalog-heat-templates repo or something?
17:26:59 <kzaitsev_mb> kfox1111: and then app-catalog-solum, app-catalog-glance, app-catalog-docker-images? =)
17:27:20 <docaedo> yeah, I think that makes more sense than just dumping it into the main repo
17:28:16 <docaedo> then on the other hand, feels like we would be trying to solve a different problem (get people to create/maintain heat templates)
17:28:31 <kfox1111> solum/glance are tarball/image kinds of things. not very git friendly.
17:29:01 <kfox1111> yeah. it could belong to the heat project too. I've been trying for over a year to get them to do it though, with no affect.
17:29:12 <kfox1111> so it may be easier to do it here.
17:29:15 <kzaitsev_mb> oh. docaedo you wanted to put heat templates in the git repo?
17:29:19 <docaedo> yes, heat is the one that's pretty friendly for git, others, no so much
17:29:36 <kfox1111> if it ends up being wildy successful and heat wants to take ownership at that point, great. :)
17:29:44 <docaedo> kzaitsev_mb: yes, was thinking of exactly that
17:30:09 <docaedo> kfox1111: and yeah, that's kind of what I was leaning towards, because nobody else seems to want to solve that problem
17:30:20 <kzaitsev_mb> no, I actually do not think it's a good idea, since other types are not friendly to git, and it would, like separate asset types into ones that fit into repo and ones that do not.
17:30:39 <kzaitsev_mb> also. in future roles of moderators/developers might be separated (I hope so)
17:31:04 <kzaitsev_mb> and this would mean, that heat-template providers would have to be moderated by catalog developers, not catalog moderators
17:31:12 <docaedo> I think you guys have successfully talked me out of the idea
17:31:26 <kfox1111> so you could do a app-catalog-text-resource or something,
17:32:28 <kfox1111> well, having them moderated by catalog folks is still better then not having them moderated at all.
17:32:31 <docaedo> I would say we table the idea for now but keep it kicking around at least, at some point we might hit a variation of the idea that makes more sense
17:32:48 <docaedo> because one thing I realize - if I'm creating a heat template
17:33:08 <docaedo> I want to "own" it, I don't want to have to wait for a core reviewer here to bless my updates/changes
17:33:22 <kfox1111> I disagree for one reason.
17:33:34 <kfox1111> I can self own it on github today. that doesn't buy me something I want.
17:33:44 <kfox1111> openstack's great CI stuff.
17:33:49 <kfox1111> I want to contribute a template,
17:33:56 <kfox1111> and then have CI continue to check on it.
17:34:09 <kfox1111> cause stuff breaks, and I want to know when, so I can go fix it.
17:34:18 <kfox1111> github doesn't provide that.
17:34:42 <kfox1111> if its in an openstack managed repo, that's possible.
17:34:52 <docaedo> there's some truth and value there, but you could still keep it on your own github account, and we tie in some app-catalog CI (that you've talked about) to test contributed Heat elements
17:34:53 <kfox1111> I guess as econd benifit is the reviewers.
17:34:58 <docaedo> s/elements/assets/
17:35:03 <kfox1111> they can say "oh, thats good, but if you do it this way, its even better"
17:35:14 <kfox1111> I've already given j^2 help in that reguard with his heat template.
17:35:29 <docaedo> yep, and it's been great feeback (I've been watching)
17:35:45 <docaedo> in reality though, folks should be getting that from #openstack-heat
17:36:04 <kfox1111> if we have an app-catalog-heat repo, we ccan probably encurage heat developers to watch it.
17:36:08 <j^2> Yep
17:36:18 <docaedo> hey, j^2, nice to see you!
17:36:22 <kfox1111> but they currently have single no place to go and look
17:36:35 <kfox1111> with a git repo/gerrit, you can preemptively find things.
17:36:36 <j^2> Hi! I've been heads down on something
17:36:48 <docaedo> j^2: no prob
17:36:52 <kfox1111> with #irc+github, you have to wait for a developer to ask.
17:37:32 <docaedo> so on this Heat repo topic, is it worth surfacing on the ML with [heat] in the subject, asking if they think there's value in creating a repo specifically for contributors
17:37:33 <kfox1111> like, I had no idea j^2 had a heat template until he tried to add an app catalog entry.
17:37:49 <kfox1111> yeah, I think thats a good action item.
17:38:00 <docaedo> and by extension, that repo becomes a place to test heat stuff and get feedback from heat community
17:38:03 <docaedo> cool!
17:38:14 <kfox1111> if we can get some heat developers to watch the repo, then it will cause much better quaility heat templates to be produced.
17:38:45 <kfox1111> alternitively, if enough develoeprs start contributing to it, there will aready be a set of developers interested in watching it.
17:38:45 <docaedo> #action docaedo to writ to ML regarding Heat contributors repo for app-catalog
17:39:11 <kzaitsev_mb> that seems like a big if to me (although I do not know a lot about heat community responsiveness)
17:39:23 <kzaitsev_mb> so it might actually  work out
17:41:31 <kfox1111> it may, or it may not. can't be much worse then not trying?
17:42:17 <docaedo> yep - I'm goign to write the note before I let myself walk away from the computer this morning :)
17:42:38 <docaedo> Anything else for open discussion? I don't have anything else on my own list
17:44:09 <docaedo> ok - unless anyone else speaks up in the next minute or so, we can end early and move on to whatever else we're all up to...
17:45:02 <kfox1111> I think thats probably about it.
17:45:43 <docaedo> Thanks for joining today :)  Talk to you all on #openstack-app-catalog!
17:45:47 <docaedo> #endmeeting