17:01:22 <docaedo> #startmeeting app-catalog
17:01:24 <openstack> Meeting started Thu Jun  9 17:01:22 2016 UTC and is due to finish in 60 minutes.  The chair is docaedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:28 <openstack> The meeting name has been set to 'app_catalog'
17:01:33 <docaedo> #link https://wiki.openstack.org/wiki/Meetings/app-catalog#Proposed_Agenda_for_June_9th.2C_2016_.281700_UTC.29 Agenda
17:01:36 <kzaitsev_mb> o/
17:01:59 <docaedo> #topic Status updates
17:02:23 <docaedo> Anyone have any updates to share?
17:02:41 <igormarnat_> kzaitsev_mb: ^^ ?
17:03:18 * olaph has none, but waves 'hello'
17:03:22 <kzaitsev_mb> I sadly have none =( I still haven't completed/updated the patches for glare, but I intend to do so, probably tomorrow
17:03:35 * leong say hi to everyone
17:03:35 <kzaitsev_mb> Also I now have time to work on the auth middleware
17:03:36 <docaedo> kzaitsev_mb: ok, that counts as an update :)
17:03:46 <docaedo> hello leong!
17:04:04 <docaedo> kzaitsev_mb: thats great news that you'll have time to work on the auth stuff!
17:04:33 <igormarnat_> kzaitsev_mb: AFAIK the plan was to prepare remaining patches to merge and start working on preparing auth staff, right?
17:05:53 <kzaitsev_mb> so hope, that I'll have something to show next week =)
17:05:58 <kzaitsev_mb> igormarnat_: yep, that's the plan
17:06:02 <docaedo> kzaitsev_mb: excellent
17:07:00 <igormarnat_> kzaitsev_mb: docaedo we'll need to work with Infra team to start deploying new backend, right?
17:07:40 <igordcard> haven't got a chance to look at these yet
17:07:44 <docaedo> yes, once testing is solid and we're confident, deployment will just be through an update to the puppet manifest
17:07:59 <docaedo> the DB side will use trove (via rackspace)
17:08:39 <igormarnat_> docaedo: do we have some staging? I'm just curios about details of how testing is going to happen
17:08:40 <docaedo> AFAIK there is expected to be two phases - one for v1 where updates still happen via changes to assets.yaml file
17:09:06 <docaedo> then when v2 works (with auth), we would move all additions/changes/etc to be direct against the API
17:09:48 <docaedo> there's no dedicated staging server, my expectation is that myself plus whoever else wants to - will deploy for test to our own VMs to validate things work right
17:10:01 <igormarnat_> got it, thank you!
17:10:05 <docaedo> when I did the initial puppet work I just used a single VM and would manually apply the puppet manifest
17:10:36 <docaedo> When we get closer I will document how I got the base infra stuff set up so that the "puppet apply" worked right
17:11:16 <igormarnat_> Ok, so so far all the knowledge about how it works and how it should be updated is in your heads, folks:)
17:11:18 <docaedo> in this case it's going to be a little more complicated since we'll have a DB instance associated (so not sure the best way to test that short of using rackspace or else a devstack+trove instance)
17:12:55 <docaedo> igormarnat_: sort of :) the deployment stuff is standard openstack infra, and the puppet work is here: http://git.openstack.org/cgit/openstack-infra/puppet-apps_site
17:13:32 <docaedo> so any updates/changes to deployment will be managed through that - but the glare side (and how we transition) is not documented other than the high level plan in an etherpad
17:13:55 <igormarnat_> Ok, so looking forward to hear from kzaitsev_mb about readiness of new backend code, auth and deployment
17:14:08 <docaedo> When the glare stuff is ready we will have to chat in details on #openstack-app-catalog and get it all together
17:14:23 <igormarnat_> Cool
17:14:37 <docaedo> Any other status updates?
17:15:25 <igormarnat_> I wanted to talk a little bit about our progress and plans with working with apps and collaborating around them, but this is probably another part of the meeting
17:15:46 <docaedo> yep, that's the next topic
17:16:00 <docaedo> #topic App Dev Community Discussion (Igor)
17:16:01 <docaedo> specifically: Discuss test/gate pipeline for apps
17:16:16 <docaedo> igormarnat_: take it away sir!
17:16:48 <igormarnat_> docaedo: Well, just a little update about our status with this
17:17:21 <igormarnat_> We moved murano-apps repository to be managed by new team, murano-apps-core, the team is there, apps are there, there is IRC channel #murano-apps
17:17:27 <igormarnat_> So we are progressing
17:17:41 <docaedo> igormarnat_: that's good news
17:18:05 <igormarnat_> Other items from the plan was to change/simplify workflow of publishing apps to the catalog, but this obviously waits for the switching to new backend
17:18:18 <igormarnat_> docaedo: you also want to talk a bit about CI/testing for apps
17:18:24 <igormarnat_> *wanted
17:19:10 <igormarnat_> What was the question? And how to you see it to work in the future?
17:19:12 <docaedo> igormarnat_: yes, I thought we could start thinking about that, starting first with murano
17:19:28 <igormarnat_> docaedo: we also made some progress with that
17:19:48 <docaedo> right - seems like for speed, we'll need someone to donate hardware for 3rd party CI (so there's a cloud with murano ready to test the apps)
17:19:54 <igormarnat_> There is 3-rd party CI implemented for ci-cd-pipeline application
17:20:18 <docaedo> excellent!
17:20:19 <igormarnat_> and the bot which deploys an application and checks whether it was successful or not
17:20:34 <igormarnat_> For instance, https://product-ci.infra.mirantis.net/job/9.0.test_all/412/
17:20:42 <igormarnat_> Ups, sorry, wrong url
17:20:56 <igormarnat_> https://review.openstack.org/#/c/327216/
17:21:00 <docaedo> hah I was just going to say I think we need to be on the mirantis VPN for that :)
17:21:40 <igormarnat_> So there is a feedback from "murano-ci-cd-bot"
17:21:45 <docaedo> thats cool
17:22:31 <igormarnat_> Yes, it's something to begin with. Nexts steps would be to make it scalable and (hopefully, in the future) to start using OpenStack infra
17:23:42 <docaedo> Looks really good - for openstack infra though, this check relies on the cloud already being deployed and having murano installed right?
17:24:07 <igormarnat_> Yes, and the thing is though that I'm not sure it would be a good idea to use devstack for that in the future
17:24:33 <igormarnat_> Do you think we can agree with Infra folks on having somewhere Fuel community build deployed with Murano and use it for testing of apps?
17:24:34 <docaedo> no I agree, devstack would not be good, would take way too long and spends a lot of time doing something that is not relevant to the test
17:24:58 <docaedo> the problem right now is that infra is focused on testing openstack and related services
17:25:12 <docaedo> I think the only way to do it is 3rd party, because they don't have any long-running clouds or jobs
17:25:16 <docaedo> but
17:25:29 <docaedo> there was talk of potentially having a small cloud available
17:25:41 <igormarnat_> Yep, this is where this whole initiative started with:) OpenStack apps somewhat differ from OpenStack services, and as of now the whole workflow of our work is dedicated to services
17:25:44 <kzaitsev_mb> also, we'll end up having to build several test clouds if we would want to test against different openstacks
17:25:50 <docaedo> and as long as no admin access is required (user level access only), and the job can clean up after itself, there is potential
17:26:43 <igormarnat_> No admin access needed to upload and deploy new app (typically)
17:26:55 <docaedo> there's also a possibility of using a slice of OSIC maybe - but there are security concerns if the deployed apps can reach the internet
17:27:24 <igormarnat_> docaedo: Who are the guys we need to talk about these things? Infra channel or some other audience?
17:27:28 <docaedo> because this gateway then becomes a great way to sneak in backdoor access (like a new machine image that reaches out and makes a reverse tunnel to a spammers gateway)
17:27:45 <docaedo> igormarnat_: yes, #openstack-infra would be the place, I am not the authority on these things at all :)
17:29:05 <igormarnat_> docaedo: Yes, it seems this is new kind of concerns which we didn't deal before testing OS services using DevStack
17:29:14 <docaedo> indeed
17:30:22 <igormarnat_> docaedo: do you know which kind of cloud was under discussion? Any requirements/ideas about distribution?
17:31:03 <docaedo> igormarnat_: not sure - I know they have been working on setting up an infra cloud on donated HP hardware but the datacenter got flooded in texas storms around the time of the summit
17:31:24 <docaedo> so that was on hold - last I saw they were close to getting the equipment running again, but don't know about distro and so on
17:31:51 <igormarnat_> docaedo: OSIC is OpenStack Innovation Center?
17:31:56 <docaedo> which is a good question too, as there is no such thing as one openstack reference architecture (i.e. something more than devstack)
17:32:20 <docaedo> yes, OSIC is intel/rackspace cloud (innovation center)
17:32:59 <docaedo> I know intel is interested in supporting these efforts, so it might be possible to have a small cloud set up there - but of course someone has to maintain that cloud over time
17:33:10 <igormarnat_> Got it. So I probably need to take an action item to bring this into Infra team agenda somewhere soon and involve our folks working on this CI into this meeting
17:33:20 <docaedo> and usually OSIC only grants access to resources for a few weeks at a time, for scale testing and things
17:33:48 <leong> for OSIC there can be some exception but subject to approval
17:34:01 <igormarnat_> I have one good distro in mind which I know for sure works well with Murano, we'll see if this works :)
17:34:06 <docaedo> #action Igor to get on the Infra agenda to discuss app-dev CI
17:34:14 <leong> some of the OSIC infra also used for openstack infra now
17:35:36 <igormarnat_> docaedo: I think it's worth also to talk to Glance and Heat folks about their thoughts of validation of their templates and images, not sure if core teams are interested though, but we'll need to check
17:36:39 <docaedo> igormarnat_: yes I think both teams would be interested in that, especially if we can prove a sensible workflow with murano
17:37:07 <igormarnat_> I can take this action item as well
17:38:15 <docaedo> #action Igor to start threads with Glance and Heat teams about automated validation of templates and images
17:39:32 <docaedo> igormarnat_: thanks for taking all the action items :)
17:39:37 <igormarnat_> docaedo: thank you, I have two of AIs:)
17:39:40 <igormarnat_> Sure, np
17:40:00 <docaedo> anything else on this topic?
17:40:23 <igormarnat_> Not from my side
17:40:38 <kzaitsev_mb> none here too
17:40:52 <docaedo> #topic open discussion
17:41:10 <docaedo> The floor is open - I don't have any specific topics from my side
17:42:00 <igormarnat_> Same here. Looking forward to switch to new backend, this will unblock us going forward
17:43:13 <docaedo> igormarnat_: yeah I'm hopeful the new backend transition goes smoothly
17:44:22 <igormarnat_> Ok then, docaedo kzaitsev_mb thank you for chatting, talk to you soon!
17:44:56 <docaedo> you too - I think we're done, talk to you later on and ping on the app-catalog channel if there's anything I can help with, any questions, etc
17:45:03 <olaph> thanks docaedo!
17:45:21 <docaedo> thanks everyone!
17:45:24 <docaedo> #endmeeting