17:01:07 <docaedo> #startmeeting app-catalog
17:01:08 <openstack> Meeting started Thu Jul 14 17:01:07 2016 UTC and is due to finish in 60 minutes. The chair is docaedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:11 <sslypushenko> o/
17:01:11 <openstack> The meeting name has been set to 'app_catalog'
17:01:19 <olaph> o/
17:01:24 <kzaitsev_mb> o/
17:01:31 <docaedo> #link https://wiki.openstack.org/wiki/Meetings/app-catalog#Proposed_Agenda_for_July_14th.2C_2016_.281700_UTC.29 Agenda
17:01:54 <docaedo> #topic Status updates
17:02:16 <docaedo> We have on the agenda later specific glare updates from sskripnick
17:02:32 <docaedo> are there any other updates to share outside that?
17:02:35 <kzaitsev_mb> kfox1111 did a nice write up on the dashboard structure this week
17:02:40 <kzaitsev_mb> #link https://etherpad.openstack.org/p/apps-dashboard-structure
17:02:44 <igormarnat_> o/
17:03:27 <kzaitsev_mb> I've got to read it more carefully and comment a bit
17:03:27 <mfedosin> o/
17:03:34 <docaedo> oh that's great! I was traveling for work this week so have been a little disconnected
17:03:49 <kzaitsev_mb> docaedo: would appreciate if you would find a bit of time to look at it =)
17:04:42 <docaedo> I will
17:05:17 <kzaitsev_mb> I haven't updated the dashboard patches [ they're still red =( ] but planning to do that =)
17:05:38 <kzaitsev_mb> murano one is going to be a lot of renaming %)
17:05:44 <kzaitsev_mb> like really a lot of renaming )))
17:06:11 <kzaitsev_mb> I think that's all from my side of things )
17:06:37 <docaedo> any other updates?
17:06:40 <docaedo> anyone else have other stuff to share?
17:06:48 <mfedosin> oh yes
17:07:04 <mfedosin> Glare spec was merged today
17:07:11 <kzaitsev_mb> yay!
17:07:58 <mfedosin> and that's great, because we are not in limbo anymore
17:08:00 <docaedo> oh yeah I saw that!
17:08:47 <mfedosin> also we had a meeting with Heat and Murano teams and agreed on a few things:
17:08:54 <docaedo> but we still do not expect glare code to be merged before barcelona right?
17:09:13 <mfedosin> it has to be merged before 29th of July
17:09:34 <mfedosin> it's a deadline for us :)
17:10:01 <docaedo> oh that's really good news, I did not expect that
17:10:22 <mfedosin> but community is positive to these changes
17:10:50 <mfedosin> currently we are concentrated on writing tests
17:11:05 <kzaitsev_mb> even more yay!
17:11:18 <mfedosin> so, about our agreements...
17:11:38 <mfedosin> 1. artifact types shouldn't be stored in app-catalog
17:12:04 <docaedo> where would they be stored?
17:12:10 <mfedosin> currently they are https://review.openstack.org/#/c/337633/5/contrib/glare/openstack_app_catalog/artifacts.py
17:12:33 <mfedosin> we have 4 types: murano, heat, tosca, glance
17:12:55 <mfedosin> heat will be stored in glare repo
17:13:03 <mfedosin> other will have own repos
17:13:38 <mfedosin> it's done because we don't want types incompatibility
17:14:07 <mfedosin> I mean it's not good when there are two types for murano - one in app-catalog and one in murano itself
17:14:29 <docaedo> "other will have own repos" .. you mean different entire repository just for storing an artifact type definition?
17:14:55 <mfedosin> yep, and it's primarily murano requirement
17:14:59 <docaedo> I agree we should try to make these shared and the same everywhere
17:15:23 <docaedo> I'm just slightly confused about how to control that, and how we manage it from the app-catalog side
17:15:53 <docaedo> especially since I expect we will continue to add new artifact types over time - why wouldn't those definitions live in glance repo?
17:16:00 <kzaitsev_mb> docaedo: yep, basically to make life easier for different packagers
17:16:23 <kzaitsev_mb> we've had our share of pain because our glare plugin lives inside murano repo
17:16:37 <docaedo> but if it's all central and dependent to glare, shouldn't details like the artifact type live in glare?
17:17:16 <kzaitsev_mb> and it means that we had to explain deb/rpm and even kolla packagers why it's like that and how to package that plugin and that it actually depends on glance code, rather than murano code
17:18:04 <kzaitsev_mb> docaedo: I'm thinking that in murano we're going to have a separate repo and we would be able to add both glance-core and murano-core to the list of cores
17:18:33 <mfedosin> and app-catalog cores as well
17:18:35 <kzaitsev_mb> docaedo: basicaly it's the choice between how fast you go how stable you are. At least that's what I thought =)
17:18:40 <docaedo> right, so heat in glare repo is great, murano and others should be in glare repo too - that's what I don't understand, what is the advantage of having new/different repos just for an artifact definition that we want to be shared across all uses?
17:19:22 <docaedo> from the app catalog side I want artifact definitions to be just about set in stone, they should rarely (or never) change
17:20:12 <kzaitsev_mb> docaedo: I'm not insisting on having app-catalog in a separate repo =)
17:20:42 <mfedosin> artifact type is not just a description of artifact - it may have some actions, like data validation and conversion
17:20:57 <mfedosin> so they may be updated
17:20:59 <docaedo> that's a huge concern then
17:21:02 <docaedo> huge
17:21:59 <mfedosin> and I think no one will allow us to sore image artifact type in glare, because after that glare will compete with glance and provide another image api
17:22:02 <docaedo> that means someone could change a definition that causes glare to take some action on the app-catalog server, and these definitions would be spread out across multiple repos with different sets of reviewers
17:22:38 <docaedo> mfedosin: so glare couldn't store image types because it competes with glance? That doesn't make sense.
17:25:00 <mfedosin> I think we should add an option in Glare that prevents custom logic in artifact types
17:25:31 <kzaitsev_mb> oh, now I see — the question is about not having a asset type at all, but rather having a bunch of differnt types and reusing them in a.o.o
17:25:50 <mfedosin> after that artifact types will behave like a structure
17:25:57 <docaedo> I agree, I can tell you if it's possible to embed some control and actions into an artifact definition that we don't closely control from the app catalog, we can't host that
17:26:10 <mfedosin> without any code execution
17:26:14 <docaedo> +1
17:27:12 <kzaitsev_mb> yep, sounds fair — disabling custom logic feels like a good security feature for glare then
17:28:58 <docaedo> I think I agree with this now as long as we can ensure glare is not executing any code based on artifact definitions that exist outside of the app-catalog deployment
17:30:28 <mfedosin> agree, it's doable
17:30:59 <docaedo> great :)
17:31:26 <mfedosin> and also we decided to put all catalog properties in Base glare class
17:31:50 <docaedo> that makes sense to me
17:32:02 <mfedosin> like license, provided_by etc
17:32:33 <mfedosin> so we don't need to implement BaseAsset class https://review.openstack.org/#/c/337633/5/contrib/glare/openstack_app_catalog/artifacts.py@68
17:33:31 <docaedo> works for me
17:34:31 <docaedo> I think we can skip the next topic I had then, since you've said glare bits will be merged by end of month? You said it's a requirement, who's requirement, part of the project?
17:34:49 <mfedosin> OpenStack policies
17:35:07 <mfedosin> it's a feature freeze for openstack projects
17:35:20 <mfedosin> so only bug fixes are allowed after this date
17:35:25 <docaedo> oh great, so it will get the reviews it needs?
17:35:47 <mfedosin> not yet, but it will
17:35:53 <docaedo> excellent
17:36:27 <mfedosin> code doesn't affect glance, it's a plus for us
17:36:40 <docaedo> I was going to talk more about our options for deploying code that's still under review
17:37:01 <docaedo> but we don't need to, which is good - because our best option was going to be a new github repo with a fork :)
17:37:44 <docaedo> #topic Glare 0.1 API status (sskripnick)
17:38:01 <docaedo> I don't see sskripnick here, anyone else able to provide a status update on this?
17:38:15 <kzaitsev_mb> shouldn't it be 1.0? =)
17:38:19 <mfedosin> he's sick leave today
17:38:53 <docaedo> UNACCEPTABLE!
17:39:10 <docaedo> There are no sick days in app catalog!
17:39:18 <docaedo> haha ok .. we can move on to...
17:39:29 <docaedo> #topic Mascot for the catalog
17:40:12 <kzaitsev_mb> oh, i have to do the same for murano...
17:40:30 <mfedosin> lemongrab?
17:40:36 <docaedo> Should we start an etherpad? Does anyone have strong opinions? I like this one:
17:40:38 <docaedo> http://www.boredpanda.com/quokka-selfie-trend-cute-rodent-australia/
17:41:05 <docaedo> even though it's a possible release name, it's also the cutest damn animal on the planet, and it would be nice to associate the app catalog with that :)
17:41:05 <mfedosin> http://pre03.deviantart.net/e6fa/th/pre/i/2013/012/e/e/the_earl_of_lemongrab_by_darthguyford-d5r9gts.jpg
17:41:21 <olaph> yay quokka
17:41:24 <docaedo> mfedosin: hahahaha
17:42:13 <docaedo> an alternative could be a kangaroo with a pouch full of apps :) But I don't think it matters TOO much
17:42:47 <docaedo> quick vote - who wants an etherpad to submit ideas?
17:42:53 <kzaitsev_mb> quokka is hard to beat, yeah
17:42:57 <igormarnat_> I also thought about kangoo with the bag of apps:)
17:43:01 <docaedo> woot!
17:43:06 <docaedo> haha igormarnat_ we think the same!
17:43:10 <kzaitsev_mb> igormarnat_: just what I was thinking
17:43:20 <kzaitsev_mb> =)
17:43:54 <docaedo> Event hough the quokka is cute, a kangaroo with a pouch full of apps sounds pretty appealing to me
17:44:20 <docaedo> (and I figure we should pick that fast, because other teams are probably thinking the same thing - kangaroo is always a good mascot!)
17:44:21 <kzaitsev_mb> and let's face it — no one knows what a quokka is, untill he sees the pics )
17:44:28 <docaedo> kzaitsev_mb: true
17:46:17 <olaph> I was thinking off long cat, as it used almost the same letters as catalog
17:46:55 <docaedo> what's a long cat? Like a cat that got stretched out?
17:47:26 <olaph> man, you really do live under a rock...
17:47:40 <igormarnat_> Like this one? http://img.memecdn.com/Long-Cat-Is-Long_o_103864.jpg
17:47:45 <sslypushenko> +1 for the cat) everybody love cats)
17:47:53 <kzaitsev_mb> app 🐱alog
17:48:08 <docaedo> oh man that's scary
17:48:26 <docaedo> Doesn't the animal have to exist in nature? :P
17:48:43 <docaedo> sounds like I need to start an etherpad so we can all share ideas...
17:49:10 <kzaitsev_mb> you'll have to have unicode font for my option =)
17:49:19 <kzaitsev_mb> with emoji %)
17:49:25 <docaedo> haha
17:49:52 <docaedo> #action docaedo to create etherpad and share with ML for agreeing on app catalog mascot
17:51:37 <igormarnat_> docaedo: mfedosin so do you, folks, have any ideas when we could launch beta version of app catalog with new backend? In several weeks?
17:51:50 <docaedo> #topic Open discussion
17:52:39 <mfedosin> igormarnat_: yes, we will start working on it from Monday
17:52:57 <mfedosin> sskripnick is sick this week
17:53:25 <docaedo> mfedosin: that's great, let me know how I can help, and definitely keep a discussion going on the #openstack-app-catalog channel about installation requirements
17:53:51 <igormarnat_> Ok. I wanted to send an update to community with the status of our initiative of improving collaboration around apps development, and switching of catalog is a blocker for more than half of it
17:53:55 <docaedo> if we have it boiled down to a simple shell script, I can take that and turn it into puppet, which we will need for infra
17:54:26 <igormarnat_> So wanted to have something up and running before sending update across. I'll wait for several more days then
17:55:17 <mfedosin> we'll keep you informed
17:55:28 <igormarnat_> I hope so:)
17:56:16 <sslypushenko> docaedo: we almost run out of time, so I just ask you for re-review RefStack client app)
17:56:40 <docaedo> sslypushenko: yep, I'll do it right after the meeting
17:56:59 <sslypushenko> Great thx!
17:57:33 <docaedo> and we're just about out of time - thanks for coming everyone!
17:58:01 <docaedo> #endmeeting