17:05:50 <kzaitsev_mb> #startmeeting app-catalog
17:05:51 <openstack> Meeting started Thu Sep 1 17:05:50 2016 UTC and is due to finish in 60 minutes. The chair is kzaitsev_mb. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:05:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:05:54 <openstack> The meeting name has been set to 'app_catalog'
17:05:56 <igormarnat_> Besides "work items" here https://blueprints.launchpad.net/app-catalog/+spec/glare-work
17:05:59 <kzaitsev_mb> ok, let's do it the formal way )
17:06:17 <kzaitsev_mb> #topic Updates
17:06:27 <kzaitsev_mb> #link https://blueprints.launchpad.net/app-catalog/+spec/glare-work
17:06:43 <kzaitsev_mb> sskripnick: can you comment on igormarnat_'s questions )
17:07:33 <kzaitsev_mb> from my side
17:07:38 <kzaitsev_mb> #link http://lists.openstack.org/pipermail/openstack-dev/2016-September/102712.html
17:07:55 <sskripnick> yes, I need to finish all work items in glare-work blueprint. also we need at least to patches in glare
17:08:11 <sskripnick> first one https://review.openstack.org/#/c/360001/
17:08:16 <sskripnick> and second one is in progress
17:08:23 <kzaitsev_mb> plan to figure all things when docaedo returns and ping kfox to make sure we agree on the same structure. ETA next week =)
17:08:59 <sskripnick> second patch is about 'latest_version' filter
17:09:00 <sskripnick> thats it
17:10:55 <igormarnat_> sskripnick: Sergey, puppet folks told me that there is some dependency which blocks them from finishing work and this work is being done by you and you ETA is about 2-3 weeks
17:10:59 <igormarnat_> Is that correct?
17:12:32 <sskripnick> We decided to go with temporary packages on pypi (openstack_app_catalog and glare_dev)
17:12:39 <sskripnick> So they are not quiet blocked
17:13:21 <igormarnat_> Are temporary packages already available or someone works on them?
17:14:03 <sskripnick> yes they both are available, and we have good progress with openstack_app_catalog
17:14:30 <sskripnick> #link https://review.openstack.org/#/c/359029/
17:14:36 <igormarnat_> So puppet folks can complete their work very soon, nothing blocks them?
17:14:40 <sbanka> Hi Sergey. Was Bartek informed about these packages?
17:15:02 <sskripnick> here is patch made by him ^
17:15:29 <sskripnick> the patch above is based on openstack_app_catalog temporary package
17:15:55 <sskripnick> and Peter was informed about glare_dev package
17:16:21 <sskripnick> I can inform Bartosz as well
17:16:28 <sbanka> yes.. and he is working on manifests now.
17:17:35 <sbanka> Please provide Bartosz access to temporary packages so he can make necessary changes in manifests.
17:17:49 <sskripnick> sure
17:19:31 <sbanka> Sergey, what about this change: https://review.openstack.org/#/c/337633/
17:19:41 <sbanka> When do you expect to land this?
17:20:19 <sskripnick> I need to finish work items ( https://blueprints.launchpad.net/app-catalog/+spec/glare-work )
17:21:19 <sskripnick> but i'd like to split this patch. here is the first one https://review.openstack.org/#/c/363139/
17:21:34 <sskripnick> sbanka: ^
17:22:35 <sbanka> I’ll ask Bartosz to sync with you on this. He states he cannot merge his part unless you merge ^^^.
17:24:02 <sskripnick> I wanted to sync with him today -_-
17:24:12 <sskripnick> during this meeting
17:24:37 <sskripnick> ok we can sync later on irc
17:25:48 <sbanka> he is joining
17:25:50 <sbanka> moment
17:26:05 <zynzel> o/
17:26:10 <sskripnick> hiyo
17:26:25 <kzaitsev_mb> the meeting is suddenly big and lively =)
17:27:03 <mfedosin> it's a blackout here
17:27:22 <kzaitsev_mb> mfedosin: that's why I'm WFH the outage was planned ;)
17:27:31 <mfedosin> I'm sitting with a candle in my hand
17:28:22 <kzaitsev_mb> sskripnick: sbanka: zynzel: so you're all here you can sync on the status of the packages and commits and see what we need to merge and in what order
17:29:10 <sbanka> Bartek. Plase comment on what you need to have merged before you can merge your commits.
17:29:42 <zynzel> yep, puppet automation is prepared base on https://github.com/redixin/app-catalog/tree/dev afaik (i use openstack-app-catalog package from pypi)
17:30:01 <sskripnick> can we deploy something like staging.apps.openstack.org first?
17:30:26 <sskripnick> and later just switch to new instance?
17:30:35 <zynzel> sskripnick: app-catalog part is +/- ready, if you provide working glare_endpoint we can deploy testbed
17:30:45 <mfedosin> so, it was a sarcasm about big and lively meeting :)
17:31:30 <sskripnick> zynzel: glare should be deployed on the same node
17:31:46 <zynzel> sskripnick: ok, but we still lack of automation for glare
17:32:03 <zynzel> sskripnick: so we can deploy glare manualy, and app-catalog from puppet
17:32:05 <sskripnick> zynzel: there is a package glare_dev on pypi
17:32:27 <zynzel> sskripnick: yep, from pypi package is one thing, and puppet manifest to deploy whole glare is another
17:32:35 <zynzel> and manifests for glare are not ready
17:33:17 <sskripnick> app_catalog itself it not ready too. so we all need some more time to finish
17:33:57 <zynzel> sskripnick: so imho we should backport redixin/app-catalog/tree/dev to master + merge https://review.openstack.org/#/c/337633/
17:34:26 <zynzel> i hope that after this we will have glare automation ready, and we can deploy staging.apps.openstack.org
17:34:33 <sskripnick> if we merge it, current app-catlog site will be broken, right?
17:35:14 <sskripnick> because jenkins will try to deploy new version, which wont work without glare, memcached, etc
17:35:17 <kzaitsev_mb> let's see if https://review.openstack.org/#/c/337633/ can be just merged and wouldn't break existing app-catalog
17:35:30 <zynzel> we need to confirm this with infra folks
17:35:46 <sskripnick> it can't. i can try to figure out how to fit both versions in one tree
17:36:01 <zynzel> imho we should disable auto-deploy of app-catalog during moving from old app catalog to new one
17:36:25 <sskripnick> but if we disable it, we will not be able to merge updates to assets.yaml
17:36:48 <kzaitsev_mb> from the looks of it it would require at lest memcached to be deployed somewhere so naturally it would break current site, or am I wrong?
17:36:50 <sskripnick> i mean we will be able to merge, but it wont be updated on app-catalog site
17:37:30 <zynzel> hmm, so maybe we can create branch in appcatalog, named 'glare-support'
17:37:33 <zynzel> merge everything there
17:37:40 <sskripnick> kzaitsev_mb: you are right. in my patch I've just removed old code
17:37:50 <zynzel> deploy staging.app., test
17:38:01 <zynzel> backport branch glare-support to master
17:38:02 <kzaitsev_mb> feature branches in OS are usually a bad thing, but in this case this looks like a solution
17:38:10 <zynzel> switch apps.openstack.org to new staging.apps
17:38:44 <kzaitsev_mb> #idea merge sskripnick glare work to glare-support branch, to unlock puppet work
17:39:01 <sskripnick> is this necessary? can we deploy without code merged?
17:39:32 <sskripnick> we only need pypi packages
17:40:11 <zynzel> kzaitsev_mb: puppet work is not blocked, as i use packages created from https://github.com/redixin/app-catalog/tree/dev
17:40:15 <sskripnick> btw we can't merge updates to puppet manifests for the same reason
17:41:03 <kzaitsev_mb> ok, wrong wording )
17:41:19 <zynzel> yeah, we cant update system-config (manifests used by infra team), because mismatch in app-catalog version :)
17:41:43 <zynzel> so we need do all those changes available in same time (puppet for app-catalog, puppet for infra, app-catalog source code)
17:41:53 <sskripnick> IMO safest solution is new repository for new app-catalog manifests
17:42:14 <sskripnick> and deploy everything on new node
17:42:25 <sskripnick> and switch app-catalog to it later
17:42:29 <sskripnick> zero downtime
17:42:39 <zynzel> sskripnick: yeah, but new repo will be overkill
17:42:43 <zynzel> if we can use branch
17:43:05 <kzaitsev_mb> +1 to zynzel =) seems like an overkill
17:43:12 <zynzel> i will talk tomorrow with infra guys, and ask them about this
17:43:19 <zynzel> maybe they have some kind of procedure for cases like this
17:44:07 <kzaitsev_mb> #action zynzel talk to infra about procedure to update a.o.o seamlesly
17:44:11 <kzaitsev_mb> if you don't mind =)
17:44:26 <zynzel> sure, i already planned it :)
17:46:12 <zynzel> so i have 1 question, do anybody have anything against changes introduced in https://github.com/redixin/app-catalog/tree/dev?
17:46:26 <kzaitsev_mb> ok, so current plan is to have a branch for new puppets/code, use it to deploy staging, then switch staging to main a.o.o, right?
17:46:34 <zynzel> i ask sskripnick for many things, to make puppet manifest working corectly
17:47:02 <zynzel> kzaitsev_mb: yes, and after switching staging to a.o.o we need to merge our custom branches to master
17:47:17 <sskripnick> zynzel: We need to backport all this changes and ask app-catalog-cores to review it
17:47:47 <sskripnick> i dont think they will review on github
17:47:52 <kzaitsev_mb> yeah, looking at github is hard =)
17:48:17 <sskripnick> as for me, github is much better then gerrit %)
17:48:57 <zynzel> so we need to prepare gerrit changes which will cover all things we fix in app-catalog ;)
17:49:01 <zynzel> for core-reviewers
17:49:22 <kzaitsev_mb> true, after all gerrit is the source of truth
17:49:54 <sskripnick> zynzel: yep. except of changes in package name. we will need to change package name in puppet later (openstack_cap_catalog -> openstack_catalog)
17:51:20 <kzaitsev_mb> sounds like we have a plan =)
17:52:05 <zynzel> yep :)
17:56:09 <kzaitsev_mb> ok, thanks for your participation today, please keep us updated in #openstack-app-catalog pls if there would be any suggestions from infra folks )
17:56:29 <mfedosin> yep, thanks :)
17:56:39 <zynzel> kzaitsev_mb: sure i already ping Igor Shishkin
17:56:47 <zynzel> when i get anything new, i will share progress on #o-a-c
17:57:24 <sskripnick> thanks. bye
17:57:44 <kzaitsev_mb> #endmeeting