17:01:12 <docaedo> #startmeeting app-catalog
17:01:12 <openstack> Meeting started Thu Sep 29 17:01:12 2016 UTC and is due to finish in 60 minutes.  The chair is docaedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:16 <openstack> The meeting name has been set to 'app_catalog'
17:01:21 <docaedo> #link https://wiki.openstack.org/wiki/Meetings/app-catalog#Proposed_Agenda_for_September_29th.2C_2016_.281700_UTC.29
17:01:37 <docaedo> The agenda is basically "what's next for glare implementation" :)
17:02:06 <sskripnick> review a lot =)
17:02:10 <docaedo> I know I owe sskripnick some bunch of reviews, and have been looking through stuff this morning, planning to try to do nothing else
17:02:19 <mfedosin> o/
17:02:28 <docaedo> until the outstanding patches are reviewed today
17:02:53 <sskripnick> btw i've made some ansible automation for appcatalog+glare
17:02:55 <sskripnick> https://github.com/redixin/ansible-appcatalog
17:03:13 <sskripnick> thats how http://apps.r-ci.tk is deployed
17:03:13 <docaedo> sskripnick: one question I have, I'm working on the local copy of the glare puppet stuff, and looking at https://review.openstack.org/#/c/359029/
17:03:50 <sskripnick> docaedo: i've tested that patch, it works for me
17:03:59 <docaedo> ah, the ansible interesting too, nice
17:04:47 <docaedo> so my question is if I want to use the example install glare from git, but I'm calling the way infra will (FACTER_fqdn=apps.openstack.org puppet apply --modulepath=/etc/puppet/modules:system-config/modules system-config/manifests/site.pp)
17:05:26 <docaedo> I am too tired this morning I think, I'm not seeing where to fold in the example file
17:06:15 <sskripnick> no idea. maybe Bartosz is here?
17:07:24 <docaedo> would be good to get him on the app-catalog channel, I can ask questions there
17:08:09 <docaedo> in the mean time I'll give him some feedback asking to update the commit message with testing instructions, that will help
17:08:34 <docaedo> then I can use the ansible play you shared to validate some stuff locally today
17:10:24 <docaedo> other than needing reviews sskripnick, have you run into anything, or have any questions? At this point I'm pretty happy with the way things look, I just need to run through more testing with it
17:10:38 <sskripnick> oh i have something to ask
17:10:46 <sskripnick> about storage.apps.openstack.org
17:10:57 <sskripnick> what is it? can we use it as glare backend?
17:11:31 <docaedo> storage.apps.openstack.org is a rackspace cloud-files account.  It's accessible via swift API
17:11:58 <sskripnick> glare can work with swift, so we can use it if we want to
17:12:25 <docaedo> the expectation is that we will not keep using it long term though, infra said they would supply swift storage for the app-catalog
17:13:00 <sskripnick> ok so we are going to move everything from storage to glare?
17:13:14 <sskripnick> i need to make some changes to import script
17:13:46 <docaedo> ok - it does not NEED to happen during the import (i.e. we could migrate those assets/storage later)
17:14:27 <sskripnick> there will be broken links in older versions of artifacts
17:14:31 <docaedo> but if we plan to move them all during the initial import, it makes sense probably because we can also make sure the path/redirect is right so we don't break older versions of murano
17:14:34 <docaedo> yeah
17:15:12 <sskripnick> only glance images will be affected. we use "external blobs" for images only
17:15:30 <sskripnick> all other artifacts will be stored at glare's backend
17:15:44 * kzaitsev_mb lurking
17:15:57 <docaedo> ok - right now most glance images are stored externally, it's the few murano images that live on storage.a.o.o
17:16:53 <sskripnick> we can download everything to glare (not using external blobs) should we?
17:17:17 <docaedo> no, some of those glance images can't be hosted/served by us
17:17:37 <sskripnick> or download everyting except of glance images that are not stored on aoo
17:17:51 <docaedo> (for instance canonical usually does not allow it - they are unlikely to notice or care, but they have asked others in the past to take down ubuntu images they hosted)
17:18:23 <docaedo> I would say download any glance image that is currently served from storage.a.o.o, and leave the others external
17:18:45 <sskripnick> okay
17:19:15 <sskripnick> That's what I mean =)
17:20:04 <docaedo> cool
17:21:28 <docaedo> ok for me the next thing I need to make sure is moving well is the puppet stuff, and start working with infra to make sure it's in a format that will let us do the staging site
17:25:15 <docaedo> kzaitsev_mb: while you're lurking, any questions or anything to share? otherwise I think we're done
17:27:25 <docaedo> :crickets:
17:27:45 <kzaitsev_mb> nope sorry for being almost away for 2 meetings in a row =)
17:28:03 <docaedo> kzaitsev_mb: that's ok, you have a lot on your plate!
17:28:08 <kzaitsev_mb> have we discussed Barcelona Summit topics? btw =)
17:28:16 <docaedo> anyway sskripnick has been doing a ton of work
17:28:36 <kzaitsev_mb> I'm going to start planning my schedule for Barcelona next week )
17:29:02 <docaedo> kzaitsev_mb: no have not disussed summit topics yet, I also have not started to look at my schedule (I'm scared, I need to be many places at the same time I am sure!)
17:29:24 <kzaitsev_mb> as usual +)
17:30:17 <docaedo> I'll start an etherpad and send an email regarding summit topics, then we can plan to wrap it up next week
17:31:10 <docaedo> also I'm traveling oct 13 so can't chair a meeting, and then  .. I think it's the summit after that?
17:31:39 <docaedo> #action Aedo to start etherpad and send email for summit work room planning
17:32:31 <docaedo> I think we are done unless anyone has anything to bring up?  (I'll wait 2 minutes before ending)
17:32:45 <mfedosin> I want to say a couple of words
17:32:58 <mfedosin> we're working on SL plugin
17:33:09 <mfedosin> and I believe it will available next week
17:33:35 <mfedosin> so, do you have any plans to integrate SL with App Catalog?
17:33:55 <mfedosin> seems like another puppet will be required
17:34:03 <mfedosin> SL is Searchlight
17:34:36 <docaedo> haha I was just typing "what is SL?"
17:34:58 <docaedo> We expected to need SL in order to be able to search the contents of the catalog
17:35:24 <docaedo> but it's not required for switching to glare, I thought we would end up doing that after the main transition
17:36:01 <mfedosin> okay, that great
17:36:23 <docaedo> really glad to hear you're already starting to work on search light plugin though!
17:36:24 <mfedosin> sl dramatically increases usability of the catalog
17:36:40 <docaedo> yes totally
17:36:41 <mfedosin> so, we should try to enable it before the summit
17:37:50 <mfedosin> okay, I don't have any questions :)
17:38:23 <docaedo> I don't have any questions either
17:39:45 <docaedo> alright thanks everyone!
17:39:51 <docaedo> #endmeeting