17:00:36 <docaedo> #startmeeting app-catalog
17:00:37 <openstack> Meeting started Thu Oct  6 17:00:36 2016 UTC and is due to finish in 60 minutes.  The chair is docaedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:41 <openstack> The meeting name has been set to 'app_catalog'
17:00:45 <docaedo> Agenda:
17:00:48 <docaedo> #link https://wiki.openstack.org/wiki/Meetings/app-catalog#Proposed_Agenda_for_October_6th.2C_2016_.281700_UTC.29
17:01:15 <docaedo> let's hold a minute, see who else shows up, then we can dive in :)
17:01:42 <kzaitsev_ws> o/
17:02:52 <docaedo> we've had a few emails on the infra list around our plan:
17:02:54 <docaedo> #link http://lists.openstack.org/pipermail/openstack-infra/2016-September/004707.html
17:02:56 <docaedo> #link http://lists.openstack.org/pipermail/openstack-infra/2016-October/004762.html
17:02:58 <docaedo> #link http://lists.openstack.org/pipermail/openstack-infra/2016-October/004763.html
17:04:07 <kzaitsev_ws> docaedo: and I'm going to remind you to see if you have time for https://review.openstack.org/#/q/topic:bp/catalog-dashboard-reorg =)
17:04:17 <kzaitsev_ws> osh helped me out with rebasing things on master )
17:04:39 <kzaitsev_ws> he also said that couldn't reproduce the bug, but tbh I haven't looked carefully myself
17:04:57 <docaedo> kzaitsev_ws: thanks for the reminder ..
17:04:59 <kzaitsev_ws> docaedo: what do you think will we be able to get that merged/done before Barcelona? =)
17:05:25 <mfedosin> o/
17:06:08 <docaedo> kzaitsev_ws: I'm good to go - the bug shows up reliably for me last week but I haven't looked at it this week
17:06:19 <docaedo> I think we are safe though, and the re-org layout is good
17:06:35 <kzaitsev_ws> ok then let me double-check tomorrow and see if I can reproduce and/or fix it
17:06:40 <docaedo> so if there's a bug between app-catalog-ui and horizon we just have to work on it, but don't need that to hold up progress
17:06:49 <docaedo> I +2'd the app-catalog-ui one
17:07:26 <kzaitsev_ws> cool ) would wrap things up tomorrow )
17:08:36 <docaedo> great
17:09:26 <kzaitsev_ws> any updates from the glare side of the app-catalog? =) mfedosin? need reviews somewhere?
17:09:36 <mfedosin> folks, I made a patch for creating apps-dev site
17:09:50 <mfedosin> https://review.openstack.org/#/c/382971/
17:10:14 <mfedosin> But I don't get why it fails on jessie
17:10:45 <sskripnick> about reviews: https://review.openstack.org/#/q/status:open+project:openstack/app-catalog+branch:feature/glare-support+topic:bp/glare-work
17:10:45 <mfedosin> I asked fungi for help and he promised to look there
17:11:21 <mfedosin> but he's on leave from tomorrow and we have to take it on by ourselves
17:11:32 <docaedo> mfedosin: I'll poke in today and see if I can see why jessie is failing too
17:11:45 <mfedosin> and yes - sskripnick's work is on review :)
17:11:51 <fungi> yep, that's why i tried to provide a lot of updated context in my ml reply to docaedo yesterday
17:11:57 <docaedo> thanks fungi !
17:12:29 <fungi> we have a bunch of root sysadmins on the infra team, so hopefully it won't be too hard for them to take over
17:12:36 <docaedo> fungi: while you're on leave, that means you won't be too closely monitoring infra stuff - means you'll have lots of extra time for app-catalog right?
17:12:52 <kzaitsev_ws> =)
17:13:12 <fungi> the most complicated aspect of it, i expect, is going to have to do with the fact that it needs debian rather than ubuntu for now, and worse it needs packages from unstable and experimental
17:13:41 <docaedo> oh right .. yuck
17:13:54 <docaedo> I thought we had options though for installing from git or pip?
17:14:02 <docaedo> or is it just the glare stuff that needs a package?
17:14:41 <fungi> well, mfedosin was suggesting that it has non-python dependencies satisfied only by packages in debian experimental at the moment
17:15:12 <fungi> or at least i have to assume it's non-python dependencies, otherwise not sure why the insistence on using distro packages for that
17:15:12 <mfedosin> it's better to ask zigo
17:15:32 <mfedosin> he helped us making this package
17:15:49 <docaedo> but if we've been installing glare from git for testing so far, why can't we continue doing that?
17:16:12 <mfedosin> but afaik there are no non-python dependencies without packages
17:16:19 <fungi> just for the record, we do have a lot of infra-managed servers that run things installed via pip from pypi and from git, installed with npm, et cetera
17:16:39 <mfedosin> so, glare should work if we install it from pypi directly
17:16:59 <docaedo> yeah I'd be strongly in favor of that approach, and NOT relying on running on a debian and using packages from experimental
17:17:03 <docaedo> for the app-catalog
17:17:15 <docaedo> for broader glare adoption, packaging is necessary for sure :)
17:17:16 <fungi> which would allow us to stick with ubuntu trusty or xenial, consistent with the current apps site
17:17:19 <mfedosin> sskripnick: what was an issue with installing glare from pypi?
17:17:45 <sskripnick> mfedosin: -2 to our patch
17:17:49 <fungi> (current apps site is running on trusty)
17:18:01 * sskripnick is trying to find link
17:19:25 <mfedosin> sskripnick: lol
17:19:36 <sskripnick> omg gerrit
17:19:48 <sskripnick> how to find patch if i know owher?
17:19:53 <sskripnick> Maciej Relewicz
17:20:25 <mfedosin> owner:
17:21:18 <sskripnick> hmm
17:23:46 <sskripnick> https://review.openstack.org/#/c/373805/
17:24:05 <sskripnick> Patch Set 3: Code-Review-2puppet openstack modules are rely only on UCA or RDO packaging. If you want to add your own provider - you need to do it only on your orchestration layer. We are not using pip, gem or whatever else.
17:25:11 <sskripnick> mfedosin: fungi: docaedo: ^
17:25:50 <docaedo> hmm, that's strange to me, as puppet-apps_site sure does not use packages
17:25:52 <mfedosin> glare is not in UCA
17:26:07 <docaedo> I had looked at that patch but did not notice that comment
17:26:10 <mfedosin> so we can't use debian?
17:26:55 <fungi> we probably _can_ use debian, but the question is whether that's actually less work to maintain than doing some installs from pypi/source on the same distro/release we use for our normal servers
17:27:18 <fungi> oh, you're trying to use puppet-openstack to deploy this?
17:27:43 <fungi> right, so the puppet-openstack team's policies are not the same as the infra puppet reviewers'
17:27:54 <mfedosin> emm yes
17:27:56 <fungi> that may be where the confusion is arising
17:28:07 <sskripnick> probably we can include glare stuff into app-site
17:28:18 <docaedo> oh shoot yeah, that's where I got confused too - my puppet-apps_site is in openstack-infra
17:28:19 <sskripnick> and use git/pip whatever
17:28:26 <fungi> there is very little of puppet-openstack consumed by infra (we really only use it for infra-cloud if memory serves)
17:29:40 <mfedosin> sskripnick: maybe it's a good plan
17:29:48 <mfedosin> but how long it will take?
17:30:16 <mfedosin> put all puppets from puppet-glare to app-site
17:30:30 <docaedo> however long it would take to fix up the puppet manifest, I bet it's a bunch faster than waiting for packaging and trying to solve debian issues
17:31:37 <sskripnick> +1
17:32:35 <mfedosin> hmm, if it accelerate the work we can start doing this
17:33:12 <docaedo> awesome, that might un-block us at this point
17:34:45 <mfedosin> I think we should document this plan ans start to follow it asap
17:35:17 <sskripnick> So we need to ask Maciej to move all glure staff into this patch https://review.openstack.org/#/c/359029/
17:35:18 <sskripnick> right?
17:35:34 <mfedosin> yep
17:35:41 <docaedo> mfedosin: agreed - do you or sskripnick want to do that? Or me? Should respond to that mailing list thread (openstack-infra) for record keeping
17:36:05 <docaedo> also will help because the infra team will all see that conversation, and see what we have in mind
17:36:20 <mfedosin> Maciej may help us with it
17:36:46 <mfedosin> btw, I think I can order apps-dev vm on trusty or xenial
17:37:18 <mfedosin> actually xenial, because trusty doesn't have all required packages
17:37:42 <mfedosin> and we will be able to deploy it from apps-site puppets
17:38:11 <docaedo> xenial would be best
17:38:11 <mfedosin> sounds like a plan and I hope it will work
17:38:44 <docaedo> seems like a productive plan :) need to know who will take the action of documenting the plan
17:39:10 <mfedosin> I'll take it on
17:39:30 <mfedosin> assign it to me :)
17:39:46 <docaedo> #action mfedosin to document new plan to move glare stuff into https://review.openstack.org/#/c/359029/
17:40:20 <docaedo> quick update from me - I will be on a plane during next weeks meeting so probably no meeting unless someone else wants to chair
17:40:39 <docaedo> after that I'm traveling for a few days, but will be back online at least 2-3 days per week leading up to the summit
17:40:55 <kzaitsev_ws> well, I'm the usual replacement =)
17:41:03 <docaedo> I'll be responsive to email and code review though, and will not hold things up (as long as I can get myself connected to the internet from random spots in Europe!)
17:41:15 <docaedo> #action kzaitsev_ws to chair next weeks IRC meeting
17:41:30 <kzaitsev_ws> so that we can document the progress or in case someone else walks by =)
17:42:18 <docaedo> yep, thanks for doing that
17:43:10 <docaedo> I think we can do a final round of reviews on sskripnick code once the infra staging/test instance is up
17:43:28 <docaedo> and the work to get that instance going will cover getting the DB and swift access
17:43:40 <docaedo> finish line is in sight!
17:45:18 <mfedosin> fingers crossed
17:46:22 <docaedo> anything else? Or now we just get the puppet stuff sorted ASAP and go from there
17:46:39 <docaedo> (also thank you as always for all the great work you all are doing!)
17:47:05 <mfedosin> nothing from my side
17:47:19 <mfedosin> thanks for your support folks
17:48:13 <docaedo> ok thank you everyone!
17:48:16 <docaedo> #endmeeting