22:00:42 <docaedo> #startmeeting app_ecosystem_wg
22:00:43 <openstack> Meeting started Mon May 16 22:00:42 2016 UTC and is due to finish in 60 minutes.  The chair is docaedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:46 <openstack> The meeting name has been set to 'app_ecosystem_wg'
22:01:20 <docaedo> I recently got off a plane and found wifi, glad the timing worked out :)
22:01:53 <leong> o/
22:01:57 <leong> hellow
22:02:06 <docaedo> CraigSterrett: do you have a link to the agenda handy?
22:02:09 <docaedo> leong: hello!
22:02:12 <qwebirc83432> Hello
22:02:31 <CraigSterrett> https://etherpad.openstack.org/p/2016_May_16_App_Ecosystem_Workgroup
22:02:37 <docaedo> thanks!
22:03:28 <CraigSterrett> Guess there wasn't anything in that etherpad
22:03:54 <docaedo> #link https://etherpad.openstack.org/p/2016_May_11_App_Ecosystem_Workgroup Last Weeks meeting agenda
22:04:48 <docaedo> Nice thing about an IRC meeting is that meetingbot will give us a nice set of minutes (including attendees, who talked, etc.)
22:05:01 <CraigSterrett> that was a separate meeting where we just went over the plans for FirstApp
22:05:10 <docaedo> so anyone who is here for the meeting (now that it started) should say hello, or wave with a "o/"
22:05:11 <CraigSterrett> But I can give an update if you like
22:05:31 <docaedo> ah no, I was not at that meeting, I just saw it was the last one when I was looking around for the agenda for this week
22:05:35 <annegentle> o/ hi
22:05:38 <GheRivero> o/
22:06:08 <leong> o/
22:06:17 <CraigSterrett> #link https://etherpad.openstack.org/p/2016_May_9_App_Ecosystem_Workgroup
22:06:22 <CraigSterrett> That is the last one
22:06:37 <docaedo> Hopefully we'll see John here :)
22:07:01 <docaedo> Let's start with status updates from last week
22:07:06 <docaedo> #topic status updates
22:07:45 <docaedo> CraigSterrett, do you have a quick recap of the "plans for the fistapp" meeting?
22:07:46 <mbonell> o/
22:07:56 <docaedo> (and sorry to put you on the spot suddenly!)
22:08:06 <CraigSterrett> I have heard back from Carolyn Van Slyck and she has said she will work on the .NET Firstapp
22:08:17 <docaedo> thats good news!
22:08:18 <CraigSterrett> and also Jamie Hannaford has agreed to work on the pkgcloud
22:08:31 <CraigSterrett> Flanders was supposed to check on jcloud
22:08:38 <CraigSterrett> I have not heard back on that one yet
22:09:44 <docaedo> Sounds like pretty good progress here though, thanks
22:09:53 <CraigSterrett> The plan is to also try and complete one for Python using a OpenStack SDK either shade or python-openstack
22:10:06 <leong> As far the FirstApp is concerned, i think the next step is: 1. Finished up shade. 2. .NET with OpenStack.NET. 3. Java with jcloud
22:10:21 <leong> ps: not listed in order
22:10:40 <CraigSterrett> Yep I agree
22:10:50 <mbonell> :Craig, do you have any update from Caleb?
22:10:59 <leong> so we already have Caroyln Van Slyck covering OpenStack.NET
22:11:00 <docaedo> good to see all of those progressing, and nice to know they can happen in parallel
22:11:03 <GheRivero> I can help with shade
22:11:14 <CraigSterrett> No I fogot to get ahold of Caleb
22:11:18 <CraigSterrett> I will do that today
22:11:25 <mbonell> ok, thanks
22:12:06 <leong> docaedo, do you want to mark that as an agreement as in the irc notes
22:12:19 <mbonell> Caleb will help with shade, he attended the wg session in austin
22:12:39 <docaedo> #chair leong
22:12:40 <openstack> Current chairs: docaedo leong
22:12:42 <johncallaghan> sorry for being late and no etherpad
22:12:53 <docaedo> johncallaghan: no problem, great to see you here!
22:13:04 <johncallaghan> glad to be here.
22:13:11 <docaedo> leong: not sure which part you want to make an agreement so I made you co-chair so meetingbot will listen to you ;)
22:13:32 <johncallaghan> it may be a short stay as I am being pulled out in a couple of minutes.
22:14:00 <leong> following up from the FirstApp meeting on May 11, i think we agree to finish up shade for python
22:14:16 <leong> then also work on jCloud (java) and OpenStack.NET (.NET)
22:14:20 <docaedo> Maybe that should be then:
22:14:29 <johncallaghan> leong, can you lead today?
22:14:32 <leong> these are the 3 priority for this cycle (First App)
22:14:33 <docaedo> #action finish work on first app tutorial for shade
22:14:52 <leong> ok
22:14:59 <docaedo> #action Begin working on jcloud (java) and OpenStack.NET for First App tutorial
22:15:00 <johncallaghan> thanks
22:15:07 <leong> docaedo +1
22:15:41 <docaedo> BTW I should have started out first with a big thank you to everyone for taking the leap into IRC for this meeting, hopefully it'll prove to be a productive communication channel for us!
22:15:54 <annegentle> did Liang Bo want to work with Carolyn on .NET?
22:16:06 <annegentle> (seeing that name in the spreadsheet)
22:16:10 <CraigSterrett> He said he doesn't have any time to work on it now
22:16:44 <leong> so someone need to follow up the status of FirstApp for Shade, OpenStack.NET and jCloud
22:18:11 <CraigSterrett> I am taking that on
22:18:17 <leong> thank craig
22:18:28 <annegentle> ok thanks for checking, Craig!
22:18:48 <leong> #action CraigSterrett to follow the FirstApp status for Shade, jCloud and OpenStack.NET
22:19:09 <leong> i think that's should be all for the FirstApp update?
22:19:17 <leong> anymore to discuss with respect to FirstApp?
22:19:27 <CraigSterrett> Nope
22:19:54 <leong> what's next for the status update?
22:20:10 <leong> Hackathons?
22:20:42 <CraigSterrett> The next hackathon will be in Mexico, but unfortunately that meeting is going on right now, so thats where Victor is
22:20:50 <docaedo> ah that makes sense
22:20:58 <mbonell> yes, I'm in both meetings haha
22:21:05 <mbonell> :p
22:21:06 <annegentle> hee mbonell
22:21:06 <leong> oh.. ok.. that's let's put this to next meeting review
22:21:08 <docaedo> I have a quick status update re: IRC
22:21:09 <CraigSterrett> LOL I was just going to say you could give an update
22:21:31 <leong> #action Victor to update the App Hackathon status
22:21:37 <docaedo> We have this meeting time slot reserved for every other week
22:21:44 <mbonell> expect our updates for next week ;)
22:22:09 <leong> anything else from status updates?
22:22:12 <docaedo> I have been buried with work this week and did not get to write the spec yet for hosting an IRC setup for people, but will get to it no later than end of next week
22:22:43 <docaedo> The spec is for hosting "the lounge" and the testing on small scale has been going great, so I have high hopes it will provide a VERY easy entry point for people who aren't familiar with IRC
22:22:49 <leong> can I put that as an AR for you, docaedo :-)
22:23:16 <docaedo> #action Aedo to submit spec for OpenStack Infra to host "The Lounge" IRC client by 5/27
22:23:21 <annegentle> how's the Python SDK work rolling along?
22:23:27 <leong> sound god :)
22:23:45 <leong> annegentle, do you mean the FirstApp for Python?
22:24:34 <leong> For python: the libcloud is complete, the next step for Python is Shade
22:25:36 <CraigSterrett> I had another AR from lastweek, To come up with a definition of what an OpenStack app is
22:25:39 <annegentle> leong: more specifically, the Python SDK, FirstApp for that, is shade preferred?
22:25:42 <CraigSterrett> I sent an initial "what is an app" to Flanders Chris and Victor but didn't hear back.  Figured I would try to get a few people to somewhat agree before blasting it to the community
22:26:18 <leong> CraigSterrett, you might want extend that email to the maillist
22:26:23 <annegentle> #link https://github.com/openstack/python-openstacksdk
22:26:26 <annegentle> that one ^^
22:27:01 <docaedo> CraigSterrett: Sorry about not responding, I'll see if I can get my thoughts together for a response soon
22:27:26 <docaedo> I think it's OK to just share the thread and cause lots of thrashing (that is the OpenStack way I think!)
22:27:30 <CraigSterrett> We do not have anybody working on the python-openstack SDK
22:27:38 <leong> annegentle, i didn't see that in the previous meeting, is anyone interested creating the FirstApp for python-openstacksdk?
22:27:56 <docaedo> Super short version though, the more I think about it the more I believe Murano is the only project trying to support such a thing as a *distributable* OpenStack app
22:28:13 <johncallaghan> I must go, glad to see this is getting good participation.  Thanks Leong and Everyone!
22:28:22 <annegentle> leong: oh, looks like http://developer.openstack.org/draft/firstapp-openstacksdk is the draft, and Christian is listed on the spreadsheet. Looks like it's being tracked.
22:29:35 <annegentle> mbonell: I also wanted to follow up on https://review.openstack.org/#/c/292537/ -- can you address reviewer comments or would you like me to?
22:30:14 <leong> CraigSterrett and docaedo, i would suggest to forward the "openstack app" discussion to maillist when you are ready
22:30:25 <docaedo> +1
22:30:54 <leong> #action CraigSterrett & docaedo to extend the "openstack app" discussion to maillist when ready
22:31:12 <mbonell> annegentle: go ahead please
22:31:37 <leong> anything else for status update?
22:31:44 <docaedo> nothing from me
22:31:52 <CraigSterrett> Nothing from me
22:32:25 <annegentle> mbonell: okie doke
22:32:32 <leong> we don't have agenda for today... so what else we need to discuss next?
22:33:26 <leong> any specific topic that the team want to discuss here?
22:33:47 <docaedo> We can do:
22:33:51 <docaedo> #topic Open discussion
22:34:02 <docaedo> (just for the sake of organization)
22:34:02 <leong> good one :)
22:34:31 <leong> question: is next meeting also irc meeting?
22:34:41 <CraigSterrett> no voice, we alternate
22:34:43 <docaedo> no, next one is phone, and we'll alternate week by week
22:34:51 <leong> oh.. ok..
22:35:13 <leong> so is John the chair for next meeting?
22:35:26 <CraigSterrett> yes
22:35:41 <CraigSterrett> We do need to work on what training we are planning for Spain
22:35:57 <CraigSterrett> are we going to do a training class based on firstapp
22:35:57 <leong> you mean Barcelona Summit?
22:36:01 <CraigSterrett> yeah
22:36:49 <leong> i think we can have a brainstorm session for that, maybe in the next meeting?
22:37:11 <leong> or if anyone has a suggestion here?
22:38:18 <CraigSterrett> guess not
22:38:30 <mbonell> today I'll deliver an small workshop in guadalajara http://www.meetup.com/OpenStack-GDL/events/229034031/
22:38:33 <leong> #action team to brainstorm what training should be provided at Barcelona Summit
22:38:33 <carolbarrett_> As we create more training, we should look at ways we can enable openstack users groups to use the content and deliver local training
22:38:44 <docaedo> Flanders did give some guidance on this as well, regarding the app dev dojo stuff
22:38:48 <mbonell> my objective is also find the proper way to deliver this trainig for barcelona
22:39:47 <leong> the dojo is train the trainer.. i think flander has plan for that
22:40:46 <mbonell> yep, train the trainer was the objective in austin, the next step is the dojo (training)
22:40:57 <docaedo> ah ok, I thought he was pushing for that model though (with people grouped into 5s, etc.)
22:41:19 <docaedo> BTW I added Craig and John's IRC nics as chairs for future meetings: https://review.openstack.org/317120
22:41:54 <docaedo> I left myself in there as an unofficial fallback :)
22:42:22 <leong> anyone following up with Flander on the dojo?
22:43:06 <CraigSterrett> I have an update from Caleb on FirstApp for Shade: It is correct that I was the main contributor for that piece of the firstapp repo. I have started on the Swift part of the tutorial, I have not had time to finish it though, I hope to finish it in the next week and then get it reviewed, but I'm not sure if I will be able to. Bruno has given me an account on his cloud for testing, so that's what I'm using
22:43:18 <annegentle> I'd like to work on "deploying apps on OpenStack" as a training session, what do you all think?
22:43:58 <docaedo> annegentle: I think that would be great! What are you thinking about for the deployment (and packaging) approach?
22:44:07 <CraigSterrett> That is where have got stuck on what is an app.  Deploying apps on OpenStack means so many different things to different people
22:46:10 <annegentle> docaedo: lots of sections: heat/Orchestration, puppet/chef/ansible (w/heat if needed), containers (docker, mesos, kubernetes)
22:47:07 <annegentle> docaedo: images, murano, as possibilities, then best practices around perf/testing/security/12factors/etc
22:47:22 <annegentle> what do you think CraigSterrett ?
22:47:26 <docaedo> annegentle: love it - I've been thinking a *lot* about that stuff for a while too, will help you if I can find any extra time
22:47:57 <mbonell> looks very complete!
22:48:09 <CraigSterrett> I agree I think that it would be good
22:48:15 <leong> The Enterprise WG is working on a series of workload reference architecture (3-tier, ecommerc, media, big data) and with sample heat for deploying on openstack
22:48:34 <annegentle> docaedo: CraigSterrett: ok, cool, def. starting to write.
22:48:40 <annegentle> leong: that would be great!
22:49:33 <annegentle> sorry, I have to run, but thanks for the feedback/input
22:49:45 <annegentle> and for moving to IRC, helps me in my timezone anyway
22:50:06 <leong> we have 11 mins left.. anything else to discuss?
22:50:43 <CraigSterrett> Do we have anybody to work up a proposal for the training suggested by Anne?  I wasn't sure if she was offering
22:51:15 <leong> i think we can follow up that discussion in the "brainstorming" session next meeting
22:51:22 <CraigSterrett> ok
22:51:27 <mbonell> yep
22:51:29 <docaedo> That sounds like a good plan
22:51:47 <leong> i believe i have added that as one of the action item
22:52:21 <leong> #action team to brainstorm what training should be provided at Barcelona Summit
22:52:46 <leong> #action follow up with annegentle proposal "deploying app on openstack"
22:53:04 <leong> any other open?
22:53:13 <mbonell> no
22:53:17 <CraigSterrett> no
22:53:18 <docaedo> nothing here
22:53:32 <leong> we shall "talk" next week then :)
22:53:42 <mbonell> see you!
22:53:46 <docaedo> Looking forward to it!
22:53:49 <leong> thank you everyone!
22:53:51 <CraigSterrett> bye
22:53:55 <docaedo> thanks!
22:53:56 <leong> #endmeeting