22:00:03 <krotscheck> #startmeeting app_ecosystem_wg
22:00:04 <openstack> Meeting started Mon Jun 20 22:00:03 2016 UTC and is due to finish in 60 minutes.  The chair is krotscheck. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:07 <openstack> The meeting name has been set to 'app_ecosystem_wg'
22:00:14 <krotscheck> Agenda:
22:00:15 <krotscheck> #link https://etherpad.openstack.org/p/2016_June_20_App_Ecosystem_Workgroup
22:00:33 <krotscheck> Roll call, who's here?
22:01:08 <craigs> Craig
22:01:24 <krotscheck> Hey there, craigs!
22:01:35 <craigs> Hi
22:01:40 <krotscheck> docaedo is probably lurking...
22:01:49 <Patifa> Patricia
22:02:27 <krotscheck> Anyone know Sean, Caleb, and/or Marcela's IRC handles?
22:03:15 <krotscheck> Alright, let's get started.
22:03:17 <krotscheck> #topic Logistics: iCal feed
22:03:38 <krotscheck> First thing- when scheduling this meeting, I noticed that the iCal feed on eavesdrop.openstack.org says the IRC meeting is next week, not this one.
22:04:09 <krotscheck> Since other teams use this to schedule their own meetings, and it could result in a conflict, we should probably fix this. Does anyone want to volunteer to submit a patch to the meetings project?
22:04:25 <docaedo> hello!
22:04:33 <krotscheck> Hi docaedo!
22:04:50 <Patifa> hi docaedo :D
22:04:53 <docaedo> krotscheck: I can do that
22:04:58 <krotscheck> Sweet!
22:05:16 <docaedo> krotscheck: good catch, I thought I had it set right w/r/t which weeks, but I'll switch it up
22:05:17 <krotscheck> #action docaedo Fix our meeting iCal date.
22:05:41 <krotscheck> #topic Firstapp Progress: jclouds
22:05:51 <krotscheck> craigs: Anything to report?
22:06:18 <craigs> The getting started, introduction, scaling out and durability chapters are all covered. I still need to add instructions on how to get going with maven and add the block storage code.
22:06:31 <craigs> I being Martin Paulo
22:06:41 <JohnSimpson-Inte> #topic rollcall
22:06:56 * krotscheck peers at JohnSimpson-Inte
22:07:20 <krotscheck> craigs: Got it, does he report his progress through you, or will he be joining these meetings?
22:07:41 <craigs> I will ask if he can join, he has not attended in general and I am not sure why
22:07:58 <krotscheck> craigs: Alright- I'll mark that segment as Craig (obo Martin) for now
22:08:26 <krotscheck> craigs: Do you know what is timeline is for getting the project completed?
22:08:33 <krotscheck> *his
22:08:56 * krotscheck waves at mbonell :)
22:09:18 <craigs> No I do not have any date
22:09:55 <krotscheck> craigs: Alright, would you mind asking him for that? In the meantime we'll move on.
22:10:04 <craigs> yep
22:10:11 <krotscheck> #topic Firstapp progress: OpenStack.Net
22:10:22 <krotscheck> Anyone know if Carolyn has a representative here?
22:10:26 <krotscheck> (or if she's around?)_
22:10:50 <craigs> She does not attend
22:11:12 <krotscheck> Unfortunate. We'll mark that as no progress reported and then move on.
22:11:33 <krotscheck> #topic Firstapp progress: shade
22:12:09 <Patifa> mbonell?
22:12:15 <krotscheck> mbonell: I saw your updates to the etherpad. Anything in particular you'd like to highlight?
22:12:40 * krotscheck wonders if calebb is listening
22:13:12 <vhdiaz> marce?
22:13:41 <krotscheck> She might be behind a netsplit.
22:14:04 <notmars> Marcella need some notification activated when her nick is written :)
22:14:22 <krotscheck> Marcela ran tests on Caleb's most recent patch (today). She also submitted patch https://review.openstack.org/#/c/331760/ which coveres the "make it durable" section
22:14:22 <docaedo> (offtopic, but per my earlier action item, feel free to review: https://review.openstack.org/331863)
22:14:54 <krotscheck> And, I believe, that completes the shade example.
22:15:00 <krotscheck> So \o/ mbonell!
22:15:29 <krotscheck> Moving on to fog...
22:15:36 <krotscheck> #topic Firstapp progress: fog
22:16:01 <krotscheck> Anyone know if Sean's attending?
22:16:08 * krotscheck doesn't know what everyone's IRC handle is yet.
22:17:10 <krotscheck> Well, mbonell included an update for him: No news, no progress, but he's working on it.
22:17:11 <craigs> update was sent today "Wish I had some news but no progress yet. It’s proving to be a hectic month for me!"
22:17:18 <craigs> from Sean
22:17:20 <vhdiaz> I don't recal seen Sean in the meeting
22:17:24 <krotscheck> Works.
22:17:29 <krotscheck> Next
22:17:47 <krotscheck> #topic Firstapp status: pkgcloud/openstack-lib
22:17:49 <krotscheck> That's mine!
22:18:13 <krotscheck> The SDK still doesn't have any code, we're currently in heavy design discussions.
22:18:58 <krotscheck> There are some design specs under review here https://review.openstack.org/#/c/331801/ and here https://review.openstack.org/#/c/331359/, as well as a few others under construction by vkramsikh that will all be discussed wednesday morning.
22:19:36 <krotscheck> I'm hoping the first portion of FirstApp will land around august. This is mostly because I'll be on vvacation the first half of July
22:19:43 <vhdiaz> awesome!
22:20:15 <krotscheck> If anyone would like to take on some of the work that we're discussing, that'd be great :D.
22:20:19 <krotscheck> And that's it for me.
22:20:34 <krotscheck> #topic Firstapp progress: Open Discussion
22:20:52 <krotscheck> Are there any firstapp -related things that anyone would like to bring up?
22:21:13 <vhdiaz> nop
22:21:20 <notmars> my own pet project is done for the getting started part
22:21:32 <notmars> (objective-c / ios+watchos+tvos)
22:21:40 <krotscheck> notmars: Bruno?
22:21:45 <notmars> me indeed :)
22:21:48 <krotscheck> Ahah!
22:21:54 <krotscheck> I was about to bring you up :)
22:22:11 <notmars> I'm there
22:22:13 <notmars> :)
22:22:23 <krotscheck> notmars: Can you add a section to the agenda regarding the current status then so we can check in with you next week?
22:22:58 <notmars> of course, working for devstack, Dreamhost, Internap and soon Datacentred (received the credentials today)
22:23:15 <krotscheck> As an FYI to everyone else, Bruno's trying to figure out how to build an iOS sdk in a way that satisfies OpenStack's open source testing requirements.
22:23:27 <notmars> and there s that part :)
22:24:07 <krotscheck> notmars: As a suggestion (and hopefully not a derailment), it looks like Swift will run on linux. You may be able to make faster progress reimplementing in that.
22:24:11 <notmars> which prove to be quite interesting, currently spawning a gcc objective c config file to see how/if I can do it
22:24:26 * krotscheck wishes notmars luck :)
22:24:32 <notmars> indeed
22:24:40 <notmars> I'll check it when it's released
22:24:47 <notmars> and running
22:24:47 <krotscheck> Alright, moving on
22:24:50 <notmars> :)
22:25:01 <krotscheck> #topic App Hackathon
22:25:20 <notmars> we need to invoke Marcella I think
22:25:22 <krotscheck> vhdiaz, Patifa: I think you two are the best to give an update on this, yes?
22:25:28 <vhdiaz> yes
22:25:31 <krotscheck> Since mbonell seems to have timed out.
22:26:23 <vhdiaz> 2 things: Past Friday I talked to a ong: CodeandoMexico, these guys have government data samples, they want to participate .. That can connect us to the social elements we want to add to our hackathon
22:27:25 <krotscheck> oooh, neat!
22:27:40 <vhdiaz> the other thing is that we received platinum sponsorship from Intel
22:27:52 <krotscheck> \o/
22:27:58 <vhdiaz> We are working on the trainings
22:28:21 <vhdiaz> This would also make for a great pre-training as the Shade SDK will work cross cloud and we could make a requirement be for the grand prize that it works on 2 or more clouds?
22:29:19 <vhdiaz> and We are still pending to secure more sponsors
22:29:28 <notmars> vhdiaz: still loving the multi cloud idea :)
22:29:41 <krotscheck> vhdiaz: I submitted the sponsorship request last week for HPE, no word yet on when the OSPO is having its next funding meeting.
22:29:59 <vhdiaz> ;), it will be awesome to have HPE
22:30:14 <krotscheck> vhdiaz: Sadly, the do not give me a discretionary budget :D
22:30:15 <vhdiaz> we sent the prospectus to several telcos.. no answer yet
22:30:28 <vhdiaz> We need to close on sponsors pretty soon
22:30:30 <krotscheck> notmars: ANy chance internap might be interested?
22:30:42 <notmars> we already said yes :)
22:30:45 <krotscheck> Oh good!
22:30:50 <notmars> we're sending someone do the training there
22:30:52 <notmars> in person
22:31:12 <notmars> (pre-training sorry)
22:31:33 <krotscheck> vhdiaz: You reached out to mordred directly for funding, yes?
22:31:38 <krotscheck> And/or training?
22:32:39 <vhdiaz> for Training
22:32:52 <vhdiaz> I understand He said He is willing to come
22:33:00 <vhdiaz> but I did not ask for funding
22:33:21 <krotscheck> vhdiaz: Well, he's at RedHat now, you might be able to convince them :)
22:33:36 <krotscheck> Does anyone else have corporate connections that could help fund this?
22:33:53 <vhdiaz> I talked to Maria from RH
22:33:54 <reed> fund what?
22:33:58 * reed scrolls back
22:33:59 <vhdiaz> Let me go that way
22:34:26 <reed> the next hackaton?
22:34:28 <krotscheck> reed: The Guadalajara App Hackathon
22:34:35 <krotscheck> vhdiaz: Good call
22:35:06 <krotscheck> Hey there, reed! Good to see ya!
22:35:31 <reed> krotscheck, it's outside of my target, we'll have to pass... if we do one in US/Canada I would sponsor
22:35:39 <reed> s/if/when
22:36:06 <krotscheck> That's unfortunate, but understandable for Dreamhost
22:36:22 <krotscheck> vhdiaz: Anything else on the App hackthon? Your next meeting's wednesday, yes?
22:37:21 <vhdiaz> nop
22:37:24 <vhdiaz> thanks
22:37:27 <krotscheck> Alright, moving on.
22:37:36 <krotscheck> #topic Barcelona!
22:38:12 <krotscheck> On our call last week, i recall someone reaching out to flanders to ask what the actual logistics of the event were, plus what the foundation had planned for training. I don't recall who that was, can someoner efresh my memory?
22:38:25 <vhdiaz> me
22:38:34 <vhdiaz> wip
22:38:58 <vhdiaz> no updates, I need to touch base with flanders
22:39:06 <krotscheck> vhdiaz: Alrightey.
22:39:44 <krotscheck> The conference track nominations are still open. Victor's nominated a few people, but is there anyone here who'd like to be nominated as one of the track chairs?
22:40:34 <krotscheck> Categories are available here: https://www.openstack.org/summit/barcelona-2016/categories/
22:40:56 <notmars> I'll submit a talk, so abstening on the track chairs :)
22:42:08 <krotscheck> mbonello's already been nominated as well. Patifa, any desire to help out?
22:42:20 * docaedo nominated himself since he enjoyed the process last summit
22:42:37 <Patifa> let me have a look.
22:42:55 <krotscheck> Excellent. Ping me and/or victor offline and we'll send up a nomination if you're interested.
22:43:09 <krotscheck> #topic Hosted IRC Gateway (The Lounge)
22:43:15 <krotscheck> docaedo: How's that coming?
22:43:23 <Patifa> ok
22:43:26 <vhdiaz> :
22:43:30 <vhdiaz> :O
22:43:48 <docaedo> regarding IRC, I brought it up last week during open comments of infra meeting
22:43:55 <docaedo> got a few more people looking at the spec
22:44:27 <docaedo> planning to do the same tomorrow to see if there's a feeling on whether the spec needs much more before I can request a vote
22:45:13 <docaedo> also, I have a version of "The Lounge" running on a VM and will gladly give out accounts to anyone interested. It wouldn't be a permanent offering but I could easily leave it up until there's an "official" one available
22:45:16 <krotscheck> docaedo: How's reception been so far?
22:45:47 <notmars> docaedo: I'd like one if you can
22:45:52 <docaedo> Generally positive, and any resistance usually ends with "oh, yeah, this idea makes sense"
22:46:14 <docaedo> notmars: cool - please email me (doc@aedo.net) and I'll get something back to you in the next day or two :)
22:46:19 <docaedo> (same goes for anyone else)
22:47:00 <krotscheck> Alright, so we'll check in again next week to see how things are going.
22:47:08 <docaedo> sounds good
22:47:12 <krotscheck> #topic What is an OpenStack App / WG Charter
22:47:30 <docaedo> krotscheck: I think you were going to send me a link to "getting a local version of infra" for puppet manifest testing as well
22:48:10 <krotscheck> docaedo: Oh right, i need to write that post.
22:48:18 * krotscheck was just going to link https://krotscheck.net/2016/06/01/how-to-simulate-an-openstack-infra-slave.html, but it's a little specific.
22:48:37 <krotscheck> #action krotscheck Write howto simulate infra server for docaedo
22:48:53 <docaedo> krotscheck: thanks!
22:49:31 <krotscheck> craigs, docaedo: So on the "What is an app" discussion, have you made any progress on that?
22:50:05 <docaedo> from what I can see the conversation on the mailing list died out pretty quick
22:50:09 <craigs> We had transferred that to you, you were going to write up a proposal of what App means to this WG
22:50:28 * krotscheck blnks
22:50:36 <craigs> Instead of trying to get everyone to try and agree on one definition
22:50:42 <krotscheck> Right. My bad. Totally fell off my radar.
22:50:47 <craigs> NP
22:51:07 <krotscheck> #action krotscheck Write 'what is an app' synopsis, propose to group.
22:51:38 <krotscheck> Alright, that's it for that topic I believe.
22:51:43 * krotscheck feels sheepish
22:51:47 <krotscheck> #topic Open Discussion
22:52:00 <krotscheck> We have 9 minutes for open discussion, anyone want to bring something up?
22:52:14 <docaedo> for what it's worth, I thought this email asked some really good questions (relevant to what is an app) http://lists.openstack.org/pipermail/user-committee/2016-May/000889.html
22:52:18 <notmars> phpopencloud, are anybody in the team around ?
22:52:41 <notmars> do we know anybody working on that at Rackspace ?
22:53:23 * rockyg doesn't feel quite so bad now, forgetting to check AIs from IRC meetings
22:54:22 <craigs> I could ask around
22:54:54 <notmars> craigs: I'd be interested to chat up with someone
22:55:09 * krotscheck left his PHP roots behind 10 years ago.
22:55:17 * notmars too
22:55:25 <craigs> We know Jamie is not working on it anymore?
22:55:34 <notmars> still, I think we shouldn't neglect it :)
22:55:50 <krotscheck> craigs: The google doc says it needs a new owner.
22:56:13 <notmars> which is what I wanted to discuss :)
22:56:39 <krotscheck> Does that doc represent the status as of the summit, with "new owner" being post summit?"
22:56:43 <notmars> i'd want to know if they're gonna support it or not...
22:56:50 <craigs> I will have to dig through my emails, I assume I had heard from Jamie
22:57:04 <notmars> craigs: I'll be interested to know
22:58:10 <krotscheck> Last commit was 8 days ago, I'm going to assume they're supporting it.
22:58:20 <craigs> Yep just typing that
22:58:26 <krotscheck> jamie may not be focused on the firstapp portion of it.
22:58:51 <krotscheck> Also, he's in berlin, and right now is a REALLY inconvenient time for him.
22:58:59 <notmars> oh
22:59:09 <notmars> we'll wait then :)
22:59:29 <krotscheck> notmars: How about you reach out to him directly and ask?
22:59:38 <notmars> I did
22:59:42 <krotscheck> No answer?
22:59:48 <krotscheck> (less than a minute left, about to close shop)
22:59:57 <notmars> fresh from today
22:59:59 <notmars> so no
23:00:05 <krotscheck> Got it. Let's wait then.
23:00:08 <krotscheck> Thanks everyone!
23:00:08 <notmars> :)
23:00:09 <krotscheck> #endmeeting