22:00:09 <Patifa> #startmeeting app_ecosystem_wg
22:00:10 <openstack> Meeting started Mon Sep 12 22:00:09 2016 UTC and is due to finish in 60 minutes.  The chair is Patifa. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:14 <openstack> The meeting name has been set to 'app_ecosystem_wg'
22:00:20 <Patifa> Hello everyone
22:00:32 <docaedo> Hello!
22:00:37 <Patifa> Agenda can be found on our etherpad https://etherpad.openstack.org/p/2016_Sep_12_App_Ecosystem_Workgroup
22:00:51 <Patifa> Let's get started
22:00:54 <topol> Hi, can I add an agenda item at the bottom of the etehrpad?
22:01:02 <Patifa> #topic rollcall
22:01:06 <Patifa> topol sure!
22:01:09 <topol> o/
22:02:01 <craigs> o/
22:02:07 <topol> o/
22:02:28 <Patifa> ok, welcome everyone
22:02:29 <Patifa> #topic WG Chair
22:03:00 <Patifa> As most of you know Michael left the WG and we're looking into getting a new co-chair.
22:03:43 <Patifa> Flanders is helping reach out to other companies to see if we can find a good name.
22:04:13 <Patifa> We've already contacted RedHat
22:04:14 <docaedo> what's a co-chair need to do?  I could make time to help more with this
22:04:36 <docaedo> (and I'm not at HP or Intel so it'd be a chance of pace!)
22:04:49 <Patifa> Organize meetings
22:05:08 <Patifa> That would be a lovely change of pace...
22:05:14 <docaedo> that's a short list!
22:05:55 <docaedo> (short list of things the co-chair would need to do) .. I would have weighed in last week but trip to china and resulting jetlag took its toll
22:06:14 <Patifa> I believe the main role is to help drive the execution of what ever the WG needs to deliver
22:07:34 <Patifa> Also help shape the direction group wants to go..
22:07:50 <Rockyg> o/
22:08:18 <docaedo> well I'm pretty committed to making "apps on openstack" a thing, so I'll volunteer myself to be a co-chair with you Patifa
22:08:37 <topol> docaedo ++ :-)
22:08:43 <Patifa> Maria Bracho from Red Hat is also interested.
22:08:59 <docaedo> though there should be some voting probably, and hopefully a secret initiation ceremony somewhere
22:09:15 <docaedo> Not really sure how we're running this working group when it comes to such things :)
22:09:28 <Patifa> I like the idea of voting.
22:09:46 <Patifa> #action Patifa contact possible candidates
22:09:54 <Rockyg> docaedo, ++
22:10:21 <Patifa> #action Patifa start voting process
22:10:26 * docaedo gets to work on his campaign slogan
22:10:45 <Patifa> any ideas on how we do the voting process? Mailing list?
22:10:51 * topol make apps on openstack great again
22:11:06 <docaedo> topol: hahaha I was just typing that!!
22:11:20 <docaedo> Patifa: mailing list sounds good to me
22:11:23 <Rockyg> mailing list to advertise, the voting in meeting, plus proxies
22:11:28 <Patifa> besides stealing questionable slogans...
22:12:07 <Patifa> and voting in a call meeting or IRC meeting?
22:12:14 <Patifa> next one is a call meeting...
22:12:54 <docaedo> I would say just email - anyone who cares will respond
22:13:02 <csterret_> we could just use a doodle
22:13:25 <Rockyg> if you advertise today, you could vote next meeting, but otherwise, second meeting.
22:13:31 <reed> a doodle for what? I don't follow
22:13:34 <csterret_> vote
22:13:46 <Patifa> vote for the new co chair
22:13:57 <Rockyg> one week for nominations, then at least a couple days before vote
22:14:01 <Patifa> I want to give more time for new candidates to show up
22:14:05 <reed> there is a vote system on IRC
22:14:09 <reed> #vote
22:14:25 <reed> or condorcet... but are there more than one candidate? :)
22:14:53 <Patifa> There are 2 ATM... still talking to other companies to see if new names show up
22:15:10 <anteaya> why does the working group need two chairs?
22:15:11 <reed> http://docs.openstack.org/infra/system-config/irc.html#voting
22:15:38 <docaedo> so the new people - are they ones that have been involved with this working group, or is this an effort to sort of "reboot" the group by bringing in new folks?
22:16:08 <Rockyg> condorcet's a bit heavy for this purpose
22:16:13 <Patifa> I want to have 2 chairs to reduce the change of downtime when one is too busy. the other one is to help reboot this.. increase corporate diversity
22:17:03 <docaedo> sounds like a good plan
22:17:08 <anteaya> why don't you just start by asking for a volunteer to help increase attendance and participation in the working group?
22:17:19 <anteaya> if that is the goal
22:18:12 <csterret_> Any volunteers?
22:19:11 <Rockyg> docaedo?
22:19:25 <Patifa> anteaya do you see any problems if we have 2 chairs?
22:19:29 <reed> for what exactly? at this point, I don't see any tasks I or others at DreamHost can help with
22:19:56 <docaedo> reed: I think the bigger issue is to clarify the mission and start putting better action points to it
22:20:10 <reed> until a while ago the focus was on the first app tutorial... nowadays I don't know what we need to work on
22:20:10 <anteaya> Patifa: there is no problem, I was just wondering what the goal was
22:20:15 <maeca1> increasing attendance is not something that can be done alone. A co-chair can help drive the effort and add activities that will increase participation, but the group can add ideas as well
22:20:42 <Patifa> docaedo you're right.
22:20:48 <docaedo> polishing a bunch of guides for different languages was great, but we definitely need more clarity on the path ahead, and the goal (as I understand it) is to build the ecosystem of humans developing apps on OpenStack
22:21:00 <reed> the hackatons are not very interesting for dreamhost frankly, unless they happen in North America
22:21:32 <clarkb> reed: I think the most recent one was in north america?
22:21:43 <reed> clarkb, you're right :)
22:21:45 <docaedo> reed: the hackathons are just one part, but certainly dreamhost would be interested in some in the states?
22:22:21 <Patifa> reed one of the goals for Barcelona is to try to define what other activities for the WG. And we have the AppHack WG now to work on future hackathons
22:22:23 <reed> docaedo, I can justify states/canada, we're sponsoring one coming up on Ruby for example
22:22:52 <anteaya> reed: where?
22:23:01 <docaedo> awesome
22:23:32 <reed> there is a separate WG for hackaton?
22:24:00 <Patifa> reed yep. It's new... and we've been collaborating with them.
22:24:17 <reed> anteaya, it happens online... https://www.rubyrampage.com/
22:24:19 <Rockyg> So, I'd like o mention there is an interop challenge that is based on some common apps.
22:24:53 <Rockyg> I actually came here to taalk about starting an apps contrib repo for these sortss of apps.
22:24:56 <docaedo> Rockyg: yep topol added that as an agenda topic at the end of the etherpad
22:25:05 <reed> Rockyg, URL?
22:25:21 <anteaya> reed: ah the rebranded rails rumble, nice
22:25:28 <Rockyg> I'll need to find it.  It was one of the Austine talks.
22:25:52 <topol> #link https://wiki.openstack.org/wiki/Interop_Challenge
22:25:55 <anteaya> the feminine version of the last summit
22:26:06 <Rockyg> So, I could see this group curating contributd apps, creating other language versions, identifying gaps in contributed apps.
22:26:22 <docaedo> before we jump too far off the agenda
22:26:26 <reed> that's the issue I have with all these community efforts lately: there is not a solid website where all these things can be found, discovered and shared
22:26:27 <Patifa> can we move to the next topic?
22:26:38 <docaedo> let's give Patifa a chance to knock off the other items :)
22:26:44 <Rockyg> Currently there are some in the osops-contrib directory, but an apps contrib would be better
22:27:03 <Rockyg> So, get the cochair, and work on more apps?
22:27:29 <docaedo> next items are under Barcelona
22:27:36 <Patifa> #topic Barcelona - WG Meetings and sessions
22:27:43 <Rockyg> reed, ++
22:28:15 * topol need to go pickup my son. (thought today was a phone meeting). Rockyg will cover our item. Details of needs are in the etherpad
22:28:32 <Patifa> ok topol
22:28:35 <Rockyg> thanks, topol !
22:28:51 <Patifa> We're still waiting for approval for our meeting in Barcelona, it looks we're getting it.
22:29:22 <Patifa> We need to start planning the meeting there.. since it looks like a great opportinity to start over
22:29:32 <Patifa> #link https://etherpad.openstack.org/p/AppEcoSystem_WG_Barcelona_Meetup
22:30:16 <Patifa> I started an Etherpad so we can collect names... and start listing what we want our objectives to be
22:30:17 <Rockyg> Would be good to coordinate with hackathon wg for ither a BoF or the meetup
22:30:43 <docaedo> good plan to circle up in barcelona on this
22:30:59 <Rockyg> ++
22:32:10 <Patifa> I've added the need to increase the participation of other companies.. but I believe that might happen naturally if we have well defined goals and deliverables ppl can help with
22:32:50 <docaedo> agreed on that point - if what we are doing makes clear sense for the companies that are deeply invested in OpenStack we should start to see a lot more interest
22:33:55 <Patifa> I think if we start drafting the plan before Barcelona we can have a better audience there
22:34:22 <Patifa> and come out with a more significant set of items... preferably with owners. heeh
22:34:23 <docaedo> we'll need to be focused on making openstack relevant for the users (devs), and showing that we're building a welcoming platform for people who need a place to run large scalable apps
22:35:21 <Patifa> I started a conversation last meeting about audiences and actions to map what can be done
22:35:32 <Patifa> https://docs.google.com/drawings/d/1byHa_oTF2OTjfZZCJW0W3QXxs8PiQUqM8-6b0uWVOp4/edit
22:35:49 <Patifa> have not had time to edit the diagram yet... with the feedback from last meeting.
22:36:11 <Patifa> we can continue the conversation over the phone next week.
22:36:26 <Patifa> (hard to discuss the diagram on IRC... at least for me)
22:37:20 <Patifa> For the meantime we can start adding items to the list of goals...
22:37:53 <docaedo> sounds good to me
22:38:01 <Patifa> ok. moving on
22:38:12 <Patifa> #topic App Dev oriented session tracker
22:38:25 <Patifa> #link https://etherpad.openstack.org/p/App_Ecosystem_Workgroup-Barcelona_sessions
22:38:54 <Patifa> Here's where were listing all the sessions that might be of interest for app dev at the summit.
22:39:31 <Patifa> we started with our own submissions... but I believe we can add other sessions that were not submitted by members.
22:40:06 <Patifa> it'll help with the App Dev Cheat Sheet we're trying to put together for app devs attending the summit
22:40:24 <Rockyg> ++
22:40:51 <Patifa> so feel free to add!
22:40:56 <Rockyg> Interop challenge should be on there.  I'll see if we can coolect and add them
22:41:02 <docaedo> yep, I have it in mind to add any sessions that look relevant when I finally go through and work on my schedule
22:41:03 <Patifa> yay!
22:42:08 <Patifa> we can also try to categorize them.. good for "new to openstack" dev, good for enterprise app devs..
22:42:11 <Patifa> etc...
22:42:44 <Patifa> #action Patifa clean session tracker - remove sessions not approved
22:43:20 <Patifa> #action Patifa add categories/tags to be used by "curators"
22:43:40 <Patifa> I'm calling you guys "curators" now.. I hope it's ok
22:44:03 <Rockyg> another day, another hat ;-)
22:44:15 <Patifa> :D Rockyg
22:44:15 <calebb> heh
22:44:40 <docaedo> 15 minutes remaining :)
22:44:51 <Patifa> is there anything else we could be looking at in terms of prework fro the summit?
22:44:57 <vhdiaz> Patricia I got to drop :(
22:45:12 <Patifa> ok vhdiaz :D get some rest
22:45:16 <vhdiaz> c you all!
22:45:19 <vhdiaz> thanks
22:45:28 <Rockyg> thanks!
22:45:39 <Patifa> #topic OpenStack Academy
22:45:46 <Patifa> Flanders here
22:45:47 <Patifa> ?
22:46:24 <Patifa> guess not. next!
22:46:30 <Patifa> #topic First app
22:47:16 <Patifa> I move to make first app progress report status biweekly
22:47:47 <Patifa> and created an etherpad for the status
22:47:51 <Patifa> #link https://docs.google.com/spreadsheets/d/18Zj2JU0jR4hy8y1HxFl30gTEGeqgBjc6hqv0ZAByVYo/edit#gid=0
22:47:52 <Patifa> https://etherpad.openstack.org/p/firstapp_progress
22:48:00 <Patifa> oops
22:48:10 <Patifa> #link https://etherpad.openstack.org/p/firstapp_progress
22:48:11 <docaedo> +1 for bi-weekly
22:48:37 <Patifa> (bi-weekly = every other week)
22:49:31 <csterret_> I have not updated the sheet yet
22:49:57 <Patifa> we only have 10 min.. I'll move to the last item in the agenda
22:50:20 <csterret_> If anybody has time to do some testing on the jclouds version it is ready for testing
22:50:37 <Patifa> #topic Interop CHALLENGE
22:50:40 <Patifa> oops.. caps
22:50:59 <docaedo> I like the caps, like Flanders is shouting CHALLENGE!
22:51:01 <Patifa> Rockyg the floor is yours
22:52:13 <Rockyg> OK.  So the challng got started and started putting th apps in osops contrib.  I suggestd th apps WG could start and own an apps-contrib repo where th donated apps sourc code could liv
22:52:35 <Rockyg> You guys (and mayb an interop dv or two) would have merg priveliges
22:53:09 <docaedo> the problem with this sort of thing is that it's pretty intensive to validate the contributions work
22:53:10 <Rockyg> Th apps wg definees rewquirements for documentation, testing, content, etc for an app to be included
22:54:12 <docaedo> I've had conversations with infra and have explored (a little) how we could actually check things and provide CI feedback, and the hard part is that for the feedback to be timely, we need a "long running cloud" to deploy these things on top of
22:54:20 <docaedo> not saying it's a reason not to do it!
22:54:26 <Rockyg> That's why you guys defin the test requirements.  So, it's more content review, not a full review.  Others will file and fix bugs
22:54:38 <docaedo> just saying there's more to automating this if we want it to actually include checks
22:54:53 <Rockyg> I suspect w could get OSIC
22:55:02 <Rockyg> Yup.
22:55:07 <docaedo> sure, if it's just content review that's easier in a sense, but also can leave big gaps (like lots of ansible stuff looks good to me until I actually try to run it)
22:55:35 <docaedo> Relevant thread Igor started a while back, trying to do something similar for Murano (and other) apps
22:55:37 <docaedo> #link http://git.openstack.org/cgit/openstack/osops-tools-contrib/tree/
22:55:49 <docaedo> oops, thats not the link!
22:55:50 <Rockyg> But, w've got seed apps that can be used to allow cloud vendors to demonstrate these apps work on their versions of openstack
22:55:59 <docaedo> #link http://lists.openstack.org/pipermail/openstack-dev/2016-May/095917.html
22:56:16 <Rockyg> Yeah it is...
22:56:46 <docaedo> I mean, I pasted the link you happened to be talking about Rockyg :)  That's where there's stuff now.  Second link is the ML thread from Igor
22:57:00 <Notmars> We (internap) would be interested
22:57:01 <Rockyg> It would be a lot like th old unix usr/bin/contrib directory.
22:57:02 <reed> I've made a notice to myself to check the osops-contrib tree and test things with DreamHost cloud
22:57:14 <Rockyg> Cool!  even better!
22:57:41 <docaedo> Notmars: you'll be the first one I lean on then when we're ready to start writing some tests!
22:57:59 <Notmars> And reed :-p he did say yes too :-p
22:58:15 <docaedo> haha sure!
22:58:20 <Rockyg> So, to get the repo, it's a matter of a couple of patches.  The team here would need to define a workable dirctory structure so apps could be submittd
22:59:03 <Rockyg> And miminum standards for docs and submittinhg bugs against an app
22:59:14 <docaedo> oh time is up :(
22:59:18 <csterret_> What group did the interop challenge come out of?  Are they asking us to take over hosting?
22:59:45 <Patifa> this looked interesting. I'll add to the agenda next week
22:59:53 <docaedo> good q csterret_ that's the question I was going to ask, how it moved from interop challenge to app ecosystem
22:59:57 <Rockyg> They don't have a location.  They grabbed a repo that had fewer hoops to gt merged.  I think it belongs with this group
23:00:00 <docaedo> yep would love to discuss further
23:00:13 <Patifa> #action Patifa add interop conversation to the agenda
23:00:17 <Patifa> time to go!
23:00:29 <Patifa> thanks everyone!
23:00:30 <Patifa> #endmeeting