22:00:27 <Patifa> #startmeeting app_ecosystem_wg
22:00:30 <openstack> Meeting started Mon Nov  7 22:00:27 2016 UTC and is due to finish in 60 minutes.  The chair is Patifa. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:33 <openstack> The meeting name has been set to 'app_ecosystem_wg'
22:00:46 <Patifa> Agenda can be found on our etherpad
22:00:53 <Patifa> #link https://etherpad.openstack.org/p/2016_Nov_7_App_Ecosystem_Workgroup
22:01:08 <Patifa> #topic rollcall
22:01:14 <Patifa> anyone out there?
22:01:18 <CarolBarrett> Hi
22:01:26 <Patifa> Hi CarolBarrett!
22:01:36 <cbsterrett> HI
22:01:49 <Patifa> Hi cbsterrett
22:02:26 <docaedo> Hola
22:02:39 <Patifa> There you are docaedo
22:02:53 <Patifa> #chair docaedo
22:02:54 <openstack> Current chairs: Patifa docaedo
22:03:03 <leong> o/
22:03:12 <docaedo> Will switch to computer in 1 min :)
22:03:18 <Patifa> hi leong
22:03:41 <Patifa> Let's get this party started.
22:03:50 <Patifa> #topic Group name change
22:04:36 <Patifa> docaedo started the conversation on the ml about changing our name to App Developer Enablement or App Developer Support
22:05:13 <CarolBarrett> Patifa: Is this the name for the converged Application Developer WG?
22:05:38 <Patifa> No, for the App Eco WG.
22:06:16 <Patifa> But I was thinking that it touches the conversation about the converged App Dev WG.
22:06:23 <CarolBarrett> Is that because the merge isn't going to happen or ?
22:07:04 <Patifa> It's because we feel Ecossystem is to broad and we wanted to focus on the App Developer
22:07:52 <docaedo> I am personally a big fan of consolidation though, and the name to app dev enablement would support that I think
22:08:06 <CarolBarrett> Patifa: That makes sense
22:08:23 <leong> +1 to App Dev Enablement
22:08:29 <Patifa> Me too.. we need to see if the other parties are  big fans of consolidating too
22:08:29 <docaedo> (Also by the governance stuff we are really not a working group, but it doesn't seem like UC cares too much about the distinction at the moment)
22:08:37 <CarolBarrett> docaedo: the larger context could be scoped to app developers or it could include the ecosystem too
22:09:03 <CarolBarrett> I got lost in the UC discussion about teams and work groups...
22:09:32 <docaedo> CarolBarrett: true, but seemed that consensus in barcelona was that "ecosystem" is so broad a term as to not be (very) useful
22:09:47 <CarolBarrett> Seems like an unneccesary distinction to me, as long as teams have a mission and set goals and re-evalute the necessity to continue to operate each release cycle
22:09:58 <docaedo> CarolBarrett: sorry I will not distract this topic with the one about "should we be a working group" :)
22:10:08 <CarolBarrett> docaedo: understand...and agree
22:10:09 <docaedo> (maybe we save it for later if we get through agenda)
22:10:18 <CarolBarrett> ok
22:11:19 <Patifa> #action docaedo add "should we be a working group" discussion to agenda (future or today - time allowing)
22:12:18 <Patifa> as for the name, do we feel comfortable changing it today or do we need more time or a formal process?
22:12:41 <Patifa> Actually, is there a forma process?
22:12:55 <docaedo> There's no formal process that I am aware of
22:13:22 <docaedo> The mailing list thread seemed to have agreement around "App Dev Enablement" for new name, and I'm OK with that
22:13:31 <docaedo> I'd suggest if anyone disagrees, speak up :)
22:13:45 * Patifa quite
22:13:49 <docaedo> otherwise I can take the action to follow up on the mailing list and say we're going to change the name (and I can also update the wiki and stuff)
22:14:01 <Patifa> works for me
22:14:02 <cbsterrett> sounds good
22:14:18 <Patifa> (and I can't spell QUIET apparently)
22:14:48 <docaedo> #action docaedo to follow up on mailing list re: name change to "App Dev Enablement", then will update wiki pages as appropriate
22:14:49 <Patifa> #action docaedo follow up on the mailing list and say we're going to change the name
22:14:53 <docaedo> HAHA
22:14:55 <Patifa> hahah
22:15:00 <docaedo> I'll let you write the actions then ;)
22:15:15 <Patifa> tks!
22:15:24 <Patifa> I guess
22:15:31 <Patifa> Next topic
22:15:39 <Patifa> #topic Goals for "P"
22:16:11 <Patifa> Here are the proposed goals for this cycle
22:16:13 <Patifa> #link https://etherpad.openstack.org/p/app-eco-objectives
22:16:45 <Patifa> We were not able to go thru all of them at the summit.
22:16:55 <CarolBarrett> What about the Ocata cycle (ie now)?
22:18:08 <Patifa> that's a good question. docaedo why did we decide P instead of O...
22:18:34 <docaedo> well, since flanders isn't here I'm gonna say it was his fault :p
22:18:49 <Patifa> me too. :D
22:18:50 <docaedo> actually I don't really know - all I was thinking was "what will we try to cover before the next summit"
22:18:59 <CarolBarrett> Good call! :)
22:19:45 <Patifa> What I wanted to do is go thru them, see if we're all in agreement, and start breaking them in actionable items
22:20:06 <docaedo> +1
22:20:55 <leong> the list looks good to me in general.. the "actionable items / AR" in each list are the tricky parts...
22:21:18 <leong> i would suggest for O cycle , focus on (0) improve developer.openstack.org
22:21:22 <Patifa> Moving forward I want to propose that we create an etherpad for each of the goals and track actions and progress there. And I’d love if we had owners for each one of the tracks
22:21:43 <leong> and maybe develop plan towards some other lists?
22:22:30 <Patifa> other lists?
22:22:45 <leong> the list in the etherpad : https://etherpad.openstack.org/p/app-eco-objectives
22:23:25 <Patifa> ah ok :D
22:23:32 <leong> pick item (0) for Ocata
22:23:54 <leong> P cycle is towards Nov 2017
22:23:59 <Patifa> item 4 also is something we should aim for Ocata..
22:24:10 <Patifa> Working more closely with other related Working Groups
22:24:18 <Patifa> IMO
22:24:27 <CarolBarrett> It's a long list - how many goals do you realistically think the team can take on in this short cycle?
22:24:27 <leong> we need something for O May 2017
22:24:48 <leong> that's why i'm suggesting pick only (0) for O cycle :-)
22:25:23 <CarolBarrett> I would like to propose #4 for this cycle too
22:25:45 <docaedo> #0 and #4 seem reasonable to me
22:25:49 <docaedo> seem achievable
22:25:52 <Patifa> I think we can do those in parallel
22:26:04 <CarolBarrett> do you want to use a +1 system to "vote"? Like everyone gets 2 votes or ...?
22:26:07 <leong> #4 is an ongoing process .. :-) but that's definitely a good goal for O cycle
22:26:49 <Patifa> we should at least have a definition of how the teams can work together... if we merge, who merges with who...
22:28:19 <Patifa> and the one common goal on the discussion at the summit was item 0 of the list. both on the AppEcoWG and the App Enabling uber group (I don;t have good name for that)
22:29:45 <Patifa> if we're all in agreement with focusing on #0 and #4 for Ocata what are the next steps?
22:30:42 <docaedo> maybe a mailing list thread noting that those are our goals, and we start throwing out actionable suggestions for how to proceed?
22:31:01 <docaedo> Just think that we can't solve it in this meeting, and might end up engaging some folks who aren't here at the moment
22:31:50 <Patifa> that is correct. two threads then? one for each item? And we bring #0 to the agenda next week?
22:32:18 <Patifa> and make it a planning session for our call meeting?
22:32:48 <Patifa> while I schedule time with the other WG/team leads around #4
22:33:50 <docaedo> agrred on all counts
22:33:57 <docaedo> *agreed
22:34:16 <leong> +1
22:34:47 <Patifa> time for actions!
22:35:48 <docaedo> #actoin docaedo to let Patifa specify the actions for this meetings
22:36:22 <Patifa> #action Patifa start thread about decision of focusing on #0, add to agenda next week and call for participants
22:37:18 <Patifa> #action Patifa send doodle to other WG/team leads and schedule time to discuss #4
22:37:28 <Patifa> no more actions for docaedo ;)
22:37:38 <docaedo> :D
22:38:28 <Patifa> At the summit, since we did not have etherpad, I ended up working on a plan for #0 after our meeting
22:38:33 <Patifa> #link https://etherpad.openstack.org/p/AppEco_WG_BCN
22:39:15 <docaedo> nice
22:39:30 <Patifa> we had two actions from stefano and alejandra+olaph
22:39:44 <Patifa> Stefano to share on going effort to identify problems for developers
22:39:44 <Patifa> Alejandra + Olaph to propose a plan
22:39:45 <leong> might want to consider creating a series of "tutorial" to help AppDev to jump onboard on OpenStack.. at developer.openstack.org
22:40:19 <Patifa> I like that leong
22:41:06 <leong> let's push that into the planning meeting
22:41:20 <docaedo> Agreed on that, seems like a good idea
22:41:50 <Patifa> just added to 1.1.2.1
22:42:07 <Patifa> on the etherpad - under "generate content"
22:42:48 <Patifa> the other low hanging fruit was the survey
22:42:57 <Patifa> creating a survey to collect data from app developers to be distributed at events like Hackathons, Meetups etc.
22:43:52 <Patifa> I know that the AppHack WG folks were working with Piet (UX project) on this...
22:46:12 <docaedo> (15 minutes remaining)
22:46:37 <Patifa> Should we invite them to the conversation? Alejandra, Olaph, Stephano, Gonzalo, Michael Jenkins and Piet Kruithof?
22:47:29 <docaedo> definitely
22:47:39 <leong> one area i would like to brought up here for consideration: this team need to consider moving focus beyond FirstApp to more about cloud-native topics (e.g. app arch changes, design pattern, container for apps, etc).
22:47:54 <leong> i talked about that in the maillist: http://lists.openstack.org/pipermail/user-committee/2016-November/001355.html
22:47:58 <docaedo> I think olaph would normally be here but he might be in transit today for a team meeting we are having later this week
22:48:36 <Patifa> do you want this action docaedo? to invite them?
22:48:57 <docaedo> Patifa: sure :)
22:49:55 <Patifa> #action docaedo invite Alejandra, Olaph, Stephano, Gonzalo, Michael Jenkins and Piet Kruithof to the party (meeting) next week to contibute with the plan to improve  developer.openstack.org
22:50:48 <Patifa> leong, back to your point. I agree with you. How do we add it to our laundry list?
22:51:28 <leong> we can talk about that as part of the list (0), it might span additional sub-topics
22:52:39 <leong> pls put that into the planning list :-) sorry i need to drop.. talk to you next time... :-)
22:53:03 <Patifa> ok.. I'll add it to the list of possible content. We'll see if ppl have that content already that they can share in developer.openstack.org and plan to create the content that is missing in the future
22:53:16 <Patifa> any objections?
22:53:51 <docaedo> sounds good to me
22:54:32 <CarolBarrett> sounds good
22:54:39 <Patifa> ok, added to the plan!
22:54:56 <docaedo> (5 minutes left)
22:55:11 <docaedo> (and we're doing pretty good w/r/t the agenda!)
22:56:24 <Patifa> yep! :D
22:57:31 <Patifa> Anything else we feel we can discuss in the remaining 3 min?
22:59:28 <docaedo> think that's a no :)
22:59:36 <docaedo> thanks for running the meeting Patifa
22:59:46 <Patifa> np! let me close it!
22:59:52 <docaedo> thanks everyone!
22:59:52 <Patifa> #endmeeting