22:00:27 <Patifa> #startmeeting app_ecosystem_wg
22:00:28 <openstack> Meeting started Mon Feb 13 22:00:27 2017 UTC and is due to finish in 60 minutes.  The chair is Patifa. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:33 <openstack> The meeting name has been set to 'app_ecosystem_wg'
22:00:50 <Patifa> Agenda can be found on our etherpad
22:00:51 <Patifa> #link https://etherpad.openstack.org/p/2017_Feb_13_App_Dev_Enablement
22:01:07 <Patifa> #topic rollcall
22:01:41 <Patifa> anyone for the App Dev Enablement WG meeting?
22:01:46 <cbsterrett> Hi
22:02:08 <Patifa> hey cbsterrett
22:02:46 <Patifa> anyone?
22:02:50 <vhdiaz> zuup
22:03:05 <Patifa> hey vhdiaz!
22:04:20 <Patifa> We have the usual suspects... let's give folks a few more min to see if we have any non-Intel participants
22:05:30 <Patifa> guess not!
22:05:43 <notmars> Hi
22:05:49 <notmars> I am a non-Intel participant :P
22:06:01 <Patifa> Hi notmars!
22:06:07 <notmars> I must, I'm probably THE non-Intel participant :P
22:06:36 <Patifa> :D thanks for coming! let's move on!
22:06:43 <Patifa> #topic dev.o.o
22:07:29 <Patifa> Craig worked on a proposal for changes in the dev.o.o site. You can see them here:
22:07:44 <Patifa> https://etherpad.openstack.org/p/2017_Feb_13_App_Dev_Enablement
22:08:01 <Patifa> cbsterrett can you explain what you've proposed?
22:08:41 <cbsterrett> The page was totally focused on the SDK's and API.  I added more of the flow that I went through when learning to develop on OpenStack
22:09:23 <cbsterrett> I added a section on where to find a Dev environment, links to the FirstApp, links to the enterprise WG reference architectures
22:09:51 <cbsterrett> All of the changes are really in the top.jpg file, the other two files just show the rest of the SDK and API section which I didn't change
22:10:29 <notmars> I like it, it's a great first step I think
22:10:47 <cbsterrett> We have talked about adding in information for PaaS, but I have not done that yet.  The thought was we would link to another page with more of a PaaS marketplace feel
22:11:29 <cbsterrett> It is easier to add to what is there than re-write it all.  Changing format would require a lot more input from the foundation
22:11:46 <Patifa> I think we can consider this a solid first step and we can continue the discussion for PaaS for a second iteration..
22:11:48 <cbsterrett> notmars: have anything to add to it?
22:11:49 <notmars> ultimately, I would do the same regarding SDKs...like putting all the business somewhere like http://sdk.openstack.org
22:12:06 <notmars> and having a pure 'welcome developer' page
22:12:11 <notmars> but let's start here
22:13:00 <notmars> and we can slowly move the part in the screenshot 'middle' somewhere like sdk.openstack.org later :)
22:13:28 <cbsterrett> There is also this page https://www.openstack.org/appdev/
22:14:03 <notmars> one should strongly link to the other, no ?
22:14:06 <cbsterrett> I can either send it out to the mail list for more input, or just take the AR to make the change now
22:14:24 <notmars> I would put the change for review
22:14:51 <Patifa> +1
22:15:05 <notmars> if nobody react
22:15:08 <notmars> then we go forward
22:15:11 <notmars> :)
22:15:15 <vhdiaz> +1
22:15:23 <cbsterrett> You mean review in the mail list?
22:15:26 <Patifa> review=list?
22:15:46 <notmars> yeah, sorry for the ambiguity, mailing list
22:16:18 <Patifa> Go for it cbsterrett
22:16:39 <notmars> we just have to assess the reaction next week
22:16:45 <Patifa> #action cbsterrett send proposal to ML to review.
22:16:47 <notmars> and proceed from there (if it's positive) or reasses
22:17:02 <cbsterrett> ok
22:18:02 <Patifa> Great! Do we want to start talking about a second iteration - like how to add PaaS content now or put it to the list to?
22:19:00 <cbsterrett> How do we go about adding PaaS info, just promote OpenSource solutions?
22:19:40 <cbsterrett> Or get feedback from the foundation on what PaaS solutions they may be working with?
22:19:56 <Patifa> Yep.. It kind of ties to the second item in the agenda - to build relatonships with platforms whose audience is App Devs
22:20:35 <vhdiaz> I think we should know what is the Foundation's point of view about PaaS
22:20:42 <vhdiaz> or what is the angle about promoting solutions
22:21:17 <cbsterrett> That is how I feel, I think we need some support from the foundation before promoting non-OpenStack on OpenStack web sites
22:21:25 <notmars> agreed
22:21:36 <Patifa> same here
22:21:44 <cbsterrett> OK we will add PaaS in phase 2
22:22:07 <Patifa> any actions for now?
22:22:54 <cbsterrett> For topic 2?  If so we were going to write up a general statement of what we were hoping the companies would provide/support
22:22:55 <Patifa> let's move on to the next topic.. the action might be there ;)
22:23:00 <cbsterrett> yep
22:23:05 <Patifa> #topic build relationships with platforms whose audience is AppDev
22:23:14 <Patifa> there you go!
22:23:50 <cbsterrett> I think we do need an action to talk to Flanders about what we need to do before promoting PaaS
22:23:52 <cbsterrett> I can take it
22:24:10 <notmars> +1
22:24:17 <Patifa> #action talk to Flanders about what we need to do before promoting PaaS
22:24:25 <Patifa> damn
22:24:31 <Patifa> #action cbsterrett talk to Flanders about what we need to do before promoting PaaS
22:25:38 <Patifa> I had the action of contacting OneOps, but I felt like I needed a good pitch as to why it'd be interesting for them to help the WG
22:26:19 <notmars> I also think that meeting the platform eye to eye at the summit would be easier to get them on board
22:26:21 <cbsterrett> Yeah I think we need to come up with a pitch, why join the App Dev Enablement WG
22:26:55 <Patifa> So, create a pitch... chat with them at the summit?
22:27:01 <cbsterrett> +1
22:27:08 <notmars> that would be good first steps there !
22:27:12 <notmars> +1
22:27:37 <vhdiaz> +1
22:28:58 <Patifa> so there are two actions here? work on the pitch and make sure we have a session to approach the platforms?
22:29:24 <notmars> I would do it organically honestly at first
22:29:30 <notmars> we just have to know who's who
22:29:39 <notmars> and try to squeeze some time with them
22:29:52 <notmars> just to see how the pitch is received
22:29:57 <notmars> but it's just me :)
22:30:11 <cbsterrett> Yeah we may have to just hit some up at the marketplace
22:31:08 <notmars> I fear a formal event will be neglected by them
22:31:19 <Patifa> true true
22:31:31 <Patifa> so we work on the pitch.. divide and conquer
22:31:39 <notmars> at this stage, I,d say we need to make the first move ;)
22:31:42 <notmars> yup
22:32:13 <cbsterrett> sounds good
22:32:33 <Patifa> before the summit we should have a plan of who to approach and get volunteers to do that
22:32:40 <notmars> yup
22:32:44 <cbsterrett> yep
22:33:28 <Patifa> #action Patifa keep item on agenda until summit to create a list of platforms to approach and volunteers
22:34:27 <Patifa> but we need to work on the pitch... is this something we want to take to the ML or just use the meetings to whip up a first copy?
22:34:38 <Patifa> oh wait
22:34:46 <Patifa> #topic pitch
22:35:05 <notmars> I'd draft in the WG
22:35:16 <notmars> and then publicize for comment
22:35:31 <cbsterrett> someone may need to take a first stab at it since our attendance is so low
22:35:39 <notmars> hmmm
22:35:53 * notmars feel like eyes are slowly moving towards him
22:35:58 <Patifa> we can take a stab now.. https://etherpad.openstack.org/p/app-dev-wg-pitch
22:36:01 <cbsterrett> LOL
22:36:41 <Patifa> ;) don't worry notmars... we have your back
22:39:14 <notmars> I tried
22:39:15 <notmars> :P
22:40:00 <Patifa> That's a good start.. I'll copy it to the pitch etherpad
22:40:57 <notmars> tsk :)
22:40:59 <notmars> tks
22:42:33 <notmars> cool
22:42:46 <cbsterrett> In the pitch do we want to ask them to join this meeting?  If so what would this bring to them?  Or are we just offering to put some advertisement on the openstack web page and then ask for other favors?
22:43:06 <notmars> hmm
22:43:13 <notmars> good question, I'd say let's start small
22:43:34 <Patifa> i'd love to have them join this forum
22:43:38 <cbsterrett> It would be nice to know what we could do for them in this group
22:43:40 <cbsterrett> yep
22:44:04 <cbsterrett> We have talked about taking more of a PaaS focus, but not really what that means yet
22:44:10 <notmars> one good way would be to ensure we always consider their agenda
22:45:43 <Patifa> and also what we could offer on the behalf of the foundation
22:45:51 <notmars> if we say 'we'll be there for you representing you and your agenda inside other's WG/teams', I think that's an attractive proposition for them
22:46:14 <Patifa> 15 min
22:46:17 <cbsterrett> I think we need to know from Flanders what is the foundation planning on doing for htem
22:46:23 <notmars> yup
22:46:29 <notmars> strongly agreed
22:46:35 <Patifa> ok! action here!! uhu!!!
22:47:30 <notmars> get flanders to spill the beans ? :P
22:47:52 <Patifa> #action Patifa to chat with Flanders about foundation support intentions for PaaS/CaaS platforms - to add to pitch
22:48:06 <cbsterrett> Is that duplicate to my action?
22:48:17 <cbsterrett> "talk to Flanders about what we need to do before promoting PaaS"
22:48:25 <cbsterrett> we can combine into one meeting
22:48:29 <cbsterrett> team up on him
22:48:49 <Patifa> sure.. I like that
22:48:49 <Patifa> :D
22:48:52 <notmars> that would be a great to make sure he doesn't slip somewhere far :)
22:48:59 <notmars> +1
22:49:23 <Patifa> alright Craig.. you got my action. ;P
22:51:01 <Patifa> I'll keep the topic on the agenda! I can start a straw man for the presentation/pitch for next meeting
22:51:45 <notmars> +1
22:52:08 <Patifa> #action Patifa start pitch straw man for next meeting
22:52:29 <Patifa> Oops! Next meeting.. it's a holiday (Intel US at least)
22:53:28 <cbsterrett> We may need to post on the news group since notmars will not make the phone meeting anyhow
22:53:31 <notmars> lucky you
22:53:41 <notmars> ahahaha
22:53:46 <notmars> yes please
22:53:47 <Patifa> #action Patifa to chat with docaedo to see if he'll be available to run meeting.
22:54:58 <Patifa> ok 5 min... next topic, opens or call it the day?
22:55:07 <docaedo> #action docaedo to host next weeks meeting (which will be a phone meeting)
22:55:19 <notmars> call it :)
22:55:26 <Patifa> thks docaedo!
22:55:42 <cbsterrett> LOL see who is listening
22:55:42 <Patifa> I'll have a drink for you that day
22:55:56 <docaedo> No need, I'll be drinking on the call!
22:56:03 <notmars> works for me
22:56:17 <Patifa> I really like your style, docaedo :D
22:56:28 <docaedo> I do my best!
22:56:30 <Patifa> ok folks, thanks for the time!
22:56:38 <Patifa> #endmeeting