19:01:36 <SpamapS> #startmeeting arch_wg
19:01:37 <openstack> Meeting started Thu Sep 29 19:01:36 2016 UTC and is due to finish in 60 minutes.  The chair is SpamapS. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:40 <ttx> o/
19:01:41 <openstack> The meeting name has been set to 'arch_wg'
19:01:46 <jroll> \o
19:01:52 <SpamapS> Courtesy ping again just in case for nikhil, harlowja, dstanek, kragniz
19:02:13 <SpamapS> #link https://wiki.openstack.org/wiki/Meetings/Arch-WG#Agenda
19:02:24 <SpamapS> greetings earthlings
19:02:29 <Rockyg> o/
19:02:59 <SpamapS> Light o/ load today. :)
19:03:05 <cdent> o/ late
19:03:08 <SpamapS> 'sok
19:03:12 <dtroyer_zz> o/
19:03:23 <SpamapS> I'm dragging my feet because nikhil had the most interesting previous action items. ;)
19:03:50 <SpamapS> But let's get started with the other ones
19:03:52 <SpamapS> #topic previous meeting action items
19:04:02 <SpamapS> #link http://eavesdrop.openstack.org/meetings/arch_wg/2016/
19:04:43 <SpamapS> * ACTION: SpamapS find an APAC friendly slot in the odd weeks. [carried over] (SpamapS, 19:06:18)
19:04:59 <SpamapS> I went ahead and submitted a review, and I have a topic slot for this after this, so maybe we can discuss then.
19:05:21 <SpamapS> * ACTION: nikhil Create architecture-wg git repository for proposals and general WG documentation. (SpamapS, 19:11:59)
19:05:27 <SpamapS> nikhil: any chance you're here yet?
19:05:55 <SpamapS> We'll come back to that then.
19:06:17 <SpamapS> #topic alternative meeting times for TZ coverage
19:06:25 <SpamapS> #link https://review.openstack.org/379768
19:07:05 <SpamapS> I chose 0100 UTC, as it allows me to attend at least sometimes (it's smack in the middle of family time, but I can keep an eye on IRC then)
19:07:38 <ttx> who would lead it whn you're not around ? Not me :)
19:07:45 <SpamapS> I figure none of our APAC friends will be here, so I'm going to send that out to the mailing list for them to know it's there and comment on.
19:08:03 <ttx> SpamapS: maybe better to pick a time that you can actually attend ?
19:08:06 <Rockyg> I could be available.
19:08:06 <SpamapS> ttx: great question, I'll make sure to suggest that somebody from the APAC region step up to chair.
19:08:29 <SpamapS> ttx: there aren't any APAC friendly time slots that are not in family time or horrendously overbooked.
19:08:36 <ttx> I think having someone that can pass the baton between regions (by attending both) would be useful
19:08:55 <ttx> SpamapS: Ah, a bit like me and California
19:08:55 <SpamapS> I intend to pass that baton. Just, hopefully not as chair, but as ACTION acknowledger.
19:09:16 <SpamapS> ttx: precisely. We're just too far apart otherwise.
19:09:17 <Rockyg> ttx, that makes lots of sense.
19:10:10 <SpamapS> I see us gaining more participants this way, and really, we don't need everybody to be at every meeting, as long as we're pushing proposals forward and ticking off work items.
19:10:26 <dtroyer_zz> SpamapS: is that 0100 UTC on Thursday or Friday?
19:10:39 <SpamapS> dtroyer_zz: thursday, which means it will be on APAC Friday
19:10:42 <SpamapS> in the morning
19:10:53 <SpamapS> wait no
19:10:58 <SpamapS> 0100+8/9/10
19:11:00 <SpamapS> so yeah, Thursday mornings
19:11:00 <ttx> SpamapS: time is hard
19:11:25 <SpamapS> ttx: we should employ interdimensional beings to do this for us
19:11:48 <ttx> or make Earth flat again
19:12:00 <Rockyg> so thursday morning utc would be yesterday afternoon fo pst
19:12:05 <SpamapS> mmmm flatearth
19:13:04 <SpamapS> #ACTION SpamapS send proposal for APAC friendly time slot to openstack-dev to get feedback from actual APAC dwellers.
19:13:25 <SpamapS> #action SpamapS send proposal for APAC friendly time slot to openstack-dev to get feedback from actual APAC dwellers.
19:13:34 <SpamapS> Ok, let's move on
19:13:43 <ttx> SpamapS: beware it might get directly approved unless you Workflow-1 it
19:13:52 <SpamapS> ttx: good point
19:13:54 * SpamapS does that now
19:14:54 <SpamapS> #topic Proposal Process Review
19:15:08 <SpamapS> so Nikhil did submit a review to infra for a repo creation, but I haven't checked the status
19:15:16 <SpamapS> a moment while I dig it up
19:16:24 <SpamapS> #link https://review.openstack.org/#/c/375093/
19:16:33 <SpamapS> #link https://github.com/komawar/arch-wg
19:17:26 <SpamapS> Since nobody disagreed with dtroyer_zz's ML post, I assume we're all good with this going forward. :)
19:17:55 <SpamapS> #action nikhil continue to drive forward repo creation
19:18:14 <cdent>19:18:32 <SpamapS> going to skip ahead to a quick topic and then we'll get back to the fun part
19:18:33 <jroll> ++
19:18:35 <SpamapS> #topic Summit Cross-Project Space Request
19:18:45 <SpamapS> #link https://etherpad.openstack.org/p/ocata-cross-project-sessions
19:19:16 <ttx> Deadline is Sunday, we'll review the proposals Monday and have the program approved by the TC on Tuesday
19:19:28 <ttx> So far, not too many, so I'd say we have good chances
19:19:31 <SpamapS> this is just a reminder that we have made such a request, and anyone interested in having a spot on the schedule in Barcelona for this WG should go there, make sure the proposal is accurate and awesome, and bribe.. err... sweet talk the electorate ;)
19:19:31 <dtroyer_zz> once that is approved I'll propose adding the etherpad doc
19:19:36 * dtroyer_zz is a bit behind
19:20:23 <SpamapS> we can all dogpile on that repo creation review btw.. keep it moving forward and alive so it does not languish. :)
19:20:51 <SpamapS> ttx: thanks, that's good info
19:21:08 <Rockyg> ++
19:21:14 <ttx> If there were 30 proposals for 12 slots I'd tell you the chances are slim and we'd better meet at the bar
19:21:17 <SpamapS> #info Deadline is Sunday, TC should have the program approved on Tuesday
19:21:31 <ttx> But here we have more slots than proposals currently
19:21:38 <ttx> so unfortunately, no bar
19:21:47 <SpamapS> I approve a subsequent overflow session at the bar
19:22:09 <Rockyg> ++
19:22:13 <SpamapS> #topic Proposals for work
19:22:18 <cdent> I can come up with a few proposals, to force some bar
19:22:26 <cdent> (and that might even be useful)
19:22:39 <SpamapS> So, since we don't have a repo yet, we're still going on our looser "hey I want to talk about this" process
19:23:02 <SpamapS> I want us to keep momentum forward on that, even though I want us to establish the process ASAP so we don't get too distracted.
19:23:12 <SpamapS> * Base Services - ttx
19:23:22 <ttx> Right, so... this one is pretty simple, could be used as a test drive for the process
19:23:23 <dtroyer_zz> we can use the etherpad for that
19:23:36 <ttx> It's all about defining the concept of "base services", things that specific services can assume will be present in "OpenStack" installs
19:23:40 <SpamapS> ttx: we actually had a nice discussion about this last week, but it's getting to the point where we need to define our outputs before we can do much more than chat
19:24:00 <ttx> Obviously they don't /have to/ use them, but they shouldn't be shy about using them if those can bring extra value/functionality/scale/reliability/security
19:24:13 <ttx> Currently, that would be Keystone, an oslo.db database, and an oslo.messaging MQ
19:24:28 <ttx> Happy to submit something once we have a repo
19:24:40 <ttx> (and a process)
19:25:22 <SpamapS> So for something like this, I'd like to see a clear statement of where we're at now, and some data about how that's working.
19:25:42 <SpamapS> And then a hypothesis about where we should go, and estimation of work necessary to achieve it.
19:25:51 <ttx> SpamapS: yes, I was thinking about mentioning the "too many drivers" trade-off
19:26:06 <ttx> SpamapS: which you touched on when you starte dthe oslo.messaging spring cleanup
19:26:14 <SpamapS> I feel like oslo has gotten pretty good at that now.
19:26:36 <ttx> Those are elements where less is more
19:26:46 <SpamapS> AFAICT, the oslo bits in wide use have maybe 2 alternatives from the mainstream driver.
19:26:48 <ttx> (compared to say, cinder drivers where more is more more
19:26:51 <ttx> )
19:27:31 <ttx> SpamapS: so yes, the definition is also the occasion to reflect back -- like are those good things
19:27:34 <SpamapS> Right, driver propagation that allows charging rent on real things ++   driver propagation that allows using operators pet favorites at the expense of complexity of testing matrix --
19:28:10 <ttx> SpamapS: would you be interested in co-authoring ? You have some experience of that question
19:28:38 <SpamapS> I do, and yes, I'd definitely love to at the very least work as an editor on it.
19:28:42 <ttx> and since this is a bit historical / definition-oriented, more monkeys, better
19:29:00 <ttx> #info SpamapS interested in co-authoring base services
19:29:24 * jroll is happy to help review that
19:29:29 <ttx> #info should make sure to reflect back on history, not just describe current state
19:29:33 <SpamapS> Let's work in an etherpad, and as soon as the repo is available, we can submit as a proposal doc to that.
19:29:49 <ttx> #action ttx and SpamapS to statr etherpadding thoughts
19:30:04 <SpamapS> perfect
19:30:17 <ttx> #info don't forget to mention the drivers trade-off
19:30:22 <SpamapS> I'd also like to encourage mailing list discussions under the [architecture] tag
19:30:28 <cdent> ml++
19:31:08 <SpamapS> Basically, what I'd like to see happen is we author the initial proposal, and submit as a review to the repo, and then socialize that review, and hopefully get a ML discussion that can be linked to in the documentation we produce.
19:31:27 <Rockyg> create the etherpad now and link to it here in the meeting?
19:31:52 <SpamapS> I'm sure people who are too busy to join this WG will want to interject, and the idea is that we give them a place to do that with low barrier, so as we go from "where we are now" to "where should we go?" we have as much context as possible.
19:31:53 <ttx> on it
19:32:16 <ttx> #link https://etherpad.openstack.org/p/arch-wg-base-services
19:32:26 <Rockyg> Thanks!
19:32:32 <SpamapS> lovely
19:33:10 <jroll> nice
19:33:23 <ttx> ok, we can move on I think
19:33:27 <SpamapS> Ok, I think that's a great starting proposal. I've also lost interest in micro servicing OpenStack, and I think it's too tall of an order for us to make real headway on until we've done a few smaller initiatives.
19:33:50 <SpamapS> so unless somebody else wants to submit that, I'm not going to.
19:33:58 <cdent> can we at least stop telling lies :)
19:34:20 <SpamapS> cdent: That's just OpenStack being OpenStack.
19:34:29 <cdent> (but yeah, agree it is probably too soon to make real headway)
19:34:45 <SpamapS> cdent: your API WG would definitely be one I'd want to involve heavily in such an effort.
19:35:04 <SpamapS> Since the whole point is if you have actual good reliable public API's you are 90% of the way to micro-services.
19:35:22 * cdent nods
19:35:55 <jroll> and if you don't, you need them :D
19:36:09 <SpamapS> ttx: one point of interest last week was Barbican. It seemed like there was a lot of real discord about its value.
19:36:23 <SpamapS> in the context of base services
19:36:51 <ttx> Right, I don't think we should add it -- I think we should discuss it since it was raised recently
19:36:53 <cdent> yes, it quickly went off in the weeds
19:37:05 <ttx> in some ML thread
19:37:12 * ttx looks for reference
19:37:28 <SpamapS> I think it needs to be mentioned and addressed, even if we say "We want to add that, but right now we don't think there's enough agreement about it to get that done."
19:38:01 <ttx> So I just wanted our group to look into the two additions that were suggested in the past (DLM, Barbican) and potentially have a recommendation on them
19:38:04 <jroll> SpamapS: ++
19:38:16 <ttx> but that's second order after we define what we mean by base service
19:38:19 <SpamapS> So, yeah, I think we have plenty to do with base services already.
19:38:28 <dtroyer_zz> ++
19:38:33 <SpamapS> Does anybody else have another effort they'd like to see on our initial set of proposals?
19:39:10 <cdent> I don't know if this would be initial, but a very popular topic is "fixing rpc/messaging"
19:39:17 <Rockyg> mine is on the etherpad, but it's more tactical.
19:39:21 <cdent> since that is as broad as the amazon, I'm not sure we can going anywhere there
19:39:32 <Rockyg> ++ to fixing rpc
19:39:48 <Rockyg> We can document th current states
19:39:57 <dtroyer_zz> cdent: identifying the issues would be useful, if for no other reason that to point to them for everyone new who things we need to takcle that
19:40:04 <SpamapS> cdent: It's broad from one angle (every project touches) but narrow from another angle (only one library facilitates it)
19:40:28 <ttx> there was a good one-email summary of the RPC issues in a recent thread
19:40:34 <SpamapS> there was indeed
19:40:36 <jroll> +1 for agreeing on the issues first
19:40:38 * cdent nods
19:41:06 <SpamapS> Would somebody like to gather that into a proposal of its own? IT does not have to be super deep, just a summary so we can get it on our radar. Because I also would like to see it addressed.
19:41:39 <dtroyer_zz> sure, I'll take that on
19:41:46 <SpamapS> And I know that I can muster up a couple of developers to attack it if we come up with a solid design.
19:41:56 <cdent> dtroyer_zz: if you start that on an etherpad, I'd be happy to chase it with you
19:42:19 <SpamapS> can you make the etherpad link now so we can action it for next meeting?
19:42:51 <dtroyer_zz> #link https://etherpad.openstack.org/p/arch-wg-messaging-status
19:43:29 <SpamapS> dtroyer_zz: thanks!
19:43:49 <SpamapS> Anything else?
19:44:10 <SpamapS> Rockyg: you said "mine are in the etherpad" can you #link that etherpad for posterity
19:44:30 <Rockyg> Lemme go find it... from last week...
19:45:10 <SpamapS> https://etherpad.openstack.org/p/arch-wg-draft ?
19:45:48 <SpamapS> https://etherpad.openstack.org/p/arch-wg-status-board ?
19:46:02 <SpamapS> That's the one
19:46:05 <SpamapS> #link https://etherpad.openstack.org/p/arch-wg-status-board
19:46:07 <Rockyg> #link https://etherpad.openstack.org/p/arch-wg-status-board
19:46:10 <SpamapS> Hah yay
19:46:13 <SpamapS> double the links
19:46:17 <SpamapS> Rockyg: thanks
19:46:41 <Rockyg> I'm thinking about a couple more, but need to crystallize them more
19:46:57 <SpamapS> That's fine, we're going to be overwhelmed with proposals if we have about 1 more. ;)
19:47:04 <Rockyg> They go to useability but also clarrity
19:47:30 <SpamapS> The nice thing is, as we start to get them done, we can start to break them up into smaller chunks and we'll get better at completing things.
19:47:43 <SpamapS> #topic open discussion
19:48:01 <SpamapS> I think for me, we've discussed enough. If there's nothing else to talk about, maybe we end meeting early?
19:48:12 <ttx> +1 for end "early"
19:48:29 <Rockyg> +1
19:48:42 <SpamapS> Alright, the ayes have it.
19:48:47 <dtroyer_zz> ++
19:48:52 <cdent> +1
19:48:56 <SpamapS> thanks everyone for turning up and continuing to make forward progress!
19:49:10 <SpamapS> #endmeeting