20:01:12 <SpamapS> #startmeeting arch_wg
20:01:13 <openstack> Meeting started Thu Dec  1 20:01:12 2016 UTC and is due to finish in 60 minutes.  The chair is SpamapS. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:17 <openstack> The meeting name has been set to 'arch_wg'
20:01:25 <Rockyg> o/
20:01:27 <harlowja> sup
20:01:34 <ttx> hola
20:01:44 <SpamapS> Courtesy pings for nikhil, harlowja, dstanek, kragniz, auggy, rockyg, rocky_g, kgiusti -- Arch-WG Meeting has begun.
20:01:58 <SpamapS> #link https://wiki.openstack.org/wiki/Meetings/Arch-WG#Agenda
20:02:08 <SpamapS> #topic previous meeting action items
20:02:10 <SpamapS> #link http://eavesdrop.openstack.org/meetings/arch_wg/2016/
20:02:53 <SpamapS> Also welcome! :)
20:03:05 <harlowja> welcome
20:03:09 <harlowja> your welcome
20:03:21 <Rockyg> well, come on in
20:03:25 <SpamapS> Real quick.. I haven't been able to do much for Arch-WG.. holidays.. family stuff.. I hope to get back to it now that those things are through.. until 2 weeks from now, when the next round of holidays happen ;)
20:03:35 <SpamapS> So, to the actions:
20:03:39 <SpamapS> * SpamapS email proposed arch-wg repo process to openstack-dev
20:03:54 <SpamapS> Just didn't do it.
20:04:00 <SpamapS> #action SpamapS email proposed arch-wg repo process to openstack-dev
20:04:02 <SpamapS> carrying forward
20:04:38 <SpamapS> * SpamapS submit base services etherpad contents to arch-wg repo upon its creation.
20:05:06 <SpamapS> So, I didn't really finish creating the repo until about 5 minutes ago when I approved this change:
20:05:08 <SpamapS> #link https://review.openstack.org/#/c/399201/1
20:05:23 <SpamapS> so, now that we have a structure (yay!) we can send out the process and get the base services thing merged.
20:05:49 <Rockyg> yay!
20:05:54 <SpamapS> #action SpamapS submit base services etherpad contents to arch-wg repo upon its creation.
20:05:56 <SpamapS> so, carried
20:05:58 <ttx> standing by to review/iterate on when the etherpad will be posted
20:06:13 <SpamapS> and the other one is a follow up to that
20:06:15 <SpamapS> #action SpamapS add ttx to review for base services
20:07:08 <SpamapS> #topic Proposal Process Review
20:07:19 <SpamapS> I haven't sent out the write-up yet, so this is hard.
20:07:31 <SpamapS> I don't think we should really talk about it until that is sent out (really sorry.. this is going so.. slow..)
20:08:03 <SpamapS> Is anybody worried we're not getting more done? I feel like it's about 1% of my focus the last few weeks, so I think it's normal. But I want to make sure we're not just being bureaucrats.
20:08:14 <ttx> anything we could take from you ? You seem to be on the critical path everywhere
20:08:32 <SpamapS> ttx: if you want to submit the base services proposal.. that would be great.
20:08:34 <Rockyg> ttx, ++
20:08:40 <ttx> I'll take that
20:09:03 * harlowja needs to be a better bureaucrat
20:09:04 <harlowja> lol
20:09:21 <SpamapS> I'm also taking it slow because I'm very wary of this turning into a bureaucracy just by the nature that if we grow it fast, it'll be hard to shrink or change.
20:09:43 <SpamapS> #action ttx to actually submit base services etherpad contents to arch-wg repo
20:09:52 <Rockyg> hey, I feel your pain.  Log wg is moribund, but someone wants to kick it back to active.  Even arranging a handoff is hard...
20:10:07 <ttx> SpamapS: the archwg repo is up and running right
20:10:30 <SpamapS> ttx: it is! clone https://git.openstack.org/openstack/arch-wg
20:10:36 <ttx> cool
20:10:41 <SpamapS> #link https://git.openstack.org/openstack/arch-wg
20:11:07 <SpamapS> ttx: We can worry about formatting of proposals later. Just having a block of text in there will let us get some editting done and then lay out the work.
20:11:43 <ttx> ack
20:11:59 <SpamapS> So, process wise, I think we're doing ok. Now, on to the proposals we don't have many of...
20:12:05 <SpamapS> #topic Proposals for work
20:12:38 <SpamapS> So we already covered base services. I also note that we haven't had many people add any yet, because I think we're still being a bit pedantic about having a process.
20:13:40 <SpamapS> I spoke with John Dickinson a few weeks ago about Swift and the Arch-WG. He was happy to hear about the Arch-WG, and felt that Swift might have some ideas for bringing a few of the ways they do things to the rest of OpenStack (such as being a microservice architecture inside Swift).
20:13:43 <Rockyg> link to etherpad, please?
20:14:00 <SpamapS> gah, I've lost the link
20:14:06 <SpamapS> let me find it in older meeting minutes
20:14:35 <SpamapS> #link https://etherpad.openstack.org/p/arch-wg-status-board
20:14:45 <SpamapS> Rockyg: thanks for reminding me.. I forgot we even had it.
20:15:24 <pranav> hello
20:16:17 <SpamapS> Do we want to discuss any of those right now?
20:16:50 <SpamapS> Or maybe here's another approach.
20:17:00 <SpamapS> Does anybody see anything in there they'd like to write up and submit to the repo for discussion here?
20:17:16 <Rockyg> well, Nikhil doesn't seem to be around, otherwise glance stuff would be god.  Oaktree also has highlighted a bit of glance work needs
20:17:33 <SpamapS> Indeed, Oaktree is somethign I'd love to get on our radar.
20:17:41 <Rockyg> ++
20:18:03 <Rockyg> I'm sure mordred would love it, too.
20:18:04 <SpamapS> While it is mostly relevant to the API-WG, it definitely highlights things about what's under the API's too.
20:18:33 <Rockyg> Eliminating implementation bleedthrough is a biggy for us.
20:18:49 <SpamapS> Right, I think that actually goes into micro services.
20:19:15 <SpamapS> If we were to eliminate implementation details in the APIs, it makes it easier to isolate the services from eachother.
20:19:39 <Rockyg> ++
20:19:39 <SpamapS> I stand by the fact that the interface between nova-compute and everything else is _very_ poorly defined and rife with implementation bleedthrough.
20:19:39 <mordred> I'm behind in getting more into oaktree such that it can be helpful here - but definitely on my list
20:19:46 <mordred> SpamapS: +100000
20:20:13 <SpamapS> #action SpamapS write up nova-compute rant as a proposal to arch-wg repo
20:20:33 <harlowja> lol
20:21:33 <Rockyg> oh, cool!
20:21:44 <SpamapS> In manyw ways, every line of code in Shade is classified as either API simplification, or implementation obfuscation.
20:22:07 <harlowja> every line???
20:22:15 <mordred> even the blank ones
20:22:32 <harlowja> nice nice
20:22:33 <SpamapS> So, it might make sense for a group of us who like making implementations better to address those implementation bleedthroughs in each API, so we can start changing the implementations.
20:22:50 <SpamapS> the blank ones are obfuscating THE MOST
20:23:25 <SpamapS> But I've got too much to do, so not going to submit a proposal for arch-wg to document all implementation bleed through
20:23:29 <SpamapS> I wonder if API-WG is trying to do that at all.
20:23:38 <SpamapS> It seems like a worthwhile backlog to create and throw people at fixing.
20:24:02 <Rockyg> It's also a great way to get senior devs who are n00bies coding for openstack
20:24:50 <Rockyg> don't think the api-wg is doing that...
20:24:56 <SpamapS> Yeah me neither.
20:25:50 <SpamapS> Rockyg: did you want to take a stab at a paragraph or two to make a hypothesis about implementation bleedthrough in API's? I think it might be somethign we could send out to openstack-dev and get some more cross-project folks interested in contributing on.
20:26:04 <SpamapS> Otherwise, I think we'll move on.
20:27:18 <Rockyg> Hmm.  Thats' agood idea...  I'll throw some stuff into an etherpad and ask for comments/changes.
20:27:31 <Rockyg> action item me...
20:27:49 <SpamapS> #action Rockyg to write up implementation bleed-through thoughts and submit to arch-wg repo
20:27:53 <SpamapS> Rockyg: ^5
20:28:13 <SpamapS> #topic Open Discussion
20:28:18 <ttx> FYI there are a significant number of people who selected ArchWG room as a place they would spend time on at the PTG (mostly people who come for the 2nd part of the week and are not working in a specific horizontal team -- so I expect that day we plan to have there to be well-attended
20:28:37 <SpamapS> ttx: oh, perhaps I should register and book travel then. ;)
20:28:51 <ttx> no comment
20:28:54 <SpamapS> ;)
20:29:11 <SpamapS> I was planning to anyway.. my main focus is on Zuul dev at the moment, and there is a lot to do there.
20:29:18 <clarkb> re bleed through I have been putting thoughts on https://etherpad.openstack.org/p/openstack-user-api-improvements much of which is related to bleed through of implementation details through the api
20:29:31 <SpamapS> #link https://etherpad.openstack.org/p/openstack-user-api-improvements
20:29:37 <SpamapS> clarkb: sweet
20:29:51 <Rockyg> Cool.  Thanks.  I'll peruse that for help.
20:30:52 <SpamapS> Even if all we do is document all of those places.. and submit them as bugs to be addressed in the next major rev of API, that seems a useful exercise.
20:31:04 <Rockyg> Maybe we submit that to the repo and iterate on that, too, clarkb?
20:31:20 <clarkb> the repo?
20:31:29 <SpamapS> clarkb: openstack/arch-wg
20:31:29 <Rockyg> Some might end up as BPs, too.
20:31:37 <SpamapS> clarkb: just the place we're using to keep track of what we're doing and docs we produce.
20:31:43 <clarkb> oh sure, this was mostly me rambling thoughts based on using openstack for the last 4 years
20:31:52 <clarkb> fine by me if it finds a better home
20:32:06 <SpamapS> that's exactly the sort of thing we need as supporting background for work to propose we all collaborate on.
20:32:34 <Rockyg> ++
20:32:53 <SpamapS> Get some supporting info.. make a hypothesis.. design a data collection strategy, and then once data is collected, check hypothesis, and create a plan of action to affect change.
20:33:28 <SpamapS> it's science yo. ;)
20:33:57 <SpamapS> With that, I think we can end.
20:34:10 <ttx> +
20:34:23 <SpamapS> Reminder that next week is the APAC friendly timeslot, so those in APAC please do join us. Otherwise see you in 2 weeks.
20:34:34 <SpamapS> #endmeeting