20:06:22 <SpamapS> #startmeeting arch_wg
20:06:23 <openstack> Meeting started Thu Feb  9 20:06:22 2017 UTC and is due to finish in 60 minutes.  The chair is SpamapS. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:06:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:06:27 <openstack> The meeting name has been set to 'arch_wg'
20:06:33 <cdent> o/
20:06:39 <SpamapS> Courtesy ping for nikhil, harlowja, dstanek, kragniz, auggy, rockyg, rocky_g, kgiusti, thingee, denaitre
20:06:41 <rocky_g> o/
20:06:58 <SpamapS> ttx: since it's today, and not yesterday, will you be joining?
20:07:07 <SpamapS> #link https://wiki.openstack.org/wiki/Meetings/Arch-WG#Agenda
20:07:24 <SpamapS> #topic previous meeting action items
20:07:26 <SpamapS> #link http://eavesdrop.openstack.org/meetings/arch_wg/2016/
20:07:41 <SpamapS> #link http://eavesdrop.openstack.org/meetings/arch_wg/2017/
20:07:46 * SpamapS fixes wiki page
20:08:49 <SpamapS> looks to me like the meeting last week did not carry actions forward
20:08:58 <SpamapS> (last time rather)
20:09:18 <SpamapS> * Rockyg to write up implementation bleed-through thoughts and submit to arch-wg repo (carried from December 2016)
20:09:23 <SpamapS> rocky_g: ^
20:10:00 <SpamapS> rocky_g: shall we drop that action? or would you like to carry it forward and try to get to it during the PTG?
20:10:08 <rocky_g> oops.  Missed that.  Dang.
20:10:36 <rocky_g> Soon
20:10:58 <rocky_g> Let's do it at PTG.  We can get Monty ;-)
20:11:53 <SpamapS> rocky_g: can you maybe seed the discussion with an ML thread so we have people prepared with background information at the PTG?
20:11:54 <cdent> It would be nice, if possible, to lay some groundwork before ptg, but if everyone else is like me, there's not much in the way of spare time
20:11:59 <cdent> jinx-ish
20:12:02 <SpamapS> Hah yeah
20:12:04 <rocky_g> Yeah.  I can do that
20:12:04 <SpamapS> same
20:12:16 <rocky_g> now that it's back on my radar
20:12:20 <cdent> yay!
20:12:24 <SpamapS> Been trying to find an hour to move nova-compute-api to active with more of a plan of action for a month now :-P
20:12:30 <SpamapS> this month has been travel heavy
20:12:59 <SpamapS> #action rocky_g Send email regarding implementation bleed-through (stretch: submit as raw proposal)
20:12:59 <rocky_g> And will continue to be.
20:13:26 <SpamapS> * ttx to move base-services to active and complete the details
20:13:30 <SpamapS> I believe that is _done_
20:13:38 * cdent nods
20:13:42 <SpamapS> and ttx has even jumped further forward and has submitted a spec for the TC
20:14:13 <rocky_g> kewl
20:14:21 <SpamapS> it would be amazing if I had that link handy ;)
20:14:46 <SpamapS> #link https://review.openstack.org/#/c/430965/
20:15:20 <SpamapS> we can talk more when we get to active proposal check-ins
20:15:32 <SpamapS> * SpamapS to move nova-compute-api to active status and add structure
20:15:35 <SpamapS> fail
20:15:45 <SpamapS> #action SpamapS to move nova-compute-api to active status and add structure (Carried from Jan 2017)
20:16:14 <SpamapS> I will be dedicating an entire day next week to prep for arch-wg PTG sessions, and we'll talk more about that later too
20:16:18 <SpamapS> that's all the actions
20:16:25 <rocky_g> Cool.
20:16:31 <SpamapS> #topic Proposal Process Review
20:16:39 <SpamapS> I feel like the process is going ok.
20:16:46 <SpamapS> I'd like to see another proposal enter the queue.
20:17:24 <SpamapS> as right now we're a bit too efficient at keeping our inbox at 0 ;)
20:17:59 * cdent chants dlm
20:18:13 * cdent and pings harlowja
20:18:20 <harlowja> lol
20:18:26 * rocky_g hums along
20:18:32 <harlowja> sorry, got a presentation later (at a openstack meetup) will be sorta in here, ha
20:18:35 <SpamapS> dlm is a bit contentions
20:18:37 <SpamapS> contentious
20:18:44 <harlowja> meh
20:19:02 <SpamapS> thingee specifically raised concerns that we'd be stepping on the cross-project team's toes by wading in before Cinder has done their work.
20:19:11 <harlowja> memberberries
20:19:14 <harlowja> i need more memberberries
20:19:14 <harlowja> lol
20:19:38 <SpamapS> But it's worth noting that we don't have a good way of just rallying people to an existing effort.
20:19:47 * cdent nods
20:19:48 <rocky_g> We can ping Cinder at PTG to see where they are..
20:19:51 <SpamapS> Maybe that's the proposal to submit harlowja ? "Go help existing effort -->"
20:19:56 <cdent> I'm not familiar with what cinder is up to?
20:20:06 <harlowja> SpamapS perhaps
20:20:09 <rocky_g> Yeah.  Me either
20:20:15 <SpamapS> cdent: there's already an openstack spec spelling out DLM options and Cinder was working toward being the first user.
20:20:31 <harlowja> ironic and ceilometer might be father along
20:20:57 <rocky_g> we can ping gordc about ceilometer
20:21:03 <SpamapS> so, how about this
20:21:16 <SpamapS> let's get this in our pipeline as a "we are interested and want to help socialize this effort" thing
20:21:21 <cdent> SpamapS: I had the vaguely unclear sense that "openstack specs" were dead and replaced by openstack goals?
20:21:46 <rocky_g> cdent, no.  They both are alilve
20:21:51 <SpamapS> cdent: oh, I thought the goals were a stronger thing, where as specs were just cross-project agreements.
20:22:04 <rocky_g> spec is used for tracking crossproject efforts
20:22:15 <cdent> I know they are _supposed_ to be alive, but the cross project repo has seen no activity for weeks if not months
20:22:23 <rocky_g> Goals are more general.
20:22:26 <SpamapS> like, a goal is something we need to get done together and track progress of, but a spec is "If you do this, do it this way"
20:23:10 <SpamapS> cdent: mysql cluster was submitted as an openstack spec
20:23:19 <SpamapS> 2 days ago
20:23:35 <cdent> well, that's the first noise in there for a very long time
20:23:38 <SpamapS> And that's a good example of one.
20:23:41 <rocky_g> and ProdWG works toward getting the userstories to specs
20:23:50 <SpamapS> So
20:23:56 <SpamapS> backing up.. they're alive, but maybe have lost focus
20:24:01 <cdent> I'm glad to see it is still alive, just worried it was not. Proof of life is good.
20:24:03 <rocky_g> ++
20:24:20 <SpamapS> what say instead of adopting things in there into our process, we just add a permanent agenda item to check in on specs we care about?
20:24:36 <rocky_g> I think Ocata removed focus from there.  It should come back with Pike
20:24:36 <cdent>20:24:44 <SpamapS> If we see one falling by the wayside, we can adopt it into our process.
20:25:09 <SpamapS> #info openstack-specs needs love, adding an agenda item to check in on specs we care about or think need re-socializing.
20:25:25 <SpamapS> rocky_g: that's a good point. No time to work on anything except bug fix and ship.
20:25:47 <SpamapS> heh, we should do a 9 month cycle some time.
20:26:15 <rocky_g> man, wouldn't that be nice.  But, I don't think most devs have that long an attention span.
20:27:59 <SpamapS> ok, let's try it now
20:28:02 <SpamapS> #topic OpenStack Specs check-in
20:28:04 <SpamapS> #link https://review.openstack.org/#/q/status:open+project:openstack/openstack-specs
20:28:06 <SpamapS> #link http://specs.openstack.org/openstack/openstack-specs/
20:28:27 <SpamapS> So what I want to do here is to just check in and see if there are specs which we should look at raising awareness of
20:28:41 <SpamapS> Not going to go through them all
20:28:48 <SpamapS> but more of a "speak now or forever hold your pieces"
20:29:05 <SpamapS> #link http://specs.openstack.org/openstack/openstack-specs/specs/chronicles-of-a-dlm.html
20:29:45 <SpamapS> harlowja: still here? is there anything we should do to try and kick-start this one?
20:29:53 <rocky_g> So, headsup.  Looks like Error Codes and log improvements getting hot again.  NTT, OSIC will likely spearhead the effort.  I'm going to do history and handoff at midcycle
20:30:17 <SpamapS> rocky_g: cool
20:30:33 <rocky_g> So, if we could get the spec in shape at PTG, we can hand them a jumpstart.
20:30:54 <SpamapS> rocky_g: is it still in review?
20:32:44 <rocky_g> I think it might be abandoned at the moment.  I can resurrect it.  I'd like to do a pass on cleanup, but, we could bring it back as is and then post a new version
20:33:37 <SpamapS> rocky_g: the most important thing is that we socialize it as an opportunity for improvement looking for resources.
20:34:02 <SpamapS> The whole idea of this group is to raise awareness and gather like-minded efforts to get them done.
20:34:28 <SpamapS> so it's good that NTT and OSIC want to work on it. It's even better if somebody else coming to the PTG finds out about it before PTG, and joins in.
20:34:29 * cdent puts a daisy in someone's gun
20:34:35 <rocky_g> Yup.  And NTT and OSIC have bodies to implement.  Also, LCOO wants to put bodies against it.  We can clean up the log messages if we can get the spec to an implementable (read dev approved) state
20:34:57 <SpamapS> cdent: no we're doing carnations, we're not the PFJ! ;)
20:35:15 * cdent laughs
20:35:20 <rocky_g> I let the NTT and OSIC (and ATT) know about PTG and midcycle.
20:35:39 <SpamapS> rocky_g: can I give you the action to resurrect it and send to openstack-dev?
20:36:09 <harlowja_> SpamapS sorry, had another meeting
20:36:15 <SpamapS> #action rocky_g Resurrect Error Codes and Logging Improvements spec and socialize appropriately before PTG
20:36:23 <SpamapS> harlowja_: np
20:36:26 <rocky_g> Uh, I gotta get my gerrit working again.
20:36:38 <rocky_g> I can do that.  Yeah.  Sure.  OK.
20:36:48 <SpamapS> rocky_g: ok. I'm not letting you take any more though. ;)
20:37:17 <SpamapS> harlowja_: so, the DLM spec. Do you think there's anything we can do to help? Should we jump in and do an analysis of progress so far?
20:37:20 <rocky_g> Yeah.  If I can't resurrect, I'll get help.  My gerrit setup got messed up and Infra was stumped.
20:38:24 <SpamapS> harlowja_: going once?
20:38:36 <harlowja_> SpamapS sureeee
20:38:38 <harlowja_> lol
20:39:56 <SpamapS> doesn't sound like you're that convinced. :)
20:40:00 <SpamapS> and I have enough on my arch-wg plate already
20:40:56 <SpamapS> #topic Proposals for work
20:41:13 <SpamapS> I haven't transitioned nova-compute-api yet.. already carried the action
20:41:19 <SpamapS> also there's nothing in the review queue
20:41:21 <SpamapS> so.. moving on
20:41:28 <SpamapS> #topic Active workstreams
20:41:34 <SpamapS> * Base Services - ttx
20:41:48 <SpamapS> We discussed earlier. This is moving forward. It's our only active workstream right now.
20:42:05 <SpamapS> #topic PTG
20:42:12 <SpamapS> So! PTG is coming up
20:42:21 <SpamapS> We'll have a fair amount of time allocated to us
20:42:25 <SpamapS> and people are very interested.
20:42:52 <cdent> #link etherpad for ptg: https://etherpad.openstack.org/p/ptg-architecture-workgroup
20:42:52 <SpamapS> What I'd like to do there is basically ask the community to rally around our two active workstreams.
20:42:59 <cdent> (for reference)
20:43:29 <SpamapS> #link https://etherpad.openstack.org/p/ptg-architecture-workgroup
20:43:31 <SpamapS> nice
20:44:29 <cdent> earlier today in api-wg we expressed some concern about how to make sure that the right people were around for the right topics when they will likely want to move from room to room, topic to topic
20:44:49 <cdent> I know that the ethercalc is supposed to help with that but if so, it probably needs to be pre-loaded a bit, at least for monday.
20:45:08 <SpamapS> cdent: absolutely
20:45:19 <SpamapS> I'd like to have a firm structure well in advance.
20:45:22 <clarkb> yes ttx sent mail about it
20:45:27 <SpamapS> I thought actually Monday we don't have space
20:45:27 <clarkb> at least for the shared rooms with projectors
20:45:35 <SpamapS> Monday the SWG gets the room we'll have all day Tuesday
20:45:47 <clarkb> https://ethercalc.openstack.org/Pike-PTG-Discussion-Rooms
20:46:06 * cdent wonders what kind of notification settings clarkb has
20:46:12 <cdent> you pop up
20:46:18 <clarkb> cdent: lurk all the channels settings
20:46:24 <SpamapS> What I really want to do is use the time to get facts about things we already know we want to talk about, and to get new proposals into the pipeline.
20:46:28 <clarkb> (I actually try to specifically lurk this meeting)
20:47:30 <SpamapS> cdent: does that fit in with what API-WG wants to use the time for too?
20:47:55 <cdent> mostly the former
20:48:21 <cdent> but it's expected that people will have different views on the facts
20:48:34 <cdent> thus the desire for doing in person
20:49:18 <SpamapS> so our structure should probably look something like   intro,  review active workstreams and ask for proposals, nova-compute-api fact finding, [API-WG topic], [ other topic ], [head-down paired up quiet working time], [ wrap up ]
20:50:28 <cdent> are these rooms in addition to whatever room is available on monday and tuesday or the actual and only rooms available monday and tuesday?
20:50:38 <SpamapS> cdent: exactly, for fact finding, what I'd like to see is a sort of hearing->subject format.. so have somebody stand up, say they're here to disseminate [X] and then the group can pepper them with questions and rebuttals.
20:50:51 <SpamapS> cdent: Arch-WG only has space dedicated to it for Tuesday.
20:51:13 <SpamapS> Which is really fun for me because I also need to do infra stuff :-P
20:51:21 <cdent> but that space is elsewhere from these ethercalc rooms?
20:51:53 <SpamapS> cdent: the ethercalc is for rooms w/ projectors and is more limited, IIRC
20:51:57 <rocky_g> ttx is the source of all truth on this
20:52:15 <clarkb> SpamapS: yes its just the rooms with projectors
20:52:28 <clarkb> SpamapS: basically those rooms are a shared resource for all the people meeting in addition to the space assigned
20:53:00 <SpamapS> right, so can I just block out arch-wg for all day tuesday in Macon ? ;)
20:53:03 <cdent> So that gets back to my original point then: On Tuesday, in the room that is assigned to arch-wg it may be useful to be able to prepare a skeleton of a schedule for potential attendees
20:53:47 <SpamapS> I'm so confused
20:54:22 <SpamapS> #action SpamapS talk to PTG organizers and confirm what space is dedicated, what is shared, and create a general schedule based on that.
20:54:22 <cdent> if you're confused than so am I, as I was building off what you were saying :)
20:54:28 <cdent>20:54:31 <cdent> good plan
20:54:37 <SpamapS> cdent: yes, I'm confused because I'm doubting what I believed
20:54:42 <SpamapS> so I'll just get the info
20:54:55 <SpamapS> and I'll send out a plan
20:55:09 <cdent> \o/
20:55:54 <SpamapS> One thing is for sure though, if you want to talk about something at the PTG, please start talking about it _now_ on openstack-dev with the [architecture] tag, so people can come with real facts.
20:56:16 <cdent> ++
20:56:23 <SpamapS> We need to spend time explaining complicated things to eachother, not reading specs/code/wiki pages.
20:56:32 <SpamapS> #topic Open Discussion
20:56:34 <SpamapS> anything else?
20:56:46 <cdent> Before we run out of time here I want to draw attention of the fine brains in this group to api-wg review: https://review.openstack.org/#/c/421846/
20:57:02 <SpamapS> #link https://review.openstack.org/#/c/421846/
20:57:03 <cdent> that's the rewrite of the guidelines for what should cause a "version" in an api
20:57:24 <cdent> it has architectural impacts because it is essentially declaring that you _must_ version
20:57:29 <cdent> (the API)
20:57:53 <rocky_g> just a quickie.  I also have solid responsibilities to be in the Interop meetings.  All the horizontal stuff in two days is bad.
20:57:53 <SpamapS> Oh very +1 :)
20:58:07 <cdent> the version that I've just put up is a distllation of a lot of conversations that I'm not particularly happy with but seems to capture the consensus
20:58:59 <SpamapS> rocky_g: yeah, I think there tend to be deep people, and wide people. Very few both. So us wide people will be screwed M-Tu, then bored Wed-Fri
20:59:07 <cdent> rocky_g: yeah, lots of people been saying so
20:59:23 <cdent> feh, I'm going to be soaked through the entire week
20:59:33 <cdent> buried every single day :)
20:59:41 <SpamapS> BUT
21:00:00 <SpamapS> one good thing, we get full access to project team people for two days
21:00:24 <SpamapS> cdent: thanks for sharing, I'll give it a close look
21:00:33 <SpamapS> we're out of time! :) Thanks everyone, see you in Atlanta!
21:00:34 <cdent> SpamapS: awesome. thank _you_.
21:00:40 <rocky_g> Yeah.  But us wide people can huddle on w-f
21:00:46 <SpamapS> Oh also we'll cancel the next IRC meeting since it's during PTG
21:00:50 <cdent> bring me coffees
21:00:52 <SpamapS> #info we'll cancel the next IRC meeting since it's during PTG
21:00:54 <SpamapS> #endmeeting