20:01:06 <SpamapS> #startmeeting arch_wg
20:01:08 <SpamapS> #chair SpamapS
20:01:08 <openstack> Meeting started Thu Mar  9 20:01:06 2017 UTC and is due to finish in 60 minutes.  The chair is SpamapS. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:10 <SpamapS> #link https://wiki.openstack.org/wiki/Meetings/Arch-WG#Agenda
20:01:11 <cdent> o/
20:01:13 <openstack> The meeting name has been set to 'arch_wg'
20:01:14 <openstack> Current chairs: SpamapS
20:01:15 <SpamapS> o/
20:01:40 <rockyg> o/
20:01:45 <SpamapS> Architecture WG courtesy ping for nikhil, harlowja, dstanek, kragniz, auggy, rockyg, rocky_g, kgiusti, thingee, denaitre, bastafidli
20:02:06 <SpamapS> #topic previous meeting action items
20:02:14 <SpamapS> #link http://eavesdrop.openstack.org/meetings/arch_wg/2017/
20:02:30 <harlowja> yo yo
20:03:12 <SpamapS> * rocky_g Send email regarding implementation bleed-through (stretch: submit as raw proposal)
20:03:17 <SpamapS> rockyg: I don't recall seeing that. Carry?
20:04:32 <rockyg> HAHAHAHAHA!   Yeah.  One of the bosses has been in town (still is) and another is out, so each of them wants me to do stuff for them that wasn't part of my planned schedul
20:05:10 <rockyg> Although, I came up with a comparison for Shade along those lines.
20:06:04 <rockyg> Shade, like abortion, trying to make it safe and seldom used.
20:06:16 <SpamapS> np, we'll carry it
20:06:41 <SpamapS> #action rocky_g Send email regarding implementation bleed-through (stretch: submit as raw proposal) (Carried since Feb 9 2017)
20:06:48 <SpamapS> * SpamapS to move nova-compute-api to active status and add structure (Carried from Jan 2017)
20:06:50 <rockyg> Thanks.
20:06:57 <SpamapS> I did that, but it hasn't been +A'd yet
20:07:19 <SpamapS> #link https://review.openstack.org/435555
20:07:43 <SpamapS> Going to just consider that done, and hopefully ttx and dtroyer get active again
20:07:53 <SpamapS> * rocky_g Resurrect Error Codes and Logging Improvements spec and socialize appropriately before PTG
20:08:00 <SpamapS> rockyg: did you get to any of that?
20:09:03 <SpamapS> * SpamapS talk to PTG organizers and confirm what space is dedicated, what is shared, and create a general schedule based on that.
20:09:10 <SpamapS> THat's done and PTG is done. :)
20:09:13 <rockyg> Yes and no.  Got some time at the Ops midcycle for working on that stuff.
20:09:26 <rockyg> PTG, most of the folks interested weren't there.
20:09:41 <SpamapS> rockyg: do you want to keep that here? I liked the idea. :)
20:09:59 <rockyg> Yeah.  I should have a report back from the ops midcycle
20:10:32 <SpamapS> #action rocky_g Resurrect Error Codes and Logging Improvements spec and socialize appropriately before PTG (Carried since Feb 9 2017)
20:10:38 <SpamapS> cool, going a little off-agenda here
20:10:42 <cdent> rockyg: are you familiar with the work that ediardo's been doing?
20:10:43 <SpamapS> #topic PTG Recap
20:11:16 <cdent> rockyg: http://172.99.106.155/exceptions/#/
20:11:32 <cdent> (I feel I may have mentioned this before, but it's been a long day)
20:12:15 <rockyg> Oh, yeah.  I think so.  This is also part of the fault genes wg work.  I'm coordinating wht the chair and some of the others in the group.
20:12:26 <SpamapS> #link http://lists.openstack.org/pipermail/openstack-dev/2017-February/113016.html
20:12:27 <rockyg> They're part of the spec reboot at the ops midcycle
20:12:54 <SpamapS> anyway, just wanted to give peopel a chance to comment on my recap email
20:13:04 <rockyg> And thanks for the reminder.  Need to add the link to the etherpad
20:13:48 <cdent> SpamapS: it recapped effectively as far as I can recall (not that I was there for all of it, having moved next door)
20:14:26 <SpamapS> cool
20:14:32 <SpamapS> #topic OpenStack Specs check-in
20:14:48 <SpamapS> We discussed the DLM spec at the PTG just to check-in.
20:14:54 <harlowja> ah, DLM
20:14:57 <harlowja> good ole dlm
20:14:58 <harlowja> lol
20:15:00 <SpamapS> harlowja: le DLM
20:15:03 <harlowja> def
20:15:17 <SpamapS> c'est la DLM
20:15:28 <rockyg> Tooz!  Zookeeper! DLM! Zaqar!
20:15:47 <SpamapS> What I think I learned is that we're in a deadlock with DLM
20:15:59 <harlowja> we need a DLM
20:16:00 <harlowja> lol
20:16:08 <SpamapS> Cinder has added support, and _can_ be deployed with a tooz backend that supports its guarantees
20:16:18 <SpamapS> But can also survive without one
20:16:28 <SpamapS> which makes people think its ok to keep pretending DLMs don't exist
20:16:42 <SpamapS> and to keep implementing liveness/membership/etc. in databases
20:16:54 <cdent> this is a cultural rather than technical problem?
20:16:55 <harlowja> ya, i'm unsure what to do here, half of this is education
20:16:59 <SpamapS> cdent: yep
20:17:09 <SpamapS> And it kind of wraps back to the nova-compute-api thing too
20:17:23 <SpamapS> and what you described earlier in #openstack-architecture as the "Nova Hegemony"
20:17:44 <SpamapS> Which is that if Nova doesn't need it.. everybody can't depend on it.
20:17:56 <cdent> so really just gotta convince nova it needs a dlm then we can move straight on to step 3
20:18:14 <harlowja> ^ feels messed up
20:18:23 <cdent> very
20:19:14 <rockyg> we might get Matt to listen to reason.
20:19:30 <rockyg> Maybe we can get them to add the dependency but never use it?
20:19:40 <harlowja> ^ also feels messed up
20:19:41 <harlowja> lol
20:19:46 <SpamapS> Well Nova's being reasonable
20:19:56 <SpamapS> It was architected around not having a DLM
20:20:14 <SpamapS> To introduce a DLM would likely be to change many things very fundamentally in Nova.
20:20:15 <harlowja> ya, retrofitting things after the fact == the suck
20:20:51 <SpamapS> For instance, the resource tracker and host manager would be a great use of Zookeeper/etcd.
20:21:13 <rockyg> So, don't rearchitect, just have the unused dependency.  The other projects have different needs/requirements than nova, but some are also core
20:21:17 <SpamapS> Replace the db with ZK/etcd and you no longer need to poll the DB or broadcast the hosts usages.
20:21:49 <harlowja> ya
20:21:58 <harlowja> a co-worker when i was at yahoo was trying to do that
20:22:19 <SpamapS> It's pretty fundamental
20:22:21 <harlowja> as u would expect, as there is only 1 impl thatworks (the DB) it requires unwinding of things to change it
20:22:31 <SpamapS> I will say, placement being extracted into its own microservice makes it more likely
20:22:33 <harlowja> and due to slowness of change, that's about a 3 cycle change to do anything
20:22:41 <SpamapS> anyway
20:22:43 <harlowja> and the guy left yahoo (along with others) before that, lol
20:22:46 <rockyg> If we can come up with good reasons for changing, such as performance, scale, etc, maybe we can get a refactor to that way started.
20:23:31 <SpamapS> rockyg: that's the thing.. at this point.. Nova's been so hardened as its current implementation.. I don't think we can say it's "better" with a ZK/etcd.
20:23:46 <SpamapS> We saw a mountain and we climbed it.
20:24:00 <rockyg> performance, scale, multicloud?  any of those work?
20:24:10 <harlowja> everyone else is climbing the mountain to, and its a slghtly different mountain, lol
20:24:11 <SpamapS> Nova's built all of those and made them work at scale without any DLMs
20:24:19 <SpamapS> and operators have learned to debug that
20:24:47 <SpamapS> so all we can do is help Cinder/Ironic/Glance/etc. avoid the same,
20:24:53 <rockyg> I'm wondering if nested quotas might work better with it...
20:25:06 <SpamapS> Nested quotas is indeed a challenge with the db
20:25:21 <SpamapS> so yeah, maybe at some point we can replace the DB w/ DLMs for placement
20:25:21 <rockyg> camel's nose and all that.
20:25:37 <SpamapS> Anyway, DLM is still moving slowly
20:25:48 <SpamapS> Cinder at the head of the pack, and others perhaps not knowing they can follow.
20:26:04 <SpamapS> We'll keep on checking on it I think.
20:26:21 <SpamapS> #link https://review.openstack.org/#/q/status:open+project:openstack/openstack-specs
20:26:23 <SpamapS> #link http://specs.openstack.org/openstack/openstack-specs/
20:26:34 <SpamapS> Other than that, are there other cross-project specs we want to track?
20:26:42 <harlowja> maybe we just need everyone to read https://azmuri.files.wordpress.com/2013/09/george-coulouris-distributed-systems-concepts-and-design-5th-edition.pdf (or equivalent, lol)
20:27:24 <rockyg> Sounds good to me.  How do we make *that* happen?-)
20:27:32 <harlowja> reading sessions at the summit?
20:27:33 <harlowja> lol
20:27:36 <harlowja> story time!
20:27:40 <harlowja> with little handpuppets
20:27:40 <SpamapS> nice
20:27:44 <SpamapS> oh and lets link DLM spec
20:27:53 <SpamapS> #link http://specs.openstack.org/openstack/openstack-specs/specs/chronicles-of-a-dlm.html
20:28:06 <SpamapS> anyway, I don't see any other current or pending cross project specs we can/should pick up
20:28:15 <rockyg> and also quotas:  #link http://docs-draft.openstack.org/03/441203/11/check/gate-keystone-specs-docs-ubuntu-xenial/c3fc2b3/doc/build/html/specs/keystone/backlog/hierarchical-quota-scenarios.html
20:28:29 <rockyg> quotas.
20:28:44 <SpamapS> That one feels too high level for us to get too involved in.
20:29:08 <SpamapS> I mean, we had the discussion in our room because there wasn't another place to do it..
20:29:11 <rockyg> Need someone with dev rep to push the DLM story.  Have you read it?  It has a number of schemas in it.
20:29:26 <rockyg> Well, really, models.
20:29:47 <rockyg> I'm worried that it won't get the right ones because of lack of devops in review.
20:30:00 <SpamapS> I think we set it straight at PTG
20:30:09 <SpamapS> (and then I almost blew it but sdague fixed me ;)
20:30:19 <SpamapS> So they seem to be on the right track
20:30:23 <SpamapS> (quotas I mean)
20:30:27 <SpamapS> anyway, I'd like to move on
20:30:34 <SpamapS> #topic Proposal Process Review
20:30:53 <SpamapS> We haven't really had any proposals so I think one bit of feedback I'd give ourselves is "tell people they can submit anything and we'll talk about it"
20:31:19 <SpamapS> basically "bring us your tired ideas, your teeming masses of complaints yearning to be hard"
20:31:32 <cdent> I'd guess a lot of people are waiting to see the process go to its next steps to see if the concept has legs.
20:32:06 <rockyg> ++ like the PWG hasn't made that transition yet, so, let's wait and see
20:32:09 <SpamapS> cdent: yeah, we have to establish more credibility.
20:32:42 <harlowja> i shall make 100 more libraries
20:32:46 <SpamapS> #topic Proposals for work
20:32:47 <harlowja> and get credibility
20:32:53 <SpamapS> We don't have proposals ATM
20:33:08 <SpamapS> unless somebody wants to 'git review' one they've typed up in anger right now..
20:33:33 <SpamapS> #topic Active workstreams
20:33:34 * cdent 's got nothin'
20:33:42 <SpamapS> * base-services (ttx)
20:33:59 <SpamapS> ttx doesn't seem to be here today, but I will say this one seems to be gaining traction
20:34:15 <SpamapS> we had a ton of great discussions with Barbican about how to get the ducks in a row so that deployers can embrace key management.
20:34:43 <SpamapS> and the DLM spec is basically just an extension of this idea.
20:34:59 <SpamapS> However, I don't see much formal work having happened recently.
20:35:27 <SpamapS> * nova-compute-api (SpamapS)
20:35:46 <SpamapS> I have written up an initial stream of consciousness for analysis, and I'm in the process of editting it for review
20:36:20 <SpamapS> My analysis so far suggests we just table this and look for other things to do, as the projects outside Nova dont' seem interested in changing their relationship with Nova
20:36:43 <SpamapS> and Nova _is_ trying to make nova-compute more of a driver-consuming thing, so the lines are less blurry now and will continue to clarify
20:37:12 <SpamapS> #action SpamapS submit analysis for nova-compute-api as patch to nova-compute-api work stream.
20:37:27 <SpamapS> #topic Open Discussion
20:37:33 <SpamapS> Anybody else have stuff to bring up?
20:38:24 <cdent> no, thanks
20:38:38 <rockyg> Pi day is coming up
20:38:49 <SpamapS> indeed
20:39:23 <rockyg> otherwise, nada
20:39:25 <SpamapS> #info next meeting will be in 2 weeks on March 23
20:39:37 <SpamapS> thanks everyone for continuing to work on things here!
20:39:42 <SpamapS> #endmeeting