20:02:27 <cdent> #startmeeting arch_wg
20:02:28 <openstack> Meeting started Thu Mar 23 20:02:27 2017 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:31 <openstack> The meeting name has been set to 'arch_wg'
20:02:47 <cdent> #link agenda: https://wiki.openstack.org/wiki/Meetings/Arch-WG#Agenda
20:02:58 <cdent> say hello to this week arch-wg
20:03:01 <cdent> harlowja you here?
20:03:09 <harlowja> oh hi
20:03:12 <cdent> #chair ttx SpamapS harlowja
20:03:13 <openstack> Current chairs: SpamapS cdent harlowja ttx
20:03:20 <harlowja> u aren't clint, lol
20:03:23 <ttx> harlowja: o/
20:03:26 <harlowja> what did u do with clint, lol
20:03:35 <cdent> nom nom nom
20:03:37 <cdent> #topic previous meeting action items
20:03:37 <cdent> #link http://eavesdrop.openstack.org/meetings/arch_wg/2017/
20:04:09 <cdent> no rocky_g here today two actions from here to care over
20:04:22 <cdent> #action rocky_g Send email regarding implementation bleed-through (stretch: submit as raw proposal) (Carried since Feb 9 2017)
20:04:30 <cdent> #action rocky_g Resurrect Error Codes and Logging Improvements spec and socialize appropriately before PTG (Carried since Feb 9 2017)
20:04:45 <cdent> SpamapS was supposed to "submit analysis for nova-compute-api as patch to nova-compute-api work stream."
20:05:05 <cdent> did that happen?
20:05:21 <ttx> haven't seen that yet
20:05:46 <cdent> doesn't look like it
20:05:54 <cdent> the 'move to active' review is still pending as well
20:05:57 <cdent> #link https://review.openstack.org/#/c/435555/
20:06:25 <cdent> #topic OpenStack Specs check-in
20:06:26 <cdent> #link https://review.openstack.org/#/q/status:open+project:openstack/openstack-specs
20:06:26 <cdent> #link http://specs.openstack.org/openstack/openstack-specs/
20:06:41 <cdent> I guess this is a prompt to check in on anything openstack-specs that might relevant?
20:06:57 <cdent> no recent activity in gerrit for openstack-specs
20:07:38 * cdent skips #topic Proposal Process Review
20:07:45 <cdent> #topic Proposals for work
20:07:45 <cdent> * nova-compute-api - SpamapS
20:08:03 <ttx> I had a question on https://review.openstack.org/#/c/449078/1
20:08:15 <harlowja> it'd also be interseting to figure out what https://github.com/openstack/mogan is :-P
20:08:46 <ttx> like should I consider the earlier thing implemented and push a new thing
20:08:56 <cdent> on the nova-compute-api I guess we are waiting additional input and plans
20:09:00 <ttx> or is it ok to modify it
20:09:05 <cdent> ttx I think modifying is fine at this stage
20:09:18 <cdent> we don't need to overburden the process yet?
20:09:23 <ttx> ok
20:09:34 <harlowja> more process!!!
20:09:35 <harlowja> lol
20:09:46 <cdent> #topic Active workstreams
20:09:47 <cdent> * Base Services - ttx
20:09:57 <cdent> started that discussion already, is there more to say?
20:09:58 <ttx> right so I touched on that just earlier
20:10:24 <cdent> we all seem to be in agreement that pitching it slightly different is a good idea?
20:10:40 <ttx> not much. I wanted to document the expand/contract thing so that we use it with postgres
20:11:06 <ttx> but then also mention the direct route we'll likely follow for the dlm
20:11:27 <ttx> should definitely order them the other way :)
20:11:56 <cdent> #action ttx to change expand/contract concept to default first to picking the best if possible
20:12:10 <cdent> anything other active workstreams?
20:12:15 <ttx> the next base service is likely to be the dlm now, so we'll probably have to work on that
20:12:23 <harlowja> can we also not call it DLM :)
20:12:28 <cdent> or perhaps a better question is: what active workstreams should we push
20:12:30 <cdent> harlowja++
20:12:31 <harlowja> jus a suggestion ;)
20:12:34 <harlowja> *just
20:12:35 <ttx> we can call it 'etcd'
20:12:45 <harlowja> lol
20:13:05 <cdent> "canonical hub for cluster coordination and state management"
20:13:07 <harlowja> ya, need a better name, something that doesn't describe one particular feature of these things
20:13:09 <cdent> is a bit of a mouthful
20:13:14 <harlowja> CHCCSM
20:13:17 <harlowja> lol
20:13:41 <ttx> scs -- shared context service
20:13:49 <cdent> fancy!
20:14:16 <cdent> does that mean we can start a shared context service as a service service?
20:14:29 <ttx> +service++
20:15:02 <ttx> ok that is all on base services
20:15:11 <clarkb> this might not be the best venue for it, but considering the current memory pressure in integration testing we likely want to keep an eye on that as we add a new service. But also putting more pressure on project teams to go on a diet like heat would be awesome
20:15:28 <cdent> indeed
20:15:51 <harlowja> so that might be another kind of thing to start a spec on
20:16:01 <harlowja> i don't really think people even have visiblity into there memory consumption
20:16:04 <ttx> memory consumption ?
20:16:11 <harlowja> ya i know
20:16:12 <harlowja> lol
20:16:14 <ttx> that's a good one
20:16:52 <cdent> so that would a workstream to encourage or do some analysis?
20:17:01 <harlowja> it may not be possible to fix, but at least some visibility might help
20:17:08 <clarkb> harlowja: eh I think its 100% fixabnle
20:17:15 <cdent> if this were for publishing guidance the guidance would be "don't be fat"
20:17:16 <clarkb> harlowja: heat had like a 60% reduction just with a few changes
20:17:34 <harlowja> did they just scale back active engines and ... ?
20:17:35 <ttx> yeah, the low hanging fruit can represent 80%
20:17:36 <cdent> clarkb: anything that sounds like it will be repeatable elsehwere?
20:17:38 <clarkb> and we've trimmed a fair bit out of the supporting cast of services too. Its just a matter of people looking at what is using it and trimming it down
20:17:59 * ttx types slowly, trying to learn a US keyboard
20:18:00 <cdent> repeatable in the "oh, duh, yeah" sense
20:18:10 <clarkb> cdent: harlowja my understanding of it was they changed the way they stored all their state in memory
20:18:19 <cdent> ah
20:18:30 <clarkb> previously it was naive and it showed
20:18:47 * cdent suspects there could be a bit of that in the nova-conductor and -scheduler
20:19:05 <harlowja> ya, i think they use the python stack for all there engine coroutine state, so it'd be understandable that such state could be large
20:19:15 <harlowja> *especially if there are a bunch of active engines
20:20:14 <cdent> I haven't got cycles do volunteer for this. does anyone?
20:20:48 <clarkb> I've been poking at it on the more infra side of things since that is what I am familiar with. Things like apache and wsgi have been tuned down and I have a change up to enable ksm
20:20:56 <ttx> same here, we could maybe put a 'help wanted' sign on the ml ?
20:20:58 <clarkb> but likely oyu want individuals in each project pushing from within each project
20:21:17 <harlowja> yup
20:21:19 <ttx> a queens goal would probably be too late
20:21:25 * cdent nods
20:21:41 <cdent> I was thinking more in terms of an agitator, coordinator, not someone to go fix everything
20:22:29 <clarkb> jordanP on the qa side ahs been doing things too. Might be interested?
20:22:36 <harlowja> i am good at agitating,lol
20:22:56 <cdent> #action harlowja to spin up some attention to memory usage in projects
20:23:05 <cdent> oh look, you won first prize!
20:23:10 <harlowja> :-P
20:23:32 <cdent> I can undo that if you feel that was a gross abuse of power.
20:23:45 <harlowja> nah, its fine
20:23:47 <cdent> or you can too
20:23:55 <cdent> woot
20:24:03 <ttx> cdent: you're a natural born leader
20:24:10 <cdent> I think we're already there but:
20:24:11 <cdent> #topic Open Discussion
20:24:52 * cdent adds ttx quote to CV
20:25:40 <ttx> if nothing else I'll go back to my regular evening
20:25:57 <cdent> I've got one: I personally think that unitl we make concrete active progress on the SCS the arch-wg is sort of walking slowly
20:25:59 <ttx> got that m key is killing me
20:26:14 <ttx> gott or god, not got
20:26:42 <cdent> or to put it another way: SCS will prove the pudding
20:26:50 <cdent> I'm not sure why I feel that way.
20:27:20 <harlowja> so another thing, i know there are architects out there that are not on here
20:27:24 <ttx> yes, base services was more like a framework to introduce scs
20:27:33 <harlowja> they have to exist (just like there are engineer managers that exist in the shadows somewhere)
20:27:34 <cdent> harlowja: quite
20:27:37 <harlowja> so how can we find them :-P
20:27:50 <harlowja> and get them into here
20:27:55 <cdent> by doing something intriguing and valuable?
20:28:12 <harlowja> sounds like alot to ask
20:28:13 <harlowja> lol
20:28:14 <cdent> api-wg got interesting when we started drawing attention to how wrong some uses of http were
20:28:27 <harlowja> we need a PR person
20:28:28 <harlowja> lol
20:28:34 <cdent> and providing concrete advice on how to change, not just documenting the status quo
20:29:14 <harlowja> ya, i mean i get that
20:29:27 <cdent> but...
20:29:57 <ttx> until we actually do something, we'll just be another random group of nice folks
20:30:13 <harlowja> is that the only way?
20:30:34 <harlowja> i mean alot of us have done things, so is there any way to use that to jumpstart things?
20:30:47 <harlowja> like put ttx  in newsweek or something
20:30:51 <harlowja> or cdent
20:30:52 <harlowja> lol
20:31:01 <harlowja> CNN may take anyone at this point?
20:31:01 <harlowja> lol
20:31:33 * cdent wonders how harlowja feels about being called "nice"
20:31:45 <harlowja> i'm always nice
20:31:59 <harlowja> :-P
20:32:23 <ttx> I need to run
20:32:35 <cdent> yeah, shall we call it, before I start making more stupid puns and jokes?
20:32:54 <ttx> call
20:33:05 <cdent> thanks everyone, we are at least laying in some common language and mind so we can make a bright future ... soon
20:33:13 <cdent> #endmeeting