18:01:52 <adam_g> #startmeeting astara
18:01:53 <openstack> Meeting started Mon Nov 23 18:01:52 2015 UTC and is due to finish in 60 minutes.  The chair is adam_g. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:56 <openstack> The meeting name has been set to 'astara'
18:01:57 <adam_g> i/
18:02:01 <adam_g> o/ rather
18:03:31 <adam_g> markmcclain is not going to be here this morning. davidlenwell elo ryanpetrello anyone else around?
18:03:54 <davidlenwell> ug .. my cal still shows this meeting for an hour from now
18:05:12 <adam_g> http://eavesdrop.openstack.org/meetings/astara/2015/astara.2015-11-16-18.01.html
18:05:36 <adam_g> #topic Outstanding project rename tasks
18:06:12 <adam_g> i think we're still waiting on markmcclain's patches to update the astara repo's code and modules for the rename
18:06:44 <adam_g> i did the code renaming for astara-horizon and the DIB portion of the astara-appliance repo
18:06:50 <adam_g> those are up for review now
18:07:56 <adam_g> davidlenwell, saw some of your doc patches have landed. there are still more coming i assume?
18:08:00 <elo> i'm around
18:08:16 <adam_g> oh, and weve officially moved over to #openstack-astara
18:08:42 <davidlenwell> adam_g: I was waiting on the rename patches before I continued.. there are still a lot of unknowns
18:08:58 <adam_g> davidlenwell, what do you mean?
18:09:54 <davidlenwell> the remaining files still reference paths to things and process names that are pre-rename.. still say akanda rug..
18:10:24 <davidlenwell> since I don't know exactly how mark is moving things around it seemed silly to try to update that file
18:10:32 <adam_g> davidlenwell, the processes / console script have all already been rename to astara-* equivs
18:10:53 <adam_g> also im specifically wondering about http://akanda.readthedocs.org/en/latest/developer_quickstart.html
18:11:07 <adam_g> the devstack instructions should be fine to update now
18:11:42 <davidlenwell> I am doing that in paralel to the new functionality in devstack..
18:11:43 <adam_g> sincec thats an entry point for potential new users/devs, we need that updated to reflect new locations/variables/repos
18:12:01 <davidlenwell> I can do the doc first though
18:12:11 <adam_g> davidlenwell, any chacne you can push it up sooner? it should be a relatively simple one
18:12:13 <adam_g> cool
18:12:54 <davidlenwell> my morning is back to back meetings .. but later this after noon I should have time to get that in
18:13:01 <adam_g> #action davidlenwell to continue /w doc patches, specifically getting the devstack/quickstart guide updated
18:13:16 <adam_g> #action markmcclain to continue on /w astara module renames
18:13:34 <adam_g> #topic Mitaka Development
18:14:24 <adam_g> davidlenwell, how is the devstack work coming along to add ability to standup new features?
18:14:50 <adam_g> ive enriched the functional test suite in our tree with some patches that are up, and would be able to piggyback on your work to add similar functional tests for LB
18:14:55 <davidlenwell> I'm just about ready with the lbaas functionality.. will try to push that today ..
18:15:12 <davidlenwell> the debug iterations are slow
18:15:33 <adam_g> im hoping we can get our test suite beefed up a bit now before we start really rolling on new mitaka features
18:15:44 <davidlenwell> have been burning down and starting with a new vm each test.. running into a bug then fixing it then running it again..
18:16:45 <adam_g> davidlenwell, ive found our stuff generally does a pretty good job of cleaning up with unstack.sh, making it easier to just unstack.sh + fix bug + stack.sh rather than wiping the VM
18:16:59 <davidlenwell> okay
18:17:00 <adam_g> the subsequent stack's are much quicker with warm caches and already-installed packages
18:17:10 <davidlenwell> yes they are
18:17:20 <adam_g> ryanpetrello, around?
18:17:44 <davidlenwell> I'll get it repeating clean that way then test it again with a fresh vm
18:18:53 <davidlenwell> do we want the ha rug stuff in devstack too?
18:18:58 <adam_g> davidlenwell, it already is
18:19:03 <adam_g> well, its enabled by default
18:19:11 <adam_g> so we exercise it with a single node/process
18:19:11 <davidlenwell> ahh
18:19:26 <adam_g> if we want to expand that we can either look to add an option to spawn multiple astara processes on one node
18:19:33 <adam_g> or use the multinode devstack stuff to do it across 2 nodes
18:19:48 <adam_g> its not the easiest thing to actual test tho, at least not ATM
18:19:57 <davidlenwell> Im just trying to understand if this task includes anything other than lbaas
18:20:07 <adam_g> davidlenwell, Pez
18:20:29 <davidlenwell> ahh.. okay.. I'm gonna need more memory someplace to test that I think
18:21:04 <adam_g> davidlenwell, it should work with pez's pool set to 1. then you need only a node that can host 2 booted VMs at once
18:21:24 <adam_g> also the instance's flavor specs are configurable, so you should be able to shrink it down to its minimum if its not already
18:21:43 <davidlenwell> alright.. I'll ping you when I get to that
18:21:46 <adam_g> k
18:22:22 <adam_g> aside from that not much else to report. like i said, im hoping to get our testing a bit more before i start pushing forward with some of the bigger features for this cycle. will likely continue with that till after the tgiving holiday
18:22:43 <adam_g> #topic open discussion
18:22:43 <davidlenwell> adam_g:  are you in two days this week or three ?
18:23:00 <adam_g> davidlenwell, planning on 3, or maybe 2.5
18:23:19 <davidlenwell> I'm only working m-tues
18:23:39 <elo> adam_g: do you know how to add this project to the activity.openstack.org dashboard?
18:24:22 <adam_g> elo, hmm nebver seen that before
18:24:46 <adam_g> elo, someone in #openstack-infra should be able to tell you
18:24:52 <adam_g> im sure its managed via a git repo somewhere
18:25:24 <elo> yeah.. it the metrics for development.
18:25:35 <adam_g> so one thing i'd like some feedback on is https://review.openstack.org/#/c/246005/ which configures the astara API endpoint in keystone
18:26:04 <adam_g> theres a corresonpding horizon patch at https://review.openstack.org/246039 to do the lookup via keystone instead of config file
18:26:48 <adam_g> also, i created a astara gerrit dashboard that ive been using, others might find it handy: https://goo.gl/onzTmP
18:26:49 <elo> ok. will review and give useful feedback
18:27:09 <adam_g> anyone got anything else?
18:28:57 <elo> all good
18:29:12 <adam_g> cool. tty all later
18:29:13 <adam_g> #endmeeting