19:02:16 <maishsk> #startmeeting auc
19:02:16 <openstack> Meeting started Thu Jul 14 19:02:16 2016 UTC and is due to finish in 60 minutes. The chair is maishsk. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:20 <openstack> The meeting name has been set to 'auc'
19:02:44 <shamail> Hi everyone
19:02:52 <dc_mattj> hey
19:02:53 <maishsk> #chair shamail
19:02:53 <MeganR> Hi
19:02:54 <openstack> Current chairs: maishsk shamail
19:03:05 <maishsk> hi shamail
19:03:16 <shamail> maishsk: do you want to lead this meeting?
19:03:23 <dc_mattj> apologies I missed the last meeting
19:03:45 <shamail> np, it was just MeganR and I… yet we still made progress :)
19:03:59 <MeganR> I asked a bunch of questions!! :)
19:04:30 <maishsk> np shamail
19:04:42 <maishsk> So agenda for today
19:04:45 <shamail> Awesome, all yours.
19:05:09 <maishsk> #link#link https://wiki.openstack.org/wiki/AUCRecognition#Meeting_Information
19:05:27 <maishsk> First up
19:05:31 <maishsk> #topic Update on centralized data source proposal by Tom Fifield (MeganR)
19:06:34 <maishsk> MeganR: would you like to give us an update?
19:06:40 <MeganR> They are working on centralizing the data obtained for ease of pulling the AUC information. The information they are pulling looks good.
19:06:50 <MeganR> - slow typer -
19:07:31 <MeganR> We also talked about how to track WG participation for teams not currently using IRC, and looks like the decision is to go really high tech: Google Docs
19:07:45 <maishsk> :)
19:07:50 <maishsk> super hi-tech
19:08:17 <MeganR> there are only a few teams that don't use IRC, so the Google Doc will track active attendance/participation, but will not allow us to count lines in IRC
19:08:38 <shamail> MeganR: How about a google forms? (I know, I am now going bleeding edge…)
19:08:53 <MeganR> lol - whoa, I need a min to take that in :)
19:09:04 <shamail> We could have a link to a form where WG chairs could put in the WG name and list all members in one place.
19:09:13 <shamail> This would automatically give us categorized data :)
19:09:13 <MeganR> I don't know Google Forms, but can take a look at it this next week - like that idea
19:09:26 <MeganR> maybe we can use it for the indiv. submissions as well.
19:09:34 <shamail> All good, happy to help if you want
19:09:40 <shamail> MeganR: +1
19:09:48 <MeganR> you might regret that - thank you!
19:09:54 <shamail> lol
19:10:42 <maishsk> Megan you mentioned that the info they are pulling looks good.
19:10:45 <maishsk> In what way?
19:11:35 <MeganR> Tom went through what we are focusing on for "AUC Criteria" and how they will put that info into the person's profile
19:12:02 <MeganR> still some manual processes, but helps in automating some of the data - and having it for "historical" purposes as well
19:12:08 <maishsk> Good to hear
19:12:21 <dc_mattj> will that data be publicly available ?
19:12:41 <MeganR> I don't know
19:12:59 <shamail> Yes, I believe so
19:13:05 <MeganR> cool
19:13:21 <maishsk> Anything on this topic or shall we move on ?
19:13:26 <maishsk> else *
19:13:34 <MeganR> I'm all done - unless there are questions
19:13:47 <shamail> The plan (please correct me if I am wrong MeganR) is to capture metrics for IRC meetings/lines, commits to UC repos, user group organization, ops-summit mods, etc. and make them all accessible via API from the person’s profile
19:13:47 <maishsk> #topic Milestone-5 update
19:14:19 <MeganR> shamail: you are right
19:14:22 * maishsk jumped the gun. …. . ..
19:14:33 <shamail> Not at all, we were done.
19:14:49 <maishsk> ok so I started to draft a proposal for the review board
19:14:59 <maishsk> #link https://etherpad.openstack.org/p/uc-recog-m5-output
19:15:13 * maishsk waits for everyone to go and have a look at the link
19:16:21 <maishsk> The idea was to create a group of members, and uneven number. Majority of the representation will be from the UC - but also representation from the TC and the Openstack Foundation employees
19:16:48 <maishsk> That way we have the complete openstack community involvement
19:17:08 * shamail flips over to etherpad
19:17:16 <maishsk> There are still a few things that we need to iron out and that I put under the ‘Things to consider’
19:17:43 <dc_mattj> maishsk, looks good
19:17:54 <shamail> maishsk: I would suggest also adding at least 1-2 people from the user organizers community (e.g. ambassadors), WG chairs, AskOpenStack Mods, Ops-Meetup organizers
19:18:07 <shamail> this would ensure that we have a SME from the represented activity on the panel too
19:18:15 <dc_mattj> I suspect there won't be many of these, but good to have it defined anyway
19:18:54 <maishsk> shamail: works for me - I just don’t want to have too big of a body that needs to review - as long as we keep it under 10
19:19:37 <shamail> maishsk: +1
19:21:04 <maishsk> Please feel free to add something to etherpas with suggestions and improvements.
19:21:44 <maishsk> If you don’t all mind - we should leave this open for comments an discussion on the etherpad until next meeting - and then summarize?
19:22:02 <maishsk> Are there any points on there that you feel we need to disucss today?
19:22:23 <shamail> The nomination date
19:22:33 <shamail> I was going to bring that up during the next topic anyway
19:22:43 <shamail> but it has implications for this topic too
19:22:55 <maishsk> the floor is yours shamail
19:23:18 <shamail> When do we want to do “cut-off” for AUC (e.g. when will we run scripts and say this is the final list)? The nomination period probably needs to start after that.
19:23:34 <shamail> This way the only people that self-nominate are the ones who didnt get AUC
19:23:48 <shamail> ATC passes are already going out for Barcelona
19:23:53 <shamail> and I believe they do it in waves
19:23:54 <maishsk> So the obvious question for me is are we looking to follow the same cycle the ATC?
19:24:10 <shamail> I think that makes sense to me maishsk
19:24:12 <maishsk> every six months - based on a OpenStack release?
19:24:19 <shamail> That is for sure.
19:24:29 <shamail> My question is about when in that six month period to we build our list
19:24:41 <shamail> we cant wait until the end because then people won’t get AUC in time for the summit
19:24:48 <maishsk> Does anyone know how the list is built for the ATC? What that process is?
19:24:59 <shamail> They have already started I believe
19:25:09 <shamail> but they do 3-4 waves
19:25:27 <shamail> so I think they run their scripts 3-4 times during the release (maybe each milestone?)
19:25:30 <MeganR> do you know what waves are used for ATC - I believe cores and such receive status first - can we assign equivalents to those waves
19:25:55 <shamail> #link http://releases.openstack.org/newton/schedule.html
19:26:20 <shamail> My recommendation would be to align with each release’s Feature Freeze date
19:26:27 <maishsk> What I dont understand - is are we talking about the initial AUC - or the cycles thereafter (if there is actually any difference - I don’t know)
19:26:34 <shamail> We don’t have as many AUCs as ATCs so even one run (near the end) should work
19:26:48 <shamail> both, I don’t think there will be a difference maishsk
19:27:03 <shamail> we just need to find a consistent point in time for each release to compile our list
19:27:39 <maishsk> So I would suggest is to use the tried and tested method that Openstack already uses for ATC - keep to the same schedule
19:27:46 <MeganR> I think it would make the most sense to align to the ATC schedule for future cycles
19:27:48 <shamail> If we align with FF then that would mean we identify AUCs (via manual and automated ways) by 08/02/16 (for this release)
19:28:00 <maishsk> That is tight
19:28:07 <MeganR> wow - that is tight
19:28:11 <maishsk> ;)
19:28:12 <shamail> Yep
19:28:20 <MeganR> I think we could be there by Sept.
19:28:30 <shamail> I have a pre-lim list going (which I will give details on in the next topic)
19:28:57 <shamail> Okay so how about we align with RC-1 date?
19:29:03 <shamail> This would be 9/12 for this release
19:29:17 <shamail> I will take an action to reach out to UC and Tom to find out if that is enough room for them as well
19:29:21 <maishsk> I think that is reasonable
19:29:32 <MeganR> +1 on the date
19:29:38 <shamail> We are balancing our ability to collect the data and the UC’s ability to have the list with enough advance notice to do something with it
19:30:03 <maishsk> #action shamail to reach to tom F to see if the proposed date will work for them
19:30:08 <shamail> #action shamail to contact UC with tentative date of 9/12 for AUC list
19:30:14 <shamail> oops, sorry maishsk
19:30:16 <maishsk> ;)
19:30:29 <maishsk> ok then - next topic
19:30:42 <maishsk> #topic Update on preliminary count
19:31:25 <shamail> Thanks maishsk
19:31:48 <shamail> Sorry, I am now in two meetings at once
19:31:53 <shamail> will be a little slower than usual :)
19:32:28 <shamail> So I have spent time this week updating the uc-recognition scripts to reflect the AUC criteria
19:33:11 <shamail> https://review.openstack.org/#/c/341958/
19:33:14 <shamail> #link https://review.openstack.org/#/c/341958/
19:33:22 <shamail> #link https://review.openstack.org/#/c/341955/
19:34:27 <shamail> Here is what I have so far for counts (am still updating scrpts to ensure we dont miss any WGs, repos, etc.)
19:35:00 <shamail> I set the start date for the scripts to 04/08/2016 (the day after Mitaka release)
19:35:17 <shamail> Active WG member count: 41
19:35:25 <shamail> Ask OpenStack Moderators: 20
19:35:35 <shamail> Commiters to user story repos: 16
19:35:55 <shamail> I have not collected data for ops meetup moderators, superuser contributors, and user group organizers since those will be manual
19:36:04 <shamail> I am going to send emails this week to get that data
19:36:11 <shamail> The running total so far is 77
19:36:29 <shamail> which is very low so I am thinking my scripts are off (even though I am double/triple checking)
19:36:30 <MeganR> wow - thought it would be higher
19:36:37 <MeganR> :)
19:37:09 <shamail> Will keep the team posted but thats what I have for now
19:37:13 <shamail> Any questions?
19:37:45 <maishsk> It is a start - and I think that number will grow - especially after the first round.
19:38:23 <maishsk> I would expect that number to cross over the 100 easily with all the manual peices we collect
19:38:44 <MeganR> a really good start, it's good to have some numbers to correlate with what we have identified
19:38:56 <maishsk> It will be interesting to see what comes back after the email rounds.
19:38:59 <shamail> I am really worried that the numbers are so low
19:39:08 <shamail> since Tom had mentioned osmething like 400+?
19:39:19 <shamail> I am thinking the date adjustments I did made the differene
19:39:22 <shamail> difference*
19:39:28 <maishsk> shamail - what about the ops repos?
19:39:35 <shamail> accounted for
19:39:41 <shamail> lots of commits
19:39:44 <shamail> but from like 2-3 people
19:39:51 <maishsk> interesting
19:39:56 <shamail> same thing with user stories repo even
19:41:54 <shamail> I have to drop for now
19:41:57 <shamail> sorry
19:42:04 <maishsk> Thanks shamail
19:42:06 <MeganR> bye
19:42:09 <shamail> Take care!
19:42:29 <maishsk> Well there was nothing else on the agenda for today - unless someone wants to raise a topic?
19:43:02 <MeganR> I'm good
19:45:06 <maishsk> OK then so lets call it for today - and catch you all next week.
19:45:06 <maishsk> Thanks everyone
19:45:06 <maishsk> #endmeeting