19:01:26 <shamail> #startmeeting auc
19:01:27 <openstack> Meeting started Thu Aug  4 19:01:26 2016 UTC and is due to finish in 60 minutes.  The chair is shamail. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:30 <openstack> The meeting name has been set to 'auc'
19:01:37 <shamail> Hi everyone.  Who is here for the AUC recognition meeting?
19:02:00 <MeganR> o/
19:02:12 <shamail> Hi MeganR
19:02:35 <MeganR> Hi
19:02:35 <shamail> How was your break?
19:03:14 <MeganR> it was great, but catching up from being out isn't fun
19:03:20 <shamail> +1 :)
19:03:31 <MeganR> that will teach me to take a week off without internet  :)
19:03:50 <shamail> Here is agenda I had hoped we could cover today but Summer vacations seems to be keeping our attendance low :)
19:03:53 <shamail> #link https://wiki.openstack.org/wiki/AUCRecognition#Meeting_Information
19:04:20 <shamail> Let’s tackle what we can and then close it out, sound good?
19:04:21 <MeganR> I would be fine for a shorter meeting - then I can work on my "tasks" for here  :)
19:04:29 <MeganR> perfect
19:04:47 <shamail> #topic Update on data collection for non-IRC WGs
19:05:03 <shamail> Have you had a chance to reach out to the WGs that do not use IRC yet?
19:05:11 <shamail> If not, do you want help?
19:05:46 <MeganR> So, I started today going through some meeting notes on the WG that are not using IRC, going back about 5-6 weeks, and taking an average of the attendees.  I figure that will help with a number.
19:06:26 <MeganR> Then I need to send out two emails - one for the attendee count, asking the chairs to verify and the second for the Google form review - I didn't have a chance to send that out earlier.
19:06:31 <shamail> Could you reach out to the WG chairs and just ask them to provide you with a list of active members?
19:06:46 <MeganR> Sure
19:06:56 <shamail> I feel it is unfair for you to be gathering that information for all of them on your own
19:07:03 <shamail> The chairs should be able to knock it out fairly quick
19:07:35 <shamail> Is it just Enterprise and Faulty Genes?
19:07:46 <MeganR> np - I'll do that this afternoon - and ISV  :)
19:07:54 <shamail> Awesome, thanks
19:07:58 <shamail> Oh yeah, ISV
19:07:59 <shamail> lol
19:08:13 <MeganR> I was thinking, if someone has attended within the past month we count them as active
19:08:18 <MeganR> :)
19:08:24 <shamail> Thanks MeganR!
19:08:43 <shamail> We could also have the other scenario though (someone has been active but has gone on extended break for summer)
19:09:07 <shamail> Okay to move on?
19:09:20 <MeganR> very true - I was thinking more along the lines of something easy for them to pull together, and will give us a rough estimate.
19:09:23 <MeganR> yup - good to go
19:09:38 <shamail> Fair :)
19:09:42 <shamail> #topic Update on preliminary count
19:10:20 <shamail> Here is what I have so far… still missing some but in good shape I think:
19:10:26 <shamail> Running totals (as of 07/14/2016):
19:10:30 <shamail> Committers to UC governed repositories (OSOps, User Stories, Ops-Tags): 19
19:10:34 <shamail> Active WG members (for WGs that use IRC): 28
19:10:40 <shamail> Ask OpenStack moderators: 20
19:10:45 <shamail> Track chairs for upcoming summit: 98
19:10:49 <shamail> Organizers of Official OpenStack User Groups: 46
19:10:53 <shamail> Contributors to Superuser: 28
19:10:59 <shamail> Overall AUC Count (duplicates have not been removed from data): 239
19:11:03 <shamail> Data that still needs to be collected (as of 08/02/2016):
19:11:07 <shamail> Active WG members (for WGs not on IRC): TBD
19:11:10 <shamail> Ops Meetup Moderators: TBD
19:11:25 <shamail> The count is lower than I anticipated so far
19:11:40 <shamail> I don’t think the remaining two categories will increase it significantly
19:11:48 <MeganR> I agree, especially thing that there are some duplicates - interesting
19:12:02 <shamail> Yeah
19:12:40 <shamail> Once we get the final two categories we can share the findings with UC
19:12:58 <MeganR> sounds good
19:13:13 <shamail> #topic Discussion on AUC status cycle
19:13:29 <shamail> So Tom and I have been having a conversation in gerrit on a patch I submitted
19:13:36 <shamail> #link https://review.openstack.org/#/c/341955/
19:14:07 <shamail> Tom was proposing that we run the count more often (rather than once per cycle) and also questioning how long AUC status is valid
19:14:20 <shamail> He raised some great points and gave some good reference links in his last comment
19:14:47 <shamail> Key questions/considerations:
19:15:02 <shamail> Correct me if I'm wrong here, but it seems much of the thinking is around getting an AUC designation on summit badges? If so, I'd advise trying to think more broadly, but to complete this one first: did you know that ATC discount codes are sent out at multiple points throughout the cycle? Part of the reasoning behind that is to encourage those qualifying to register early so we have the best possible idea of numbers as early as we can.
19:15:11 <shamail> How about User Committee Voting. That might happen in January, for instance. Assuming AUC members are qualified to vote, when is their eligibility determined? From the last list made in milestone 3 of whatever release cycle was previously done?
19:15:18 <shamail> How does that kind of script work for AUC candidates standing for the UC election?
19:15:23 <maishsk> Sorry I am late
19:15:27 <shamail> More outlandish: what about if the foundation somehow falls upon a ton of stickers and some stamps/envelopes and want to mail AUC recipients some "tomorrow"
19:15:31 <shamail> Hi maishsk, np
19:15:34 <shamail> #chair maishsk
19:15:35 <openstack> Current chairs: maishsk shamail
19:15:48 <MeganR> Hi maishsk
19:15:56 <maishsk> Hi All
19:16:03 <shamail> maishsk: we are discussing comments by Tom on https://review.openstack.org/#/c/341955/
19:17:10 <MeganR> He brings up great points, and now I think I understand what he was originally asking
19:17:14 <shamail> I will investigate whether we can modify https://github.com/openstack/election/blob/master/tools/check-candidacy.py for UC election eligbility
19:17:45 <shamail> #action Research modifying ATC election eligibility script for AUC (shamail)
19:17:55 <shamail> Same here MeganR
19:17:58 <MeganR> and if we automate most of this, we should be able to run it whenever necessary
19:18:03 <shamail> Yeah
19:18:07 <shamail> welcome fifieldt
19:18:20 <shamail> we were just talking about our conversation on https://review.openstack.org/#/c/341955/
19:18:59 <shamail> So how can we address these items?
19:19:53 <shamail> Do we think the AUC ‘term’ should be from milestone-3 to milestone-3… This would allow someone to get badge status at the summit following their contributions but also stay AUC for a good portion of the next cycle to be eligible for elections and voting
19:20:16 * shamail putting together an example using real world dates
19:20:20 <maishsk> So I am trying to understand the issue here - is it one of timing? Length of validity of the AUC? or something else?
19:20:33 <shamail> It is two fold:
19:20:44 <shamail> 1) The timing of when the data is gathered and how often
19:21:27 <shamail> 2) How long AUC is valid once obtained (the benefits of AUC are applicable beyond the summit itself since they are eligible to stand for and vote in UC elections)
19:22:00 <shamail> For example, if we did milestone-3 to milestone-3 between Mitaka and Liberty...
19:24:06 <shamail> For the Mitaka summit, any AUC contributions made after  Liberty milestone-3 (roughly Sept 2015) would qualify someone to have AUC badge in the summit
19:24:32 <shamail> Subsequently, the person would’ve stayed ‘AUC’ until Feb 2016
19:25:05 <shamail> Which means they could’ve voted in Mitaka UC elections (if there was such a thing) if they happened a month or two after the release of Liberty
19:25:37 <shamail> Thoughts?
19:26:04 <shamail> We could also collect the data (and have scripts handy to do ad-hoc collection) at least once a month.
19:26:09 <maishsk> I am sorry - but it could be the late hour - and me spacing out - but I still do not understand the issue
19:26:55 <shamail> The issue is how long should AUC be valid to allow for summit benefits and any additional rights during the release cycle.
19:27:23 <shamail> We had discussed one release cycle (forward facing… so a contribution right now would give someone AUC for Ocata)
19:27:57 <shamail> but does that actually work or should status have some buffer beyond a release cycle for elections
19:28:35 <shamail> I guess as I am writing this, one question that we probably need to know the answer to (before we could formulate a response to the current challenge) is what does the UC think will be there election cycle
19:28:36 <maishsk> Honestly - I have not really given this any thought - but I feel I must ask - are we trying to re-invent the wheel?
19:29:06 <shamail> On the contrary, I think we want to align this as closely to ATC schedules as possible so the question becomes how.
19:29:16 <maishsk> I assume that all these questions are not only for the AUC - they should be relevant for the ATC as well - so why should the AUC be any different?
19:29:38 <shamail> maishsk: +1
19:30:06 <MeganR> I agree - and honestly, the thought of voting had not even occurred to me.
19:30:48 <shamail> I’ll do some more work here and come back with a formulated response to how we can closely align with ATC’s answers to these questions
19:30:49 <maishsk> And regarding the voting cycle - I would hope that the UC elections - if and when they occur - will also align with the ATC
19:31:33 <shamail> maishsk: +1 but we need the UC to tell us if they plan to align with the TC schedule (7 positions in spring, 6 in fall)
19:31:47 <shamail> or whether they will have elections for all members at once (per year)
19:31:55 <shamail> We need to align with ATC and UC should align with TC
19:32:43 <shamail> #action Send an email to UC to understand their thoughts on the election process in the future
19:33:21 <shamail> Anything else on this topic for now?  Sorry, for not articulating it properly initially but I think we are all on the same page now
19:33:52 <MeganR> that sounds good
19:33:53 <shamail> #topic Milestone-5 update
19:34:10 <shamail> maishsk: Have you had a chance to make any more edits to the “self-nomination” process for AUC?
19:34:24 <shamail> #link https://etherpad.openstack.org/p/uc-recog-m5-output
19:34:51 <shamail> or do we consider it being in good shape and just need to summarize it?
19:35:26 <maishsk> I did not really have a chance to go over it - but I think we are in good shape
19:35:37 <shamail> Okay
19:35:42 <MeganR> +1
19:35:51 <shamail> Do you mind summarize the proposal and sending it to the UC to get their feedback?
19:35:58 <shamail> summarizing*
19:37:18 <maishsk> I will draw up a summary
19:37:22 <maishsk> :)
19:37:49 <maishsk> #action maishsk will summarize up Milestone 5 and send out to UC
19:37:54 <shamail> #action Summarize milestone-5 output and validate desired AUC self-nomination review committee composition and process (maishsk)
19:37:55 <shamail> Thanks!
19:37:58 <shamail> #topic Opens
19:38:09 <shamail> Does anyone else have additional topics for today?
19:38:37 <MeganR> no
19:38:45 <maishsk> Not really - but I was going over the milestones we set
19:38:53 <maishsk> and looking at #7
19:39:42 <maishsk> It is quite vague
19:40:02 <shamail> maishsk: +1, I will go ahead and remove it
19:40:05 <maishsk> Create a model of estimated costs while working with user committee on new charter
19:40:06 <shamail> thats more of a UC thing
19:40:15 <maishsk> That was my thought as well
19:40:19 <maishsk> thanks shamail
19:40:38 <shamail> Thanks
19:40:45 <shamail> Alright, have a great day/evening!
19:40:51 <MeganR> Bye!
19:40:52 <shamail> #endmeeting