20:00:49 <jraim> #startmeeting barbican
20:00:50 <openstack> Meeting started Mon Feb  3 20:00:49 2014 UTC and is due to finish in 60 minutes.  The chair is jraim. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:54 <openstack> The meeting name has been set to 'barbican'
20:01:07 <jraim> #topic DDOSing Freenet is for losers
20:01:19 <jraim> Alright, anyone here for the Barbican meeting?
20:01:23 <jvrbanac> o/
20:01:25 <hgedikli> yes
20:01:38 <redrobot> o/
20:01:50 <arunkant> yes
20:01:52 <warlord_> yo
20:01:54 <hockeynut> :-o
20:02:00 <reaperhulk> I am here
20:02:05 <hockeynut> je suis ici
20:02:10 <woodster> o/
20:02:18 <lisaclark> o/
20:02:22 <jraim> Cool, looks like we have a quorum
20:02:31 <reaperhulk> o/
20:02:40 <jraim> So the only agenda item that i have on my list is our readiness for incubation
20:02:46 <jraim> The status is here
20:02:48 <jraim> #link https://wiki.openstack.org/wiki/Barbican/Incubation
20:03:05 <jraim> And I believe that we have everything landed sans the devstack stuff which in in progress
20:03:29 <chadlung> Barbican's entry to DevStack PR: https://review.openstack.org/70512
20:03:31 <jraim> So just to dispense with this quickly, does anyone know of anything still outstanding for our incubation request tomorrow?
20:04:08 <jraim> #agreed Barbican will come up for our incubation vote tomorrow
20:04:09 <jraim> yay
20:04:10 <redrobot> #link https://wiki.openstack.org/wiki/Barbican/Incubation
20:04:21 <reaperhulk> :D
20:04:25 <redrobot> derp, just saw jraim had already put that up there
20:04:36 <jraim> Okay, I saw that hgedikli is here and some other folks
20:04:39 <jraim> so I'll open the fllow
20:04:41 <jraim> *floor
20:04:52 <jraim> does anyone have any issues they'd like to discuss?
20:05:16 <jraim> #info ::crickets::
20:05:33 <kris_h> hi all
20:05:39 <kris_h> Kris here from IBM
20:05:41 <jraim> hi kris_h
20:05:52 <kris_h> I am still waiting for the final step of our contributor process
20:05:57 <hockeynut> Hi Kris (from an ex-IBMer)
20:06:05 <kris_h> / hey :)
20:06:09 <kris_h> to be able to initiate the enc-at-rest for Swift
20:06:12 <hgedikli> jraim : are we expecting rsa stuff to be in icehouse release?
20:06:31 <jraim> hgedikli: I think it would be lovely, but we don't have a lot of time to land it
20:06:37 <kris_h> and there one of the module is to for coupling with Barbican -- so I will bug you to help me polish that part once out
20:06:59 <jraim> that work woudl have to land by March 6th to be a candidate for icehouse release
20:07:21 <jraim> kris_h: that's great news, we're happy to help whenever you guys are ready
20:07:29 <jraim> #link https://wiki.openstack.org/wiki/Icehouse_Release_Schedule
20:08:01 <jraim> hgedikli: so in short, if we are happy with the state of things by the 6th, we can land it and it'll be part of the icehouse release
20:08:28 <woodster> hgedikli: Do you mean related to this CR?: https://review.openstack.org/#/c/70189/
20:08:57 <jraim> reaperhulk: have you looked at this?
20:08:59 <jraim> #link http://sourceforge.net/projects/lunamech/
20:09:02 <hgedikli> woodster: yes and rsa key generation
20:09:38 <reaperhulk> Yeah, I was pointed that way this morning. I haven't had a chance to look at the configuration options it exposes, but it may be useful for automated configuration for our own deployments.
20:09:53 <reaperhulk> Of course, we don't configure new HSMs all that often so we'll see what it gains us
20:10:02 <woodster> it would be good for folks to weigh in on that CR to at least get RSA key storage squared away
20:10:17 <jraim> #action reaperhulk will look at lunamech to see if it would be useful to add to barbican
20:10:24 <jraim> woodster: agreed
20:10:41 <woodster> I think the rsa key *generation* part might be the more difficult one to land by March 6th
20:10:53 <redrobot> I liked the idea of having a separate repo for the API, has there been any updates on that front?
20:11:10 <hgedikli> woodster: after the CR is complete,next step will be working on order api for key generation
20:11:17 <redrobot> it would be useful to document the Containers api related to hgedikli's PR
20:11:24 <hgedikli> agreed
20:11:34 <jraim> redrobot: I thought I saw that ayoung put in a request for that
20:11:36 <hgedikli> redrobot: i'll update the blueprint w same request/response
20:11:39 <jraim> not sure where it is though
20:11:48 <hgedikli> sample
20:11:50 <dstufft> lunamech is apparently not on PyPI
20:12:01 <jraim> dstufft: boo
20:12:27 <jraim> I guess we could package it if it is useful
20:12:50 <codekobe> the link shows lunamech as "first working version"
20:12:57 <jraim> codekobe: yuck
20:13:01 <jraim> okay, it might be lame
20:13:07 <jraim> we'll see
20:13:08 <codekobe> with a single commit on 7/20/2013
20:13:29 <dstufft> jraim: ew
20:13:33 <dstufft> GPLv3+
20:13:36 <dstufft> lunamech is
20:13:42 <jraim> garg
20:13:44 <jraim> okay
20:14:06 <jraim> #agreed folks will comment on hgedikli 's patch
20:14:10 * dstufft is mostly here to ruin people's day with packaging woes
20:14:19 <jraim> any other issues we should discuss while everyone is here?
20:14:53 <jraim> alright then. Everyone back to #openstack-barbican :)
20:14:55 <jraim> #endmeeting