#openstack-meeting-alt: barbican

Meeting started by redrobot at 20:02:48 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Barbican (redrobot, 20:03:22)
    2. malini is making progress on adding Barbican to OpenStack security guide. (redrobot, 20:07:03)
    3. https://blueprints.launchpad.net/openstack-manuals/+spec/security-guide-key-management (malini, 20:07:55)
    4. https://blueprints.launchpad.net/openstack-manuals/+spec/security-guide-key-management (redrobot, 20:08:06)

  1. Crypto plugin contract changes (redrobot, 20:09:10)
    1. https://blueprints.launchpad.net/barbican/+spec/update-crypto-plugin-interface (redrobot, 20:10:21)
    2. AGREED: DTO should be used to pass data to plugin (redrobot, 20:13:19)
    3. DTO = data transfer object (redrobot, 20:14:22)
    4. rellerreller https://github.com/stackforge/barbican/blob/master/barbican/crypto/plugin.py#L85 (redrobot, 20:17:53)
    5. https://github.com/stackforge/barbican/blob/master/barbican/crypto/plugin.py#L85 (redrobot, 20:18:08)
    6. ACTION: alee_ will upload WIP change to plugin (redrobot, 20:25:40)
    7. https://github.com/cloudkeep-ops/chef-dogtag (redrobot, 20:27:39)
    8. HELP: we need someone to cook up a dogtag drm recipe (redrobot, 20:28:27)

  2. Blueprints (redrobot, 20:36:41)
    1. https://review.openstack.org/#/c/81310/ (redrobot, 20:38:58)
    2. ACTION: rellerreller to add blueprint for adding arbitrary metadata (redrobot, 20:54:37)


Meeting ended at 20:56:30 UTC (full logs).

Action items

  1. alee_ will upload WIP change to plugin
  2. rellerreller to add blueprint for adding arbitrary metadata


Action items, by person

  1. alee_
    1. alee_ will upload WIP change to plugin
  2. rellerreller
    1. rellerreller to add blueprint for adding arbitrary metadata


People present (lines said)

  1. redrobot (60)
  2. malini (23)
  3. alee_ (14)
  4. annegentle (10)
  5. rellerreller (7)
  6. arunkant (7)
  7. reaperhulk (3)
  8. bdpayne (3)
  9. openstack (3)
  10. codekobe (1)


Generated by MeetBot 0.1.4.