20:00:21 <redrobot> #startmeeting barbican
20:00:21 <openstack> Meeting started Mon Jun 2 20:00:21 2014 UTC and is due to finish in 60 minutes. The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:25 <openstack> The meeting name has been set to 'barbican'
20:00:36 <redrobot> hi everyone, can I get a show of hands for the Barbican meeting?
20:00:43 <atiwari> 0/
20:00:49 <rellerreller> hi
20:00:50 <chadlung> o/
20:00:58 <kaitlin-farr> o/
20:01:06 <Kevin_Bishop> o/
20:01:08 <paul_glass> hello
20:01:11 <tsv> hello
20:01:15 <reaperhulk> o/
20:01:35 <redrobot> alrighty! lots of people here today :)
20:01:45 <redrobot> as usual the agenda can be found here:
20:01:50 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican
20:02:15 <redrobot> I'll wait just a minute or two for any late peeps and then we can get started on the agenda items
20:02:20 <atiwari> I would like to introduce two new folks
20:02:28 <redrobot> atiwari go ahead
20:02:46 <atiwari> TSV who is looking at api refactoring
20:02:53 <tsv> hi there
20:02:55 <atiwari> tenant_id removal from uri
20:02:59 <redrobot> hi tsv!
20:03:10 <atiwari> Meera who is looking at adding tempest tests
20:03:22 <redrobot> hi meera!
20:03:23 <meera> hello everyone
20:03:29 <redrobot> nice to e-meet y'all
20:03:45 <redrobot> we have a couple of new folks on the Rackspace team as well.
20:04:01 <redrobot> Kevin_Bishop and paul_glass are interning with us for the summer.
20:04:06 <Kevin_Bishop> hello!
20:04:10 <paul_glass> hi!
20:04:15 <atiwari> hi there
20:04:25 <tsv> hi. nice to meet you all
20:04:34 <atiwari> nice e-meeting you guys
20:04:41 <redrobot> ok, it's 2005 UTC. Let's get started.
20:04:52 <redrobot> #topic Hacking enabled on pep8 gate
20:05:17 <redrobot> we're ---> <---- that close to enabling hacking
20:05:23 <redrobot> #link https://review.openstack.org/#/c/96839/
20:05:37 <redrobot> looks like there's only one more issue we need to fix before this CR will go through
20:05:50 <reaperhulk> yeah I'm going to update momentarily
20:05:57 <reaperhulk> as soon as I actually read the error and fix the import ;)
20:06:13 <redrobot> reaperhulk I can take care of it after the meeting.
20:06:14 <chadlung> Whoops, my mistake for approving that before zuul finished
20:06:36 <redrobot> I just wanted to bring this up so that everyone is aware that existing CRs may break after this one is landed
20:06:54 <redrobot> many thanks to paul_glass and Kevin_Bishop for their work squashing all the hacking viloations.
20:07:09 <atiwari> +1
20:07:28 <redrobot> I think that's all I have on this point, unless someone else wants to weigh in on it.
20:07:30 <rellerreller> +1
20:07:40 <tsv> nice job!
20:08:13 <redrobot> ok, moving on.
20:08:25 <redrobot> #topic barbican-specs repository for Blueprints
20:08:40 <redrobot> We've talked about this before
20:08:49 <redrobot> basically moving Blueprint proposals to Gerrit.
20:08:59 <atiwari> My understanding is this repo is just for specs
20:09:10 <redrobot> I think reaperhulk was going to work on this today?
20:09:12 <atiwari> what it mean ato add blueprints there?
20:09:38 <redrobot> atiwari, Jarret proposed a new process for creating blueprints
20:09:48 <rellerreller> Is there a defined format for the blueprints that are submitted?
20:10:15 <atiwari> redrobot, that I know is that mean we are decommissioning https://blueprints.launchpad.net/barbican/?
20:10:17 <redrobot> rellerreller yes there is, let me fish out the link
20:11:04 <redrobot> atiwari not really. We would still open a blueprint in launchpad, but the specification would go through gerrit. It would be kind of like the Not4MergeJust2Review CRs that you've sent before
20:11:18 <redrobot> atiwari except that we would be able to vote on it, and when it is merged, it would be considered approved.
20:11:35 <atiwari> redrobot, thats good
20:11:56 <atiwari> I am glad to have this new process :)
20:12:22 <rellerreller> What does it take to get a bp approved?
20:12:34 <redrobot> #link https://github.com/jarretraim/barbican-specs/blob/master/specs/template.rst
20:12:41 <redrobot> ^^ rellerreller this is the proposed format
20:13:11 <redrobot> rellerreller approval would be the same as merging into the main repo. 2x +2, and a workflow +1
20:13:18 <rellerreller> redrobot Thanks!
20:13:27 <reaperhulk> redrobot: yes I am going to spend some time on the specs today so we can get it merged hopefully tomorrow
20:13:46 <atiwari> redrobot, what about the current api specs?
20:14:15 <redrobot> #action reaperhulk will send the openstack-infra CR to create a stackforge/barbican-specs repository
20:14:52 <atiwari> e.g #link https://review.openstack.org/#/c/88463/11/api-docs/keystore-api-v1-order-more-type.md . am I suppose to move it to new repo?
20:15:25 <redrobot> atiwari, Yes, I think that would be better. This way we can vote using Gerrit.
20:15:31 <tsv> redrobot, Also, I have a barbican client CR based on a blueprint filed using old process. Should the bp migrate to the new process ?
20:15:47 <atiwari> redrobot, sure I will do.
20:16:29 <redrobot> tsv, we can look at it on a case-by-case basis. Since you already have an implementation CR we can vote on it there.
20:16:48 <tsv> redrobot, sounds good. thanks
20:17:36 <redrobot> I'll be sure to blast the email list once our repo is up
20:17:54 <redrobot> #action redrobot will notify dev mailing list once barbican-specs is avaliable
20:18:05 <redrobot> any other questions or comments on this before we move on?
20:18:51 <atiwari> redrobot, we moved our repos (barbican and client) to openstack , should we expect an official email?
20:19:17 <redrobot> atiwari I think the infra guys have already notified the list. I can send another email if you think it's necessary though.
20:19:31 <atiwari> no I am good
20:19:49 <redrobot> ok
20:19:53 <atiwari> actually one Keystone folks was asking me
20:20:13 <atiwari> I think we are good
20:20:28 <redrobot> ok
20:20:31 <redrobot> moving on
20:21:01 <redrobot> #topic Order Model changes
20:21:10 <redrobot> atiwari I think you proposed this topic?
20:21:14 <atiwari> yes
20:21:21 <redrobot> atiwari go ahead
20:21:30 <atiwari> great thanks
20:22:20 <atiwari> that was fast :)
20:22:30 <redrobot> I think this would make for a good use case to test out our new barbican-specs repository
20:22:48 <redrobot> atiwari I mean go ahead and talk about it ^_^ ...
20:22:57 <atiwari> Ok
20:23:21 <atiwari> as we discussed I am adding API support for different key generation
20:23:37 <atiwari> as per #link https://review.openstack.org/#/c/88463/11/api-docs/keystore-api-v1-order-more-type.md
20:24:13 <atiwari> we had agreement in the summit and just wanted to check if we are still good
20:24:16 <atiwari> ?
20:24:30 <atiwari> with this model change
20:24:55 <atiwari> I have stared implementation for the same.
20:26:12 <redrobot> atiwari ok, have you sent it as WIP? If so we can look at it there.
20:26:44 <atiwari> it is there but abandoned
20:26:52 <atiwari> I will resubmit the same
20:27:00 <atiwari> and let you guys know
20:27:26 <redrobot> atiwari thanks, yeah, it's good to upload model changes like that early so we can get lots of eyes on the review.
20:28:00 <redrobot> atiwari anything else you want to talk about on this topic? Or can we move on to the next item on the agenda?
20:28:12 <atiwari> redrobot, I am working on model change as per #link https://github.com/cloudkeep/barbican/wiki/Database-Migrations
20:28:24 <atiwari> I am good
20:28:36 <redrobot> ok, moving on
20:28:53 <redrobot> #topic Tempest tests for Barbican
20:29:03 <redrobot> jvrbanac ping
20:29:12 <redrobot> meera you're already working on these?
20:29:15 <atiwari> meera, it is your topic
20:29:19 <jvrbanac> redrobot, here
20:29:37 <meera> Yeah, i have started looking into adding some basic tempest tests for barbican API
20:29:41 <redrobot> jvrbanac good, I was hoping you'd be here to talk Tempest with meera :)
20:30:18 <redrobot> meera meet jvrbanac he's our main guy when it comes to Quality Engineering
20:30:34 <meera> jvrbanac: hi
20:30:46 <jvrbanac> meera, hi!
20:31:08 <redrobot> jvrbanac do we have any existing Tempest stuff?
20:31:57 <jvrbanac> redrobot, not anymore. We had a couple tests originally that was based on the Solum work, but that method doesn't seems to be working anymore
20:32:31 <redrobot> cool, so it looks like we have a clean slate for you to work with meera.
20:32:41 <jvrbanac> redrobot, meera yep!
20:32:41 <meera> Here's the link to the blueprint for tempest work: https://blueprints.launchpad.net/tempest/+spec/add-basic-tests-for-barbican
20:32:47 <atiwari> thats good meera you have lots of work to do :)
20:33:19 <meera> yeah
20:33:37 <chadlung> meera: good luck, I'd love to see some Tempest tests working in Barbican
20:34:01 <jvrbanac> meera, I'll be looking to spend some more time on that in the near future.
20:34:25 <redrobot> #action meera will begin work on Tempest testing for Barbican
20:34:36 <meera> I will be syncing up with the tempest folks to get the bp approved and start the implementation
20:35:02 <redrobot> ok, well it seems like it's positive all around :)
20:35:12 <atiwari> +1
20:35:29 <redrobot> This is all we have on the agenda for today. Does anyone else have any topics you would like to discuss?
20:35:41 <redrobot> if not we'll have a short meeting this week.
20:35:41 <atiwari> redrobot, yes
20:35:45 <rellerreller> Any news on the mid-cycle?
20:36:00 <rellerreller> Do we have any official dates or a location?
20:36:02 <redrobot> #topic Mid-cycle meetup
20:36:14 <atiwari> reaperhulk, has added new dependency for cryptography
20:36:15 <redrobot> rellerreller, I think the official location will be Geekdom in San Antonio, TX
20:36:35 <redrobot> atiwari, I can make that the next topic.
20:36:41 <atiwari> ok
20:36:49 <redrobot> rellerreller not sure about dates though
20:37:07 <redrobot> last I saw was tentative dates, but I think you ( rellerreller ) had a conflict with them?
20:37:57 <rellerreller> Ya, I wasn't sure if others would also have conflict for first day since right around July 4
20:38:26 <redrobot> yep, it's a valid point. I'll try to ping Jarret and see if they've decided on set dates.
20:38:29 <rellerreller> If we started July 7 I might just have to come late.
20:38:45 <redrobot> #action redrobot to check with jraim about mid-cycle meetup dates
20:39:19 <rellerreller> Is the OSSG still meeting with us that week? I saw that they had a few options for different weeks.
20:40:04 <redrobot> yeah, I think they were wanting to overlap OSSG as well, since we share many of the same interests...
20:40:24 <redrobot> does anyone else have more info than me? reaperhulk I'm looking your way...
20:40:40 <rellerreller> https://etherpad.openstack.org/p/ossg-juno-meetup
20:40:51 <reaperhulk> I believe OSSG has said they can't make it due to conflicts
20:40:53 <redrobot> #link https://etherpad.openstack.org/p/ossg-juno-meetup
20:41:28 <redrobot> bummer :-\
20:41:32 <rellerreller> reaperhulk Just for that week or not meeting in general?
20:41:50 <reaperhulk> for that week
20:41:58 <reaperhulk> but I don't know where that stands now
20:43:06 <rellerreller> Those were all of the questions that I had
20:43:13 <redrobot> I'll bug jraim about it... it's about a month away, so we definitely need to get the dates nailed down.
20:43:21 <redrobot> moving on.
20:43:39 <redrobot> #topic PyCA's Cryptography added as a dependency
20:43:54 <redrobot> atiwari you had questions about this?
20:44:19 <atiwari> yes are we planning to remove Crypto?
20:44:29 <reaperhulk> atiwari, yes, we are planning to remove pycrypto entirely eventually
20:44:51 <reaperhulk> the dev plugin will transition to using cryptography exclusively, but since it's just a dev plugin it still should not be used in production
20:45:02 <atiwari> ok
20:45:13 <chadlung> As a side note, I just updated the Barbican wiki on installing DevStack + Barbican. This change added some needed dependencies on a clean ubuntu system (for testing) #link https://wiki.openstack.org/wiki/BarbicanDevStack#Running_Barbican_via_DevStack
20:45:24 <reaperhulk> The reason we're using PyCrypto for asymmetric generation still is because cryptography doesn't support the serialization we need for keys just yet (should be available in 0.5, which should be out in ~2 weeks)
20:45:58 <atiwari> reaperhulk, make sense
20:45:58 <redrobot> thanks for the fyi chadlung
20:46:48 <redrobot> atiwari any other questions about this?
20:46:54 <atiwari> I am good
20:46:56 <atiwari> thanks
20:47:00 <redrobot> np
20:47:11 <redrobot> alrighty guys, that's all we have in the agenda for today.
20:47:21 <redrobot> any last minute questions/comments?
20:47:35 <nati_ueno> QQ: certificate support is implemented?
20:47:49 <nati_ueno> I would like to integrate it with SSL-VPN in neutron
20:48:08 <redrobot> hi nati_ueno, we're still in the blueprint stage for dealing with certificates
20:48:21 <nati_ueno> redrobot: Ah, OK! Sure
20:48:58 <nati_ueno> redrobot: which one?
20:48:59 <redrobot> nati_ueno stay posted, and let us know your requirements, so we can plan accordingly.
20:49:48 <nati_ueno> redrobot: cool. I posted it on the mailing list but I couldn't get response
20:49:48 <redrobot> nati_ueno there's a few in-flight dealing with asymmetric keys, etc. I'm not sure we have one specifically for certificates
20:50:04 <nati_ueno> redrobot: gotcha
20:50:18 <redrobot> nati_ueno, woodster is looking into it I believe. we saw your email, but I think he's still investigating to get you the right answer
20:50:32 <nati_ueno> redrobot: Thanks! I'm grad to hear that
20:51:08 <nati_ueno> Another QQ, is, Is there any discussion about transaction & notification?
20:51:37 <nati_ueno> I mean, if user want to delete SSL-VPN config, he may want to delete SSL certificate
20:51:39 <redrobot> nati_ueno what sort of transactions/notifications were you looking for?
20:51:57 <nati_ueno> However, may be one of them will be fail
20:51:59 <nati_ueno> or constrait
20:52:14 <nati_ueno> We don't wont to get ssl certificate deleted when SSL-VPN is still active
20:52:31 <nati_ueno> This kind of thing is really easy if we are using same DB.
20:52:38 <nati_ueno> I mean, RDBMS
20:52:38 <redrobot> I see... I think that's something we still have to discuss... we're running out of time for today, but we can definitely talk about it on the mailing list, or make it an agenda item for next week.
20:52:50 <nati_ueno> Sure! Thanks
20:53:30 <redrobot> np. We definitely have Neutron in mind. :)
20:53:40 <nati_ueno> awesome! Thanks
20:53:43 <arunkant> I have planning to work on event consumption by barbican ..may be can look into notification side of it as well..https://blueprints.launchpad.net/barbican/+spec/ability-to-consume-keystone-events-for-project-delete
20:53:52 <nati_ueno> arunkant: Sure!
20:54:17 <redrobot> OK, guys, that's about all the time we have for today. Thanks for coming!
20:55:07 <redrobot> #endmeeting