20:00:18 <redrobot> #startmeeting barbican
20:00:19 <openstack> Meeting started Mon Jun  9 20:00:18 2014 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:23 <openstack> The meeting name has been set to 'barbican'
20:00:32 <redrobot> hi everyone, can I get a show of hands for the Barbican weekly meeting?
20:00:37 <tsv> 0/
20:00:43 <jraim> o/
20:00:45 <reaperhulk> o/
20:01:14 <woodster> o/
20:01:28 <atiwari> o/
20:01:31 <kaitlin-farr> o/
20:01:38 <meera> o/
20:01:46 <rellerreller> o/
20:02:04 <jvrbanac> o/
20:02:08 <redrobot> looks like all the usual suspects are here :)
20:02:23 <redrobot> as usual the agenda can be found here:
20:02:25 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican
20:03:01 <redrobot> let's get started
20:03:11 <redrobot> #topic barbican-specs repository
20:03:30 <redrobot> The official repo is live
20:03:32 <redrobot> #link https://github.com/openstack/barbican-specs
20:03:59 <redrobot> it includes a template that should be used for new blueprints:
20:04:01 <redrobot> #link https://github.com/openstack/barbican-specs/blob/master/specs/template.rst
20:04:30 <redrobot> I think there's been a couple of CRs sent in for review.
20:04:46 <redrobot> so everything is looking good on our front
20:04:53 <atiwari> +1
20:04:55 <jraim> documentation of the process is here #link https://wiki.openstack.org/wiki/Barbican/Blueprints
20:05:06 <jraim> it should be very close to Nova's
20:05:32 <redrobot> cool.  any questions/comments about the new repo or blueprint process?
20:05:58 <rellerreller> That's only for new bp's, right?
20:06:14 <jraim> we'll need to port over anything that is planned to land for Juno
20:06:18 <jraim> but that can happen over time
20:06:39 <jraim> For those that are already approved, it should just be a reformatting effort
20:06:43 <jraim> which I'll try to do some of :)
20:06:50 <redrobot> rellerreller yes.  I think woodster has been working on drafting a couple of BPs to track the stuff we talked about at the summit.
20:07:15 <atiwari> jraim, is it ok to log the high level bp @ #link https://bugs.launchpad.net/barbican?
20:07:20 <woodster> yes, one is out there now regarding restructuring to support different plugins
20:07:42 <jraim> atiwari: the BPs in launchpad will only be used for release tracking.
20:07:42 <atiwari> and detail spec will go tp the spec repo.
20:07:46 <jraim> all content should be in the spec
20:07:54 <jraim> the BP will just have a link to the spec really
20:08:27 <atiwari> jraim, ok
20:09:20 <redrobot> sounds like we're all on the same page for moving forward with the barbican-specs repo
20:09:52 <redrobot> let's move on
20:10:04 <redrobot> #topic juno-1 release
20:10:24 <redrobot> The first release for Juno is scheduled for this Thursday.
20:10:39 <jaosorior> hello
20:10:43 <redrobot> I think we'll be holding off on merging big patches, and only try to merge bug fixes for the next couple of days.
20:10:47 <redrobot> hi jaosorior
20:11:20 <redrobot> woodster do you have anything to add?  I think you were triaging Bugs this morning?
20:11:51 <woodster> Yes, I'll put up the 3 bug-reatled CRs that could land if approved by Wed mid day or so
20:12:10 <redrobot> woodster awesome, thanks
20:12:20 <redrobot> anyone have any questions/comments about the upcoming release?
20:12:27 <woodster> ….here they are: https://review.openstack.org/#/c/98562/,  https://review.openstack.org/#/c/97554/,  https://review.openstack.org/#/c/98473/
20:12:52 <woodster> Just noting that Juno-M1 is *not* a feature freeze milestone…we have more time before that happens. :)
20:13:08 <jvrbanac> :)
20:13:43 <redrobot> cool
20:13:58 <redrobot> jaosorior I think that answers the question you had about merging 97554?
20:14:07 <jaosorior> yes
20:14:24 <jaosorior> that's quite helpful since I usually test stuff with curl
20:14:39 <jaosorior> yet, I have not figured out why I get the error that I get when I try to run the migration script
20:14:55 <jaosorior> as I put here http://paste.openstack.org/show/83444/
20:15:40 <redrobot> alrighty moving on
20:15:48 <redrobot> #topic Mid-cycle meetup
20:15:50 <woodster> jaosorior: there has been some activity related to migrations of late, so their might be integration-related regressions a work.
20:16:08 <redrobot> rellerreller I know you were waiting to hear from us.
20:16:33 <redrobot> Still working with Geekdom in San Antonio, TX to confirm the space, but it does look like we will be meeting July 7, 8 and 9.
20:16:38 <rellerreller> Ya, I need to know when and where to fly to :)
20:17:08 <redrobot> The Keystone meetup will be at the same venue on July 9, 10, and 11.
20:17:55 <jaosorior> woodster, alright, but, do you have any workarounds? or should I start debugging and trying to fix it?
20:18:04 <jaosorior> redrobot, are you talking about the hackathon?
20:18:24 <redrobot> jaosorior yes.  mid-cycle meetup (aka hackathon) is the current topic
20:18:36 <woodster> jaosorior: let's talk about it after the meeting for sure
20:18:36 <redrobot> jaosorior https://wiki.openstack.org/wiki/Meetings/Barbican
20:18:39 <jaosorior> is that open to everybody or is it just for the core team?
20:19:08 <redrobot> anyone is welcomed to attend.  as soon as I get confirmation about space for Barbican I'll send a note to the mailing list
20:19:41 <jaosorior> cool!
20:20:00 <woodster> redrobot: I think the dates/city are set, just the actual venue location is up in the air, correct?
20:20:15 <woodster> …so 'save the date' so to speak?
20:20:18 <jraim> it will be geekdom, they are just being annoyingly slow to answer the email
20:20:29 <jraim> so people should plan on San Antonio, downtown somewhere
20:21:15 <redrobot> yes, save the date:
20:21:21 <redrobot> July 7th-9th in San Antonio, TX
20:22:46 <redrobot> any more questions about the meetup?
20:24:08 <redrobot> I'll take that as a no.  let's move on.
20:24:53 <redrobot> #topic Meera's patch to data migration script
20:24:55 <redrobot> #link https://review.openstack.org/#/c/98473
20:25:16 <redrobot> I think we've already agreed to try to get this merged before the M1 cutoff.
20:25:24 <redrobot> meera do you have any more comments on this?
20:25:45 <meera> redrobot: no
20:25:59 <atiwari> redrobot, please refresh the meeting agenda page
20:26:24 <redrobot> atiwari will do
20:27:03 <redrobot> let's move on
20:27:34 <redrobot> #topic Blueprint api-orders-add-more-types
20:27:50 <redrobot> #link https://review.openstack.org/#/c/98174
20:27:59 <redrobot> ^^ is the barbican-specs CR
20:28:08 <redrobot> #link https://review.openstack.org/#/c/97844/
20:28:08 <atiwari> redrobot, I think you missed 1 before that
20:28:29 <redrobot> ^^ CR to implement the blueprint
20:28:45 <redrobot> atiwari did you have any specific questions about these?  or do you just need more eyes to review?
20:29:17 <redrobot> atiwari, just refreshed.  I think I've covered everything so far?
20:29:19 <atiwari> No question wondering if OK to merge or more review is needed
20:30:24 <redrobot> atiwari the barbican-specs CR has a couple of positive votes already.  Looks like we just need to get some more reviewers to look at it.
20:31:11 <woodster> just a note that the plugin CR (https://review.openstack.org/#/c/98286/) would be changing the home where plugins live, so we'll just need to coordinate CRs that come from these blueprints carefully.
20:32:05 <atiwari> redrobot OK, and any thoughts https://review.openstack.org/#/c/97844/ is it OK to be merged?
20:32:12 <atiwari> woodster, ^
20:32:34 <redrobot> atiwari I think we can talk about it on the regular channel.  I don't want to burn meeting time reviewing patches.
20:32:54 <redrobot> atiwari unless we have controversy and scandal :)
20:33:00 <atiwari> reaperhulk, ok
20:33:19 <woodster> I've given that CR a +2, so yes :)
20:33:25 <redrobot> #agreed need more eyes on Arvind's CRs
20:33:52 <redrobot> ok, let's move on
20:34:01 <redrobot> #topic Testing Code Pattern
20:34:07 <redrobot> rellerreller I think you added this to the agenda?
20:35:00 <rellerreller> Yes, Kaitlin was looking at the testing patterns you guys use
20:35:31 <rellerreller> She noticed that the naming conventions and test code layout was slightly different compared to other projects
20:35:45 <rellerreller> She can explain more if needed.
20:35:52 <woodster> Kaitlin mentioned that Barbican's unit tests have a different style than other openstack projects.
20:35:57 <redrobot> Yeah...  I think it may just be that we're not as familiar with other projects...
20:36:03 <rellerreller> The question is do we follow existing patterns or switch to something more similar to Nova
20:36:40 <rellerreller> Our thought was that we did not want to implement tests in existing pattern if integration into core makes us switch
20:36:58 <woodster> I had suggested putting up a small CR with the alternate unit test for the new work she was working on, for the community to take a look at.
20:37:04 <rellerreller> We're good either way, but we wanted to bring it up
20:37:25 <woodster> A greater refactoring of existing unit tests would be best detailed in a blueprint CR I'd think.
20:37:28 <redrobot> that's a good point.  we definitely want to be on the TC's good side for integration :)
20:38:06 <rellerreller> So should we try a style similar to other core projects and see what Barbican folks think?
20:38:46 <redrobot> That sounds reasonable to me.  Unless it's going to take a ton of effort to get the review up?
20:38:48 <rellerreller> We could post a WIP when we have a few written
20:39:02 <woodster> rellerreller: could a new small test be written in that revised style as a small CR?
20:39:08 <kaitlin-farr> Got it! :]
20:39:37 <rellerreller> woodster: we can submit a WIP for our KMIP secret store impl
20:39:50 <woodster> rellerreller: sounds good
20:40:19 <rellerreller> Thanks! That's all we needed to know.
20:40:33 <redrobot> #action kaitlin-farr will upload a WIP CR to review a more openstack-like testing pattern
20:41:11 <redrobot> ok, let's move on, I think we may have enough time to cover everything in the agenda
20:41:25 <redrobot> #topic Progress on eventing system
20:41:32 <redrobot> atiwari do you want to talk about this?
20:41:55 <atiwari> redrobot, I wanted to know where we are in this one
20:42:05 <atiwari> who is doing that ....
20:42:28 <woodster> atiwari: I'm working on a formal blueprint for that work in progress CR related to SSL cert workflow plugins…that requires eventing for example.
20:42:32 <redrobot> woodster did you have an etherpad on who's-doing-what?
20:43:08 <woodster> This was an etherpad that came out of the Atlanta conference:
20:43:11 <woodster> #link https://etherpad.openstack.org/p/barbican-juno-roadmap
20:43:17 <atiwari> woodster, any etherpad or spec would be helpful
20:43:47 <atiwari> woodster, ok
20:44:02 <redrobot> woodster thanks, that's the one I was thinking about.
20:44:14 <woodster> However, the blueprint I'm working on now for the specs repo (up today) will add more details for the cert generation requirements anyway.
20:45:17 <woodster> My thoughts are to make the event a plugin that by default just logs, but we could add a CADF/Ceilomoter type one that is available in core barbican.
20:45:31 <redrobot> so it sounds like we're still gathering requirements, and don't have a BluePrint for eventing yet?
20:46:38 <woodster> Just to be clear here….eventing has two sides, a part that fits into barbican to issue events (so individual blueprints with eventing reqs will cover those) and what is handling the events once issue…. The latter one is probably a separate blueprint?
20:47:22 <jaosorior> woodster, I would find the logging plugin very useful for auditing. That's something we are really looking for
20:47:47 <woodster> So the certificate workflow blueprint I'm working on now will cover event generation relative to the code logic. But the implmentation of the plugin, esp. connecting to Ceilometer (for example) would be a separate blueprint.
20:47:57 <redrobot> I was thinking we were going to need a blueprint to lay the framework for issuing events?
20:48:20 <woodster> Ah got it. So we probably need to analyze the CRUD places we would like Barbican to surface events for.
20:49:21 <redrobot> yeah, sounds like an eventing-specific blueprint is needed that gathers the crud places where we need eventing and also takes into account the eventing stuff needed in other BPs
20:49:22 <atiwari> woodster, eventing system has to be independent from ssl cer (or anything else) processing
20:49:23 <woodster> I can start an eitherpad to focus on place we need to issue events from in the code base
20:50:03 <redrobot> #action woodster will start an etherpad for planning the eventing framework.
20:50:06 <woodster> atiwari: correct, but there should be a clear interface with methods like 'notify_cert_ready()' that a workflow plugin can call to start the event flow up.
20:50:30 <woodster> ….that is separate from how the event is handled.
20:50:40 <atiwari> woodster, +1
20:50:41 <woodster> redrobot: Thanks, will do.
20:51:30 <atiwari> woodster, I will be looking for your etherpad
20:51:33 <atiwari> thanks
20:51:49 <redrobot> ok, sounds like we're all on the same page now.
20:51:55 <redrobot> let's move on to the last topic on the agenda
20:52:16 <redrobot> #topic Is v2 needed to remove tenant_id from URI?
20:52:45 <atiwari> redrobot, we are working on this cr and wondering is it time to start v2?
20:52:50 <redrobot> I think it's a good question... I'm not sure how much longer we can use the "nobody is using us" excuse for breaking changes. :)
20:53:14 <redrobot> I think the underlying question is:
20:53:26 <woodster> Well, I'm thinking no one is using us in production yet. :)
20:53:28 <redrobot> Does incubation mean that v1 is set in stone?
20:53:51 <redrobot> or, does incubation mean that we are working towards a v1 that is stable and then set in stone?
20:54:18 <jraim> interesting question
20:54:26 <jraim> I'll ask about it
20:54:47 <atiwari> woodster, redrobot in that case maintaing backward compatibility is really needed?
20:54:48 <woodster> So for now assume v2 is not required?
20:55:26 <redrobot> Yeah, I would assume v2 is not needed unless the TC gets heartburn over it.
20:55:39 <woodster> The only dependencies on Barbican  I'm aware of are the python client, Heat (starting integration work) and maybe the Johns Hopkins team with their encryption work?
20:55:52 <redrobot> #action jraim will ask the TC if breaking changes during incubation require a new major api version
20:56:25 <rellerreller> I think our code so far is small enough that we could adapt to a new version
20:56:33 <woodster> Just a note regarding LBaaS integration with Barbican. One or two blueprints will probably come out of that stakeholder discussion this week I expect.
20:57:05 <atiwari> woodster, I have added one today. I will discuss with you later
20:57:18 <redrobot> ok guys, almost out of time here.
20:57:21 <woodster> atiwari: nice, thanks
20:57:43 <tsv> woodster, redrobot, am working on a spec for the tenant_id removal that atiwari mentioned about. should be ready before end of today
20:58:21 <redrobot> tsv sounds good
20:58:37 <redrobot> ok guys, our time is up for today.  see you guys back here next week.
20:58:45 <redrobot> #endmeeting