20:00:36 <redrobot> #startmeeting barbican
20:00:37 <openstack> Meeting started Mon Jun 23 20:00:36 2014 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:40 <openstack> The meeting name has been set to 'barbican'
20:00:50 <redrobot> #topic Roll Call
20:01:13 <redrobot> Hi Everyone!  It's time for the weekly Barbican meeting again
20:01:15 <rellerreller> hi
20:01:33 <redrobot> can I get a show of hands from attendees?
20:01:35 <jvrbanac> o/
20:01:36 <chellygel> o/
20:01:37 <arunkant> o/
20:01:38 <redrobot> hi rellerreller
20:01:41 <tsv> o/
20:01:42 <woodster__> o/
20:01:59 <kaitlin> o/
20:02:01 <redrobot> Awesome!
20:02:16 <redrobot> As usual, the agenda can be found here:
20:02:18 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican#Agenda
20:02:46 <redrobot> #topic Action Items
20:02:59 <redrobot> Let's start by revisiting some action items from last week
20:03:17 <redrobot> Hopefully you all saw the invite for the mid-cycle meetup I sent to the mailing list
20:03:42 <redrobot> I'll talk a little more about that after the action items
20:03:55 <atiwari> o/
20:04:06 <redrobot> woodster__ have you had a chance to set up an etherpad for the eventing discussion?
20:05:11 <woodster__> I had sent that out before, I'll send again though....
20:05:13 <bubbva> yep, thanks, redrobot!
20:05:20 <bubbva> o/
20:05:38 <woodster__> #link https://etherpad.openstack.org/p/barbican_event_processing
20:05:43 <redrobot> woodster__ sorry I may have missed it...
20:05:49 <redrobot> woodster__ thanks for the link
20:06:19 <tsv> woodster, thanks for your etherpad link on the keystone client v3 support work for barbican client
20:06:41 <woodster__> tsv: just trying to keep track of the many discussion that happened on that CR! :)
20:07:16 <redrobot> tsv regarding the action item from last week's meeting.  have you had a chance to start a blueprint for removing the tenant id from the URI?
20:07:28 <tsv> redrobot, yes
20:07:42 <tsv> link: https://review.openstack.org/#/c/100386/4
20:08:04 <tsv> redrobot, there were good review comments. i cleaned it up based on comments and submitted again
20:08:11 <tsv> more reviews please :)
20:08:20 <redrobot> #link https://review.openstack.org/#/c/100386/
20:08:27 <redrobot> tsv I see it now, thanks
20:08:43 <redrobot> I talked to jraim about the need for backwards compatibility
20:09:15 <tsv> ok. i also mentioned about an optional middleware if backwards compatibility is desired
20:09:18 <redrobot> he asked the TC about it and their response was that we can choose to break it, but that we should communicate that to the community
20:09:49 <tsv> ok, how should we do that ?
20:09:54 <jraim> And explain why we are breaking it including our plan around Python-barbican client.
20:10:10 <redrobot> I'm going to send an email to the dev list explaining what we're trying to do, include a link to the BP and let everyone know that we don't plan to provide backwards compatibility for this
20:10:26 <redrobot> ohai jraim!  I thought you'd be out otday.
20:10:43 <tsv> redrobot, thanks
20:10:47 <jraim> I'm on my phone.
20:11:10 <redrobot> #action redrobot will email list about plans to remove the tenant id from the URI
20:11:18 <tsv> jraim, got you. thanks
20:11:30 <atiwari> tsv, redrobot, jraim  and woodster, we have discussed one use case in summit around order order
20:12:01 <redrobot> atiwari use case regarding the tenant ID in the URI?
20:12:02 <atiwari> where we need an ability to specify x-keystone-id in header for Orders POST case
20:12:09 <atiwari> yes
20:12:20 <atiwari> and we had a verbal approval from jraim
20:12:41 <redrobot> atiwari I think the keystone middleware takes care of that?
20:12:42 <atiwari> that is not included in tsv bp
20:13:07 <atiwari> I don't think so
20:13:22 <atiwari> let me add my concern in bp
20:13:29 <redrobot> atiwari ok, sounds good
20:13:31 <redrobot> let's move on
20:13:39 <redrobot> #topic Mid-cycle meetup
20:14:07 <redrobot> hopefully everyone knows about this already... it will be in two weeks in San Antonio, TXS
20:14:10 <redrobot> *TX
20:14:27 <bubbva> yes
20:14:37 <redrobot> #link https://wiki.openstack.org/wiki/Barbican/JunoMeetup
20:15:14 <redrobot> also, please RSVP if you're planning on coming to the meetup/hackathon
20:15:25 <redrobot> we want to make sure we have enough room for everyone
20:16:21 <redrobot> any questions/concerns about the meetup?
20:16:44 <rellerreller> Is there an agenda or anything yet?
20:18:02 <redrobot> rellerreller we don't have a set agenda...  I've only been to one of these before, for the Swift project.  I was thinking we'll probably be discussing outstanding blueprints, or trying to merge some of the larger CRs that are in flight.
20:18:57 <rellerreller> OK, I didn't know what to do if we have something we want to talk about. I guess we just bring it up when we get there?
20:20:17 <redrobot> rellerreller yeah, or bring it up here, or at next week's meeting if you feel we need some time to prepare before the meetup
20:20:38 <rellerreller> OK, sounds good
20:20:42 <woodster__> maybe we need an etherpad to capture issues folks have?
20:20:50 <notmyname> redrobot: we've now done 2. we jsut had the second one in the Denver area a few weeks ago
20:21:04 <redrobot> woodster__ that's a good idea
20:21:05 <rellerreller> They had an etherpad for the Nova one I went to
20:21:32 <redrobot> #action redrobot will add an etherpad page for meetup discussion
20:21:38 <notmyname> in our experience, starting the first day with a whiteboard/flipchart list of stuff people wanted to cover is really good. then self-organize to do that, allowing for a little structure to guide things that need more participation
20:22:08 <redrobot> notmyname that sounds like a good plan.  thanks!
20:22:21 <reaperhulk> strangely this notmyname character seems to know what's up ;)
20:22:33 <notmyname> reaperhulk: it's a clever facade ;-)
20:23:03 <reaperhulk> people make entire careers out of such façades! *eyes dart back and forth*
20:23:22 <notmyname> redrobot: and as to types of things to do would include design discussions, in-person code reviews (_really_ useful for major patches), and logistics. in my mind the best thing is just that a bunch of smart people get in the same room together :-)
20:23:56 <tsv> notmyname, meetup at Denver, hmm...closer to where I and atiwari live/work
20:24:12 <redrobot> notmyname I agree... especially the in-person code reviews.
20:25:03 <notmyname> redrobot: ya, but the balancing act is that with 20-30 people in the room, you can't effectively have good participation on just one thing at a time. 6-8 is generally the best for covering a single thing
20:26:45 <woodster__> I really liked that Swift hackathon last year, just sayin' ;)
20:27:15 <notmyname> great to hear!
20:28:55 <redrobot> ok, that's all I have on the agenda for this week
20:29:04 <redrobot> does anyone want to bring up anything?
20:29:48 <woodster__> Just keep on reviewing...a few blueprints and CRs out there for your reviewing pleasure
20:30:48 <tsv> redrobot, one question
20:30:54 <redrobot> tsv yes?
20:31:17 <tsv> we have few CRs around pecan based issues. do we need to open CR with pecan instead of using hooks to fix it ourself ?
20:31:37 <redrobot> #topic Pecan issues
20:32:12 <redrobot> tsv I think it depends on which issues we're talking about...  woodster__ and jvrbanac were having an interesting discussion about that this morning
20:32:24 <redrobot> jvrbanac ping
20:32:57 <tsv> redrobot, here is one of my CR review: https://review.openstack.org/#/c/100814
20:33:41 <redrobot> tsv, yes I think that's the one we were talking about today...
20:33:46 <redrobot> hockeynut ping
20:34:44 <tsv> redrobot, is there an action item to open CRs with pecan ? or should i open one for this CR ?
20:35:50 <jvrbanac> redrobot, so I think that there were a couple of concerns across some of these CR's. It seems like we're using hook behavior when it should probably be dealt with elsewhere in Barbican or upstream
20:35:52 <redrobot> tsv I was hoping jvrbanac or hockeynut would respond to this.  I know hockeynut (Steve Heyman) has talked to the Pecan folks about issues before
20:36:07 <tsv> redrobot, ok. thanks
20:36:17 <woodster__> I think hockeynut was going to approach Pecan about this issue
20:37:10 <tsv> woodster, makes sense. i remember falcon handling this automatically
20:38:07 <jvrbanac> tsv, woodster__, yeah I think hockeynut was going to see if there was a proper way of dealing with this in Pecan or discover if it's something we should help them with.
20:38:38 <tsv> jvrbanac, thanks. will wait to hear what they say
20:39:09 <tsv> redrobot, jvrbanac, woodster, so no code change, but could we have the tests that expects 405 in ?
20:40:36 <jvrbanac> tsv, I think there will be some sort of code change, but hopefully not where we are trying to intercept the calls and test them manually.
20:40:56 <redrobot> #action hockeynut will follow up with Pecan devs about index function side-effect
20:41:37 <tsv> jvrbanac, ok
20:41:43 <jvrbanac> tsv, we really just need to chat with the Pecan folks a bit on this as this seems like it affects more than just us.
20:41:53 <redrobot> jvrbanac how do you feel abotu adding the 405 tests?
20:42:24 <woodster__> won't those tests fail now without some code behind it?
20:43:06 <tsv> woodster, yes it would. it makes sense to add those after the pecan fix is in
20:43:37 <jvrbanac> tsv, agreed. Whatever the solution is for pecan, I think the tests should follow that
20:43:52 <tsv> jvrbanac, thanks.
20:46:09 <redrobot> ok, guys, we have about 15 still.  are there any other topics we want to discuss?  If not we can call it a day
20:49:35 <redrobot> I'll take that as a no.  Thanks everyone!  See you all back here next week.
20:49:40 <redrobot> #endmeeting