20:00:27 <redrobot> #startmeeting barbican
20:00:28 <openstack> Meeting started Mon Jun 30 20:00:27 2014 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:33 <openstack> The meeting name has been set to 'barbican'
20:00:42 <redrobot> #topic Roll Call
20:01:32 <redrobot> Hi everyone, can I get a show of hands for this week's Barbican meeting?
20:01:42 <atiwari> o/
20:01:42 <woodster__> o/
20:01:44 <tsv> o/
20:02:16 <jvrbanac> o/
20:02:32 <redrobot> I'll wait a couple of minutes for some more folks to jump on...
20:02:34 <chellygel> o/
20:03:55 <redrobot> ok, let's get started
20:04:10 <redrobot> as usual the agenda can be found here:
20:04:13 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican
20:04:18 <redrobot> #topic Action Items
20:04:51 <redrobot> is hockeynut here?  I didn't see him raise his hand for roll call?
20:05:34 <woodster__> might be Austin bound?
20:05:44 <redrobot> maybe so... I'll update on his action item
20:06:23 <redrobot> so, hockeynut was working with the Pecan folks for a good approach for dealing with the default index function
20:06:38 <redrobot> which ended up in a change being made upstream to Peacn
20:06:41 <redrobot> *Pecan
20:07:04 <tsv> redrobot, woodster, i saw an update on that CR by Ryan
20:07:04 <redrobot> we're going to need to update some stuff on Barbican
20:07:24 <redrobot> #link https://bugs.launchpad.net/barbican/+bug/1334872
20:07:25 <uvirtbot> Launchpad bug 1334872 in barbican "refactor barbican controllers to match pecan recommended approach" [Medium,Confirmed]
20:07:48 <redrobot> the bug was opened to track the changes that will need to be made once Pecan releases their change
20:08:11 <redrobot> tsv, is the stuff I mentioned accurate?
20:08:16 <tsv> yes
20:08:28 <redrobot> ok, good.
20:08:36 <tsv> redrobot, Ryan said he is planning on releasing pecan 0.6.0 this week
20:09:03 <redrobot> tsv great, we'll definitely need to keep an eye on that so we can update when it is released
20:09:22 <redrobot> the other action items were for me
20:09:43 <redrobot> and I think we'll touch on them on the agenda for today, so let's move along
20:09:53 <redrobot> #topic Mid-Cycle Meetup
20:10:21 <redrobot> So the mid-cycle meetup will be next week.  If you haven't had a chance to RSVP, please do so
20:10:36 <redrobot> #link https://wiki.openstack.org/wiki/Barbican/JunoMeetup
20:10:53 <redrobot> the wiki entry has all the information, including venue, RSVP link, etc
20:11:16 <redrobot> also, we have an etherpad to start jotting down topics we want to cover during the meetup
20:11:26 <redrobot> #link https://etherpad.openstack.org/p/barbican-juno-meetup
20:11:43 <redrobot> any questions/comments on the upcoming meetup?
20:11:58 <rellerreller> I have a question
20:12:16 <redrobot> rellerreller what's up?
20:12:24 <rellerreller> The World Cup is going on, and I believe the semi-finals are that week. Are we doing anything for that :)
20:12:43 <redrobot> rellerreller hehe, we certainly could :)
20:12:48 * jvrbanac thinks "Gooaaaallllllll"
20:13:09 <rellerreller> I may be MIA while the games are going on :)
20:13:09 <atiwari> rellerreller, good question :)
20:13:20 <woodster__> do they have big screens at the Geekdom?
20:13:24 <jraim> they do
20:13:41 <jraim> we should be able to stream it in
20:13:50 <jraim> or there are plenty of bars downtown
20:14:02 <redrobot> I think we could put it up on the projectors...
20:14:55 <redrobot> rellerreller you and me both :D
20:15:13 <atiwari> make sure you guys not adding "Gooaaaallllllll" instead of for loop ;)
20:15:22 <redrobot> any other non-fĂștbol concerns?
20:15:29 <rellerreller> I'm good
20:15:55 <redrobot> ok, looking forward to seeing everyone next week.
20:16:01 <redrobot> let's move on to the next topic
20:16:12 <redrobot> #topic Backwards Compatibility for removing tenant id
20:16:44 <redrobot> So I think we just need to get on the same page for this one
20:17:00 <redrobot> atiwari to answer your question in the agenda, I think we decided to go ahead without backwards compatibility
20:17:18 <redrobot> I left a comment on the BP with a -1 to remove the Backwards compatibility section
20:17:25 <atiwari> redrobot, it is not about tenant_id removal
20:17:31 <tsv> redrobot, thanks. working on cleaning up the spec
20:17:44 <redrobot> atiwari oh, sorry... I must have confused myself.
20:17:49 <atiwari> it is about adding more type in order
20:17:58 <atiwari> resource
20:18:16 <redrobot> ah, yes.... hmm...  that's a good question
20:18:37 <redrobot> tsv thanks!  I'll vote it up and send an email to the dev list once you get a new patch up
20:18:40 <rm_work> so, the removal of tenant_id is interesting to me, as I'm *just* implementing the first real function on the admin-api, and I've just gotten it working *with* tenant_id
20:19:03 <redrobot> rm_work yes, I think it would be best if you plan on not including a tenant_id in the URI
20:19:17 <rm_work> can you summarize the timeline for this change/
20:19:18 <rm_work> ?
20:19:38 <redrobot> rm_work so tsv is working on removing the tenant_ids
20:20:08 <redrobot> tsv after we get the blueprint approved, about how much effort do you think it would take to get a patch submitted?
20:20:12 <rm_work> ok, I suppose I will have to refactor based on his work then, once that gets reviewed and merged?
20:20:31 <woodster__> rm_work: removing the tenant-id shouldn't affect the resource work you do (within REST verb methods anyway)
20:20:45 <tsv> rm_work, redrobot, am working on code changes side by side. should be ready in couple days - by Wednesday
20:20:46 <jvrbanac> #link https://review.openstack.org/#/c/100386/
20:20:54 <rm_work> woodster__: well, the admin-api didn't HAVE any of this stuff yet, I had to make some stubs and such and it does relate
20:21:21 <redrobot> woodster__ yeah, rm_work is pretty much working on an empty app, since the admin side only has the version resource right now.
20:22:03 <rm_work> yeah I'll just have to look at the changes tsv makes and do the same thing on the admin side
20:22:12 <rm_work> that answered my question though, thanks!
20:22:48 <redrobot> ok, so now, let's move on then
20:22:57 <redrobot> #topic Backwards compatibility for order resource
20:23:36 <atiwari> my vote - just clean it ;)
20:23:43 <atiwari> redrobot, ^
20:24:02 <redrobot> ok, so now to address atiwari's question about the order resource...  is this something we can also use the "not in production yet" card and not worry about it?
20:24:15 <redrobot> atiwari that's certainly the easier route :)
20:24:22 <jraim> heat has done some integration work
20:24:36 <jraim> I assume they are using the orders resource
20:24:45 <woodster__> and the Johns Hopkins team
20:24:52 <woodster__> probably not orders resource though
20:25:37 <woodster__> jraim: I think they've only defined resource elements for the APIs, so could be changed without much issue I'd think, but should check with them
20:25:47 <jraim> woodster__: seems reasonable
20:26:50 <atiwari> woodster__, please check and let me know.
20:26:50 <redrobot> atiwari do you want to check with the heat folks about the change?
20:27:10 <atiwari> redrobot, any specific person ?
20:27:15 <atiwari> to reach
20:27:42 <redrobot> atiwari that answers my question. :)  I think that if we also send them a patch with the new order structure, it would be easier than to deal with the old format in Barbican
20:27:44 <jraim> you can probably reach out to whoever put in the PRs
20:28:05 <atiwari> ok
20:28:15 <atiwari> I will check
20:28:23 <jraim> https://review.openstack.org/#/c/98684/
20:28:58 <redrobot> #action atiwari will check with Heat team about changes to the Orders resource.
20:29:13 <atiwari> jraim, redrobot I will do
20:30:00 <redrobot> ok, that's all we have in the agenda for today.  Does anyone else have any questions/comments they'd like to bring up?
20:30:18 <redrobot> if not we can go back to watching the Germany game
20:30:41 <jvrbanac> I had a question about the spec regarding consuming keystone events
20:31:06 <redrobot> jvrbanac sorry about that
20:31:12 <redrobot> I had it in the Agenda and totally missed it
20:31:17 <redrobot> #topic Blueprint: Keysotne events
20:31:28 <redrobot> jvrbanac go ahead
20:31:33 <jvrbanac> #link https://review.openstack.org/#/c/99658/
20:31:42 <jvrbanac> It seems like this blueprint/spec really needs to be split up into two different blueprints. One to address how're going to accept Keystone events, and one to deal handling and processing of events.
20:31:54 <jvrbanac> thoughts?
20:32:35 <woodster__> agreed....there could be different choices for *how* to handle such events, ranging from full deletion as proposed in the blueprint, to a 'softer' approach, such as marking the project as suspended
20:33:06 <atiwari> jvrbanac, are you thinking about a framework to consume and processing two separate BP
20:33:07 <atiwari> ?
20:33:49 <atiwari> woodster__, we are only talking about soft delete
20:34:51 <jvrbanac> atiwari, I think my primary concern is that it feels like we're trying to pack to much into the bp. In reality the method of capturing keystone events is a discrete chunk on it's own
20:35:04 <jvrbanac> likewise with the processing of events
20:35:20 <atiwari> jvrbanac, I am OK with two BPs
20:35:41 <atiwari> but can we have two separate CR to address this BP ?
20:35:46 <atiwari> jvrbanac, ^
20:36:02 <atiwari> that way we can make it atomic
20:36:57 <atiwari> we can add multiple work items
20:37:30 <jvrbanac> atiwari, I think that works. I'm just trying to make sure that we can easily describe where we are going and what it takes to get there.
20:38:48 <redrobot> ok, so we're agreeing to keep the BP as is, but split implementation into two separate CRs
20:38:49 <redrobot> ?
20:38:59 <atiwari> great
20:39:22 <atiwari> I will update Arun as he is working on that part
20:39:28 <jvrbanac> redrobot, that should work.
20:39:47 <redrobot> ok, sounds good guys...
20:39:55 <woodster__> CAn I make comments about the restructure CR?
20:40:13 <woodster__> Really just to make folks aware of the change in the crypto flows
20:40:21 <redrobot> #topic Plugin restructure
20:40:25 <redrobot> woodster__ go ahead
20:40:44 <woodster__> This is the big restructure Ade, Nathan and I spoke of in Atl
20:41:10 <woodster__> So the framework was already laid last week, but this CR pulls the crypto stuff over:
20:41:13 <woodster__> #link https://review.openstack.org/#/c/103431/
20:41:24 <woodster__> I'm working on a fix to the broken unit test shortly....
20:41:43 <woodster__> Just wanted to make folks aware that it does change where the crypto related stuff lives
20:42:08 <woodster__> so we'll start to use the store_secret.py interface that Nathan put together as the 'outer' interface
20:42:28 <woodster__> If there are no questions about that, I'll work to fix that CR today for review
20:44:35 <woodster__> I think that ends this topic then, thanks!
20:45:03 <redrobot> alrighty
20:45:13 <redrobot> now, we're all out of agenda items
20:45:36 <redrobot> any more questions/comments?
20:47:11 <redrobot> ok then, that does it for this week.
20:47:41 <redrobot> We probably won't have an IRC meeting next week since we'll all be down at Geekdom for the mid-cycle meetup
20:47:47 <redrobot> thanks everyone!
20:47:51 <redrobot> #endmeeting