20:00:08 <redrobot> #startmeeting barbican
20:00:13 <openstack> Meeting started Mon Jul 21 20:00:08 2014 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:17 <openstack> The meeting name has been set to 'barbican'
20:00:35 <redrobot> #topic Roll Call
20:00:38 <chellygel> \o/
20:00:40 <jvrbanac> o/
20:00:45 <rellerreller> o/
20:00:54 <jvrbanac> _o/
20:01:07 <atiwari> o/
20:01:12 <tsv_> o/
20:01:30 <redrobot> Awesome!  Lots of barbicaneers here today. :)
20:01:40 <redrobot> As usual the agenda can be found here:
20:01:47 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican
20:03:08 <redrobot> Ok, let's get started!
20:03:21 <redrobot> #topic Launchpad Cleanup
20:03:46 <redrobot> So good news is that OpenStack Infra is going to be handling the release of Barbican for j2
20:04:31 <redrobot> So I've been trying to get launchpad cleaned up so that bugfixes/blueprints are correctly sorted by release
20:04:51 <redrobot> since this is how Infra is going to know what to put on the release notes
20:05:17 <redrobot> One thing I want to clean up is that we have 30+ blueprints and only a few SPEC files in review
20:06:25 <redrobot> I was going to do this last week, but atiwari was a bit confused for the unexpected closing of a BP
20:06:32 <redrobot> so I figured I'd wait and talk about it here.
20:06:56 <redrobot> I'm proposing to abandon Blueprints on Launchapd after 5 days without a corresponding SPEC file CR.
20:08:00 <atiwari> redrobot, IMO 5day are not enough I think 2 weeks are OK
20:08:04 <atiwari> thoughts?
20:08:06 <rellerreller> Is that a one time thing or going forward I need to have a spec within five days?
20:08:29 <redrobot> I would like to have it going forward
20:08:33 <rellerreller> OK
20:08:42 <redrobot> I'm trying to avoid having tons of blueprints without any work being done on them
20:08:58 <rellerreller> I think five days is good. I feel like both should be submitted at the same time.
20:09:11 <rellerreller> I don't see much value in a BP without a spec.
20:09:58 <redrobot> atiwari I think two weeks would be too long...  I think if it takes more than 5 days to draft the Spec, then maybe you should wait to open the Launchpad BP
20:10:18 <atiwari> redrobot, reopening the closed BP is possible ?
20:10:29 <atiwari> redrobot, OK
20:10:48 <redrobot> atiwari Yes, I would consider reopening Blueprints when a Spec is submitted
20:10:56 <atiwari> +1
20:11:09 <redrobot> atiwari awsome! :)
20:11:33 <redrobot> anyone else have any comments?
20:14:03 <redrobot> ok, in that case
20:14:24 <tsv_> redrobot, will the 5 days limit be applied even if nobody looked/commented on the blueprint ?
20:14:53 <redrobot> tsv_ the purpose of the SPEC file is for people to be able to comment on them.
20:15:25 <redrobot> tsv_ IMO a Launchpad BP is just used for tracking progress, but discussion should happen on the Spec CR.
20:15:35 <atiwari> redrobot, I think tsv_ has raise a valid question
20:15:57 <atiwari> IMO there has to be some somments in BP it self.
20:16:12 <atiwari> that will save sometime.
20:16:25 <redrobot> atiwari no, we all agreed that the spec repo would be used for comments.
20:16:30 <atiwari> somments/ comments
20:16:39 <tsv_> redrobot, atiwari, thanks. so the blueprint is only for tracking with launchpad ?
20:16:43 <redrobot> Launchpad does not lend itself for good conversations the way Gerrit does.
20:17:07 <redrobot> tsv_ Yes, Blueprints is just for tracking status, so that we know what BP go into each release.
20:17:14 <tsv_> ok
20:17:18 <redrobot> tsv_ all comments should be done on the spec repo
20:18:14 <tsv_> redrobot, got it
20:19:27 <redrobot> ok, any more questions/comments? ...
20:20:59 <redrobot> ok, then
20:21:27 <redrobot> #agreed We'll abandon Launchpad Blueprints after 5 days without a corresponding Spec CR.
20:21:33 <redrobot> moving on
20:21:38 <redrobot> #topic Juno 2
20:21:54 <redrobot> As you may know, the next milestone release will happen this week.
20:22:00 <redrobot> https://launchpad.net/barbican/+milestone/juno-2
20:22:35 <redrobot> There are a couple of pending items that I wanted to check the status on
20:23:21 <redrobot> Adam Harwell is waiting on reviews for the service-to-container registration https://review.openstack.org/#/c/107845/
20:23:39 <redrobot> So, if you guys could take some time after this meeting to review, that would be awesome.
20:23:48 <redrobot> If we can't get this merged today, I'll bump it to J3
20:24:18 <atiwari> redrobot, I will look in to it
20:24:31 <redrobot> atiwari you have a pending CR for a bugfix with a -1 review https://review.openstack.org/#/c/99967/
20:24:46 <redrobot> atiwari do you think you'll be able to address the -1 today?
20:24:58 <redrobot> If not, I can kick that bugfix to J3
20:25:21 <atiwari> redrobot, I will look at it too
20:25:30 <redrobot> atiwari awesome, thanks!
20:26:04 <atiwari> redrobot, as per Steve Heyman comments, he want it to be handled in Pecan
20:26:11 <atiwari> https://review.openstack.org/#/c/99967/3/barbican/api/app.py
20:26:24 <atiwari> in that case nothing for me to do
20:26:56 <redrobot> atiwari There was also a comment about adding a Bug # to the commit message, I think?
20:27:07 <atiwari> hmm
20:27:31 <redrobot> I think Steve Heyman is out for the afternoon, so I may have to kick this to J3 after all...
20:27:49 <atiwari> redrobot, I think Closes-Bug #1326481 is there
20:27:50 <uvirtbot> Launchpad bug 1326481 in barbican "406 response when Accept header is application/json on DELETE requests" [Medium,In progress] https://launchpad.net/bugs/1326481
20:27:55 <atiwari> let make it J3
20:28:11 <redrobot> atiwari ok, will do.
20:28:31 <redrobot> also Arun Kant has an open CR with negative reviews for a bugfix https://review.openstack.org/#/c/98926/
20:28:56 <redrobot> is Arun here?
20:29:09 <atiwari> redrobot, I will check with Arun on that one
20:29:20 <atiwari> I think he is not in the meeting
20:29:38 <redrobot> atiwari ok, thank you... same goes for him about J3.  If he can't get to it we can just push to J3.
20:29:49 <atiwari> ok
20:30:30 <redrobot> ok guys, that's all I had on the agenda for today.  Does anyone else have something they would like to talk about?
20:30:50 <atiwari> redrobot, Can we start reviewing https://review.openstack.org/#/c/87405/.
20:31:54 <redrobot> atiwari sure, I'll try to take a look at it today.
20:32:02 <atiwari> redrobot, thanks
20:32:46 <tsv_> redrobot, for the tenant-id removal from uri, I have updated https://review.openstack.org/#/c/105562 with answers to many of the comments. could we please have more reviews while i work on rebasing the next patch ?
20:33:47 <redrobot> tsv_ looks like it's failing on a couple of gates.
20:34:13 <tsv_> redrobot, yep - am working on fixing that
20:34:35 <redrobot> tsv_ I usually don't review patches unless all gates are passing, since it can't be merged that way.   I'll take a look once Jenkins gives it a +1
20:35:30 <tsv_> redrobot, i understand. i meant the answers to the existing comments
20:35:44 <tsv_> and thanks
20:36:10 <redrobot> tsv_ If I have time I'll try to take a look.
20:36:22 <tsv_> redrobot, excellent. thanks
20:38:41 <redrobot> Ok, guys, if no one else has anything to talk about we can call it an early meeting.
20:41:12 <woodster__> An FYI that I put up a blueprint CR for modifying version resource info
20:41:32 <woodster__> ....so we can move away for hardcoded versions in our service catalogs at some point
20:41:51 <woodster__> https://review.openstack.org/#/c/108163/
20:42:51 <redrobot> woodster__ cool.  will take a look as soon as I can
20:43:02 * redrobot is going to be busy reviewing stuff all week... >_<
20:43:36 <woodster__> Yeah, the M3 milestone is the bigger one, so August will be even busier I think
20:44:15 <redrobot> for sure...
20:46:55 <redrobot> ok guys, that wraps it up for this week.  thanks everyone for coming!
20:47:04 <redrobot> #endmeeting