20:00:02 <redrobot> #startmeeting barbican
20:00:03 <openstack> Meeting started Mon Aug  4 20:00:02 2014 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:06 <openstack> The meeting name has been set to 'barbican'
20:00:30 <redrobot> As usual the meeting agenda can be found here:
20:00:32 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican
20:00:37 <redrobot> #topic Roll Call
20:00:43 <jvrbanac> _o/
20:00:45 <reaperhulk> o/
20:00:45 <hockeynut> o/
20:00:49 <SheenaG1> o/
20:00:52 <tsv> o/
20:00:52 <chellygel> \o/
20:00:53 <rellerreller> o/
20:00:56 <alee> o/
20:00:57 <sicarie> o/
20:00:59 <kaitlin-farr_> o/
20:01:01 <paul_glass> o/
20:01:26 <woodster_> o/
20:01:31 <lisaclark1> o/
20:01:36 <woodster_> \o
20:01:50 <redrobot> woohoo!  lots of barbicaneers here today
20:02:06 <redrobot> ok, let's get this started
20:02:15 <redrobot> #topic #openstack-barbican in eavesdrop
20:02:35 <redrobot> ok, so I added this to the agenda
20:02:50 <redrobot> just wanted to make sure that everyone is aware that #openstack-barbican is now being logged by infra
20:02:53 <redrobot> #link http://eavesdrop.openstack.org/irclogs/%23openstack-barbican/
20:03:17 <redrobot> it should hopefully make it easier to keep track of conversations if you're not idling on the channel all the time
20:04:05 <redrobot> any questions/comments?
20:04:37 <rellerreller> How long are the logs around before they are deleted?
20:04:50 <redrobot> rellerreller good question!  I don't know the answer to that
20:05:23 <woodster> just watch what you say now folks :)
20:05:33 <redrobot> lgos on some channels go back futher than a year... so quite some time apparently
20:06:01 <redrobot> yes... now people will have proof that reaperhulk is a jerk. :-P
20:06:28 <kaitlin-farr_> whoaa openstack-meeting goes back to 2010
20:06:52 <woodster> do an expletives search...
20:07:39 <redrobot> kaitlin-farr_ wow... isn't that older than openstack itself?!
20:08:11 <redrobot> well... that's about all I have on the agenda for today... I'll open up the floor for any topics you guys feel we need to talk about
20:08:37 <hockeynut> a search for expletives should give http 413 :-)
20:09:38 <SheenaG1> Unrelated to expletives - rellerreller and kaitlin-farr_ - are you guys still working on integrating Barbican into the encryption work you had done?  I apologize if this is old news, I've been out of the loop for a while.
20:10:09 <rellerreller> Yes, we are still working on that
20:10:13 <kaitlin-farr_> SheenaG1, yup!
20:10:36 <woodster> rellerreller: is that planned for Juno?
20:10:38 <rellerreller> It's not totally unrelated. There are some expletives dropped while doing the dev
20:10:55 <SheenaG1> Ha!
20:10:58 <rellerreller> We would like to have this done in Juno. I don't know if it will happen.
20:10:59 <SheenaG1> I believe that.
20:11:21 <rellerreller> We are working on integrating Barbican into Nova. Getting anything into Nova is quite difficult.
20:11:21 <woodster> rellerreller: the infra plugin also records conversations, so yes, we know
20:12:21 <SheenaG1> Fair enough - I was just curious since we hadn't kicked the thread in a bit.  :-)
20:12:21 <redrobot> #topic JPL update
20:12:25 <woodster> rellerreller, kaitlin-farr: are you guys planning to have KMIP ready in juno?
20:12:29 <rellerreller> We had someone out at the Nova mid-cycle meetup. There is some resistance to integrate a Barbican key manager until Barbican is fully integrated.
20:12:38 <bubbva> sorry, I'm here, just was reading email. o/
20:12:42 <redrobot> #agreed It is quite difficult to merge patches into nova
20:13:02 <rellerreller> Topic change to APL not JPL. JPL is a competitor.
20:13:15 <SheenaG1> We're working on it...  redrobot has promised to deliver unto us the integration requirements from the TC
20:13:18 <redrobot> #topic APL Update
20:13:37 <rellerreller> Thanks, redrobot :)
20:13:46 * redrobot nods
20:13:50 <jaosorior> What's barbican missing to get integrated?
20:14:24 <redrobot> jaosorior I think it's a requirement to be incubated for a full cycle before asking for integration
20:14:46 <redrobot> last I heard jraim__  was going to ask the TC about integrating in the K release
20:15:04 <redrobot> we also want to have a stable api
20:15:17 <SheenaG1> I believe that's still the plan, although we'll have to start working with them well in advance to land it
20:15:23 <redrobot> so we definitely want to land breaking changes like Arvind's refactor of orders
20:15:23 <SheenaG1> them == TC
20:15:50 <redrobot> also removing the Tenant ID from the URL needs to land
20:15:59 <redrobot> and we really should stabilize the client
20:16:08 <tsv> redrobot, o/
20:16:18 <redrobot> tsv yes?
20:16:22 <tsv> for the tenant-id removal work, i reviewed the associated client changes required. it is minimal and I have locally updated few tests for it. shall i go ahead and submit the code for review ?
20:16:42 <redrobot> tsv for the client?  yes, that would be awesome
20:17:14 <tsv> redrobot, sure, will do. thanks. is there a CR already open ? if not i will create one
20:18:12 <redrobot> tsv I don't think anyone has done any work in the client related to the tenant-id removal.  You should be able to open a new CR for that.
20:18:25 <tsv> thanks. will do
20:18:31 <atiwari> tsv, is it for client change due to tenant-id removal ?
20:18:42 <tsv> atiwari, yes
20:18:47 <atiwari> great
20:19:18 <redrobot> rm_work wanna talk about that comment?
20:19:40 <redrobot> #topic Argument pass-through using **kwargs
20:19:42 <rm_work> err, not sure if that's really a topic for this meeting, but
20:19:52 <rm_work> I'll definitely plug my review :P
20:19:58 <rm_work> https://review.openstack.org/#/c/107845/
20:20:04 <redrobot> well we ran out of agenda items, and it would be good to talk about since we have everyone here
20:20:08 <rm_work> heh
20:20:38 <rm_work> Arvind's suggestion was to pass the repo's through as kwargs instead of explicitly, if they are needed in a sub-resource but not in that resource specifically
20:20:40 <redrobot> rm_work it's much easier than having you chase everyone down for the next couple of days ;)
20:20:49 <rm_work> (see containers.py passing consumerRepo through to consumers.py)
20:21:06 <rm_work> it's only needed for the Mocks in the unit tests
20:21:22 <rm_work> but since Consumers it is a sub-resource of Containers, I need to pass the resource through
20:21:29 <rm_work> can this be done via kwargs?
20:21:47 <rm_work> I don't think so? since kwargs would come in to the _init_ and they aren't USED until the index function
20:21:58 <rm_work> or the on_get (depending on if we've updated to that method)
20:22:19 <rm_work> so I'd have to like… store the kwargs and pass them back through later, and it looks really ugly
20:22:37 <redrobot> #link https://review.openstack.org/#/c/107845/16/barbican/api/controllers/containers.py
20:22:43 <redrobot> line 38
20:23:30 <rm_work> although to be fair I think possible secret_repo isn't needed in that first one, but I need to double-check
20:23:40 <rm_work> that's kind of beside the point tho
20:24:32 <alee> redrobot, rm_work, woodster  - I thought that there was a plan to replace these repo arguments with factory methods to get the repos as needed.
20:25:09 <woodster> alee: that's correct
20:25:21 <woodster> hopefully will do so in the next week or so
20:25:44 <alee> rm_work, redrobot then this issue about kwargs etc. will go away very soon.
20:25:53 <woodster> ...and then get rid of that context object passed into the secret_store methods
20:26:15 <rm_work> ok
20:26:24 <rm_work> so, could we move forward with my change then? :)
20:26:30 <rm_work> +2s all around? :P
20:26:37 <redrobot> yeah... seems it would be easier to leave this CR as is and then address the repos later when we refactor with factory methods
20:26:40 <rm_work> and it can be fixed as part of that refactor?
20:26:59 <redrobot> atiwari does that sounds like a reasonable plan?
20:27:03 <jaosorior> I dig the factory idea
20:27:18 <atiwari> rm_work, please add a code improvement bug and add in the code
20:27:26 <atiwari> for place holder
20:27:39 <rm_work> T_T
20:27:46 <atiwari> redrobot, what do you say?
20:27:51 <rm_work> atiwari: if I have to "recheck no bug" this another 8 times I will cry
20:28:10 <rm_work> speaking of, did that make it onto the agenda?
20:28:14 <rm_work> I may have missed it
20:28:36 <atiwari> rm_work, just add come comment IMO
20:28:40 <redrobot> rm_work nope, only thing on the agenda was the barbican channel being logged in eavesdrop
20:28:44 <rm_work> ok
20:28:57 <rm_work> I would like to mention that the dsvm tests are really broken
20:29:12 <redrobot> k, we'll talk about that next
20:29:15 <rm_work> they are failing for no discernible reason
20:29:36 <rm_work> i think chellygel was seeing it too?
20:29:52 <redrobot> #action rm_work to add TODO to consumer registration CR for repo-factory-refactor
20:29:55 <rm_work> though I see it much more often because the issue is with the tempest tests and my change has more than double the amount of tests in Master :P
20:30:11 <chellygel> anyone running stuff through zuul on friday would've dealt with it rm_work
20:30:20 <rm_work> chellygel: so is it fixed now:?
20:30:50 <rm_work> i haven't run more checks since
20:30:56 <rm_work> anyway, I will do that
20:31:04 <rm_work> thanks, have to run to another meeting :(
20:31:04 <chellygel> yeah from what i can see, jvrbanac made some changes to tox and its bueno now
20:31:04 <redrobot> #topic dsvm tests are too fragile
20:31:18 <rm_work> chellygel: err, I was seeing the issue well after that
20:31:25 <reaperhulk> the fixes jvrbanac did were to fix a separate testr issue
20:31:30 <rm_work> I think it is something wrong with the build process
20:31:32 <rm_work> for the VM
20:31:35 <rm_work> not sure though
20:31:41 <hockeynut> that seems to be happening more and more often
20:31:52 <rm_work> all I know is that random tempest tests are getting failures that look more network related than test related
20:32:04 <rm_work> and really sorry, but I do have a meeting right now, bad scheduling T_T
20:32:35 <redrobot> rm_work k, noted the dsvm failures... not sure if we can do anything about them
20:32:37 <reaperhulk> unfortunately those problems are likely to be issues with the performance of the host underlying the VM and tempest itself
20:32:38 <rm_work> :(
20:33:04 <redrobot> #agreed recheck no bug x8 is not fun
20:34:19 <redrobot> ok, so I guess we can move on to another topic if anyone else has something to talk about
20:34:24 <redrobot> if not we can call it an early meeting
20:34:31 <atiwari> redrobot, woodster I have broken my cr for order type in to two #link https://review.openstack.org/#/c/111412/. can we start review? :)
20:34:57 <atiwari> this is one based on woodster comments
20:35:03 <redrobot> +463 looks much better than +980
20:35:19 <redrobot> atiwari thanks for splitting that up
20:35:41 <atiwari> ok,  if we can make some progress that wd be great :)
20:36:09 <redrobot> atiwari we're all heads down on some work here at the rack, so we may not be able to get you reviewed until tomorrow
20:36:25 <atiwari> tomorrow if OK
20:36:29 <redrobot> we definitely want to merge the order types soon
20:36:48 <woodster> atiwari: thanks for you work there btw!
20:36:58 <atiwari> redrobot, woodster np
20:37:28 <jaosorior> Well, if people have time these days to review the moving of the client to cliff it would be cool https://review.openstack.org/#/c/107587/ might even help for integration
20:37:41 <redrobot> ok guys, sounds like we don't really have anything else to talk about, except getting code reviewed
20:38:13 <redrobot> so let's call it a meeting and go review some code!
20:38:14 <redrobot> :D
20:39:40 <redrobot> thanks everyone for coming
20:39:47 <redrobot> #endmeeting