#openstack-meeting-alt: barbican

Meeting started by redrobot at 20:01:04 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Barbican (redrobot, 20:01:50)

  1. Roll Call (redrobot, 20:03:01)
  2. CR Sizes (redrobot, 20:05:07)
    1. AGREED: please try to keep CRs small. Big CRs take time to review, and slow down things for everyone. (redrobot, 20:08:12)

  3. String interpoation in logging calls (redrobot, 20:09:22)
    1. AGREED: Prefer new-style formatting everywhere, except for logging. (redrobot, 20:17:21)
    2. AGREED: Logging should be done using old-style formatting, passing the values as arguments to the log call (redrobot, 20:17:45)

  4. Python 3 support (redrobot, 20:18:22)
    1. https://github.com/openstack/swift/blob/master/tox.ini (reaperhulk, 20:30:18)
    2. ACTION: reaperhulk to add a py3pep8 tox job (redrobot, 20:35:01)

  5. Plugin Validation (redrobot, 20:41:49)
    1. https://etherpad.openstack.org/p/barbican-validation-options (woodster_, 20:41:58)
    2. https://etherpad.openstack.org/p/barbican-validation-options (redrobot, 20:41:58)
    3. https://review.openstack.org/#/c/116725/ (py3pep8 tox job) (reaperhulk, 20:56:40)


Meeting ended at 21:00:19 UTC (full logs).

Action items

  1. reaperhulk to add a py3pep8 tox job


Action items, by person

  1. reaperhulk
    1. reaperhulk to add a py3pep8 tox job


People present (lines said)

  1. redrobot (56)
  2. reaperhulk (33)
  3. woodster_ (30)
  4. rellerreller (21)
  5. alee (21)
  6. jvrbanac (5)
  7. openstack (3)
  8. rm_work (2)
  9. SheenaG11 (1)
  10. chellygel (1)
  11. kaitlin-farr (1)


Generated by MeetBot 0.1.4.