20:00:21 <redrobot> #startmeeting barbican
20:00:22 <openstack> Meeting started Mon Dec  1 20:00:21 2014 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:25 <openstack> The meeting name has been set to 'barbican'
20:00:35 <redrobot> #topic Roll Call
20:00:42 <tkelsey> o/
20:00:45 <dave-mccowan> o/
20:00:52 <woodster_> 0/
20:00:53 <atiwari> o/
20:00:54 <chellygel> ^( ^___^ )>
20:01:04 <jvrbanac> _o/
20:01:15 <redrobot> jvrbanac you're alive!
20:01:20 <jvrbanac> redrobot, yes
20:01:31 <jaosorior> o/
20:01:49 <redrobot> awesome, lots of barbicaneers today
20:01:59 <redrobot> as usual the agenda can be found here:
20:02:01 <rm_work> o/
20:02:01 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican
20:02:13 <redrobot> #topic Kilo Blueprints
20:02:19 <redrobot> I'm not sure who added this topic, but I agree
20:02:33 <woodster_> I added it
20:02:36 <redrobot> I think we need to get some BPs approved soon
20:02:56 <woodster_> Just curious if a video mini-meetup could help with the review proces
20:03:15 <jaosorior> that would be a good idea, probably will speed things up
20:03:16 <woodster_> some of these BPs are heavy
20:03:22 <hyakuhei> o/ - sorry I'm late
20:03:32 <atiwari> woodster_, +1
20:04:07 <alee> woodster_, +1
20:04:19 <redrobot> I think that is something we would want to do this week.
20:04:29 <woodster_> hyakuhei, we were just talking about maybe having a video meeting to review some of the bigger blueprints out there
20:04:30 <redrobot> with the holidays around the corner, I'm concerned that BPs are going to slip into next year
20:04:47 <hyakuhei> oh cool, that'd be a nice way to tie things up before the holidays
20:05:28 <jaosorior> redrobot: I can see that happening :/
20:05:46 <alee> woodster_, yup - I'd like to get through the BP's before the holidays.
20:06:15 <alee> later this week?
20:06:18 <redrobot> Kilo Milestone 1 is coming up in about two weeks
20:06:26 <redrobot> #link https://wiki.openstack.org/wiki/Kilo_Release_Schedule
20:06:43 <jaosorior> for me, the earlier the better
20:06:45 <redrobot> and as of now, we don't actually have any code for the milestone
20:06:48 <jaosorior> or beginning of next week
20:06:48 <redrobot> #link https://launchpad.net/barbican/+milestone/kilo-1
20:07:07 <hockeynut> SSL (sorry so late) - starbucks wifi was acting up
20:07:12 <alee> redrobot, do we have goals for the milestone?
20:07:27 <woodster_> redrobot: maybe because Juno's code was so good?
20:07:29 <redrobot> alee I would have liked to see at least _some_ blueprints land
20:07:35 <redrobot> woodster_ lol
20:08:13 <alee> redrobot, so can we set up a video conference for later this week?
20:08:43 <jaosorior> what about Monday next week? :D
20:08:44 <redrobot> alee yes, I think early AM in CST would be ok for our folks across the pond?
20:08:44 <woodster_> google hangouts perhaps?
20:09:41 <jaosorior> or if it's in the morning in the US, then it could work
20:09:49 <jaosorior> this week
20:10:30 <hyakuhei> Would BP's be useful for plugins too ? We've been building a KMIP secret store that is similar to the MKEK PKCS8 plugin
20:10:54 <tkelsey> +1
20:11:00 <redrobot> hyakuhei yes, a BP would be the first step for adding a new plugin
20:11:14 <hyakuhei> ok, we'll get that written up
20:13:00 <redrobot> jaosorior how does 4pm UTC sound for you?
20:13:15 <redrobot> I'm thinking Wednesday morning
20:13:24 <redrobot> to give people a chance to catch up on BPs today and tomorrow?
20:13:27 <redrobot> #link http://time.is/1000AM_3_Dec_2014_in_CST/EST/UTC
20:14:13 <jaosorior> just one hour earlier would fit perfectly for me
20:14:33 <redrobot> jaosorior that cuts into my sleeping time, but I think it would work
20:14:53 <redrobot> #link http://time.is/900AM_3_Dec_2014_in_CST/EST/UTC/London
20:14:54 <woodster_> I'll have to miss the first part of that meeting if at 9am
20:15:08 <hockeynut> ^ ditto ^
20:15:17 <rm_work> redrobot: would you want my Castellan Certificate handling BP in by then? or are you really just referring to the Barbican stuff that's in the backlog now
20:15:20 <jaosorior> oh :/
20:15:47 <jaosorior> My last bus out of the office leaves at 4pm UTC, that's why I said it would fit nicely
20:16:14 <redrobot> rm_work just barbican stuff.  Castellan is still waiting to be created...
20:16:19 <rm_work> kk :)
20:16:32 <alee> redrobot, there are something like 16 specs that are out there right now - that will make for a pretty long meeting.
20:17:23 <redrobot> alee I don't think we'd want to cover everything... maybe just timebox it?  Or pick the ones that have the most disagreement
20:18:17 <redrobot> woodster_ hockeynut is 9am doable another day?  Maybe Thursday?
20:18:24 <atiwari> redrobot, can somebody please update the video meeting details on our meeting page?
20:18:44 <redrobot> atiwari sure thing, as soon as we figure it out I'll add it to the meeting page
20:18:52 <hockeynut> thurs is ok for me.  driving down to Castle tomorrow, won't be there before 9:30
20:19:01 <woodster_> thurs works for me too
20:19:12 <jaosorior> same here
20:19:18 <alee> me too.
20:19:18 <redrobot> hockeynut I was proposing 9am for wednesday.  Tomorrow is no good for me either.
20:19:44 <redrobot> but it seems Thursday will work for everyone...
20:20:09 <hockeynut> redrobot thurs is still better for me :-)
20:20:16 <redrobot> I really would like to see some movement in the BPs before then though
20:20:28 <redrobot> ie, I don't want everyone to just wait til Thursday to go look at them :)
20:21:02 <alee> redrobot, it would be nice if we identified a list of BPs we were going to look at.  that way we can get folks to look at them before thurs.
20:21:07 <atiwari> alee,  are we going to hash out all BPs in one day?
20:21:20 <alee> atiwari, I think thats unlikely
20:21:22 <redrobot> alee surely.  I'll be cleaning up https://blueprints.launchpad.net/barbican because it's a mess right now
20:21:30 <atiwari> alee, +1
20:22:05 <redrobot> alee I think we can go down the list by priority? ... once I clean that up that is.
20:22:26 <alee> redrobot, we may need a couple of these meetings.  maybe one this week and one the next.  but by priority sounds fine by me.
20:22:26 <atiwari> in that case I think we should prioritize and add the BP link in the meeting page along with details?
20:22:27 <jaosorior> +1 for having it prioritized
20:22:34 <atiwari> +1 redrobot
20:23:22 <redrobot> #action redrobot to clean launchpad blueprint page
20:23:41 <redrobot> #action redrobot to fill in details of Google hangout on Wiki
20:24:27 <redrobot> #agreed Google hangout will be Thursday 3pm UTC http://time.is/900AM_4_Dec_2014_in_CST/EST/UTC
20:25:07 <redrobot> I think that wraps up this topic
20:25:16 <redrobot> And I don't have anything else on the agenda.
20:25:29 <redrobot> Does anyone have anything they would like to discuss?
20:25:44 <redrobot> Maybe clear up questions about BPs?
20:25:46 <kaitlin-farr> Do we know when the mid-cycle meetup will be?
20:25:53 <jaosorior> aaah, true that
20:25:57 <redrobot> #topic Mid-cycle meetup
20:26:06 <redrobot> I'm still trying to figure out the details
20:26:18 <jaosorior> Are we still gonna try to do it somewhat aligned to Keystone and OSSG?
20:26:31 <redrobot> Keystone is having their meetup in San Antonio in the middle of January
20:26:48 <redrobot> OSSG wants to have theirs in the bay area in mid-February
20:27:01 <jaosorior> ah damn
20:27:19 <jaosorior> well... If we do it in SAT, would it be possible for OSSG to reconsider?
20:27:48 <redrobot> last OSSG meeting I went to everyone was pretty much set on SF
20:28:29 <redrobot> I'm also waiting to hear about budget from the Rack... I don't know how many of us would make it out to SF if we were to have it there
20:29:01 <redrobot> kaitlin-farr I guess to answer your question, I would prefer mid-february.  It would be right after Kilo-2 milestone
20:29:37 <jaosorior> What days is the OSSG meeting?
20:29:56 <kaitlin-farr> Ok, I had heard a rumor it might be mid-January, but mid-February works better for me at least, not sure about Nate
20:30:09 <woodster_> March 5th is Kilo feature proposal freeze, so I think Feb is late to have a barbican mid cycle
20:30:10 <redrobot> jaosorior they don't have a set date yet.  I'm waiting to hear back from Geekdom SF about space availability.  Dates will depend on that.
20:30:23 <hyakuhei> So, there was a lot of love for SF from OSSG and the Barbican folks that were at our meeting
20:30:37 <hyakuhei> Waiting for redrobot on availability :)
20:30:58 <hyakuhei> Because we had a fair number of people who wanted to attend both, butting OSSG up against Barbican made a bunch of sense
20:31:07 <hyakuhei> Especially for people outside the US
20:31:24 <hyakuhei> but as always we are willing to bend to the will of the wider community
20:31:34 <redrobot> I agree.  I think we have more overlap between OSSG/Barbican than Keystone/Barbican
20:31:53 <redrobot> woodster_ I would hope we have our features figured out before the mid-cycle.
20:32:07 <jaosorior> I agree with woodster_ that feb late, but whatever fits you guys
20:33:04 <alee> woodster_, I would hope that we end up using the midcycle to whip through implementation CR reviews .. in which case, feb may not be that late.
20:33:13 <woodster_> redrobot, yeah hopefully we'll be more hacking to make progress on features by then
20:33:23 <woodster_> alee, that's true
20:33:31 <jaosorior> So SF it is?
20:34:02 <alee> besides SF is cooler :)
20:34:03 <jaosorior> for me it's the same thing, still a long ass trip :P, so whatever you guys prefer
20:34:11 <redrobot> lol
20:34:21 <jaosorior> as long as you promise me excellent mexican food I'm happy haha
20:34:48 <jaosorior> (had to bring it up)
20:34:51 <redrobot> for me it would be much easier in SA, since I don't have to ask for a budget to send a ton of folks away...  but I think most people prefer SF
20:34:53 <rm_work> hmm, easier to promise that in SA than SF I think <_<
20:35:17 <alee> redrobot, woodster_ keystone tries to have their meeting early because they want to get changes in early so people can integrate with them.
20:35:36 <alee> eventually we probably want to go to the same model - but we're not there yet
20:35:44 <woodster_> alee, that makes sense
20:35:59 <rm_work> I would like some of your changes to get in early so I can interface with them <_<
20:36:05 <dg__> alee +1
20:36:20 <alee> I have no preference either way on location - though I suspect SA will be easier on the budget.
20:36:30 <alee> rm_work, me too :)
20:37:36 <jaosorior> Will it take you guys long to figure out the budget thing? Maybe that can be sorted out for next week (or something) and once that's done, then a decision can be made
20:37:39 <redrobot> ok, I'll update you guys as soon as I hear back from Geekdom
20:37:57 <hyakuhei> redrobot: me too please :)
20:38:04 <rm_work> good luck getting RS to commit to a budget this far ahead of time (or ever) :P
20:38:12 <redrobot> hyakuhei for sure :)
20:38:54 <woodster_> I think those SF hotels are what stress out that budget :)  All sharing a room is not an option...
20:39:27 <hyakuhei> Freemont has some very nicely priced hotels :P
20:39:36 <redrobot> If we decide to do SF it will just mean some Barbicaneers will have to teleconference in
20:39:57 <redrobot> maybe set up a Geekdom-to-Geekdom link :-O
20:39:58 <dg__> hyakuhei is that the place you've been complaining about the hotels for the last 3 years?
20:40:05 <jaosorior> well, for the people not in SAT, how does things look for you?
20:40:13 <kaitlin-farr> Ok, just to clarify, if the meeting is in SA, will it probably still be in mid-February, even if it doesn't line up with Keystone?
20:40:42 <jaosorior> does it make any difference? (the place)
20:40:45 <hyakuhei> kaitlin-farr: That's my understanding
20:40:58 <hyakuhei> Either way the ambition is to have OSSG and Babrican run together
20:41:12 <hyakuhei> and it's just nuts to try mixing three projects in
20:41:25 <jaosorior> well... I don't think it's a bad idea to have the three consecuently
20:41:33 <jaosorior> but I do think it's hard
20:41:49 <alee> hyakuhei, if thats the case, though - then it makes sense to have it with ossg -- which means sf, right?
20:41:55 <hyakuhei> Especially hard for those of us with families etc who aren't based from the area
20:42:03 <hyakuhei> alee: That's the preference
20:42:52 <redrobot> kaitlin-farr yes, that's the plan so far
20:43:12 <redrobot> alee hyakuhei +1
20:43:44 <kaitlin-farr> ok, thanks! I know it's all still tentative at this point, but it's helpful for planning
20:45:01 <redrobot> I should also point out that the mid-cycle is not mandatory.  The TC has been discussing mid-cycles the last few weeks and they want to make sure that mid-cycles don't turn into mini-summits.
20:45:25 <jaosorior> redrobot: then again, last one was extremely useful to get things done
20:45:28 <hyakuhei> redrobot: Interesting, so from a cost pov I understand that
20:45:47 <hyakuhei> but actually that's what they are (imho) and we (OSSG/Barbican/whoever) get a crap-tonne done
20:47:04 <redrobot> yeah, it's been interesting to watch the TC discussions about it.  They're concerned that mid-cycles may be a symptom of bad Design Summits
20:47:22 <hyakuhei> +1000 to that
20:47:45 <hyakuhei> However, fixing the complete mess of the last design summit would be a good start to avoiding 'mini-summits'
20:47:55 <redrobot> lol, I agree
20:47:58 <hyakuhei> sorry, I get ranty past 8pm
20:48:10 <redrobot> no prob...
20:48:18 <redrobot> I think we've beaten this topic to death
20:48:22 <rm_work> to be fair, there really isn't enough time during the actual Design Summits to get actual design/work done <_< so much presenting and such
20:48:25 <redrobot> anything else that we want to discuss?
20:48:49 <hyakuhei> Just a note to those who are interested in Ephemeral PKI stuff
20:49:03 <hyakuhei> We've named it "anchor" and it should be landing in stackforge this week
20:49:16 <hyakuhei> That's all :)
20:49:44 <redrobot> awesome, I think rm_work  was looking for that
20:50:16 <rm_work> thanks :) yeah
20:50:18 <rm_work> I'll take a look
20:50:22 <hyakuhei> We've got a few things to tidy up but we figured we get our laundry out in the open asap
20:51:16 <redrobot> cool
20:51:20 <redrobot> I think we can call it a day
20:51:26 <woodster_> So I'm curious about the Kite project then...I meant to ask at the summit about it, but was constantly distracted :)
20:51:29 <redrobot> thanks everyone for coming.  See you all Thursday
20:51:38 <hyakuhei> Thanks
20:51:46 <hyakuhei> woodster_: ping tkelsey re: kite
20:51:53 <jaosorior> excellent
20:51:55 <jaosorior> see ya people
20:51:57 <woodster_> hyakuhei, will do
20:52:05 <redrobot> #endmeeting