20:00:58 <redrobot> #startmeeting barbican
20:00:59 <openstack> Meeting started Mon Dec  8 20:00:58 2014 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:03 <openstack> The meeting name has been set to 'barbican'
20:01:20 <jaosorior> o/
20:01:21 <redrobot> #topic Roll Call
20:01:25 <tkelsey> o/
20:01:25 <woodster_> o/
20:01:26 <hyakuhei> o/
20:01:29 <rm_work> o/
20:01:34 <dave-mccowan> o/
20:01:40 <elmiko> o/
20:01:45 <jvrbanac> o/
20:01:52 <lisaclark_> o/
20:02:27 <redrobot> awesome, as usual the agenda can be found here:
20:02:30 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican
20:02:45 <rellerreller> o/
20:03:11 <redrobot> #topic Integration Docs
20:03:30 <redrobot> #link https://wiki.openstack.org/wiki/Barbican/Documentation
20:03:50 <redrobot> I wanted to share the above link with everyone
20:04:03 <redrobot> I put this together a few weeks ago as I was looking into documentation requirements for integration
20:04:23 <redrobot> we have a ton of documentation that needs to be written for integration
20:05:04 <redrobot> and I wanted to bring that up here to see if we can find people who have time/would like to contribute to the docs
20:05:24 <redrobot> I think this is going to be a big topic of discussion during the integration review...
20:05:50 <redrobot> ... but also as a side note, the integration review may not even happen if the Big Tent changes land during this cycle
20:05:54 <redrobot> #link https://review.openstack.org/#/c/138504/
20:06:35 <rellerreller> What are the "Big Tent" changes?
20:06:52 <alee_> o/
20:06:56 <tkelsey> rellerreller: good question
20:07:16 <redrobot> rellerreller the linked CR summarizes them pretty well...  basically , right now you are either part of the integrated release (and thus part of openstack) or you're not
20:07:21 <SheenaG1> o/
20:07:32 <redrobot> and if you're not, then chances are you're working towards being part of the integrated release (as we are)
20:08:11 <redrobot> the TC is proposing a change which will add more categories besides just being part of the integrated release
20:08:33 <redrobot> and the integrated release will eventually go away, in favor of new "labels" that are yet to be defined
20:08:44 <redrobot> rellerreller is that clear as mud? :)
20:09:13 <jaosorior> ... aaaand, how does that affect us?
20:09:30 <rellerreller> redrobot I will have to look through the spec. Clear as mud now.
20:09:32 <redrobot> jaosorior it's not really clear how it will affect us just yet.
20:09:54 <hyakuhei> I think this is something that will be discussed for a long time
20:10:14 <jaosorior> well, either way we need the documentation set up, and it's only a positive thing for us to start working on it (better documentation = easier adoption)
20:10:16 <redrobot> I asked for clarification of the impact to Incubated projects such as ours, so hopefully we'll have some answers during the next revision of the doc
20:10:27 <redrobot> jaosorior +1
20:10:51 <redrobot> yes, I think we should continue going down the path of graduating into the Integrated Release.
20:10:56 <jaosorior> yup
20:10:59 <jaosorior> agree
20:11:14 <redrobot> I think Operation docs are going to be super important
20:11:42 <redrobot> right now, we don't really have any docs for someone who just wants to deploy and use barbican
20:13:01 <elmiko> how are the doc reviews going to happen, is there a bp/spec up, or will they be bugs against current?
20:14:01 <redrobot> elmiko the plan is to continue to work on Sphinx documentation inside the barbican repo
20:14:29 <redrobot> elmiko we could possibly set up some BPs to track the work.
20:15:09 <redrobot> A lot of the docs I listed on the Wiki page are in Docbook format, but I think it would be easier for us to produce Sphinx docs.
20:15:35 <redrobot> Also, the Sphinx docs are currently published to docs.openstack.org/developer/barbican
20:15:45 <elmiko> redrobot: that's kinda what i was curious about, a bp would be useful to allow the work to happen in a distributed manner
20:16:38 <redrobot> elmiko agreed.  I can set up some blueprints so we can track documentation work.
20:16:56 <redrobot> #action redrobot to add Blueprints to Launchpad for outstanding documentation work.
20:17:13 <redrobot> any questions or comments before we move on to the next topic?
20:17:32 <jaosorior> noup
20:17:42 <redrobot> ok, moving on
20:17:53 <redrobot> #topic Bugs
20:18:05 <redrobot> #link https://bugs.launchpad.net/barbican
20:18:29 <redrobot> I've been doing a lot of Launchpad cleanup the last few days
20:18:46 <redrobot> and one thing I've noticed is that we've been doing a less than stellar job of closing out/reviewing bugs
20:18:58 <redrobot> I think it's mostly due to the fact that nobody is using Barbican in production
20:19:15 <redrobot> so there's no motivation to get bugs closed
20:19:44 <redrobot> but I would like to see us get into the habit of fixing bugs, instead of letting them linger out in Launchpad
20:19:55 <redrobot> some bugs are 100+ days old for example
20:20:09 <jvrbanac> +1
20:20:31 <redrobot> The Kilo-1 milestone is due in 10 days
20:21:02 <redrobot> and so far, the only thing that is going into it is the Keystone work that Arun did which was held back from Juno
20:21:03 <redrobot> #link https://launchpad.net/barbican/+milestone/kilo-1
20:21:40 <redrobot> I think the other BP that jaosorior is working on will probably be pushed out to k2
20:21:53 <redrobot> and we sadly don't have any bug fixes going into k1 just yet
20:22:35 <alee_> redrobot, can we get the design BP's done and approved this week?
20:23:28 <redrobot> alee_ I hope so.
20:23:46 <redrobot> Any questions/comments about Launchpad bugs?
20:24:14 <redrobot> I did unassign everyone from any bugs that are open
20:24:27 <redrobot> because I don't think anyone was actively working on them.
20:24:46 <redrobot> so please, only assign a bug to yourself if you're actively working on it.
20:25:08 <tkelsey> redrobot: makes sense, I'll have a scan over the bug list when i get some spare cycles, would like to help out there
20:25:41 <redrobot> tkelsey thanks, that would be awesome
20:25:44 <redrobot> ok, moving on.
20:25:47 <woodster_> please feel free to ask the IRC question about bugs you'd like to take on
20:25:52 <redrobot> #topic Castellan
20:26:16 <redrobot> In case you missed it, the openstack/castellan repo is live
20:26:18 <redrobot> #link http://git.openstack.org/cgit/openstack/castellan
20:26:37 <rellerreller> woohoo
20:26:50 <tkelsey> awesome :)
20:26:50 <redrobot> we already have a pending review
20:26:51 <jaosorior> :D
20:26:53 <redrobot> #link https://review.openstack.org/#/q/status:open+project:openstack/castellan,n,z
20:26:58 <jvrbanac> w00t!
20:27:11 <redrobot> please add openstack/castellan to the list of your watched repos in gerrit
20:27:43 <redrobot> I _think_ I set up the IRC bot so that CRs to Castellan get announced in #openstack-barbican, so you'll be seeing those come through
20:28:20 <redrobot> The offical change to Governance is still pending
20:28:21 <redrobot> #link https://review.openstack.org/#/c/138875/
20:28:33 <redrobot> but I don't foresee any problems getting it merged
20:29:40 <redrobot> I also set up a Launchpad project for Blueprints/Bug tracking
20:29:41 <redrobot> #link https://launchpad.net/castellan
20:30:32 <jaosorior> excellent
20:31:06 <redrobot> I think that about covers Castellan
20:31:10 <redrobot> any questions/comments about it?
20:32:46 <redrobot> I'll go with no questions, then. :)
20:32:50 <redrobot> moving on
20:32:54 <redrobot> #topic Content Types
20:33:03 <redrobot> rellerreller did you want to talk about this?
20:33:06 <rellerreller> That was my topic.
20:33:12 <redrobot> #link https://etherpad.openstack.org/p/barbican-formats-discussion
20:33:29 <rellerreller> woodster_ created the etherpad page on this. I added a bunch of content to this.
20:34:02 <rellerreller> I was wondering if there was any feedback on it. I plan to turn it into a spec soon so wanted to have feedback before then.
20:34:28 <woodster_> rellerreller, I'll refresh on that today
20:35:00 <rellerreller> woodster_ thanks
20:35:07 <redrobot> I totally missed the etherpad link the first time around.  Will definitely look at it today.
20:35:37 <woodster_> yeah, that's pretty fundamental stuff...interested parties should definitely weigh in on it.
20:36:01 <alee_> rellerreller, I'll refresh on it today too.
20:36:21 <woodster_> good Paris conversations about that...almost as interesting as Castellan vs Wegian
20:36:42 <greghaynes> Any reason you dont just turn that into a spec now?
20:37:06 <greghaynes> leaving comments on an ether pad is meh, and thats really the whole point of review :)
20:37:23 <rellerreller> I have a terrible prepublication process
20:37:50 <rellerreller> If I did not have that in my way then I would submit spec today
20:38:31 <alee_> rellerreller, I was going to say that this was an interesting way of "publishing" a spec without publishing a spec.
20:38:51 <woodster_> the 'p' word
20:39:05 <rellerreller> alee_ Yes, I know. This whole prepub process is ridiculous.
20:39:37 <woodster_> should someone other than rellerreller ublish it ('p' was redacted) then?
20:41:01 <rellerreller> I would like to publish it and continue to follow through with it. If that is ok.
20:41:18 <woodster_> Noting that 'someone who may or may not be affiliated with JHAPL may or may not have inspired this blueprint'.
20:41:44 <woodster_> well, are you thinking this is a Kilo BP or beyond?
20:41:50 <rellerreller> Kilo
20:42:07 <alee_> rellerreller, sounds good to me.  I'l comment on etherpad/irc.  I think this should be kilo too
20:42:37 <woodster_> it seems you'd have to have this going thru the internal review process pretty soon then (yesterday?)
20:42:46 <rellerreller> Yes, I'm hoping to have comments by COB Thursday and then have prepub done by next week
20:43:11 <woodster_> sounds good
20:43:15 <rellerreller> I'm going to ask for a quick release on this.
20:43:56 <redrobot> anything else, other than please comment?
20:44:12 <rellerreller> redrobot That was it.
20:44:16 <rellerreller> redrobot thanks
20:44:22 <redrobot> rellerreller np
20:44:33 <redrobot> #topic Blueprint review
20:44:52 <redrobot> Just added this RE alee_'s question about getting BPs approved this week.
20:44:59 <alee_> redrobot, yes please
20:45:07 <redrobot> I think the hangout last Thursday was helpful
20:45:21 <woodster_> redrobot: +1
20:45:30 <redrobot> we should hopefully be super close to landing https://review.openstack.org/#/c/135490/
20:45:51 <redrobot> core peeps, please take a look at it today
20:45:52 <rellerreller> I was wondering how that went. I think those are more effective than IRC for discussions.
20:46:03 <redrobot> rellerreller +1
20:46:15 <greghaynes> ooo, that review is something ive been looking for
20:46:17 <redrobot> I was talking to reaperhulk about it yesterday
20:46:21 <alee_> redrobot, +100 -- yes plase
20:46:45 <redrobot> and he was suggesting we make Vidyo hangouts a regular thing
20:46:49 <woodster_> had some tech difficulties though
20:46:57 <redrobot> maybe every other week, and skip when not necessary
20:47:03 <alee_> also tied to that review is https://review.openstack.org/129048
20:47:05 <rellerreller> +1
20:47:30 <alee_> core peeps please take a look at that one too -- its very close as well
20:47:47 <rellerreller> I think occasional video hangouts would help a lot
20:47:58 <redrobot> Also, in case anyone missed it, the Launchpad Blueprint page is up-to-date and prioritized
20:48:00 <redrobot> #link https://blueprints.launchpad.net/barbican
20:48:12 <redrobot> please use priority as your guide for "what to review next"
20:48:40 <redrobot> I would like to see all the Essential BPs landed before the holidays
20:49:01 <alee_> redrobot, do we need another vidyo hangout this week?
20:49:16 <redrobot> alee_ I was just about to ask that :)
20:49:46 <redrobot> +1 s for a Vidyo hangout this Thursday 3pm UTC ?
20:49:56 <alee_> +1
20:50:22 <rellerreller> What time is UTC in ET?
20:50:27 <alee_> 10 am
20:50:46 <rellerreller> I could make that
20:51:03 <woodster_> Sounds good.
20:51:06 <rellerreller> What would the topic be? alee 's specs
20:51:12 <redrobot> http://time.is/300PM_11_Dec_2014_in_UTC/EST/CST/PST
20:51:13 <woodster_> I also recall that we wanted this BP (well a kilo equivalent) to be the top level BP, with info added to it for the overall expected cert generation sequence: https://review.openstack.org/#/c/99221/
20:51:24 <redrobot> rellerreller yeah, reviewing Essential BPs
20:51:34 <rellerreller> +1
20:52:23 <redrobot> I'll update https://wiki.openstack.org/wiki/Barbican/Kilo with Vidyo details for this Thursday then
20:52:52 <alee_> redrobot, rellerreller - I think we'll likely end up discussig https://review.openstack.org/127353
20:53:09 <alee_> assumign the other essential ones land.
20:54:36 <redrobot> I think that about covers everything for today...   right on time as well :)
20:54:43 <redrobot> any last minute questions/comments about BPs?
20:54:43 <tkelsey> since we are coming up to time I just want to mention this review has been abandoned after some push back i think https://review.openstack.org/#/c/104001/ concerning babrican keymanager in Nova
20:55:11 <tkelsey> mostly an FYI, but might be worth looking into why
20:55:29 <woodster_> So hopefully castellan will alleviate those concerns?
20:55:37 <redrobot> tkelsey I think rellerreller is familiar with that CR
20:55:46 <rellerreller> tkelsey bpoulos is working on that
20:56:03 <tkelsey> awesome, just wanted to bring it to peoples attention :)
20:56:11 <rellerreller> There is a new spec we are trying to put out for that.
20:56:35 <rellerreller> I cannot wait until we get Castellan in Nova.
20:56:39 <tkelsey> ok cool, got a link to the spec, or is it not in review yet ?
20:57:07 <rellerreller> Bruce came by my office a few minutes ago saying he needs a spec out now because there was an issue
20:57:23 <hyakuhei> rellerreller: can you add me as a reviewer on teh new spec when it's up? Very interested to see what we (HP) can do to help this turn into a real thing
20:57:27 <rellerreller> My guess is that the issue was that big X for the code review
20:57:34 <hyakuhei> lol
20:57:36 <tkelsey> hyakuhei: +1
20:57:45 <hyakuhei> Big X's do it every time.
20:57:52 <rellerreller> hyakuhei thanks. We will keep you posted
20:58:00 <bknudson> looks like it didn't make it in the previous release, so needs to be reproposed for K.
20:59:30 <redrobot> Ok, that's our time for today.  Thanks everyone for coming out
20:59:34 <redrobot> see y'all next week.
20:59:40 <redrobot> #endmeeting